NoPaste

hplip-Neuinstallation

von Ulidor

Dein Code:
  1. karin@debian:~$ su -
  2. Passwort:
  3. root@debian:~# apt purge hplip
  4. Statusinformationen werden eingelesen.... Fertig
  5. Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  6.   hplip-data libart-2.0-2 libgles1-mesa libsane-hpaio libvlccore8 linux-image-3.16.0-4-amd64 linux-image-4.9.0-4-amd64
  7.   linux-image-4.9.0-5-amd64 python3-dbus.mainloop.pyqt5 python3-notify2 python3-pexpect python3-pil python3-ptyprocess
  8.   python3-renderpm python3-reportlab python3-reportlab-accel
  9. Verwenden Sie »apt autoremove«, um sie zu entfernen.
  10. Die folgenden Pakete werden ENTFERNT:
  11.   hplip* hplip-gui* printer-driver-postscript-hp*
  12. 0 aktualisiert, 0 neu installiert, 3 zu entfernen und 2 nicht aktualisiert.
  13. Nach dieser Operation werden 1.579 kB Plattenplatz freigegeben.
  14. Möchten Sie fortfahren? [J/n] J
  15. (Lese Datenbank ... 202328 Dateien und Verzeichnisse sind derzeit installiert.)
  16. Entfernen von printer-driver-postscript-hp (3.16.11+repack0-3) ...
  17. Entfernen von hplip-gui (3.16.11+repack0-3) ...
  18. Entfernen von hplip (3.16.11+repack0-3) ...
  19. Trigger für mime-support (3.60) werden verarbeitet ...
  20. Trigger für cups (2.2.1-8+deb9u2) werden verarbeitet ...
  21. Trigger für man-db (2.7.6.1-2) werden verarbeitet ...
  22. Trigger für dbus (1.10.26-0+deb9u1) werden verarbeitet ...
  23. (Lese Datenbank ... 202221 Dateien und Verzeichnisse sind derzeit installiert.)
  24. Löschen der Konfigurationsdateien von hplip (3.16.11+repack0-3) ...
  25. Löschen der Konfigurationsdateien von hplip-gui (3.16.11+repack0-3) ...
  26. Trigger für dbus (1.10.26-0+deb9u1) werden verarbeitet ...
  27. root@debian:~# apt clean
  28. root@debian:~# apt install hplip hplip-gui printer-driver-postscript-hp sane-utils libnet-snmp-perl libsnmp-base hpijs-ppds pr
  29. rinter-driver-hpijs
  30. Paketlisten werden gelesen... Fertig
  31. Abhängigkeitsbaum wird aufgebaut.      
  32. Statusinformationen werden eingelesen.... Fertig
  33. hpijs-ppds ist schon die neueste Version (3.16.11+repack0-3).
  34. printer-driver-hpijs ist schon die neueste Version (3.16.11+repack0-3).
  35. libnet-snmp-perl ist schon die neueste Version (6.0.1-2).
  36. libsnmp-base ist schon die neueste Version (5.7.3+dfsg-1.7).
  37. sane-utils ist schon die neueste Version (1.0.25-4.1).
  38. Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  39.   libgles1-mesa libvlccore8 linux-image-3.16.0-4-amd64 linux-image-4.9.0-4-amd64 linux-image-4.9.0-5-amd64
  40. Verwenden Sie »apt autoremove«, um sie zu entfernen.
  41. Vorgeschlagene Pakete:
  42.   hplip-doc
  43. Die folgenden NEUEN Pakete werden installiert:
  44.   hplip hplip-gui printer-driver-postscript-hp
  45. 0 aktualisiert, 3 neu installiert, 0 zu entfernen und 2 nicht aktualisiert.
  46. Es müssen 1.104 kB an Archiven heruntergeladen werden.
  47. Nach dieser Operation werden 1.579 kB Plattenplatz zusätzlich benutzt.
  48. Möchten Sie fortfahren? [J/n] J
  49. Holen:1 http://ftp2.de.debian.org/debian stretch/main amd64 hplip amd64 3.16.11+repack0-3 [145 kB]
  50. Holen:2 http://ftp2.de.debian.org/debian stretch/main amd64 hplip-gui all 3.16.11+repack0-3 [97,0 kB]
  51. Holen:3 http://ftp2.de.debian.org/debian stretch/main amd64 printer-driver-postscript-hp all 3.16.11+repack0-3 [862 kB]
  52. Es wurden 1.104 kB in 0 s geholt (2.448 kB/s).        
  53. Vormals nicht ausgewähltes Paket hplip wird gewählt.
  54. (Lese Datenbank ... 202219 Dateien und Verzeichnisse sind derzeit installiert.)
  55. Vorbereitung zum Entpacken von .../hplip_3.16.11+repack0-3_amd64.deb ...
  56. Entpacken von hplip (3.16.11+repack0-3) ...
  57. Vormals nicht ausgewähltes Paket hplip-gui wird gewählt.
  58. Vorbereitung zum Entpacken von .../hplip-gui_3.16.11+repack0-3_all.deb ...
  59. Entpacken von hplip-gui (3.16.11+repack0-3) ...
  60. Vormals nicht ausgewähltes Paket printer-driver-postscript-hp wird gewählt.
  61. Vorbereitung zum Entpacken von .../printer-driver-postscript-hp_3.16.11+repack0-3_all.deb ...
  62. Entpacken von printer-driver-postscript-hp (3.16.11+repack0-3) ...
  63. hplip (3.16.11+repack0-3) wird eingerichtet ...
  64. Creating/updating hplip user account...
  65. dpkg-statoverride: Warnung: --update angegeben, aber /var/run/hplip existiert nicht
  66. Trigger für mime-support (3.60) werden verarbeitet ...
  67. printer-driver-postscript-hp (3.16.11+repack0-3) wird eingerichtet ...
  68. Trigger für cups (2.2.1-8+deb9u2) werden verarbeitet ...
  69. Trigger für man-db (2.7.6.1-2) werden verarbeitet ...
  70. Trigger für dbus (1.10.26-0+deb9u1) werden verarbeitet ...
  71. hplip-gui (3.16.11+repack0-3) wird eingerichtet ...
  72. root@debian:~# exit
  73. Abgemeldet
  74. karin@debian:~$
  75. karin@debian:~$ hp-setup
  76.  
  77. HP Linux Imaging and Printing System (ver. 3.16.11)
  78. Printer/Fax Setup Utility ver. 9.0
  79.  
  80. Copyright (c) 2001-15 HP Development Company, LP
  81. This software comes with ABSOLUTELY NO WARRANTY.
  82. This is free software, and you are welcome to distribute it
  83. under certain conditions. See COPYING file for more details.
  84.  
  85. Found device: hp:/net/Deskjet_2540_series?ip=192.168.1.80
  86. QXcbConnection: XCB error: 3 (BadWindow), sequence: 2079, resource id: 35691190, major code: 40 (TranslateCoords), minor code: 0
  87.  
  88. Done.
  89. karin@debian:~$ hp-check
  90. Saving output in log file: /home/karin/hp-check.log
  91.  
  92. HP Linux Imaging and Printing System (ver. 3.16.11)
  93. Dependency/Version Check Utility ver. 15.1
  94.  
  95. Copyright (c) 2001-15 HP Development Company, LP
  96. This software comes with ABSOLUTELY NO WARRANTY.
  97. This is free software, and you are welcome to distribute it
  98. under certain conditions. See COPYING file for more details.
  99.  
  100. Note: hp-check can be run in three modes:
  101. 1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to
  102. determine if the proper dependencies are installed to successfully compile HPLIP.                                            
  103. 2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already
  104. built HPLIP supplied tarball has the proper dependencies installed to successfully run.                                      
  105. 3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both        
  106. compile- and run-time dependencies).                                                                                        
  107.  
  108. Check types:                                                                                                                
  109. a. EXTERNALDEP - External Dependencies                                                                                      
  110. b. GENERALDEP - General Dependencies (required both at compile and run time)                                                
  111. c. COMPILEDEP - Compile time Dependencies                                                                                    
  112. d. [All are run-time checks]                                                                                                
  113. PYEXT SCANCONF QUEUES PERMISSION                                                                                            
  114.  
  115. Status Types:
  116.     OK
  117.     MISSING       - Missing Dependency or Permission or Plug-in
  118.     INCOMPAT      - Incompatible dependency-version or Plugin-version
  119.  
  120. warning: 2-9.5 version is not supported. Using 2-8.6 versions dependencies to verify and install...
  121.  
  122. ---------------
  123. | SYSTEM INFO |
  124. ---------------
  125.  
  126.  Kernel: 4.9.0-7-amd64 #1 SMP Debian 4.9.110-1 (2018-07-05) GNU/Linux
  127.  Host: debian
  128.  Proc: 4.9.0-7-amd64 #1 SMP Debian 4.9.110-1 (2018-07-05) GNU/Linux
  129.  Distribution: 2 9.5
  130.  Bitness: 64 bit
  131.  
  132.  
  133. -----------------------
  134. | HPLIP CONFIGURATION |
  135. -----------------------
  136.  
  137. HPLIP-Version: HPLIP 3.16.11
  138. HPLIP-Home: /usr/share/hplip
  139. warning: HPLIP-Installation: Auto installation is not supported for 2 distro  9.5 version
  140.  
  141. Current contents of '/etc/hp/hplip.conf' file:
  142. # hplip.conf.  Generated from hplip.conf.in by configure.
  143.  
  144. [hplip]
  145. version=3.16.11
  146.  
  147. [dirs]
  148. home=/usr/share/hplip
  149. run=/var/run
  150. ppd=/usr/share/ppd/hplip/HP
  151. ppdbase=/usr/share/ppd/hplip
  152. doc=/usr/share/doc/hplip
  153. html=/usr/share/doc/hplip-doc
  154. icon=no
  155. cupsbackend=/usr/lib/cups/backend
  156. cupsfilter=/usr/lib/cups/filter
  157. drv=/usr/share/cups/drv
  158. bin=/usr/bin
  159. apparmor=/etc/apparmor.d
  160. # Following values are determined at configure time and cannot be changed.
  161. [configure]
  162. network-build=yes
  163. libusb01-build=no
  164. pp-build=yes
  165. gui-build=yes
  166. scanner-build=yes
  167. fax-build=yes
  168. dbus-build=yes
  169. cups11-build=no
  170. doc-build=yes
  171. shadow-build=no
  172. hpijs-install=yes
  173. foomatic-drv-install=yes
  174. foomatic-ppd-install=yes
  175. foomatic-rip-hplip-install=no
  176. hpcups-install=yes
  177. cups-drv-install=yes
  178. cups-ppd-install=no
  179. internal-tag=3.16.11
  180. restricted-build=no
  181. ui-toolkit=qt5
  182. qt3=no
  183. qt4=no
  184. qt5=yes
  185. policy-kit=yes
  186. lite-build=no
  187. udev_sysfs_rules=no
  188. hpcups-only-build=no
  189. hpijs-only-build=no
  190. apparmor_build=no
  191.  
  192.  
  193. Current contents of '/var/lib/hp/hplip.state' file:
  194. Plugins are not installed. Could not access file: No such file or directory
  195.  
  196. Current contents of '~/.hplip/hplip.conf' file:
  197. [last_used]
  198. device_uri = hp:/net/Deskjet_2540_series?ip=192.168.1.80
  199.  
  200. [installation]
  201. date_time = 08/09/18 14:14:17
  202. version = 3.16.11
  203.  
  204.  
  205.  <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>
  206.  
  207. -------------------------
  208. | External Dependencies |
  209. -------------------------
  210.  
  211.  gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.20            OK         -
  212.  error: avahi-utils   avahi-utils                                                  OPTIONAL        -               -               MISSING    'avahi-utils needs to be installed'
  213.  scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.25          OK         -
  214.  error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
  215.  policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
  216.  xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
  217.  network              network -wget                                                OPTIONAL        -               1.18            OK         -
  218.  error: dbus          DBus - Message bus system                                    REQUIRED        -               1.10.26         MISSING    'DBUS may not be installed or not running'
  219.  
  220. --------------
  221. | COMPILEDEP |
  222. --------------
  223.  
  224.  error: make          make - GNU make utility to maintain groups of programs       REQUIRED        3.0             -               MISSING    'make needs to be installed'
  225.  error: gcc           gcc - GNU Project C and C++ Compiler                         REQUIRED        -               -               MISSING    'gcc needs to be installed'
  226.  error: libtool       libtool - Library building support services                  REQUIRED        -               -               MISSING    'libtool needs to be installed'
  227.  
  228. ------------------------
  229. | General Dependencies |
  230. ------------------------
  231.  
  232.  error: libcrypto     libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.0           MISSING    'libcrypto needs to be installed'
  233.  error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
  234.  python3-pyqt4-dbus   PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             4.11.4          OK         -
  235.  python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.5.3           OK         -
  236.  python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.4           OK         -
  237.  python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
  238.  error: cups-devel    CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               MISSING    'cups-devel needs to be installed'
  239.  error: libpthread    libpthread - POSIX threads library                           REQUIRED        -               b'2.24'         MISSING    'libpthread needs to be installed'
  240.  sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
  241.  error: sane-devel    SANE - Scanning library development files                    REQUIRED        -               -               MISSING    'sane-devel needs to be installed'
  242.  error: python3-devel Python devel - Python development files                      REQUIRED        2.2             3.5.3           MISSING    'python3-devel needs to be installed'
  243.  error: libjpeg       libjpeg - JPEG library                                       REQUIRED        -               -               MISSING    'libjpeg needs to be installed'
  244.  error: cups-image    CUPS image - CUPS image development files                    REQUIRED        -               -               MISSING    'cups-image needs to be installed'
  245.  python3-xml          Python XML libraries                                         REQUIRED        -               2.2.0           OK         -
  246.  python3-pyqt4        PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             4.11.4          OK         -
  247.  python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.3.0           OK         -
  248.  error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           -               MISSING    'libnetsnmp-devel needs to be installed'
  249.  python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               1.1.7           OK         -
  250.  
  251. ----------------------
  252. | Scan Configuration |
  253. ----------------------
  254.  
  255.  scanext              Scan-SANE-Extension                                          REQUIRED        -               3.16.11         OK         -
  256. '/etc/sane.d/dll.d/hpaio' not found.
  257.  hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.16.11         OK         'hpaio found in /etc/sane.d/dll.conf'
  258.  
  259. ---------------------
  260. | Python Extentions |
  261. ---------------------
  262.  
  263.  cupsext              CUPS-Extension                                               REQUIRED        -               3.16.11         OK         -
  264.  hpmudext             IO-Extension                                                 REQUIRED        -               3.16.11         OK         -
  265.  
  266. ------------------------------
  267. | DISCOVERED SCANNER DEVICES |
  268. ------------------------------
  269.  
  270. device `hpaio:/net/Deskjet_2540_series?ip=192.168.1.80' is a Hewlett-Packard Deskjet_2540_series all-in-one
  271.  
  272.  
  273. --------------------------
  274. | DISCOVERED USB DEVICES |
  275. --------------------------
  276.  
  277. No devices found.
  278.  
  279. ---------------------------------
  280. | INSTALLED CUPS PRINTER QUEUES |
  281. ---------------------------------
  282.  
  283.  
  284. DESKJET-690C
  285. ------------
  286. Type: Unknown
  287. Device URI: usb://HP/DESKJET%20690C
  288. PPD: /etc/cups/ppd/DESKJET-690C.ppd
  289. warning: Failed to read /etc/cups/ppd/DESKJET-690C.ppd ppd file
  290. PPD Description:
  291. Printer Unplugged or turned off-690C ist deaktiviert seit So 25 Sep 2016 19:06:55 CEST
  292. warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.
  293.  
  294. Deskjet_2540
  295. ------------
  296. Type: Printer
  297. Device URI: hp:/net/Deskjet_2540_series?ip=192.168.1.80
  298. PPD: /etc/cups/ppd/Deskjet_2540.ppd
  299. warning: Failed to read /etc/cups/ppd/Deskjet_2540.ppd ppd file
  300. PPD Description:
  301. Printer status: Drucker Deskjet_2540 ist im Leerlauf.  Aktiviert seit Do 09 Aug 2018 14:10:47 CEST
  302. Communication status: Good
  303.  
  304.  
  305. --------------
  306. | PERMISSION |
  307. --------------
  308.  
  309.  
  310. -----------
  311. | SUMMARY |
  312. -----------
  313.  
  314. Missing Required Dependencies
  315. -----------------------------
  316. error: 'cups' package is missing or 'cups' service is not running.
  317. error: 'libcups2' package is missing/incompatible
  318. error: 'libdbus-1-dev' package is missing/incompatible
  319. error: 'make' package is missing/incompatible
  320. error: 'g++' package is missing/incompatible
  321. error: 'libtool' package is missing/incompatible
  322. error: 'libtool-bin' package is missing/incompatible
  323. error: 'libssl-dev' package is missing/incompatible
  324. error: 'libusb-1.0.0-dev' package is missing/incompatible
  325. error: 'libcups2-dev' package is missing/incompatible
  326. error: 'cups-bsd' package is missing/incompatible
  327. error: 'cups-client' package is missing/incompatible
  328. error: 'libc6' package is missing/incompatible
  329. error: 'libsane-dev' package is missing/incompatible
  330. error: 'python3-dev' package is missing/incompatible
  331. error: 'libjpeg62-turbo-dev' package is missing/incompatible
  332. error: 'libcupsimage2' package is missing/incompatible
  333. error: 'libcupsimage2-dev' package is missing/incompatible
  334. error: 'libsnmp-dev' package is missing/incompatible
  335. error: 'snmp' package is missing/incompatible
  336.  
  337. Missing Optional Dependencies
  338. -----------------------------
  339. error: 'avahi-utils' package is missing/incompatible
  340.  
  341. Total Errors: 15
  342. Total Warnings: 1
  343.  
  344.  
  345. Done.

Quellcode

Hier kannst du den Code kopieren und ihn in deinen bevorzugten Editor einfügen. Alternativ kannst du den gesamten Eintrag auch als Datei herunterladen.