NoPaste

errlog-pip-install-kivy

von Trollkirsche

Dein Code:
  1. Requirement already satisfied: cython in /usr/lib/python3/dist-packages (0.29.2)
  2. Collecting kivy
  3.   Using cached https://files.pythonhosted.org/packages/7d/8b/89d220b7f96dc2662b81319067f679b4cd73cda66f4aa850db5b6c6cfc7a/Kivy-1.10.1.tar.gz
  4. Requirement already satisfied: Kivy-Garden>=0.1.4 in /usr/local/lib/python3.7/dist-packages (from kivy) (0.1.4)
  5. Requirement already satisfied: docutils in /usr/local/lib/python3.7/dist-packages (from kivy) (0.14)
  6. Requirement already satisfied: pygments in /usr/local/lib/python3.7/dist-packages (from kivy) (2.4.0)
  7. Requirement already satisfied: requests in /usr/lib/python3/dist-packages (from Kivy-Garden>=0.1.4->kivy) (2.21.0)
  8. Building wheels for collected packages: kivy
  9.   Running setup.py bdist_wheel for kivy: started
  10.   Running setup.py bdist_wheel for kivy: finished with status 'error'
  11.   Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-o_rfdeb5/kivy/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/pip-wheel-brk8yh_d --python-tag cp37:
  12.   Using distutils
  13.  
  14.   Detected Cython version 0.29.2
  15.     This version of Cython is untested with Kivy. While this version may
  16.     work perfectly fine, it is possible that you may experience issues. If
  17.     you do have issues, please downgrade to a supported version. It is
  18.     best to use the newest supported version, 0.28.2, but the minimum
  19.     supported version is 0.23.
  20.  
  21.     If your platform provides a Cython package, check if you can downgrade
  22.     to a supported version. Otherwise, uninstall the platform package and
  23.     install Cython via pip:
  24.  
  25.       pip install -I Cython==0.28.2
  26.  
  27.     Please note that the following versions of Cython are not supported
  28.     at all: 0.27, 0.27.2
  29.  
  30.   Using this graphics system: OpenGL
  31.   WARNING: A problem occurred while running pkg-config --libs --cflags gstreamer-1.0 (code 127)
  32.  
  33.   b'/bin/sh: 1: pkg-config: not found\n'
  34.  
  35.   WARNING: A problem occurred while running pkg-config --libs --cflags sdl2 SDL2_ttf SDL2_image SDL2_mixer (code 127)
  36.  
  37.   b'/bin/sh: 1: pkg-config: not found\n'
  38.  
  39.   ERROR: Dependency for context.pyx not resolved: config.pxi
  40.   ERROR: Dependency for compiler.pyx not resolved: config.pxi
  41.   ERROR: Dependency for context_instructions.pyx not resolved: config.pxi
  42.   ERROR: Dependency for fbo.pyx not resolved: config.pxi
  43.   ERROR: Dependency for gl_instructions.pyx not resolved: config.pxi
  44.   ERROR: Dependency for instructions.pyx not resolved: config.pxi
  45.   ERROR: Dependency for opengl.pyx not resolved: config.pxi
  46.   ERROR: Dependency for opengl_utils.pyx not resolved: config.pxi
  47.   ERROR: Dependency for shader.pyx not resolved: config.pxi
  48.   ERROR: Dependency for stencil_instructions.pyx not resolved: config.pxi
  49.   ERROR: Dependency for scissor_instructions.pyx not resolved: config.pxi
  50.   ERROR: Dependency for texture.pyx not resolved: config.pxi
  51.   ERROR: Dependency for vbo.pyx not resolved: config.pxi
  52.   ERROR: Dependency for vertex.pyx not resolved: config.pxi
  53.   ERROR: Dependency for vertex_instructions.pyx not resolved: config.pxi
  54.   ERROR: Dependency for cgl.pyx not resolved: config.pxi
  55.   ERROR: Dependency for cgl_mock.pyx not resolved: config.pxi
  56.   ERROR: Dependency for cgl_gl.pyx not resolved: config.pxi
  57.   ERROR: Dependency for cgl_glew.pyx not resolved: config.pxi
  58.   ERROR: Dependency for cgl_sdl2.pyx not resolved: config.pxi
  59.   ERROR: Dependency for svg.pyx not resolved: config.pxi
  60.   fatal: Kein Git-Repository (oder irgendeines der Elternverzeichnisse): .git
  61.    /usr/lib/python3.7/distutils/dist.py:274: UserWarning: Unknown distribution option: 'extra_requires''language_level' not set, using 2 for now (Py2). This will change in a later release! File: /tmp/pip-install-o_rfdeb5/kivy/kivy/_event.pxd
  62.      tree = Parsing.p_module(s, pxd, full_module_name)
  63.   building 'kivy._event' extension
  64.   creating build/temp.linux-x86_64-3.7
  65.   creating build/temp.linux-x86_64-3.7/tmp
  66.   creating build/temp.linux-x86_64-3.7/tmp/pip-install-o_rfdeb5
  67.   creating build/temp.linux-x86_64-3.7/tmp/pip-install-o_rfdeb5/kivy
  68.   creating build/temp.linux-x86_64-3.7/tmp/pip-install-o_rfdeb5/kivy/kivy
  69.   x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I/tmp/pip-install-o_rfdeb5/kivy/kivy/include -I/usr/include/python3.7m -c /tmp/pip-install-o_rfdeb5/kivy/kivy/_event.c -o build/temp.linux-x86_64-3.7/tmp/pip-install-o_rfdeb5/kivy/kivy/_event.o
  70.   /tmp/pip-install-o_rfdeb5/kivy/kivy/_event.c:4:10: fatal error: Python.h: Datei oder Verzeichnis nicht gefunden
  71.    #include "Python.h"
  72.            ^~~~~~~~~~
  73.   compilation terminated.
  74.    error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
  75.  
  76.   ----------------------------------------
  77.   Running setup.py clean for kivy
  78. Failed to build kivy
  79. Installing collected packages: kivy
  80.   Running setup.py install for kivy: started
  81.     Running setup.py install for kivy: finished with status 'error'
  82.     Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-o_rfdeb5/kivy/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-p02mx3mj/install-record.txt --single-version-externally-managed --compile:
  83.     Using distutils
  84.    
  85.     Detected Cython version 0.29.2
  86.       This version of Cython is untested with Kivy. While this version may
  87.       work perfectly fine, it is possible that you may experience issues. If
  88.       you do have issues, please downgrade to a supported version. It is
  89.       best to use the newest supported version, 0.28.2, but the minimum
  90.       supported version is 0.23.
  91.    
  92.       If your platform provides a Cython package, check if you can downgrade
  93.       to a supported version. Otherwise, uninstall the platform package and
  94.       install Cython via pip:
  95.    
  96.         pip install -I Cython==0.28.2
  97.    
  98.       Please note that the following versions of Cython are not supported
  99.       at all: 0.27, 0.27.2
  100.    
  101.     Using this graphics system: OpenGL
  102.     WARNING: A problem occurred while running pkg-config --libs --cflags gstreamer-1.0 (code 127)
  103.    
  104.     b'/bin/sh: 1: pkg-config: not found\n'
  105.    
  106.     WARNING: A problem occurred while running pkg-config --libs --cflags sdl2 SDL2_ttf SDL2_image SDL2_mixer (code 127)
  107.    
  108.     b'/bin/sh: 1: pkg-config: not found\n'
  109.    
  110.     fatal: Kein Git-Repository (oder irgendeines der Elternverzeichnisse): .git
  111.      /usr/lib/python3.7/distutils/dist.py:274: UserWarning: Unknown distribution option: 'extra_requires''/tmp/pip-install-o_rfdeb5/kivy/kivy/_event.c' Cython extension (up-to-date)
  112.     building 'kivy._event' extension
  113.     creating build/temp.linux-x86_64-3.7
  114.     creating build/temp.linux-x86_64-3.7/tmp
  115.     creating build/temp.linux-x86_64-3.7/tmp/pip-install-o_rfdeb5
  116.     creating build/temp.linux-x86_64-3.7/tmp/pip-install-o_rfdeb5/kivy
  117.     creating build/temp.linux-x86_64-3.7/tmp/pip-install-o_rfdeb5/kivy/kivy
  118.     x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I/tmp/pip-install-o_rfdeb5/kivy/kivy/include -I/usr/include/python3.7m -c /tmp/pip-install-o_rfdeb5/kivy/kivy/_event.c -o build/temp.linux-x86_64-3.7/tmp/pip-install-o_rfdeb5/kivy/kivy/_event.o
  119.     /tmp/pip-install-o_rfdeb5/kivy/kivy/_event.c:4:10: fatal error: Python.h: Datei oder Verzeichnis nicht gefunden
  120.      #include "Python.h"
  121.              ^~~~~~~~~~
  122.     compilation terminated.
  123.      error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
  124.    
  125.     ----------------------------------------

Quellcode

Hier kannst du den Code kopieren und ihn in deinen bevorzugten Editor einfügen. Alternativ kannst du den gesamten Eintrag auch als Datei herunterladen.