Update will xul-ext-foxyproxy-standard de-installieren

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
inne
Beiträge: 1798
Registriert: 25.06.2013 15:45:12
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

Update will xul-ext-foxyproxy-standard de-installieren

Beitrag von inne » 21.04.2017 10:55:55

Hallo,

das Update von Heute für Jessie, will mir xul-ext-foxyproxy-standard de-installieren. Das brauche aber noch. Warum und wieso ändert sich hier was unter stable und was kann ich dagegen tun?
Alles wegen thunderbird, aber xul-ext-foxyproxy-standard brauche ich für firefox-esr.

Code: Alles auswählen

apt-get -s dist-upgrade
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:
  iceowl-extension
Verwenden Sie »apt-get autoremove«, um es zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  xul-ext-foxyproxy-standard
Die folgenden NEUEN Pakete werden installiert:
  lightning thunderbird thunderbird-l10n-de
Die folgenden Pakete werden aktualisiert (Upgrade):
  icedove icedove-l10n-de iceowl-extension libdatetime-timezone-perl tzdata
  tzdata-java virtualbox-5.1
7 aktualisiert, 3 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
Remv xul-ext-foxyproxy-standard [3.4-1.1]
Inst virtualbox-5.1 [5.1.18-114002~Debian~jessie] (5.1.20-114628~Debian~jessie Oracle Corporation:download.virtualbox.org [amd64])
Inst tzdata-java [2017a-0+deb8u1] (2017b-0+deb8u1 Debian:stable-updates [all]) []
Inst tzdata [2017a-0+deb8u1] (2017b-0+deb8u1 Debian:stable-updates [all])
Conf tzdata (2017b-0+deb8u1 Debian:stable-updates [all])
Inst icedove-l10n-de [1:45.6.0-1~deb8u1] (1:45.8.0-3~deb8u1 Debian-Security:8/stable [all]) []
Inst icedove [1:45.6.0-1~deb8u1] (1:45.8.0-3~deb8u1 Debian-Security:8/stable [all]) []
Inst thunderbird (1:45.8.0-3~deb8u1 Debian-Security:8/stable [amd64]) []
Inst thunderbird-l10n-de (1:45.8.0-3~deb8u1 Debian-Security:8/stable [all])
Inst iceowl-extension [1:45.6.0-1~deb8u1] (1:45.8.0-3~deb8u1 Debian-Security:8/stable [all]) []
Inst lightning (1:45.8.0-3~deb8u1 Debian-Security:8/stable [amd64])
Inst libdatetime-timezone-perl [1:1.75-2+2017a] (1:1.75-2+2017b Debian:stable-updates [all])
Conf virtualbox-5.1 (5.1.20-114628~Debian~jessie Oracle Corporation:download.virtualbox.org [amd64])
Conf tzdata-java (2017b-0+deb8u1 Debian:stable-updates [all])
Conf thunderbird (1:45.8.0-3~deb8u1 Debian-Security:8/stable [amd64])
Conf thunderbird-l10n-de (1:45.8.0-3~deb8u1 Debian-Security:8/stable [all])
Conf icedove-l10n-de (1:45.8.0-3~deb8u1 Debian-Security:8/stable [all])
Conf icedove (1:45.8.0-3~deb8u1 Debian-Security:8/stable [all])
Conf lightning (1:45.8.0-3~deb8u1 Debian-Security:8/stable [amd64])
Conf iceowl-extension (1:45.8.0-3~deb8u1 Debian-Security:8/stable [all])
Conf libdatetime-timezone-perl (1:1.75-2+2017b Debian:stable-updates [all])
(=_=)

tobo
Beiträge: 376
Registriert: 10.12.2008 10:51:41

Re: Update will xul-ext-foxyproxy-standard de-installieren

Beitrag von tobo » 21.04.2017 13:56:56

Hängt wohl mit der Umstellung Icedove/Thunderbird und Iceweasel/Firefox zusammen. Abhängigkeiten von xul-ext-foxyproxy-standard sind Icedove oder Iceweasel - die liegen bei dir aber nach der Aktualisierung bestenfalls noch als Übergangspakete vor und Firefox bzw. Thunderbird sind (noch) nicht als Abhängigkeiten eingetragen!? Ich würde es einfach entfernen lassen und dann neu installieren. Bei Firefox ist der Profilpfad im Home-Verzeichnis identisch, bei Thunderbird weiß ich nicht. Vielleicht musst du da zusätzlich einen Link setzen vom alten zum neuen Profil-Verzeichnis!?

inne
Beiträge: 1798
Registriert: 25.06.2013 15:45:12
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

Re: Update will xul-ext-foxyproxy-standard de-installieren

Beitrag von inne » 21.04.2017 15:02:57

So scheint es zu sein:

Unter Jessie:

Code: Alles auswählen

$ apt-cache show thunderbird
[...]
Breaks: [...] xul-ext-foxyproxy-standard (<< 4.5.6-debian-2~)
[...]
$ apt-cache show xul-ext-foxyproxy-standard 
[...]
Version: 3.4-1.1
[...]
Mit Stretch scheint das dann wieder hinzukommen, denn dort ist Version 4.5.6-debian-2 gegeben.
(=_=)

Antworten