Fehler bei dist-upgrade auf Stretch

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
unamx
Beiträge: 6
Registriert: 12.07.2017 08:55:32

Fehler bei dist-upgrade auf Stretch

Beitrag von unamx » 12.07.2017 09:07:23

Liebe Gemeinde,
beim Upgrade von Jessie auf Stretch kommt die folgende Fehlermeldung :cry:

Fehl:1 http://mirror.23media.de/debian stretch/main amd64 libxatracker2 amd64 13.0.6-1+b2
Verbindung fehlgeschlagen [IP: 212.83.32.25 80]
E: Fehlschlag beim Holen von http://mirror.23media.de/debian/pool/ma ... _amd64.deb Verbindung fehlgeschlagen [IP: 212.83.32.25 80]
E: Einige Archive konnten nicht heruntergeladen werden; vielleicht »apt-get update« ausführen oder mit »--fix-missing« probieren?

Paketquellen habe ich bereits schon getauscht, Debian hat alles geladen, bis auf diese einzige Datei.
apt-get update --fix-missing behebt das Problem nicht.
Die Datei ist auch definitiv auf deren Server vorhanden, habe ich manuell überprüft. Die Datei lässt sich auch händisch downloaden.

Hat jemand einen Tipp?

Danke.

Benutzeravatar
catdog2
Beiträge: 5339
Registriert: 24.06.2006 16:50:03
Lizenz eigener Beiträge: MIT Lizenz

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von catdog2 » 12.07.2017 09:29:18

Nimm halt einen anderen Mirror: https://www.debian.org/mirror/list
Unix is user-friendly; it's just picky about who its friends are.

unamx
Beiträge: 6
Registriert: 12.07.2017 08:55:32

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von unamx » 12.07.2017 11:27:37

Paketquellen habe ich bereits schon getauscht, Debian hat alles geladen, bis auf diese einzige Datei.

Benutzeravatar
geier22
Beiträge: 2235
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von geier22 » 12.07.2017 15:02:19

Dumme Frage: Nach dem Tauschen der Quellen auch

Code: Alles auswählen

# apt update
gemacht?
sonst mal

Code: Alles auswählen

$ cat /etc/apt/sources.list /etc/apt/sources.list.d/*.list 
4.13.0-1-amd64 #1 SMP Debian 4.13.4-2 (2017-10-15) (Buster)/ XFCE 4.12.3 / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI (Treiber 375.82-8) / HP LP3065

unamx
Beiträge: 6
Registriert: 12.07.2017 08:55:32

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von unamx » 17.07.2017 14:15:13

apt-get update habe ich bereits ausgeführt gehabt.

Folgende Quellen benutze ich:

Code: Alles auswählen

cat /etc/apt/sources.list /etc/apt/sources.list.d/*.list 

Code: Alles auswählen

root@taurus:/home/mschwarz# cat /etc/apt/sources.list /etc/apt/sources.list.d/*.list
# Debian packages for testing
deb http://ftp.de.debian.org/debian/ stretch main contrib non-free
# Uncomment the deb-src line if you want 'apt-get source'
# to work with most packages.
# deb-src http://mirror.23media.de/debian/ testing main contrib non-free

# Security updates for stable
deb http://security.debian.org/ stable/updates main contrib non-free
deb http://downloads.linux.hpe.com/SDR/repo/mcp/ wheezy/current non-free
# X2Go Repository (release builds)
deb http://packages.x2go.org/debian jessie main
# X2Go Repository (sources of release builds)
deb-src http://packages.x2go.org/debian jessie main

# X2Go Repository (nightly builds)
#deb http://packages.x2go.org/debian jessie heuler
# X2Go Repository (sources of nightly builds)
#deb-src http://packages.x2go.org/debian jessie heuler

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 21287
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von KBDCALLS » 17.07.2017 14:28:22

Am besten erstmal die sources.list löschen und eine mit nur einem Eintrag erstellen.

Code: Alles auswählen

deb http://ftp.de.debian.org/debian/ stretch main contrib non-free
oder

Code: Alles auswählen

deb http://ftp.nl.debian.org/debian/ stretch main contrib non-free
Dann aptiude update ; aptitude full-upgrade -V Und was wird gemeldet ?
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

unamx
Beiträge: 6
Registriert: 12.07.2017 08:55:32

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von unamx » 17.07.2017 14:47:13

sources-list habe ich gelöscht, danach apt-get update und danach apt-get full-upgrade -V

Code: Alles auswählen

471 aktualisiert, 514 neu installiert, 57 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 1.084 kB von 2.872 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 2.255 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
Fehl:1 http://ftp.de.debian.org/debian stretch/main amd64 libxatracker2 amd64 13.0.6-1+b2
  Verbindung fehlgeschlagen
E: Fehlschlag beim Holen von http://ftp.de.debian.org/debian/pool/main/m/mesa/libxatracker2_13.0.6-1+b2_amd64.deb  Verbindung fehlgeschlagen
E: Einige Archive konnten nicht heruntergeladen werden; vielleicht »apt-get update« ausführen oder mit »--fix-missing« probieren?

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 21287
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von KBDCALLS » 17.07.2017 14:59:11

Läßt sich das denn herunterladen .

Code: Alles auswählen

wget http://ftp.de.debian.org/debian/pool/main/m/mesa/libxatracker2_13.0.6-1+b2_amd64.deb
Wenn nein , was ergibt

Code: Alles auswählen

traceroute ftp.de.debian.org
Sieht mir jetzt eher danach aus als wenn das Problem ganz woanders liegt.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

unamx
Beiträge: 6
Registriert: 12.07.2017 08:55:32

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von unamx » 17.07.2017 15:44:55

Der Download scheitert.

Code: Alles auswählen

root@taurus:~# traceroute ftp.de.debian.org
traceroute to ftp.de.debian.org (141.76.2.4), 30 hops max, 60 byte packets
 1  x.x.x.x (192.168.1.1)  0.205 ms  0.143 ms  0.144 ms
 2  x.x.x.x (x.x.x.x)  9.620 ms  9.623 ms  9.604 ms
 3  l-ea4-i.l.de.net.dtag.de (x.x.x.x)  16.298 ms  16.303 ms  16.247 ms
 4  80.156.160.142 (80.156.160.142)  20.878 ms  21.170 ms  21.150 ms
 5  kr-drn3.x-win.dfn.de (188.1.243.34)  29.793 ms  30.148 ms  29.897 ms
 6  ph-bey.campus.urz.tu-dresden.de (141.30.1.82)  30.039 ms  30.124 ms  29.922 ms
 7  cat6k-hem-vl970.campus.urz.tu-dresden.de (141.30.1.57)  29.926 ms  29.940 ms  29.611 ms
 8  cat6k-inf.campus.urz.tu-dresden.de (141.30.1.114)  29.776 ms  29.909 ms  29.805 ms
 9  * ftp.de.debian.org (141.76.2.4)  28.234 ms  28.361 ms

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 21287
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von KBDCALLS » 17.07.2017 15:49:50

Versuchs mal mit dem Niederländischen Server. Also nl statt de
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

Benutzeravatar
berlinerbaer
Beiträge: 3297
Registriert: 28.04.2003 01:29:55
Wohnort: daheim
Kontaktdaten:

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von berlinerbaer » 17.07.2017 16:57:46

da habe ich entweder mal wieder mehr Glück als Verstand gehabt oder der Linux-Gott hat mich für meine Ausdauer belohnt :mrgreen:
Bei mir hatte noch nie ein dist-upgrade geklappt, seit 2002 nicht und ich hatte es mir schon zur Gewohnheit gemacht, immer wieder (unter Beibehaltung der Partitionen und Erhaltung der Home und der Opt) komplett neu zu installieren. Im günstigten Fall dauerte das etwa eine bis eineinhalbe Stunde.

Dann hatte ich Jessie drauf und einfach keine Zeit wieder alles platt zu machen und ich tat diesmal etwas, was ich schon Jahre nicht mehr gemacht hatte - dist-upgrade - aus synaptic heraus und dann erledigte ich andere Arbeiten und schrieb allerdings mein System in meinem Innersten schon ab und richtete mich drauf, irgendwann wieder von Grund auf neu zu installieren.

Diesmal dauerte das keine Stunde, auch nicht anderthalb Stunden - das dauerte sage und schreibe vier Stunden - dann fuhr der Rechner runter und startete zu meiner größten Überraschung reibungslos mit nahezu fast allem, was vorher drauf war (lediglich ein paar einzelne Fremdquellen für Bluegriffon, Darktable und Lightroom mußte ich nachbasteln). Danach lief alles, flott und störfrei.

So bis dato, kann auch nicht sagen warum, an mir kann es nicht liegen. :lol:
Ebenso wenig kann ich sagen, warum es bei manch anderen so nicht klappt. Ist halt Linux.
Gruß
vom Bären

Endlich in Rente! Nur weg aus dem Irrenhaus.

unamx
Beiträge: 6
Registriert: 12.07.2017 08:55:32

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von unamx » 17.07.2017 17:03:59

Mit dem niederländsichen Server kommt diesselbe Meldung

Code: Alles auswählen

Fehl:1 http://ftp.nl.debian.org/debian stretch/main amd64 libxatracker2 amd64 13.0.6-1+b2
  Verbindung fehlgeschlagen [IP: 130.89.149.21 80]
E: Fehlschlag beim Holen von http://ftp.nl.debian.org/debian/pool/main/m/mesa/libxatracker2_13.0.6-1+b2_amd64.deb  Verbindung fehlgeschlagen [IP: 130.89.149.21 80]
E: Einige Archive konnten nicht heruntergeladen werden; vielleicht »apt-get update« ausführen oder mit »--fix-missing« probieren?

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 21287
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von KBDCALLS » 17.07.2017 17:27:09

Das update funktioniert ? Aber das dist-upgrade bzw. full-upgrade nicht mehr ?
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

Benutzeravatar
geier22
Beiträge: 2235
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von geier22 » 18.07.2017 06:37:37

http://ftp.de.debian.org/debian/pool/ma ... _amd64.deb
der Download funktioniert.
ich würde einfach anschließend mit dpkg installieren. Und gut ist, wenn das das einzige Paket ist,
an dem es hängt.
4.13.0-1-amd64 #1 SMP Debian 4.13.4-2 (2017-10-15) (Buster)/ XFCE 4.12.3 / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI (Treiber 375.82-8) / HP LP3065

guennid
Beiträge: 11019
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: Fehler bei dist-upgrade auf Stretch

Beitrag von guennid » 18.07.2017 07:47:07

Man verzeihe die Frage eines Unwissenden, aber kann das gutgehen mit diesem Versionsmix aus stretch, jessie und wheezy? Will sagen: lässt sich das im Nachhinein überhaupt noch sinnvoll reparieren?

Antworten