[gelöst] stretch und efi mixed/eficross

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
smutbert
Beiträge: 5550
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

[gelöst] stretch und efi mixed/eficross

Beitrag von smutbert » 13.09.2017 10:38:13

Hi,

auf einem alten MacPro mit amd64-CPUs und i386-EFI steh ich vor dem Problem, dass er mit stretch nicht bootet, während jessie keinerlei Probleme verursacht.

grub-ia32 aus Stretch lädt noch problemlos und macht seinerseits auch keine Schwierigkeiten den jessie-Kernel zu starten, aber nach dem Laden des stretch-Kernels (egal ob 4.9 oder 4.12) und der initrd bleibt es bei einem schwarzen Bildschirm mit blinkenden Cursor.
Auch ohne "quiet" gibt es keine Meldungen, also nehme ich an, dass es direkt nach grub hängt.

Wobei vielleicht noch erwähnenswert ist, dass Kernel 4.9 genau einmal (ungefähr beim 7. Versuch) ganz normal gestartet ist, aber davor und danach nicht mehr, auch nicht mit dem grub von jessie.
Jetzt bin ich kurz davor entweder auf den Legacy-Modus und grub-pc oder eine i386-Installation auszuweichen, aber bevor ich das mache frage ich lieber hier nach Tipps - schließlich bin ich noch nicht einmal 100%ig sicher, dass es am 32Bit EFI liegt - es ist lediglich die auffälligste Besonderheit des Computers.

lg smutbert
Zuletzt geändert von smutbert am 14.09.2017 14:42:21, insgesamt 1-mal geändert.

Benutzeravatar
smutbert
Beiträge: 5550
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: [hoffentlich gelöst] stretch und efi mixed/eficross

Beitrag von smutbert » 13.09.2017 14:50:43

Nach einem nvram-Reset und mit der Kerneloption »noefi« (entscheidend dürfte letzteres sein) scheint stretch zuverlässig zu starten.

Antworten