Passwort für Root wird nicht akzeptiert!!

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
voigf
Beiträge: 46
Registriert: 17.03.2013 20:11:04

Passwort für Root wird nicht akzeptiert!!

Beitrag von voigf » 04.12.2017 01:02:24

Habe heute Debian 9.2 von einer DVD installiert. Beim ersten Booten wird mein von mir vergebenes User-Passwort im Anmeldebildschirm erkannt. Soweit, so gut! Aber...
-Bei einem ersten Installationsprozess werden sowohl das Root- als auch mein User-Passwort, eingetragen während des Installationsprozesses, nicht akzeptiert!! Mein Keyboard hat eine deutsche Einstellung!
@debian9:~$ su
Passwort:
su: Fehler bei Authentifizierung
xyz@debian9:~$ sudo apt-get install vlc
[sudo] Passwort für xyz:
xyz ist nicht in der sudoers-Datei. Dieser Vorfall wird gemeldet.
xyzt@debian9:~$
- Wie trage ich mich in die im Text angesprochene 'sudoers-Datei' ein?
- Wer kann mir weiterhelfen?
Vielen Dank im Voraus
voigf

Benutzeravatar
CH777
Beiträge: 1117
Registriert: 27.05.2008 16:37:17

Re: Passwort für Root wird nicht akzeptiert!!

Beitrag von CH777 » 04.12.2017 07:58:56

voigf hat geschrieben: ↑ zum Beitrag ↑
04.12.2017 01:02:24
- Wie trage ich mich in die im Text angesprochene 'sudoers-Datei' ein?
Als root

Code: Alles auswählen

visudo -f /etc/sudoers
Ansonsten ist der erste Verdächtige in der Tat die Keyboardbelegung. Erscheint das Passwort korrekt, wenn du es einfach so eintippst (Sonderzeichen, Umlaute, etc)?

nudgegoonies
Beiträge: 734
Registriert: 16.02.2009 09:35:10

Re: Passwort für Root wird nicht akzeptiert!!

Beitrag von nudgegoonies » 04.12.2017 15:01:56

Das wäre auch mein Tip gewesen. Tipp Dein Passwort mal in das Feld für den Benutzernamen umzu sehen ob die Tastatureingabe stimmt oder gehe auf eine reine Textkonsole und tippe es beim Anmeldenamen.
Software: Jessie AMD64, XFCE. Repo's: Backports, Mozilla-Backports, Keine Proposed. Grafik: Radeon 4670 MESA.
Hardware: Intellistation 9229 i975X, 4GB RAM, Intel Q6600, BCM5752 NIC, EMU10K1, SATA SSD+HD, IDE DVD+RW.

Benutzeravatar
geier22
Beiträge: 2366
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: Passwort für Root wird nicht akzeptiert!!

Beitrag von geier22 » 04.12.2017 16:03:07

Als root

Code: Alles auswählen

visudo -f /etc/sudoers
Geht wohl nicht, wenn root nicht akzeptiert wird

Ich hatte das Problem auch.
Ich kopiere mal einfach meinem Beitrag, der damals geholfen hat:
viewtopic.php?f=12&t=161270&hilit=root#p1095516
Was du vor einer Neuinstallation noch versuchen kannst:

Im GRUB Menue mit Hilfe der [Pfeiltasten] den gewünschten Booteintrag auswählen (das ist meistens jener, der automatisch vorausgewählt ist)
Taste [e] drücken, um den Eintrag zu editieren
[Pfeiltasten] verwenden, um die Kernelzeile auszuwählen
die sollte so ähnlich aussehen :

Code: Alles auswählen

linux	/boot/vmlinuz-4.6.0-1-amd64 root=UUID=97ec7c1a-9ccf-4672-86f1-e9dbb2b36236 ro  quiet splash
am Ende dieser Zeile das Wort

Code: Alles auswählen

init=/bin/bash
ergänzen (mit einem Leerzeichen vor dem vorhergehenden Parameter getrennt)

ACHTUNG: Englische Tastaturbelegung
Dann mit Strg+x das ganze booten.
Wenn du Glück hast, landest du dann auf einer root Shell
dann:

Code: Alles auswählen

mount -rw -o remount /
und dann kannst du mit dem Befehl

Code: Alles auswählen

passwd
ein Passwort setzen.
reboot und gut ist (eventuell)
Edit:
Ich weiß ja nicht, ob dein "Fall" mit dem aus dem angegebenen Thread übereinstimmt, machen kannst du es in jedem Fall so.

Die Auflösung und das Warum gab es dann in diesem Thread weiter hinten:
viewtopic.php?f=12&t=161270&hilit=root& ... 0#p1095809
4.13.0-1-amd64 #1 SMP Debian 4.13.4-2 (2017-10-15) (Buster)/ XFCE 4.12.3 / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI (Treiber 375.82-8) / HP LP3065

voigf
Beiträge: 46
Registriert: 17.03.2013 20:11:04

Re: Passwort für Root wird nicht akzeptiert!!

Beitrag von voigf » 06.12.2017 18:43:20

Erst einmal vielen Dank für die schnellen Tipps. Komme erst heute zu einer Antwort. War 'aushäusig'.
Aber jetzt zu den Ergebnissen...
Leider hatte ich mit euren Vorschlägen keinen Erfolg!
Zum einen waren die Tipps nicht anwendbar, da ich, wie beschrieben, keinen Root-Zugang hatte, zum anderen wurden die Eingaben vom Rechner aus gleichen Gründen nicht angenommen. Entweder wurde nach dem Root- oder dem Userpasswort gefragt!! Schiet!!
Aber jetzt zur Lösung!
Ich habe das BS noch einmal, dieses Mal NICHT im Experten-Modus, sondern einfach den angebotenen 'Install'-Modus gewählt. Es ist nahezu der gleiche Installationsprozess, natürlich auch mit den Abfragen der Root-/User-Passwörter. Nur diesmal wurden sie nach der Installation sofort akzeptiert. :hail:

Mein erster Eindruck zur neuen Version lässt die Frage aufkommen, warum es überhaupt eine Debian 9 geben musste. Es läuft größtenteils alles wie gewohnt. Leider sind ein paar gerne genutzte Annehmlichkeiten weggefallen, aber sonst....

Ich melde mich bei neuen Schwierigkeiten wieder! 8)
Bis dahin nochmals danke für eure schnellen Tipps.
voigf

Radfahrer
Beiträge: 3249
Registriert: 15.12.2012 20:48:16
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Zu Hause

Re: Passwort für Root wird nicht akzeptiert!!

Beitrag von Radfahrer » 06.12.2017 18:47:18

voigf hat geschrieben: ↑ zum Beitrag ↑
06.12.2017 18:43:20
Mein erster Eindruck zur neuen Version lässt die Frage aufkommen, warum es überhaupt eine Debian 9 geben musste.
Warum musste es ein Debian 2 geben? :wink:
"Glauben bedeutet, Behauptungen sogar gegen besseres (Nicht-)Wissen für wahr zu halten, ohne einen seriösen Beweis dafür zu verlangen. Und ohne zu hinterfragen, wie plausibel die Glaubensinhalte eigentlich wirklich sind."
https://wenigerglauben.de/

fireburner
Beiträge: 2
Registriert: 01.12.2017 20:51:31
Lizenz eigener Beiträge: GNU General Public License
Wohnort: der wilde Süden

Re: Passwort für Root wird nicht akzeptiert!!

Beitrag von fireburner » 07.12.2017 18:02:27

Es scheint da einen bekannten Bug zu geben.
Siehe z.B.: http://forums.debian.net/viewtopic.php?f=10&t=133551
Hatte das auch letztens mal bei einer Installation. Sofern du später sudo verwenden möchtest kannst du das Root Passwort bei der Installation leer lassen (dann wird dein User automatisch für Sudo freigegeben) und du kannst später manuell ein Root Passwort setzen (sofern gewünscht).

Antworten