Problem bei Buster dist-upgrade

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
jue
Beiträge: 391
Registriert: 25.11.2006 17:44:25
Wohnort: Mitteleuropa

Problem bei Buster dist-upgrade

Beitrag von jue » 04.12.2018 08:21:17

Guten Morgen Miteinander,
heute früh habe ich bei Buster ein dist-upgrade gemacht und es kam ein neuer Kernel. Beim Neustart konnte die grafische Oberfläche nicht richtig gestartet werden. Ich verwende sddm und LXQt. Das System war nicht zugänglich. Strg+Alt+F1 usw. brachte nicht die Konsolen tty1 bis tty6. Ein gewaltsamer Reboot und die Wahl des alten Kernels funktionierte dagegen problemlos. Ich mache mir keine grossen Gedanken, denke, dass es sich mit weiteren Upgrades bereinigt. Ich wollte das nur als Warnung berichten.
Gruss von jue
-----------------------------

MSfree
Beiträge: 3632
Registriert: 25.09.2007 19:59:30

Re: Problem bei Buster dist-upgrade

Beitrag von MSfree » 04.12.2018 10:03:54

jue hat geschrieben: ↑ zum Beitrag ↑
04.12.2018 08:21:17
Ich mache mir keine grossen Gedanken, denke, dass es sich mit weiteren Upgrades bereinigt. Ich wollte das nur als Warnung berichten.
Du hast eine Graphikkarte von AMD oder Nvidia?

Ja, da kann das bei Debian-Testing schonmal vorkommen, daß bei einem Upgrade das Kernelmodul für deine Graphikkarte nicht aktualisiert wird. :wink:

Benutzeravatar
jue
Beiträge: 391
Registriert: 25.11.2006 17:44:25
Wohnort: Mitteleuropa

Re: Problem bei Buster dist-upgrade

Beitrag von jue » 04.12.2018 11:57:10

MSfree hat geschrieben: ↑ zum Beitrag ↑
04.12.2018 10:03:54
Du hast eine Graphikkarte von AMD oder Nvidia?
Nein, da ist was anderes drin. Ich bin aber gerade nicht am Gerät. Es ist ein TP T410. Es ist wahrscheinlich eine Intel GM 5700 (Integrated HD Graphics).

Nachtrag 1: Ich bin jetzt wieder am Gerät. linux-image-4.18.0-2-amd64 macht keine Probleme. Das Problem tritt nur mit linux-image-4.18.0-3-amd64 auf.
lspci -nnk | grep -i VGA -A2 sagt:
VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
Subsystem: Lenovo Core Processor Integrated Graphics Controller [17aa:215a]
Kernel driver in use: i915
Nachtrag 2: vielleicht ist es dieses Problem:
https://bugs.debian.org/cgi-bin/bugrepo ... bug=914495
Ich werde aber nicht recht schlau daraus.
Gruss von jue
-----------------------------

DerChris
Beiträge: 275
Registriert: 16.03.2009 16:45:12
Lizenz eigener Beiträge: MIT Lizenz

Re: Problem bei Buster dist-upgrade

Beitrag von DerChris » 05.12.2018 17:19:37

jue hat geschrieben: ↑ zum Beitrag ↑
04.12.2018 11:57:10
Nachtrag 1: Ich bin jetzt wieder am Gerät. linux-image-4.18.0-2-amd64 macht keine Probleme. Das Problem tritt nur mit linux-image-4.18.0-3-amd64 auf.
Ich habe hier ebenfalls das Verhalten/Problem. Thinkpad X61s, Intel-Grafik, sid & i3-wm, kein Displaymanager.
sid & i3

KP97
Beiträge: 1533
Registriert: 01.02.2013 15:07:36

Re: Problem bei Buster dist-upgrade

Beitrag von KP97 » 05.12.2018 19:13:23

Ich habe zwar kein Problem, da ich meine Kernel selbst baue, aber ihr könntet ja mal den xserver-xorg-video-intel aus dem Repo probieren.
Ich nutze den schon lange, und das ist sicher besser als nomodeset.
Versuch macht kluch...

Benutzeravatar
jue
Beiträge: 391
Registriert: 25.11.2006 17:44:25
Wohnort: Mitteleuropa

Re: Problem bei Buster dist-upgrade

Beitrag von jue » 06.12.2018 15:29:00

KP97 hat geschrieben: ↑ zum Beitrag ↑
05.12.2018 19:13:23
... den xserver-xorg-video-intel aus dem Repo probieren ...
Ja, das teste ich gleich heute Abend, wenn ich wieder am Thinkpad sitze. Danke.
Update: ich konnte es jetzt testen. Leider hatte ich keinen Erfolg mit dem xserver-xorg-video-intel. Egal, kommt Zeit, kommt Rat.
Gruss von jue
-----------------------------

nudeldieb
Beiträge: 1
Registriert: 10.12.2018 20:53:33

Re: Problem bei Buster dist-upgrade

Beitrag von nudeldieb » 10.12.2018 21:02:42

Hi,
dasselbe Problem hier, Reboot nach neuem Kernel (Buster -> aptitude safe-upgrade) funktioniert erstmal bis der Bildschirm schwarz bleibt.
Keine tty Konsolen mit alt-f*, kein Login: hier allerdings cinnamon, ist aber glaube ich egal.
Alter Kernel tut's, Grafikkarte ist eine Intel Mobile 4 Series, also nix prop. wie nvidia...
Test mal den xserver-xorg-video-intel und melde mich.
Update: nix gebracht, gucke mir den Bugreport von oben an, ist ja der abgeschlossene Roman ... :lol:
Update2: wie ich das versrtanden habe, ist das als Bug bei Debian als auch bei freedektop gefiled. i915 schent das Problem zu sein (https://bugs.debian.org/cgi-bin/bugrepo ... 914495#138), sollte aber mit einem der nächsten Kernel Updates behoben sein: https://bugs.freedesktop.org/show_bug.cgi?id=108850

Naja, wir gucken mal ...

Benutzeravatar
jue
Beiträge: 391
Registriert: 25.11.2006 17:44:25
Wohnort: Mitteleuropa

Re: Problem bei Buster dist-upgrade

Beitrag von jue » 11.12.2018 09:00:08

nudeldieb hat geschrieben: ↑ zum Beitrag ↑
10.12.2018 21:02:42
Naja, wir gucken mal ...
Hi , nudeldieb - willkommen hier!

Ich verwende einfach den alten Kernel weiter und schaue ab und zu, ob ein neuer Kernel angeboten wird.
(Oder will mich mein Karma zwingen das Kompilieren zu lernen?)
Gruss von jue
-----------------------------

Antworten