can't access tty; job control turned off Debian 7.4

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
madao
Beiträge: 3
Registriert: 28.02.2014 12:54:12

can't access tty; job control turned off Debian 7.4

Beitrag von madao » 28.02.2014 13:19:35

Hey Folks,
ich habe ein Problem mit folgender Ausgabe:
can't access tty; job control turned off

Wenn ich meinen Debian Wheezy 7.4 Server starte wird Grub2 normal geladen das System versucht zu starten es erscheint die Ausgabe :

!Alert /dev/disk/by-uuid/6f4df274-1840-48ab-9ec6-5205c441fc70 does not exist

Dies scheint mein Root System zu sein. (fstab und blkid.tab angefügt)
Die nächste Ausgabe ist:

/bin/sh: can't access tty; job control turned off

Danach bekomme ich eine Konsole in der (initramfs) steht.

Versuche ich mount -a um alle eingetragenen Systeme in /etc/fstab zu mounten spuckt die Konsole mount: Can't read '/etc/fstab' no such file or directory
Auf die Datei Fstab scheine ich generell keinen Zugriff zu haben. Mount als Befehl scheint aber zu funktionieren. fstab und blkid.tab konnte ich via Rescue Mode und anderem Linux System auslesen.

Meinen Recherchen zu Folge kann es reichen mit einer leeren Diskette zu booten, da ich kein Disketten Laufwerk einbauen kann habe ich alternativ einen leeren USB Stick versucht, dies führte aber nicht zum Gewünschten Ergebnis.
Die klassische Vorgehensweise scheint die Neuinstallation von Grub oder das anpassen der menu.lst (/boot/grub/menu.lst). Diese ist auf meinem System nicht vorhanden. Ich benutze Grub2 und dort soll diese Datei generell nicht exestieren.
Demnach fällt menu.lst anpassen und UUID's zu setzen wohl weg.

Die Reperatur via Rescatux oder Super Grub2 Disk war auch nicht möglich, Rescatux hat einfach ohne Fehler die Operation beendet und SG2D ausgab:
missing bootmgr

Zum System ich nutze ein LVM mit 2 Festplatten a 2TB. Die letzten Änderungen am System waren WakeonLan via ethtool. Einmaliges Ausprobieren, keine Dauerhafte Aktivierung. Und apt-get udate & upgrade.

Mit freundlichen Grüßen,
Madao

Inhalt von fstab

Code: Alles auswählen

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/LittleRabbit-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
#UUID=a4ffd04e-ef26-4934-b435-be5030eb308a /boot           ext2    defaults        0       2
/dev/mapper/LittleRabbit-home /home           ext4    defaults        0       2
/dev/mapper/LittleRabbit-tmp /tmp            ext4    defaults        0       2
#/dev/mapper/LittleRabbit-usr /usr            ext4    defaults        0       2
/dev/mapper/LittleRabbit-var /var            ext4    defaults        0       2
/dev/mapper/LittleRabbit-swap_1 none            swap    sw              0       0
/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0
UUID=a4ffd04e-ef26-4934-b435-be5030eb308a	/boot	ext2	defaults	0	2
UUID=a3c384e0-4dd5-4660-be5c-c185944fec10	/usr	ext4	defaults	0	2
#/dev/sdb    /Rack2-Data    ext4 rw,auto,users    0  2
Inhalt von blkid.tab

Code: Alles auswählen

<device DEVNO="0xfe01" TIME="1383146669.463689" PRI="45" UUID="1419da2f-f658-485c-a4e4-9f5b23393f9e" TYPE="swap">/dev/mapper/LittleRabbit-swap_1</device>
<device DEVNO="0x0805" TIME="1393249329.411087" UUID="JdOZ4x-cAaJ-oRiX-YJNP-5J73-495W-T50qao" TYPE="LVM2_member">/dev/sda5</device>
<device DEVNO="0x0801" TIME="1383146669.417152" UUID="a4ffd04e-ef26-4934-b435-be5030eb308a" TYPE="ext2">/dev/sda1</device>
<device DEVNO="0xfe00" TIME="1383146669.463387" PRI="45" UUID="6f4df274-1840-48ab-9ec6-5205c441fc70" TYPE="ext4">/dev/mapper/LittleRabbit-root</device>
<device DEVNO="0xfe02" TIME="1383146669.463916" PRI="45" UUID="a3c384e0-4dd5-4660-be5c-c185944fec10" TYPE="ext4">/dev/mapper/LittleRabbit-usr</device>
<device DEVNO="0xfe03" TIME="1383146669.464131" PRI="45" UUID="d49d449f-14fc-4110-a27d-d40a22bd7a2c" TYPE="ext4">/dev/mapper/LittleRabbit-var</device>
<device DEVNO="0xfe04" TIME="1383146669.464535" PRI="45" UUID="e2ca4f51-bda5-4599-ac65-19fc16cc1cdc" TYPE="ext4">/dev/mapper/LittleRabbit-tmp</device>
<device DEVNO="0xfe05" TIME="1383146669.464787" PRI="45" UUID="18f63792-6166-4cba-a850-6b4a87ee1d46" TYPE="ext4">/dev/mapper/LittleRabbit-home</device>
<device DEVNO="0x0821" TIME="1393249329.841505" UUID="SgzLMK-GDP3-uB1n-ju9n-zTMu-MNRA-mlBChu" TYPE="LVM2_member">/dev/sdc1</device>
<device DEVNO="0x0822" TIME="1393249330.178435" UUID="jppWWv-ORQu-Y43i-ko0L-am9V-thqI-3K00ap" TYPE="LVM2_member">/dev/sdc2</device>

rendegast
Beiträge: 15040
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: can't access tty; job control turned off Debian 7.4

Beitrag von rendegast » 28.02.2014 13:57:06

Alert /dev/disk/by-uuid/6f4df274-1840-48ab-9ec6-5205c441fc70 does not exist
Fehlt in der grub.cfg vielleicht ein Eintrag

Code: Alles auswählen

> insmod lvm
Gegebenenfalls auf der grub-shell ausführen.

Auf der grub-shell kannst Du Dir die verfügbaren/erkannten devices ausgeben lassen

Code: Alles auswählen

> irgendwas ( <TAB>
(im grub-Syntax)
Um gegebenenfalls

Code: Alles auswählen

> set root=(......)
zu korrigieren, anzupassen
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

madao
Beiträge: 3
Registriert: 28.02.2014 12:54:12

Re: can't access tty; job control turned off Debian 7.4

Beitrag von madao » 28.02.2014 15:18:26

Ich habe jetzt mal die grub.cfg ausgelesen, ist es richtig das die UUID statt a4ffd04e-ef26-4934-b435-be5030eb308a die UUID 6f4df274-1840-48ab-9ec6-5205c441fc70 sein sollte?
Ist das sinvoll den auf a4ffd04e-ef26-4934-b435-be5030eb308a liegt laut fstab /boot.

Code: Alles auswählen

insmod part_msdos
insmod ext2
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set=root a4ffd04e-ef26-4934-b435-be5030eb308a
if loadfont /grub/unicode.pf2 ; then
 set gfxmode=640x480
 load_video
 insmod gfxterm
 insmod part_msdos
 insmod ext2
 set root='(hd0,msdos1)'
 search --no-floppy --fs-uuid --set=root a4ffd04e-ef26-4934-b435-be5030eb308a
 set locale_dir=($root)/grub/locale
 set lang=de_DE
 insmod gettext
fi
terminal_output gfxterm
set timeout=10
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=cyan/blue
set menu_color_highlight=white/blue
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Debian GNU/Linux, mit Linux 3.2.0-4-amd64' --class debian --class gnu-linux --class gnu --class os {
	load_video
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos1)'
	search --no-floppy --fs-uuid --set=root a4ffd04e-ef26-4934-b435-be5030eb308a
	echo	'Linux 3.2.0-4-amd64 wird geladen '
	initrd	/initrd.img-3.2.0-4-amd64
}
menuentry 'Debian GNU/Linux, mit Linux 3.2.0-4-amd64 (Wiederherstellungsmodus)' --class debian --class gnu-linux --class gnu --class os {
	load_video
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos1)'
	search --no-floppy --fs-uuid --set=root a4ffd04e-ef26-4934-b435-be5030eb308a
	echo	'Linux 3.2.0-4-amd64 wird geladen '
	initrd	/initrd.img-3.2.0-4-amd64
}

rendegast
Beiträge: 15040
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: can't access tty; job control turned off Debian 7.4

Beitrag von rendegast » 28.02.2014 16:39:06

menuentry 'Debian GNU/Linux, mit Linux 3.2.0-4-amd64' --class debian --class gnu-linux --class gnu --class os {
load_video
insmod gzio
insmod part_msdos
insmod ext2
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set=root a4ffd04e-ef26-4934-b435-be5030eb308a
echo 'Linux 3.2.0-4-amd64 wird geladen '
???????????????????????????????????????
initrd /initrd.img-3.2.0-4-amd64
Da fehlt

Code: Alles auswählen

        linux   /boot/vmlinuz-3.2.0-4-686-pae root=UUID=6f4df274-1840-48ab-9ec6-5205c441fc70 .............
        echo    'Loading initial ramdisk ...'
Hast Du das vmlinuz-Ding vielleicht händisch gelöscht?
-> Reinstallieren,
oder aus dem heruntergeladenen Kernelpaket extrahieren, dorthin kopieren, und beim Booten obige (evtl weiter angepaßte) 'linux /boot/.....'-Zeile in der grub-shell eintragen, dann booten und komplettieren (Reinstall, upgrade-grub).
EDIT Gemeint ist natürlich
linux /boot/vmlinuz-3.2.0-4-amd64 .............................


'insmod lvm' muß wohl nicht in grub.cfg stehen,
da das boot-Dateisystem ja auf einem "echten" ext-FS liegt,
und das lvm und damit das root-Dateisystem wohl durch Vorgänge in der initrd für den Kernel verfügbar gemacht wird.
Zuletzt geändert von rendegast am 10.03.2014 07:48:43, insgesamt 1-mal geändert.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

madao
Beiträge: 3
Registriert: 28.02.2014 12:54:12

Re: can't access tty; job control turned off Debian 7.4

Beitrag von madao » 09.03.2014 21:44:13

So es hat jetzt bei mir etwas gedauert zu verstehen was da los ist
und wie das aufgebaut ist.

Mit dem Einsetzen der Zeile,

Code: Alles auswählen

            linux   /boot/vmlinuz-3.2.0-4-686-pae root=UUID=6f4df274-1840-48ab-9ec6-5205c441fc70 .............
            echo    'Loading initial ramdisk ...'
kam die Aufforderung von Grub den Kernel zu laden.
Ich habe jetzt nochmal die Ausgabe angefügt, welche ich erhalte wenn ich im Grub 'e' drücke.
Die Datei vmlinuz scheint auf der boot Partition vorhanden zu sein.
Um dies zu Testen habe ich ein Ubuntu Livesystem verwendet.
Desweiteren habe ich eine Festplatte eingesteckt auf der ein funktionsfähiges Kubuntu läuft und dessen Grub geupdated in der Hoffnung das dieses vielleicht weiterhilft aber Fehlanzeige.

Bild

rendegast
Beiträge: 15040
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: can't access tty; job control turned off Debian 7.4

Beitrag von rendegast » 10.03.2014 07:45:44

Mit dem Einsetzen der Zeile,
Machst nicht Du, sondern

Code: Alles auswählen

update-grub
natürlich nur, wenn dieses einen entsprechenden Kernel findet.
(oben EDIT, gemeint war "/boot/vmlinuz-3.2.0-4-amd64 ......")
Beim Arbeiten in der grub-shell kann Dir command/Pfad-Completion helfen, Vertipper zu vermeiden.
Du kannst Dort ziemlich frei zwischen Kommandomodus 'c' (grub-shell) und Editiermodus 'e' wechseln.

Die Datei vmlinuz scheint auf der boot Partition vorhanden zu sein.

Code: Alles auswählen

ls -l /boot/

md5sum /boot/vmlinuz*

Reinstallieren

Code: Alles auswählen

aptitude reinstall linux-image-3.2.0-4-amd64
oder
apt-get install --reinstall linux-image-3.2.0-4-amd64
Erklärbar ist das ganze eigentlich nur, wenn Du entweder eklatante Festplatten/Dateisystemfehler
oder selbst irgendwo was geändert hast.
/etc/grub.d/10_linux :

Code: Alles auswählen

  message="$(gettext_printf "Loading Linux %s ..." ${version})"
  cat << EOF
        echo    '$message'
        linux   ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro ${args}
EOF
  if test -n "${initrd}" ; then
    message="$(gettext_printf "Loading initial ramdisk ...")"
    cat << EOF
        echo    '$message'
        initrd  ${rel_dirname}/${initrd}
EOF
message-Text und Eintrag tauchen immer zusammen auf, daher durch ein händisches Editieren?
(Englisch/Deutsch kommt durch die Lokalisierung.)
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

Antworten