wieder Bildschirmflackern mit stretch

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
Fluse
Beiträge: 6
Registriert: 05.06.2017 12:03:52

wieder Bildschirmflackern mit stretch

Beitrag von Fluse » 22.06.2017 13:06:38

Tach zusammen!

Disclaimer: Ich habe echt wenig Ahnung von der Materie. :oops: Weiß nicht mal genau, ob ich hier im richtigen Unterforum bin, hab' mir jetzt die Informationsbeschaffung zusammengegoogelt und hoffe, dass ich ungefähr das erwischt habe, was nötig ist. Habt also bitte ein wenig Nachsicht, wenn ich nicht gleich verstehe, was gemeint ist. Ich weiß, Ihr habt hier keine Kristallkugeln :mrgreen: hoffe aber, dass wir's irgendwie hinkriegen.

Es handelt sich um ein Lenovo T410, allgemeine Infos:
Speicher: 3,7 GiB
Prozessor: Intel Core i5 CPU M 520 @ 2.40GHz x 4
Grafik: Intel Ironlake Mobile
System: Debian GNU/Linux 9 (stretch) 64 Bit

etwas genauer zur Grafikkarte:

Code: Alles auswählen

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
	Subsystem: Lenovo Core Processor Integrated Graphics Controller [17aa:215a]
	Kernel driver in use: i915

Code: Alles auswählen

OpenGL version string: 2.1 Mesa 13.0.6
Vorgeschichte:
Bisher hatte ich auf dem Rechner Kubuntu laufen, gut zwei Jahre jetzt. Mit jeder neuen Version ist's mir aber mehr auf die Nerven gegangen, weil's immer langsamer wurde und dauernd was anderes nicht ging. Vertrieben hat mich am Ende folgendes: Wenn ich "ernsthaft" gearbeitet habe (= in der Konsole oder mit Kate), hat der Bildschirm immer wieder geflackert (= es zuckte ein schwarzer Balken durch die untere Bildschirmhälfte), zum Schluss fast jedes Mal, wenn ich eine Taste gedrückt habe. Manchmal war's dann sogar so, dass ich was eingegeben habe, dann wurde der Bildschirm schwarz, und nach ein paar Sekunden ist die Maschine ausgegangen. Am Ende alle paar Minuten, nicht sehr erbaulich. Ich kann davon keine Fehlermeldungen geben, weil ich da noch nicht wusste, wie das geht und das System nicht mehr da ist …
Wenn ich nur müßigen Kram gemacht habe, also mit Firefox im Netz gesurft, Filme geschaut, whatever, war nix.

Weil ich die Maschine nicht gern aufgeben wollte, habe ich probehalber Jessie installiert (mit Gnome), und siehe da, ich konnte wunderbar flackerfrei arbeiten. Aber da ich ein neugieriger Mensch bin, "musste" ich halt doch auf Stretch upgraden :roll: (hat auch nicht so super geklappt, ich hab's letztendlich neu aufgesetzt), und jetzt ist das Bildschirmflackern wieder da. Bisher nur ab und zu, aber unter Kubuntu hat das halt auch so angefangen. … :(
Auch hier passiert es, wenn ich mit gedit oder im Terminal arbeite oder in der Konsole (ich habe ein Programm, das nur in der Konsole läuft, deshalb musste ich die nachinstallieren. Hatte ich aber schon unter Jessie). Ach, und selten mit Midori. Firefox nicht. Jetzt habe ich mal ein log mitlaufen lassen, und heute früh habe ich ihn erwischt, als ich im Terminal war (abgesehen davon, dass er ständig meckert, wenn ich aufs Touchpad tapse):

Code: Alles auswählen

Jun 22 07:39:13 debian kernel: [ 2024.142091] [drm:ironlake_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Jun 22 07:39:13 debian kernel: [ 2024.142175] [drm:ironlake_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Passt das dazu? Kann damit jemand was anfangen? Hat das vielleicht sonst noch jemand?
Das, was ich in Google finde, kapiere ich nicht … :? oder es passt m.E. nicht zu meinem Fall …

Ich wäre sehr dankbar, wenn sich jemand bis hierher durchgebissen *keksreich* und vielleicht eine Idee hätte, was ich mit meinen bescheidenen Fähigkeiten tun könnte, um das abzustellen. Wenn Ihr noch mehr Infos braucht, liefere ich die gern, so ich kann.
Wenn jetzt jemand sagt, das ist zu aufwendig, lohnt nicht bei der alten Kiste, könnte ich mir auch vorstellen, zu Jessie zurückzugehen, das lief ja scheint's schön stabil. Fände ich aber halt irgendwie schade.

Vielleicht soviel, pardon für den langen wirren Text.
Dankeschön & liebe Grüßle
F.

Jana66
Beiträge: 3546
Registriert: 03.02.2016 12:41:11

Re: wieder Bildschirmflackern mit stretch

Beitrag von Jana66 » 26.06.2017 14:04:50

Schliesse erst mal Hardwarefehler mit einer völlig anderen Live-Distribution aus. Ich würde Ubuntu Gnome oder Mint Cinnamon verwenden. Jeweils LTS-Version. Die genajnten Desktoeppe (Gnome und "Ableger" sollten am besten in die jeweilige Distri integriert sein. Also nicht installieren, nur von USB booten und damit ein Weilchen arbeiten, "Stress" machen. Funktioniert es?

Könntest auch mal während des Betriebes das Display relativ zum "Rest" mehrfach bewegen. Wenn du damit das Flackern provozieren kannst, ist es ein Kabelbruch, "Wackelkontakt".

Irgendwelche groesseren Strom-Verbraucher mit starken Wechselfeldern (Halogentrafo Schreibtischlampe, Energiesparlampen) oder HF-Sender (WLAN, Smartphone ... ) oder PowerLAN-Adapter sind nicht in der Nähe des Laptops? Ist zwar unwahrscheinlich - Funkmaus? Hilft ein Ortswechsel in ein bezüglich HF und Wechselfeldern "stilles Kaemmerlein"?
Wenn keiner was sagt, wird sich nichts ändern. Wenn alle nur reden ebenfalls nicht.

owl102
Beiträge: 2296
Registriert: 16.10.2010 13:05:57
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Timbuktu

Re: wieder Bildschirmflackern mit stretch

Beitrag von owl102 » 28.06.2017 09:05:13

Fluse hat geschrieben:

Code: Alles auswählen

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
	Subsystem: Lenovo Core Processor Integrated Graphics Controller [17aa:215a]
	Kernel driver in use: i915
Ich habe einen Lenovo X201, der ja der gleichen Generation wie dein T410 angehört, und folgende Daten:

Code: Alles auswählen

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device 215a
        Flags: bus master, fast devsel, latency 0, IRQ 26
        Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 1800 [size=8]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
        Kernel modules: i915
(Also exakt das gleiche Ding.)

Auf der Kiste habe ich kein Debian laufen, sondern Fedora, aber auch ich hatte im Laufe der letzten Jahre zwei längere Zeiträume lang das von dir beschriebene Bildschirmflackern, immer wenn ich was getippt hatte, im Terminal oder Gedit. Meine Vermutung war seinerzeit, daß es mit den Wayland-Anpassungen am i915-Treiber zusammenhing, denn manchmal traten die Probleme nur unter Wayland auf, nach einem Update dann nur unter X. (Es gab sogar Treiberversionen, wo nach einiger Zeit der Bildschirm ganz ausfiel und nur ein bunter linker Pixelrand übrig blieb. Siehe auch meine Beiträge im Wayland-Thread.) Qt-Anwendungen verhielten sich anders als Gnome-Anwendungen, so konnte es zum Beispiel sein, daß bei einer Treiberversion das Gnome-Terminal beim Tippen flackerte, das QTerminal aber nicht. Irgendwann hat sich das dann nach x neuen Treiberversionen zurechtgeruckelt, unter Fedora 26 habe ich die Probleme aktuell nicht. (Hintergrundinfo: Unter Fedora gibt es im Laufe des Releasezyklus Updates, im Gegensatz zu Debian Stable.)

Probiere also mal "Gnome unter Wayland" aus. Ist es dann besser bzw. weg? Wenn da die Probleme immer noch auftreten, hat Stretch leider eine für dich ungünstige Treiberversion erwischt, und dank "stable" wird sich da auch nichts ändern. Dann hilft nur eine Distribution mit entweder älteren oder neueren Treibern, oder das Warten auf neuere Treiber in Stretch-Backports.
Fedora 28 Workstation -- openSUSE Leap 42 / Gnome -- Debian 9 (Qnap TS-109/119) -- OmniOS (HP N54L)

Benutzeravatar
Fluse
Beiträge: 6
Registriert: 05.06.2017 12:03:52

Re: wieder Bildschirmflackern mit stretch

Beitrag von Fluse » 02.07.2017 07:25:47

Huhu, sorry, dass ich erst jetzt antworte :oops:

Vielen Dank für Eure Hinweise! Jana, einen Hardwarefehler kann ich definitiv ausschließen, s.u. … (zum Glück, ich mag mein altes Kistchen nämlich)

Owl, wow (gut, dass Du dazuschreibst, es ist das gleiche Ding :mrgreen: ), genau so ist's bei mir auch, und das
owl102 hat geschrieben:nach einiger Zeit der Bildschirm ganz ausfiel und nur ein bunter linker Pixelrand übrig blieb
hatte ich unter Kubuntu 16.10! 8O Wusste nur nicht, wie ich's in weniger als fünf Zeilen beschreiben sollte. Alle paar Minuten am Ende, lästig, und der letzte Tritt, den ich noch gebraucht hatte, mir was anderes zu suchen …

Ich bin jetzt allerdings doch erstmal wieder zu Jessie zurück, und da ist das Flackern tatsächlich weg, aber ich merke mir das mal mit den anderen Treibern, weil, irgendwas scheint hier auch nicht so rund zu laufen. Wayland musste ich erst mal googeln :oops: wie würde man das machen, stretch installieren mit Gnome und das entsprechende Paket nachinstallieren?
*zwischen was-neues-lernen-will und never-change-a-running-system schwank*

Schönen Sonntag allerseits!

owl102
Beiträge: 2296
Registriert: 16.10.2010 13:05:57
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Timbuktu

Re: wieder Bildschirmflackern mit stretch

Beitrag von owl102 » 02.07.2017 10:37:47

Fluse hat geschrieben: ↑ zum Beitrag ↑
02.07.2017 07:25:47
Wayland musste ich erst mal googeln :oops: wie würde man das machen, stretch installieren mit Gnome und das entsprechende Paket nachinstallieren?
Beim Einloggen kann man an dem Zahnrad die gewünschte Gnome-Session wählen, und so auch "Gnome unter Wayland", vorausgesetzt du nimmst überhaupt Gnome als Desktop-Umgebung. Ob man vorher was dafür installieren muß, entzieht sich meiner Kenntnis, da ich selber Debian nur ohne GUI betreibe.

Die Frage ist allerdings, ob du damit glücklich werden wirst, siehe auch viewtopic.php?f=15&t=152950 , insbesondere die letzten Seiten des Themas.

Was wäre für dich ein praktikabler Weg, wenn du bei Debian Stable bleiben möchtest? Ich würde mir wohl Stretch als Spielwiese / Dual-Boot neu installieren, dort hin-und-wieder mal hineinbooten und die aktuellen Backports des Kernels und Graphiktreiber installieren, um zu schauen, ob damit das Problem nun weg ist. Wenn ja, dann kann man das Hauptsystem, also Jessie, hochziehen.

Oder aber man überspringt Stretch und wechselt zu Buster, sobald veröffentlicht, also in ca. 2 Jahren. (Oder ab dem Freeze, also in ca. 1 1/2 Jahren.)

Wenn du (wieder) auf Ubuntu ausweichen möchtest, mußt du vermutlich auf Ubuntu 17.10 warten, um das Problem loszuwerden. (Bei Fedora ist es ab Fedora 26 weg, welches im Moment Beta ist und wohl Mitte diesen Monats veröffentlicht wird.)
Fedora 28 Workstation -- openSUSE Leap 42 / Gnome -- Debian 9 (Qnap TS-109/119) -- OmniOS (HP N54L)

Benutzeravatar
Fluse
Beiträge: 6
Registriert: 05.06.2017 12:03:52

Re: wieder Bildschirmflackern mit stretch

Beitrag von Fluse » 02.07.2017 19:46:54

Vielen Dank, das schaue ich mir mal an. Gnome finde ich schon ganz hübsch, bin eigentlich auf Anhieb gut damit zurechtgekommen und sehe jetzt keinen Grund für einen Wechsel, solange meine alte Kiste damit klarkommt.

Ich denke, ich probiere das mit dem Dual-Boot, das hätte ich von vornherhein machen sollen, :facepalm: hab mich hinterher geärgert. Platte ist ja groß genug …

Auf Ubuntu bestehe ich keineswegs 8) dieses Flackern war nur das i-Tüpfelchen, das lief, wenn ich ehrlich bin, schon seit 14.04 nicht mehr ordentlich. Aber bis man sich dann an was neues wagt, kann's halt dauern …

owl102
Beiträge: 2296
Registriert: 16.10.2010 13:05:57
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Timbuktu

Re: wieder Bildschirmflackern mit stretch

Beitrag von owl102 » 03.07.2017 07:25:58

Fluse hat geschrieben: ↑ zum Beitrag ↑
02.07.2017 19:46:54
Ich denke, ich probiere das mit dem Dual-Boot, das hätte ich von vornherhein machen sollen, :facepalm: hab mich hinterher geärgert. Platte ist ja groß genug …
Ich war in die gleiche Falle getappt, mit sowas rechnet man ja auch nicht. Da hat man eine sehr gut abgehangene Kiste, mit Intel Graphik, auf der jahrelang jede Linux-Distribution out-of-the-box funktionierte. Und nun das.
Fedora 28 Workstation -- openSUSE Leap 42 / Gnome -- Debian 9 (Qnap TS-109/119) -- OmniOS (HP N54L)

Benutzeravatar
geier22
Beiträge: 3189
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: wieder Bildschirmflackern mit stretch

Beitrag von geier22 » 03.07.2017 11:23:05

Wenn ich auch noch einen Tipp geben darf:
Ich hab auf meinen beiden Lappies Siduction installiert und bin hoch zufrieden. Hab bisher auch noch
keinerlei Probleme gehabt.
Der eine ist ein "gut abgehangener" :mrgreen: Acer Extensa 7630EZ (9 Jahre alt)
der andere ein Aspire E 15-E5-575G-56WG den ich mir an sich nur wg. DBV T2 zugelegt habe.

Vorteil: die allerneusten Treiber und Programme -- sehr liebevolle Zusammenstellung der Tools und der Oberfläche.
Nachteil oft Kernel-Updates und (natürlich) sonstige Updates.

Ich für mich werde Siduction noch eine Weile beobachten und erwäge, zumindest ein System auf meinem Hauptrechner
zu installieren.

Download-quelle:
http://ftp.spline.de/mirrors/siduction/iso/patience/
4.13.0-1-amd64 #1 SMP Debian 4.13.4-2 (2017-10-15) (Buster)/ XFCE 4.12.3 / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI (Treiber 375.82-8) / HP LP3065

owl102
Beiträge: 2296
Registriert: 16.10.2010 13:05:57
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Timbuktu

Re: wieder Bildschirmflackern mit stretch

Beitrag von owl102 » 03.07.2017 12:24:55

geier22 hat geschrieben: ↑ zum Beitrag ↑
03.07.2017 11:23:05
Wenn ich auch noch einen Tipp geben darf
Es muß ja nicht gleich "sid" sein, "testing/buster" würde ja auch reichen, wenn man sich das antun mag. (Ich aber zumindest nicht.)
Fedora 28 Workstation -- openSUSE Leap 42 / Gnome -- Debian 9 (Qnap TS-109/119) -- OmniOS (HP N54L)

Benutzeravatar
Lord_Carlos
Beiträge: 4060
Registriert: 30.04.2006 17:58:52
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Dänemark

Re: wieder Bildschirmflackern mit stretch

Beitrag von Lord_Carlos » 03.07.2017 12:54:26

Die Grafikfehler sehen nicht zufaellig so aus: https://imgur.com/a/IfKRb
Die habe ich nämlich mit meiner Intel kiste. Aber halt mit einer Recht neuen generation, deswegen glaube ich nicht wir das gleiche Problem haben.
Ich habe mir 4.11 aus unstable installiert und damit hatte ich keine Grafikfehler mehr, aber das Bild ist Dunkler.

Firmware hast du installiert?

Code: Alles auswählen

╔═╗┬ ┬┌─┐┌┬┐┌─┐┌┬┐╔╦╗
╚═╗└┬┘└─┐ │ ├┤ │││ ║║
╚═╝ ┴ └─┘ ┴ └─┘┴ ┴═╩╝ rockt das Forum!

owl102
Beiträge: 2296
Registriert: 16.10.2010 13:05:57
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Timbuktu

Re: wieder Bildschirmflackern mit stretch

Beitrag von owl102 » 04.07.2017 07:26:57

Lord_Carlos hat geschrieben: ↑ zum Beitrag ↑
03.07.2017 12:54:26
Die Grafikfehler sehen nicht zufaellig so aus: https://imgur.com/a/IfKRb
Nein, das ist ein anderes Problem.
Firmware hast du installiert?
Da es ein (mittlerweile upstream behobener) Bug im i915-Treiber ist, hilft keine Firmware.
Zuletzt geändert von owl102 am 04.02.2018 11:15:15, insgesamt 1-mal geändert.
Fedora 28 Workstation -- openSUSE Leap 42 / Gnome -- Debian 9 (Qnap TS-109/119) -- OmniOS (HP N54L)

Knogle
Beiträge: 213
Registriert: 06.05.2016 19:29:00
Lizenz eigener Beiträge: GNU General Public License

Re: wieder Bildschirmflackern mit stretch

Beitrag von Knogle » 03.02.2018 17:22:09

Moin

Exakt das gleiche Problem habe ich auch mit Debian 9.3.0, gibt es mittlerweise eine Loesung?

Benutzeravatar
Patsche
Beiträge: 3242
Registriert: 21.06.2013 01:47:54
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: /home/10001101001

Re: wieder Bildschirmflackern mit stretch

Beitrag von Patsche » 04.02.2018 00:49:53

Ich schmeiß mal ein paar Brocken hin, die vielleicht helfen könnten:
viewtopic.php?f=33&t=161884&hilit=i915

Vielleicht besteht diese Problematik immer noch?

Oder man testet mal manuell eine andere Beschleunigung aus, die man in eine manuelle xorg.conf schreibt.

Code: Alles auswählen

Option      "AccelMethod"  "uxa"
Hier ist auch noch ein Tip:
https://wiki.archlinux.org/index.php/in ... flickering
Man kann dann eine Stromsparfunktion deaktivieren mit

Code: Alles auswählen

i915.enable_rc6=0
Ein paar Test könntet ihr also noch versuchen.
Hilf mit unser Wiki zu verbessern! Unterstütze somit die Community, um schneller und effizienter mit dem besten Betriebssystem der Welt arbeiten zu können! Danke!
PS: Hier bekommt ihr stets das aktuelle Offline-Wiki!

Antworten