[gelöst] Verbose booten ohne Grub

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
samo
Beiträge: 7
Registriert: 15.01.2018 07:32:21

[gelöst] Verbose booten ohne Grub

Beitrag von samo » 15.01.2018 21:33:01

Hallo,

ich habe Debian 9.3 ohne Grub installiert und möchte mir während des Bootens den Output von systemd auf der Konsole anschauen. Welche Kernel-Einstellungen und Parameter sind dazu notwendig? Gibt es vielleicht irgendwo eine Anleitung?

Kernel-Version: 4.9.65

Code: Alles auswählen

CONFIG_CMDLINE="root=UUID=a28cd9db-86a7-4bef-baf9-bf02c36d798e video=intelfb rootfstype=ext4"
Gruß
Zuletzt geändert von samo am 17.01.2018 00:11:56, insgesamt 3-mal geändert.

Benutzeravatar
smutbert
Beiträge: 6229
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Verbose booten ohne Grub

Beitrag von smutbert » 15.01.2018 22:04:29

Es gibt die Kerneloptionen
  • loglevel=x
    legt fest ab welcher Priorität (Kernel)meldungen auch auf der Konsole landen. Ich denke für x=7 sollten alle Meldungen angezeigt werden.
    Ich hab es auf 2 gesetzt, damit ich nur wirklich wichtige Meldungen sehe. loglevel ist nur mit quiet wirksam (vermutlich weil ohne quiet ohnehin alle angezeigt werden) und nur wenn loglevel in der Kernelbefehlszeile direkt hinter quiet folgt!
  • für die systemd-Statusmeldungen will es mir nicht einfallen :wink:
    aber das kann man auch in der »/etc/systemd/system.conf« mit

    Code: Alles auswählen

    ShowStatus=yes
    
    erledigen.

samo
Beiträge: 7
Registriert: 15.01.2018 07:32:21

Re: Verbose booten ohne Grub

Beitrag von samo » 15.01.2018 23:05:25

Ich habe folgende Optionen in /etc/systemd/system.conf gesetzt:

Code: Alles auswählen

[Manager]
LogLevel=info
LogColor=yes
ShowStatus=yes
Aber der Bildschirm bleibt schwarz.
Als nächstes versuche ich es mal mit dem cmdline-Parameter "ignore-loglevel" (das Compilieren dauert aber etwas).

Benutzeravatar
smutbert
Beiträge: 6229
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Verbose booten ohne Grub

Beitrag von smutbert » 15.01.2018 23:16:24

Hm, mit ShowStatus=yes sollte es nicht schwarz bleiben.

siehst du überhaupt einen blinkenden Textcursor oder irgendwelche Meldungen der initrd am Bildschirm? Wenn nein, dann muss irgendetwas anderes faul sein.

samo
Beiträge: 7
Registriert: 15.01.2018 07:32:21

Re: Verbose booten ohne Grub

Beitrag von samo » 15.01.2018 23:51:23

Nach der Auswahl im UEFI-Bootmenü bootet Debian durch bis zum KDE Login Screen ohne irgendeine Ausgabe. Der Bildschirm bleibt die ganze Zeit schwarz.

Benutzeravatar
smutbert
Beiträge: 6229
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Verbose booten ohne Grub

Beitrag von smutbert » 16.01.2018 00:26:35

Dann würde ich vermuten, dass es ein Grafikproblem im Textmodus gibt. Mit UEFI-Bootmenü meinst du wirklich das Bootmenü des BIOS oder einen Bootmanager/-loader eines anderen installierten Systems (zB einen grub)?

Welche Hardware, insbesondere Grafikkarte steckt in deinem PC?
Falls nvidia oder amd/ati: Verwendest du den proprietären oder den freien Treiber?

samo
Beiträge: 7
Registriert: 15.01.2018 07:32:21

Re: Verbose booten ohne Grub

Beitrag von samo » 16.01.2018 00:40:18

Ich starte Debian direkt aus dem UEFI-Bootmenü. Ich verwende weder Grub noch einen anderen Linux-Bootloader. Prinzipielle HW-Probleme schließe ich aus, da andere Linux-Partitionen mit entsprechendem Output auf der Konsole starten.

Ich sehe aktuell folgende potentielle Fehlerquellen:
- Initramfs
- Kernel inkl. Cmdline
- Systemd-Konfiguration

Da ich noch nicht einmal das Laden des Initramfs sehe, halte ich eine der ersten beiden Gründe für wahrscheinlicher.

NAB
Beiträge: 5502
Registriert: 06.03.2011 16:02:23
Lizenz eigener Beiträge: MIT Lizenz

Re: Verbose booten ohne Grub

Beitrag von NAB » 16.01.2018 01:10:18

Ist für UEFI nicht "efifb" zuständig, statt "intelfb"?
Never change a broken system. It could be worse afterwards.

"No computer system can be absolutely secure." Intel Document Number: 336983-001

samo
Beiträge: 7
Registriert: 15.01.2018 07:32:21

Re: Verbose booten ohne Grub

Beitrag von samo » 16.01.2018 08:08:01

"ignore-loglevel" hilft auch nicht.

Benutzeravatar
smutbert
Beiträge: 6229
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Verbose booten ohne Grub

Beitrag von smutbert » 16.01.2018 09:12:13

NAB hat recht (zumindest fast) – ist mir gar nicht aufgefallen:

intelfb ist möglicherweise der Name der alten framebuffer-Treiber aus der Zeit vor KMS. Jedenfalls finde ich in der Konfiguration des Debiankernels „# CONFIG_FB_INTEL is not set“ und wenn der Treiber im Kernel als Modul verfügbar wäre, wäre es in den meisten Fällen keine so gute Idee ihn zu verwenden.
Ich hab ja auch eine integrierte Intelgrafik und dort ist als Name des Framebuffertreibers »inteldrmfb« eingetragen: Ich würde also ohne video-Parameter und wenn das nicht funktioniert mit video=inteldrmfb und schließlich auch noch mit video=efifb versuchen.

samo
Beiträge: 7
Registriert: 15.01.2018 07:32:21

Re: Verbose booten ohne Grub

Beitrag von samo » 16.01.2018 09:55:06

Den Parameter "intelfb" habe ich einfach aus einer anderen Distribution übernommen. Wenn CONFIG_FB_INTEL defaultmäßig deaktiviert ist, könnte das die Ursache sein.

NAB
Beiträge: 5502
Registriert: 06.03.2011 16:02:23
Lizenz eigener Beiträge: MIT Lizenz

Re: Verbose booten ohne Grub

Beitrag von NAB » 16.01.2018 16:30:42

Ich hab zwar keine Ahnung, wann der Kernel was macht, aber wenn ich das richtig verstehe, startet samo den Kernel als EFI Binary. Und ein EFI Binary sieht zuerst die "EFI GOP"-Grafik (den Ersatz für das alte VESA). Eine Intel-Grafik müsste der Kernel erst entdecken, bevor er darauf was ausgeben kann.
Never change a broken system. It could be worse afterwards.

"No computer system can be absolutely secure." Intel Document Number: 336983-001

Benutzeravatar
smutbert
Beiträge: 6229
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Verbose booten ohne Grub

Beitrag von smutbert » 16.01.2018 22:12:35

Soweit stimmen wir überein. Darüber hinaus dachte ich nur, dass wenn mein Kernel im sysfs sagt, dass er inteldrmfb für den Framebuffer der Intelgrafik verwendet, das unabhängig davon wie der Kernel gestartet wird, nicht ganz verkehrt sein kann?

Erwarten würde ich ohnehin, dass beide efifb und inteldrmfb funktionieren. Allerdings sehe ich keinen Grund, wieso die Grafik nicht auch ohne video=... Option korrekt funktionieren sollte (das wäre das einfachste, aber ich hab noch nie einen Linuxkernel direkt vom uefi starten lassen).

samo
Beiträge: 7
Registriert: 15.01.2018 07:32:21

Re: Verbose booten ohne Grub

Beitrag von samo » 17.01.2018 00:08:16

Mit video=inteldrmfb funktioniert es.

Danke.

Antworten