[gelöst] LXQT - Nach Kernel Update - could not connect to any display

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
geier22
Beiträge: 3355
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

[gelöst] LXQT - Nach Kernel Update - could not connect to any display

Beitrag von geier22 » 05.05.2018 09:47:43

Hallo und einen wunderschönen guten Morgen.
Hab heute Früh auf meinem Lappie und auf meinem Hauptrechner bei KDE und XFCE problemlos auf Kernel 4.16.0.-1 die Updates gemacht.
Das Update bei LXQT ging aber aus irgendwelchen Gründen gründlich in die Hose.
Ich lande auf TTY1

startx ergibt

Code: Alles auswählen

command not found
startlxqt
ergibt (abgetippt):

Code: Alles auswählen

qt.qpa.screen QXconnection: could not connect to display
could not connect to any display.
Die suche im Netz ist auch nicht gerade ergiebig.

Der alte Kernel startet noch problemlos.
Dummer weise war ich genau bei diesem Update Duschen, sodass ich die Bildschirmausgabe nicht beobachtet habe (lief ja 3x gut)
und hab dann einfach einen Neustart gemacht :facepalm:

Die Ausgabe von dmesg mit dem neuen Kernel: NoPaste-Eintrag40308
Sagt mir allerdings nicht viel.

Die Begriffe nvidia, display oder screen scheint es in dem dmesg Output gar nicht mehr zu geben ??? hmmmm :|

Habt ihr eine Idee, wie man das wieder hinbiegen kann?
Zuletzt geändert von geier22 am 05.05.2018 13:16:39, insgesamt 1-mal geändert.
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

RobertDebiannutzer
Beiträge: 183
Registriert: 16.06.2017 09:52:36

Re: LXQT - Nach Kernel Update - could not connect to any display

Beitrag von RobertDebiannutzer » 05.05.2018 10:16:35

Eigentlich wollte ich gar nichts sagen, denn ich bin jetzt nicht so der Wissende, aber ich habe mir kürzlich ein Mini-Log-Analyse script geschrieben, dass ich eigentlich nur mal schnell mit Deinem Log ausprobieren wollte.

Code: Alles auswählen

#!/bin/bash

grep --color=always -iE '(fail|error|permi|allow|warn|prohi|forbidden|possible|fault|found|disable)' "$@" | less -R

exit 0
Da bin ich aber dann doch auf was interessantes gestoßen, nämlich:

Code: Alles auswählen

[    0.000000] AGP: No AGP bridge found
[    0.000000] ACPI BIOS Warning (bug): Optional FADT field Pm2ControlBlock has valid Length but zero Address: 0x0000000000000000/0x1 (20180105/tbfadt-658)
[    0.000000] AGP: No AGP bridge found
AGP-Meldungen und BIOS-Bugs habe ich ganz schlecht in Erinnerung von einem ganz alten Laptop, den ich kürzlich mal mit stretch versehen habe (und der eine savage-GraKa hat *seufz*).
Inwieweit diese Meldungen jetzt aber für Dein Problem relevant sein könnten, müsste man per [Suchmaschine] rausfinden.

Benutzeravatar
geier22
Beiträge: 3355
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: LXQT - Nach Kernel Update - could not connect to any display

Beitrag von geier22 » 05.05.2018 10:25:22

Erstmal danke für den Tipp, der ja irgendwie in die richtige Richtung zu weisen scheint.
Obwohl mit nicht so klar ist, was was AGP mit PCie noch zu tun hat.

Der gleiche Rechner, auch Debian Testing nur von einer anderen Platte nach Xfce gebootet mit Kernel 4.16.0.-1

ergibt das und keine Zeile mehr:

Code: Alles auswählen

# dmesg  |grep agp
[    1.465479] Linux agpgart interface v0.103
Was ist das beim Kernel-Update abgelaufen ??
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

Benutzeravatar
smutbert
Beiträge: 6271
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: LXQT - Nach Kernel Update - could not connect to any display

Beitrag von smutbert » 05.05.2018 10:53:13

Ist Debianxinit installiert (das enthält startx)?
(ist aber zum Starten von X, zB über einen Displaymanager nicht unbedingt notwendig)

Ich glaube zwar nicht, dass das die richtige Spur ist, aber zum Vergleich wären

Code: Alles auswählen

# dmesg | grep -i agp
oder

Code: Alles auswählen

# dmesg | grep AGP
interessanter (klein geschrieben kommt agp im Ausschnitt, den Robert gepostet hat gar nicht vor).


Haben die anderen beiden Systeme, auf denen das Update geklappt hat, auch eine nvidia-Grafikkarte?
Verwendest du den proprietären Treiber von nvidia?

Wenn ja, sind die zum neuen Kernel passenden Header installiert?
Gab es vielleicht Fehler beim Bauen des nvidia-Kernelmoduls?
(Die sollten in »/var/lib/dkms/nvidia-xxx/<version>/build/make.log« stehen. Was sagt »modprobe nvidia«?)

Die Ausgabe von

Code: Alles auswählen

# dkms status
könnte auch einen Überblick verschaffen.

Benutzeravatar
geier22
Beiträge: 3355
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: LXQT - Nach Kernel Update - could not connect to any display

Beitrag von geier22 » 05.05.2018 10:54:08

Mal eine Vergleich
LXQT (der Output von journalctl)

Code: Alles auswählen

cat /media/cinnamonhome/hans/kein_start_vonX |grep drm
Mai 05 08:50:44 sparkylxqt systemd-modules-load[329]: modprobe: FATAL: Module nvidia-current-drm not found in directory /lib/modules/4.16.0-1-amd64
Mai 05 08:50:44 sparkylxqt systemd-modules-load[329]: Error running install command for nvidia_drm
Mai 05 08:50:44 sparkylxqt systemd-modules-load[329]: Failed to insert 'nvidia_drm': Operation not permitted
 |grep drm
keine Fundstelle

Code: Alles auswählen

journalctl -b |grep drm
Mai 05 09:14:49 sparkyxfce kernel: [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
Mai 05 09:14:49 sparkyxfce kernel: [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
Mai 05 09:14:49 sparkyxfce systemd-modules-load[366]: Inserted module 'nvidia_drm'
Mai 05 09:14:51 sparkyxfce kernel: Modules linked in: pci_stub vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) binfmt_misc snd_hda_codec_hdmi edac_mce_amd snd_usb_audio kvm_amd ccp snd_usbmidi_lib rng_core snd_rawmidi snd_seq_device joydev kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel pcspkr snd_hda_intel snd_hda_codec fam15h_power k10temp snd_hda_core snd_hwdep snd_pcm snd_timer snd soundcore nvidia_drm(PO) sp5100_tco sg shpchp evdev acpi_cpufreq drm_kms_helper drm nvidia_modeset(PO) nvidia(PO) ipmi_devintf ipmi_msghandler nct6775 hwmon_vid loop ecryptfs parport_pc ppdev lp parport sunrpc ip_tables x_tables autofs4 ext4 crc16 mbcache jbd2 fscrypto ecb raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor async_tx xor raid6_pq libcrc32c crc32c_generic raid1 raid0 multipath linear md_mod sr_mod
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

Benutzeravatar
geier22
Beiträge: 3355
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: LXQT - Nach Kernel Update - could not connect to any display

Beitrag von geier22 » 05.05.2018 11:30:41

smutbert hat geschrieben: ↑ zum Beitrag ↑
05.05.2018 10:53:13
Haben die anderen beiden Systeme, auf denen das Update geklappt hat, auch eine nvidia-Grafikkarte?
Verwendest du den proprietären Treiber von nvidia?
Da ist der selbe Rechner mit einen Triple-Boot alle haben identische Hardware
Verwendest du den proprietären Treiber von nvidia? ---j>a
Wenn ja, sind die zum neuen Kernel passenden Header installiert?
Ja - Das geht ja beim Update automatisch mit
zu Veranschaulichung meine Platten (cinnamonhome ist jetzt das /home von LXQT - war bisher zu faul das umzubenennen, da alles incl. VM's auf diese Partition verlinkt sind)

Code: Alles auswählen

 lsblk -o NAME,FSTYPE,LABEL,UUID,MOUNTPOINT
NAME   FSTYPE LABEL        UUID                                 MOUNTPOINT
sda                                                             
├─sda1 ext4   KDE Root     9f9af350-ae4d-4e54-b0e8-3a97a0b89374 
└─sda2 ext4   KDE HOME     1d404883-fd27-4ee2-9744-ef7d055fbf70 
sdb                                                             
├─sdb1 swap                aa201965-5dcb-4abb-8283-c9bcd378aa1e [SWAP]
├─sdb2 ext4   LXQT ROOT    3a1d59fe-0e47-45f0-bb0d-af1147817681 
└─sdb3 ext4   cinnamonhome 92ad9934-c292-42d5-b881-faab5131d33a /media/cinnamonhome
sdc                                                             
├─sdc1 ext4   XFCE ROOT    3ad66fa8-f9bd-4807-93db-7b05e752ce15 /
├─sdc2                                                          
└─sdc5 ext4   XFCE HOME    7a7e7ac0-f89f-4e91-bea1-dc1b5da85293 /home
sdd                                                             
└─sdd1 ext4   Daten        65ed219f-c502-4566-b50e-4e2ed1085518 /media/HD753LJ
sde                                                             
└─sde1 ext4   Musik        8b535dfa-0c3f-4c55-aa95-a6bd61679344 /media/Musik
sr0                                                          
Aber jetzt
LXQT da wurde anscheinen etwas vergessen :facepalm:

Code: Alles auswählen

hans@sparkyxfce:/media/hans/LXQT ROOT/usr/src$ ls -al
insgesamt 20
drwxr-xr-x  5 root root 4096 Mai  3 11:58 .
drwxr-xr-x 11 root root 4096 Mär 14  2017 ..
drwxr-xr-x  4 root root 4096 Apr 26 16:47 linux-headers-4.15.0-3-amd64
drwxr-xr-x  4 root root 4096 Apr 26 16:47 linux-headers-4.15.0-3-common
lrwxrwxrwx  1 root root   24 Mär 20 09:31 linux-kbuild-4.15 -> ../lib/linux-kbuild-4.15
drwxr-xr-x  7 root root 4096 Mai  3 11:53 nvidia-current-390.48
lrwxrwxrwx  1 root root   32 Feb 26 19:11 vboxhost-5.2.8 -> ../share/virtualbox/src/vboxhost
hans@sparkyxfce:/media/hans/LXQT ROOT/usr/src$ cd/ 
Und im Gegensatz dazu Xfce

Code: Alles auswählen

[/b]
hans@sparkyxfce:/$ ls -al /usr/src
insgesamt 2172
drwxr-xr-x  5 root root    4096 Mai  5 07:55 .
drwxr-xr-x 11 root root    4096 Mär 13  2014 ..
-rw-r--r--  1 root root 2200420 Feb 13 21:45 broadcom-sta.tar.xz
drwxr-xr-x  4 root root    4096 Mai  5 07:47 linux-headers-4.16.0-1-amd64
drwxr-xr-x  4 root root    4096 Mai  5 07:47 linux-headers-4.16.0-1-common
lrwxrwxrwx  1 root root      24 Apr 29 18:09 linux-kbuild-4.16 -> ../lib/linux-kbuild-4.16
drwxr-xr-x  7 root root    4096 Apr 27 13:03 nvidia-current-390.48
lrwxrwxrwx  1 root root      32 Apr 13 22:45 vboxhost-5.2.10 -> ../share/virtualbox/src/vboxhost
Aber Der kernel startet ja bis TTY1 /boot/ von LXQT

Code: Alles auswählen

/media/hans/LXQT ROOT/boot$ ls -al
insgesamt 99776
drwxr-xr-x  3 root root     4096 Mai  5 08:26 .
drwxr-xr-x 23 root root     4096 Mai  5 08:26 ..
-rw-r--r--  1 root root   199706 Apr 19 12:13 config-4.15.0-3-amd64
-rw-r--r--  1 root root   203168 Apr 29 18:09 config-4.16.0-1-amd64
drwxr-xr-x  5 root root     4096 Mai  5 08:26 grub
-rw-r--r--  1 root root 43066300 Mai  3 11:57 initrd.img-4.15.0-3-amd64
-rw-r--r--  1 root root 42524490 Mai  5 08:26 initrd.img-4.16.0-1-amd64
-rw-r--r--  1 root root  3093953 Apr 19 12:13 System.map-4.15.0-3-amd64
-rw-r--r--  1 root root  3139277 Apr 29 18:09 System.map-4.16.0-1-amd64
-rw-r--r--  1 root root  4933392 Apr 19 12:13 vmlinuz-4.15.0-3-amd64
-rw-r--r--  1 root root  4982544 Apr 29 18:09 vmlinuz-4.16.0-1-amd64
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

Benutzeravatar
smutbert
Beiträge: 6271
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: LXQT - Nach Kernel Update - could not connect to any display

Beitrag von smutbert » 05.05.2018 11:40:55

Na dann würde ich es einmal mit

Code: Alles auswählen

# apt install linux-headers-$(uname -r)
# dkms autoinstall -k $(uname -r)
versuchen (ich hoffe der zweite Befehl stösst wie erwartet das Bauen der Kernelmodule an).

Benutzeravatar
geier22
Beiträge: 3355
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: LXQT - Nach Kernel Update - could not connect to any display

Beitrag von geier22 » 05.05.2018 12:18:47

Irgendwo scheint das das Update aus irgendwelchen Gründen verreckt zu sein
Habe mal gerade den dpkg.log durchforstet. Die linux-headers gibt es tatsächlich nicht im log :facepalm:
und auch im var/log/apt/history.log sind sie übersehen worden :!:
seltsam dieses aus dem history.log

Code: Alles auswählen

linux-image-4.16.0-1-amd64:amd64 (4.16.5-1, automatic)
linux-image-amd64:amd64 (4.15+92, 4.16+93)
Dieses 4.16+93 verstehe ich nun garnicht
smutbert hat geschrieben: ↑ zum Beitrag ↑
05.05.2018 11:40:55
Na dann würde ich es einmal mit

Code: Alles auswählen

# apt install linux-headers-$(uname -r)
# dkms autoinstall -k $(uname -r)

versuchen (ich hoffe der zweite Befehl stösst wie erwartet das Bauen der Kernelmodule an).
Na dann werde ich mich mal wieder nach LXQT beigeben und mein Glück versuchen

zuvor noch eine Frage:
Ich kann zwar Konsolen ausgaben umleiten in irgend eine Datei. Kann ich aber gleichzeitig "glotzen" und umleiten?
würde das spiel ansich ganz gerne aufzeichnen.

Falls das dann nicht mit dem dkms autoinstall -k $(uname -r)
wäre eventuell
ein

Code: Alles auswählen

dpkg-reconfigure nvidia-driver
möglich?
Zuletzt geändert von geier22 am 05.05.2018 12:31:26, insgesamt 1-mal geändert.
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

tobo
Beiträge: 526
Registriert: 10.12.2008 10:51:41

Re: LXQT - Nach Kernel Update - could not connect to any display

Beitrag von tobo » 05.05.2018 12:29:24

Mit tee geht das (T-Stück):

Code: Alles auswählen

command -option param 2>&1 | tee output.txt

Benutzeravatar
geier22
Beiträge: 3355
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: LXQT - Nach Kernel Update - could not connect to any display

Beitrag von geier22 » 05.05.2018 12:37:22

tobo hat geschrieben: ↑ zum Beitrag ↑
05.05.2018 12:29:24
Mit tee geht das (T-Stück):

Code: Alles auswählen

command -option param 2>&1 | tee output.txt
Danke. Werde ich benutzen :THX:

Aber jetzt muss ich erst mal was zum Futtern kaufen gehen :mrgreen:
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

Benutzeravatar
geier22
Beiträge: 3355
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: LXQT - Nach Kernel Update - could not connect to any display

Beitrag von geier22 » 05.05.2018 13:16:10

So die Kuh ist vom Eis.Schreibe jetzt aus LXQT :THX: :THX: :hail: :hail:
Mit dem tee hat das irgendwie nicht geklappt --> 0 byte Datei produziert. (vorher probiert, und da hat es funktioniert)
Lag das eventuell am recovery mode ?
Aber (fast) egal
Ich glaube

Code: Alles auswählen

# apt install linux-headers-$(uname -r)
war schon ausreichend
da die Befehle

Code: Alles auswählen

# dkms autoinstall -k $(uname -r)
und auch

Code: Alles auswählen

dpkg-reconfigure --force nvidia-driver
ohne die geringste Verzögerung und Fehlermeldung sofort beendet waren.

Was apt da geritten hat, ist mir trotzdem unverständlich.
Ich habe bestimmt schon dutzende Kernel- Updates gehabt und noch nie wurden dabei die Headers "vergessen",
da sie ja sowieso wg. Nvidia und VirtualBox da sein müssen.

Wie auch immer: Vormittag ungewollt an Debian vergeben. Aber alles ist gut und die Sonne scheint immer noch.
Danke für die Tipps. :THX:
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

RobertDebiannutzer
Beiträge: 183
Registriert: 16.06.2017 09:52:36

Re: [gelöst] LXQT - Nach Kernel Update - could not connect to any display

Beitrag von RobertDebiannutzer » 06.05.2018 09:35:36

Nur aus Interesse: Kommen die AGP-Meldungen noch?

Benutzeravatar
geier22
Beiträge: 3355
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: [gelöst] LXQT - Nach Kernel Update - could not connect to any display

Beitrag von geier22 » 06.05.2018 12:16:20

RobertDebiannutzer hat geschrieben: ↑ zum Beitrag ↑
06.05.2018 09:35:36
Nur aus Interesse: Kommen die AGP-Meldungen noch?
Nee - gibt es nicht mehr
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

Antworten