[all solved] Upgrade Stretch -> Buster: eine Plage

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
ingo2
Beiträge: 821
Registriert: 06.12.2007 18:25:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Wo der gute Riesling wächst

[all solved] Upgrade Stretch -> Buster: eine Plage

Beitrag von ingo2 » 14.10.2019 22:50:11

Habe jetzt am Wochenende mich durchgrungen, auf Buster upzugraden. Das lief auch glatt durch und zunächst waren nur ein paar übliche Kleinigkeiten zur Anpassung/Konfiguration nötig, wie lightdm-gtk-greeter.conf, lightdm.conf, cups-pdf.conf, apcupsd.conf, cron.daily/apt-compat.

Rechner ist ein Intel DH77EB Mainboard, i5-3570K CPU mit HD 4000 Graphics und läuft klaglos seit Wheezy.

Dann aber kamen weitere Dinge zum Vorschein:
a) Debiansolaar startet nicht mehr korrekt mit XFCE-Autostart, um dann minimiert in Panel den Batteriestand meines Logitech-Trackballs am Unifying Receiver anzuzeigen. Meldung "no receiver found".
-> Autostart deaktiviert.

b) Liferea läßt sich auch nicht mehr minimiert (mit Icon im Panel) starten, erscheint immer maximiert.
-> Autostart deaktiviert.

c) Mein CUPS-PDF-Drucke druckt ins Nirwana. Hatte ja in der cups-pdf.conf den Zielpfad auf meine Datenpartition gelegt. /var/log/messages gibt einen Hinweis:

Code: Alles auswählen

audit: type=1400 audit(1570982984.680:33):
		 apparmor="DENIED" operation="mknod" profile="/usr/lib/cups/backend/cups-pdf" 		 name="/home/ingo/data/PDF/Buster.txt__ta_PDF.pdf" pid=1727 comm="gs" requested_mask="c" denied_mask="c"
Aha, Debianapparmor. Also Debianapparmor-utils installiert und

Code: Alles auswählen

# aa-complain /usr/lib/cups/backend/cups-pdf
und siehe da, er druckt!
Das kann ja nicht der Sinn von AppArmor sein? Später habe ich dann durch Zufall diesen Hinweis in der "conf" gefunden:
## on Ubuntu, the cupsd AppArmor profile needs to be updated
## to match the output path as per instructions in LP:147551
### Default: /var/spool/cups-pdf/${USER}
und daraufhin das Apparmor-Profil editiert und die Pfade auf meine geändert ergänzt:

Code: Alles auswählen

nano /etc/apparmor.d/usr.sbin.cupsd
	  @{HOME}/PDF/ rw,
	  @{HOME}/PDF/* rw,
Dann wieder Apparmor aktiviert:

Code: Alles auswählen

aa-enforce /usr/lib/cups/backend/cups-pdf
Das geht endlich.

d) Thunderbird leitet keine Links durch Ancklicken mehr an meinen "www-browser" (PaleMoon) weiter. Schuld ist wieder Apparmor.
Aber auch nach langem Suchen keine passable/korrekte Lösung gefunden. Also letzte Rettung:
Profil deaktivieren/auf complain setzen:

Code: Alles auswählen

aa-complain /usr/lib/thunderbird/thunderbird-bin
Dennoch echt unschön, denn jetzt spammt jeder Klick auf einen Link ins Log:

Code: Alles auswählen

audit: type=1400 audit(1571084744.687:44): apparmor="ALLOWED" operation="open" profile="thunderbird//null-/usr/lib/palemoon/palemoon" name="/lib/x86_64-linux-gnu/libdl-2.28.so" pid=4547 comm="x-www-browser" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
Lösung steht noch aus.

e) Problem ist seit Langem, bekannt, s. Debian Bugreport929834 gegen Debianlight-locker - der soll ja der eigentliche Verursacher sein:
Nach einem Screen-Lock erscheint kein Pop-UP zur Passworteingabe. Passiert auch, wenn der Monitor in Standby geht.
Notlösung: "Ctrl+ALT+F1", danach "Ctrl+ALT+F7" (Wechsel des virtuellen Terminals).
Workaround:
Statt dem default X11-driver "modesetting" den "intel" DDX konfiguriert:

Code: Alles auswählen

nano /etc/X11/xorg.conf.d/20-intel.conf		(neu erstellt)
	Section "Device"
	  Identifier    "Intel Graphics"
	  Driver        "intel"
	#  Driver       "modesetting"
	EndSection
Das hilt aberbei mir überhaupt nicht - (nach langem Suchen) weil es offensichtlicheine weitere Konfigurationsdatei gibt

Code: Alles auswählen

/usr/share/X11/xorg.conf.d/20-intel.conf

# /etc/X11/xorg.conf.d/20-intel.conf (Buster)
# /usr/share/X11/xorg.conf.d/20-intel.conf (Stretch)
# Load the intel Xorg-driver instead of modesetting.

Section "Device"
  Identifier	"Intel Graphics"
#  Driver	"intel"
  Driver       "modesetting"
EndSection
Hier den Intel-Treiber statt "modsetting" aktiviert - der Screen-Lock ist weg!

Aber:
mit dem Intel-Treiber gibt's zeitweise Pixelfehler und google-earth-pro funktioniert nich mehr (fast totes Fenster).

Ungelöst!

f) Ich mag meinen Desktop aufgeräumt, aber XFCE plaziert seit Buster für jeden in /etc/fstab aufgeführten mount unterhalb /media ein Drive-Icon auf dem Desktop. Laut Tooltip werden die Partitionen aud der HD, die nur root mounten darf als "removable" betrachtet.
Habe ein UDEV-Regel schon seit Langem:

Code: Alles auswählen

/etc/udev/rules.d/10-local.rules' mit Inhalt:

# Do not show these partitions as removable drives
# on XFCE-desktop. Newer versions of udev or xfce
# might use this settings: ENV{UDISKS_IGNORE}="1".
# Reboot is required to activate the changes.
KERNEL=="sda1",ENV{UDISKS_IGNORE}="1"
KERNEL=="sda3",ENV{UDISKS_IGNORE}="1"
KERNEL=="sda5",ENV{UDISKS_IGNORE}="1"
KERNEL=="sdb1",ENV{UDISKS_IGNORE}="1"
Laut offizielle Dokumentation soll dies die genannten DISKS komplett vor dem User verbergen!?
Hat seit Wheezy auf gleicher Hardware immer funktioniert, bei Buster nicht mehr :hail:

Habe keine Lösung gefunden.

Mal gespannt, vielleicht sammeln wir in diesem Thread auch weiter "dickere Brocken" in Buster - ich bin doch etwas enttäuscht - war früher problemloser.

Ingo
Zuletzt geändert von ingo2 am 17.10.2019 21:41:33, insgesamt 1-mal geändert.

Benutzeravatar
ingo2
Beiträge: 821
Registriert: 06.12.2007 18:25:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Wo der gute Riesling wächst

Re: Upgrade Stretch -> Buster: eine Plage

Beitrag von ingo2 » 15.10.2019 17:27:18

Der nächste "Hund":

CUPS-PDF verpaßt den Output-Files ein kryptisches Anhängsel. Beispiele:

Code: Alles auswählen

Input = Buster.txt -> Output = Buster.txt__ta_PDF.pdf
Input = check-hosts (Kopie 1) -> Output = check-hosts__Kopie_1___sing_non-Linux-generated_files.pdf
Dazu ist auch ein Debian Bugreport912993 gemeldet, der aber bisher unbeachtet blieb.
Mit Try+Error habe ich dann ein Workaround/Lösung gefunden - es ist ein alter Konfigurationsfehler:

Code: Alles auswählen

/etc/cups/cups-conf.pdf
...
### Key: TitlePref (config, ppd, lpoptions)
##  where to look first for a title when creating the output filename
##  (title in PS file or title on commandline):
##  0: prefer title from %Title statement in the PS file
##  1: prefer title passed via commandline 
### Default: 0

#TitlePref 0
TitlePref 1
Mit TitlePref 1 gesetzt ergibt sich das alte bekannte Verfahren und das Suffix im Filename wird durch "pdf" ersetzt.

Der Default ist also schon füher immer "1" gewesen - im Grunde wurde also ein alter Bug gefixt.
Habe daraufhin mal in der Stretch-Konfiguration nachgesehen - ist vom Text her mit der Buster-Version identisch und somit buggy.

EDIT:
Auch hierzu gibt's einen ähnlichen Bugreport: Debian Bugreport912993, habe den commentiert.
Zuletzt geändert von ingo2 am 16.10.2019 22:58:41, insgesamt 1-mal geändert.

Benutzeravatar
ingo2
Beiträge: 821
Registriert: 06.12.2007 18:25:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Wo der gute Riesling wächst

Re: Upgrade Stretch -> Buster: eine Plage

Beitrag von ingo2 » 16.10.2019 15:23:05

Das e) Problem mt Debianlight-locker, s. Debian Bugreport929834 läßt sich auch ganz einfach abstellen:
Gemäß dem Post von Theodore Ts'o https://bugs.debian.org/cgi-bin/bugrepo ... =929834#23 reicht es, einfach den Screen-Lock abzuschalten mit

Code: Alles auswählen

xset -s off
Das klappt und - wenn man es weiß - noch simpler:
Einfach den light-locker im Autostart von XFCE de-aktivieren:
Menu -> Einstellungen -> Sitzung und Startverhalten -> Automatisch gestartete Anwendungen
"Bildschirmspere" (Befehl = light-locker) de-selectieren.

Danach wieder "modesetting" als Xorg-Driver einstellen (dann läuft auch Google-Earth-Pro wieder) fertig!

Man sollte sich dabei nur bewußt sein, daß es jetzt keinen Screen-Lock mehr gibt (Sicherheit).
Den Monitor selbst kann man ruhig per DPMS abschalten lassen.

Jetzt ist nur noch das Problem mit dem Ausblenden der "Drive-Icons" aus fstab auf dem Desktop (HD-Partitionen werden als "removable" angesehen) ungelöst.

Hat wer eine Idee?
Ich glaube, das ist einen Bugreport wert.

KP97
Beiträge: 1891
Registriert: 01.02.2013 15:07:36

Re: Upgrade Stretch -> Buster: eine Plage

Beitrag von KP97 » 16.10.2019 17:41:24

Das ist doch eine Sache der Einstellung,
in Schreibtisch -> Symbole die Haken entfernen.
Wenn es auch in Thunar sein soll, Rechtsklick in die Seitenleiste und auch dort die Haken entfernen, wo es nicht gewünscht ist.

Benutzeravatar
ingo2
Beiträge: 821
Registriert: 06.12.2007 18:25:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Wo der gute Riesling wächst

Re: Upgrade Stretch -> Buster: eine Plage

Beitrag von ingo2 » 16.10.2019 17:58:33

KP97 hat geschrieben: ↑ zum Beitrag ↑
16.10.2019 17:41:24
Das ist doch eine Sache der Einstellung,
in Schreibtisch -> Symbole die Haken entfernen.
Ich habe nur eine Option für "Entfernbare Datenträger" (zu Deutsch "removable". Die Partitionen sind aber z.B. mit "noauto" in der fstab gelistet:

Code: Alles auswählen

UUID=ea5ad8...de2 /media/sda1 ext4  noatime,errors=remount-ro,noauto 0 0
Und es gibt eine UDEV-rule dazu:

Code: Alles auswählen

KERNEL=="sda1",ENV{UDISKS_IGNORE}="1"
Das besagt nach freedesktop-org documentation
> the "HintIgnore" property property should:
> If TRUE, the device should be hidden from users.
Außerdem sind die Icons "tot", beim Anclicken kommt:
"could not be mounted, operation permitted for root only."

Und klar, die sind weg, wenn ich das Häkchen entferne, dann werden aber auch keine USB-Sticks usw. angezeigt. Seit Wheezy hat das auf diese Weise korrekt geklappt, nur bei Buster nicht mehr.

EDIT:
Sogar meine beim Systemstart unter ~/data gemountete Datenpartition /dev/sdb2 wird auf dem Desktop als "entfernbarer Datenträger" angezeigt und die enthält das komplette Dateisystem - fast ein Wunder daß nicht auch die Systempartition nochmals erscheint :hail:

EDIT #2
Habe jetzt einen Bug gemeldet: Debian Bugreport942449, mal sehen.

Benutzeravatar
ingo2
Beiträge: 821
Registriert: 06.12.2007 18:25:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Wo der gute Riesling wächst

Re: Upgrade Stretch -> Buster: eine Plage

Beitrag von ingo2 » 17.10.2019 21:40:20

So auch diesen Punkt habe ich inzwischen gelöst:
Nachdem ich festgestellt hatte, daß die Desktop-Icons sofort verschwinden, sobald man im laufenden System! die Zeile in der fstab kommentiert (#), stand fest, das XFCE die Info garnicht über den UDEV-Filter bezieht, sondern auf anderem Wege direkt aus der fstab. Der "Schuldige": gvfs.

Nach Recherche dann hier https://github.com/GNOME/gvfs/blob/mast ... -shown.txt die Lösung gefunden:

einfach in der fstab den Parameter x-gvfs-hide an die betroffenen Mount-Zeilen angehängt wie

Code: Alles auswählen

/dev/sda1	/media/sda1	ext4	noatime,errors=remount-ro,noauto,x-gvfs-hide
und automagisch sind die toten Desktop-Icons verschwunden - braucht noch nicht einmal einen Reboot.

Jetzt ist mir auch klar, warum das Debianxfce4-mount-plugin aus dem Standard-Plugin-Pack verschwunden ist (wurde beim Upgrade entfernt) - sind sicher die Umbauten auf gtk3 und die zugehörigen von GNOME diktierten Wege Schuld.

So, das war die Odysse eines dist-upgrades, wie ich ihn bisher noch nicht erlebt habe.
Markiere den Thread jetzt als gelöst.

Ingo

Antworten