Nvidia: Treiberproblem [gelöst]

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
_ash
Beiträge: 1045
Registriert: 13.05.2005 12:35:02

Nvidia: Treiberproblem [gelöst]

Beitrag von _ash » 22.10.2019 21:19:34

Ich setze gerade einen neuen Rechner auf mit Buster. Im Rechner ist eine GeForce GT 1030 verbaut. 'nvidia-detect' sagt mir, die Karte ist unterstützt und empfielt mir, 'nvidia-driver' zu installieren. Das geht auch stressfrei, aber nach dem Reboot gibt es Probleme mit dem Treiber: sddm startet nicht, Cinnamon lässt sich starten, aber nur im 2D Modus. In den Logs habe ich bisher keinen Anhaltspunkt gefunden.

Tipps?
Zuletzt geändert von _ash am 23.10.2019 09:43:25, insgesamt 1-mal geändert.

Benutzeravatar
towo
Beiträge: 3447
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Nvidia: Treiberproblem

Beitrag von towo » 22.10.2019 21:23:49

In den Logs habe ich bisher keinen Anhaltspunkt gefunden.

Tipps?
Wie wär's, uns die Logs zu zeigen?

am2
Beiträge: 189
Registriert: 20.08.2016 21:56:44

Re: Nvidia: Treiberproblem

Beitrag von am2 » 22.10.2019 23:12:34

Die 1030 habe ich auch, mit Debian Stretch. Ohne Nvidia-Treiber lief eigentlich gar nichts. Mit dem NVIDIA-Linux-x86_64-430.14.run (von der NV-Seite) sah die Welt wieder gut aus. Hast du auch diesen installiert?

_ash
Beiträge: 1045
Registriert: 13.05.2005 12:35:02

Re: Nvidia: Treiberproblem

Beitrag von _ash » 23.10.2019 08:20:30

Ich habe jetzt den nouveau Treiber entfernet und bekomme jetzt zumindest relevantere Meldungen in den Logs:

Code: Alles auswählen

[   407.120] (==) ModulePath set to "/usr/lib/xorg/modules"
[   407.120] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   407.120] (II) Loader magic: 0x55952a9efe20
[   407.120] (II) Module ABI versions:
[   407.120] 	X.Org ANSI C Emulation: 0.4
[   407.120] 	X.Org Video Driver: 24.0
[   407.120] 	X.Org XInput driver : 24.1
[   407.120] 	X.Org Server Extension : 10.0
[   407.121] (++) using VT number 1

[   407.127] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[   407.128] (--) PCI:*(1@0:0:0) 10de:128b:1043:85f7 rev 161, Mem @ 0x4a000000/16777216, 0x40000000/134217728, 0x48000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/131072
[   407.128] (II) LoadModule: "glx"
[   407.128] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   407.128] (II) Module glx: vendor="X.Org Foundation"
[   407.128] 	compiled for 1.20.4, module version = 1.0.0
[   407.128] 	ABI class: X.Org Server Extension, version 10.0
[   407.253] (==) Matched nouveau as autoconfigured driver 0
[   407.253] (==) Matched nv as autoconfigured driver 1
[   407.253] (==) Matched modesetting as autoconfigured driver 2
[   407.253] (==) Matched fbdev as autoconfigured driver 3
[   407.253] (==) Matched vesa as autoconfigured driver 4
[   407.253] (==) Assigned the driver to the xf86ConfigLayout
[   407.253] (II) LoadModule: "nouveau"
[   407.253] (WW) Warning, couldn't open module nouveau
[   407.253] (EE) Failed to load module "nouveau" (module does not exist, 0)
[   407.253] (II) LoadModule: "nv"
[   407.254] (WW) Warning, couldn't open module nv
[   407.254] (EE) Failed to load module "nv" (module does not exist, 0)
[   407.254] (II) LoadModule: "modesetting"
[   407.254] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   407.254] (II) Module modesetting: vendor="X.Org Foundation"
[   407.254] 	compiled for 1.20.4, module version = 1.20.4
[   407.254] 	Module class: X.Org Video Driver
[   407.254] 	ABI class: X.Org Video Driver, version 24.0
[   407.254] (II) LoadModule: "fbdev"
[   407.254] (WW) Warning, couldn't open module fbdev
[   407.254] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   407.254] (II) LoadModule: "vesa"
[   407.255] (WW) Warning, couldn't open module vesa
[   407.255] (EE) Failed to load module "vesa" (module does not exist, 0)
[   407.255] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   407.255] (EE) open /dev/dri/card0: No such file or directory
[   407.255] (WW) Falling back to old probe method for modesetting
[   407.255] (EE) open /dev/dri/card0: No such file or directory
[   407.255] (EE) Screen 0 deleted because of no matching config section.
[   407.255] (II) UnloadModule: "modesetting"
[   407.255] (EE) Device(s) detected, but none match those in the config file.
[   407.255] (EE) 
Fatal server error:
[   407.255] (EE) no screens found(EE) 
[   407.255] (EE) 
Nach 'Xorg -configure' taucht das hier auf:

Code: Alles auswählen

[  1011.921] (**) ModulePath set to "/usr/lib/xorg/modules"
[  1011.921] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1011.921] (WW) Disabling Mouse0
[  1011.921] (WW) Disabling Keyboard0
[  1011.922] (II) Loading sub module "fb"
[  1011.922] (II) LoadModule: "fb"
[  1011.922] (II) Loading /usr/lib/xorg/modules/libfb.so
[  1011.922] (II) Module fb: vendor="X.Org Foundation"
[  1011.922] 	compiled for 1.20.4, module version = 1.0.0
[  1011.922] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  1011.922] (II) Loading sub module "wfb"
[  1011.922] (II) LoadModule: "wfb"
[  1011.922] (II) Loading /usr/lib/xorg/modules/libwfb.so
[  1011.923] (II) Module wfb: vendor="X.Org Foundation"
[  1011.923] 	compiled for 1.20.4, module version = 1.0.0
[  1011.923] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  1011.923] (II) Loading sub module "ramdac"
[  1011.923] (II) LoadModule: "ramdac"
[  1011.923] (II) Module "ramdac" already built-in
[  1011.928] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[  1011.928] (EE) NVIDIA:     system's kernel log for additional error messages and
[  1011.928] (EE) NVIDIA:     consult the NVIDIA README for details.
[  1011.929] Number of created screens does not match number of detected devices.
  Configuration failed.
[  1011.929] (EE) Server terminated with error (2). Closing log file.

Benutzeravatar
towo
Beiträge: 3447
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Nvidia: Treiberproblem

Beitrag von towo » 23.10.2019 08:32:58

Und das hilft jetzt wie weiter?
Laut dem 1. Logfile ist nichts vom Nvidia-Blob installiert.
Ich würde ja mal das Paket Debiannvidia-driver, günstiger Weise aus den Backports, installieren.
Und das 2. Log sagt, da ist kein nvidia Kernel-Modul da.
Da sollte ein dkms status Erleuctung bringen.

Benutzeravatar
willy4711
Beiträge: 2505
Registriert: 08.09.2018 16:51:16

Re: Nvidia: Treiberproblem

Beitrag von willy4711 » 23.10.2019 08:35:31

Doch bitte mal die Ausgabe von

Code: Alles auswählen

dpkg -l *linux* |grep ii
und

Code: Alles auswählen

dpkg -l nvi* |grep ii
und eventuell:

Code: Alles auswählen

update-alternatives --config glx
Dann kann man weitersehen- Danke
_ash hat geschrieben: ↑ zum Beitrag ↑
23.10.2019 08:20:30
Nach 'Xorg -configure' taucht das hier auf:
Das ist mir vollkommen neu, Hab das noch nie benutzt. Was soll das bewirken ?

@towo der normale Treiber von Buster sollte reichen (418.74).
siehe: https://www.nvidia.com/Download/driverR ... 6667/en-us

_ash
Beiträge: 1045
Registriert: 13.05.2005 12:35:02

Re: Nvidia: Treiberproblem

Beitrag von _ash » 23.10.2019 09:01:03

Code: Alles auswählen

# dkms status
nvidia-current, 418.74: added

Code: Alles auswählen

# dpkg -l *linux* |grep ii
ii  binutils-x86-64-linux-gnu           2.31.1-16         amd64        GNU binary utilities, for x86-64-linux-gnu target
ii  console-setup-linux                 1.193~deb10u1     all          Linux specific part of console-setup
ii  firmware-linux-free                 3.4               all          Binary firmware for various drivers in the Linux kernel
ii  libselinux1:amd64                   2.8-1+b1          amd64        SELinux runtime shared libraries
ii  linux-base                          4.6               all          Linux image base package
ii  linux-compiler-gcc-8-x86            4.19.67-2+deb10u1 amd64        Compiler for Linux on x86 (meta-package)
ii  linux-headers-4.19.0-6-amd64        4.19.67-2+deb10u1 amd64        Header files for Linux 4.19.0-6-amd64
ii  linux-headers-4.19.0-6-common       4.19.67-2+deb10u1 all          Common header files for Linux 4.19.0-6
ii  linux-headers-amd64                 4.19+105+deb10u1  amd64        Header files for Linux amd64 configuration (meta-package)
ii  linux-image-4.19.0-6-amd64          4.19.67-2+deb10u1 amd64        Linux 4.19 for 64-bit PCs (signed)
ii  linux-kbuild-4.19                   4.19.67-2+deb10u1 amd64        Kbuild infrastructure for Linux 4.19
ii  linux-libc-dev:amd64                4.19.67-2+deb10u1 amd64        Linux support headers for userspace development
ii  util-linux                          2.33.1-0.1        amd64        miscellaneous system utilities
ii  util-linux-locales                  2.33.1-0.1        all          locales files for util-linux

Code: Alles auswählen

# dpkg -l nvi* | grep ii
ii  nvidia-alternative               418.74-1     amd64        allows the selection of NVIDIA as GLX provider
ii  nvidia-detect                    418.74-1     amd64        NVIDIA GPU detection utility
ii  nvidia-driver                    418.74-1     amd64        NVIDIA metapackage
ii  nvidia-driver-bin                418.74-1     amd64        NVIDIA driver support binaries
ii  nvidia-driver-libs:amd64         418.74-1     amd64        NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries)
ii  nvidia-egl-common                418.74-1     amd64        NVIDIA binary EGL driver - common files
ii  nvidia-egl-icd:amd64             418.74-1     amd64        NVIDIA EGL installable client driver (ICD)
ii  nvidia-installer-cleanup         20151021+9   amd64        cleanup after driver installation with the nvidia-installer
ii  nvidia-kernel-common             20151021+9   amd64        NVIDIA binary kernel module support files
ii  nvidia-kernel-dkms               418.74-1     amd64        NVIDIA binary kernel module DKMS source
ii  nvidia-kernel-support            418.74-1     amd64        NVIDIA binary kernel module support files
ii  nvidia-legacy-check              418.74-1     amd64        check for NVIDIA GPUs requiring a legacy driver
ii  nvidia-modprobe                  418.56-1     amd64        utility to load NVIDIA kernel modules and create device nodes
ii  nvidia-persistenced              418.56-1     amd64        daemon to maintain persistent software state in the NVIDIA driver
ii  nvidia-settings                  418.74-1     amd64        tool for configuring the NVIDIA graphics driver
ii  nvidia-support                   20151021+9   amd64        NVIDIA binary graphics driver support files
ii  nvidia-vdpau-driver:amd64        418.74-1     amd64        Video Decode and Presentation API for Unix - NVIDIA driver
ii  nvidia-vulkan-common             418.74-1     amd64        NVIDIA Vulkan driver - common files
ii  nvidia-vulkan-icd:amd64          418.74-1     amd64        NVIDIA Vulkan installable client driver (ICD)

Code: Alles auswählen

update-alternatives --config glx
/usr/lib/nvidia    auto-mode

Benutzeravatar
towo
Beiträge: 3447
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Nvidia: Treiberproblem

Beitrag von towo » 23.10.2019 09:22:11

nvidia-current, 418.74: added
Da wurden keine Module gebaut!
Da wäre ein Blick ins make.log von Vorteil.

Benutzeravatar
willy4711
Beiträge: 2505
Registriert: 08.09.2018 16:51:16

Re: Nvidia: Treiberproblem

Beitrag von willy4711 » 23.10.2019 09:23:40

hmm, kann mir nur vorstellen dass da eins der Pakete, die von dkms abhängen fehlt
_ash hat geschrieben: ↑ zum Beitrag ↑
23.10.2019 09:01:03

Code: Alles auswählen

# dkms status 
nvidia-current, 418.74: added
da sollte eigentlich stehen: installed

Also vielleicht

Code: Alles auswählen

apt install dkms
dann

Code: Alles auswählen

apt install --reinstall nvidia-driver nvidia-xconfig 
nvidia-xconfig ist an sich nicht mehr nötig, aber mit ihr wird eine /etc/X11/xorg.conf angelegt. Ich hab sie halt noch

ich würde das zumindest im Terminal, noch besser im Rettungs-Modus ausführen.
Terminal hat den Vorteil, dass man die Meldungen abspeichern kann, und, falls Fehlermeldungen kommen hier einstellen.
um im Rettungs-Modus Internet- Verbindung zu haben, einfach nach der eingabe des Root pw

Code: Alles auswählen

dhclient
eingeben

Edit
Als Ergänzung zu towo's Anregung:
Es gibt normalerweise auch noch einen log hier:
/var/lib/dkms/nvidia-current/430.50/5.2.0-3-amd64/x86_64/log/make.log
bei dir hast du natürlich andere Bezeichnungen, gemäß deinem Kernel.

_ash
Beiträge: 1045
Registriert: 13.05.2005 12:35:02

Re: Nvidia: Treiberproblem

Beitrag von _ash » 23.10.2019 09:43:12

Ich habe dkms entfernt und neu installiert, nun tut alles. Vielen Dank!

Antworten