Debian Buster auf LinkStation LS-QVL installieren

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
festplatte32
Beiträge: 17
Registriert: 04.05.2012 22:18:14

Debian Buster auf LinkStation LS-QVL installieren

Beitrag von festplatte32 » 28.10.2019 09:13:14

Hallo, vor einigen Tagen viel mir eine Buffalo LinkStation LS-QVL mit RAID5 in die Hände. Da mir das Buffalo Betriebssystem nicht gefällt, möchte ich auf dem NAS Debian installieren. Der NAS soll erst einmal nur mit einer Festplatte als Betriebssystemfestplatte laufen.

Was ich bisher gemacht habe:

- auf einer leeren Festplatte eine 100 MB Partition mit EXT3 angelegt und den Debian Installer (https://d-i.debian.org/daily-images/arm ... lo/ls-qvl/) darauf kopiert.
- Installation per SSH gestartet und dem Paket-Mirror konfiguriert, Festplatten-Erkennung.

Bei der Partitionierung treten aber immer wieder Fehler auf. Mal kann auf dem freien Speicher kein neues Dateisystem installiert werden, mal installiert er Debian, aber bootet dann wieder den Installer.

Nun meine Frage: Wie partitioniere ich die Festplatte richtig um auf dem NAS Debian zu installieren? Ich bin langsam am Verzweifeln.

LG Thomas

debianoli
Beiträge: 3523
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von debianoli » 28.10.2019 09:19:49

Hast du dieses PDF auch gelesen? Die beschreiben, wie man partitionieren soll
https://miniconf.debian.or.jp/assets/fi ... %20NAS.pdf

festplatte32
Beiträge: 17
Registriert: 04.05.2012 22:18:14

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von festplatte32 » 28.10.2019 09:42:51

Ja die Datei kenne ich. Allerdings will ich ja nur eine Festplatte verwenden, ohne RAID.

debianoli
Beiträge: 3523
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von debianoli » 28.10.2019 10:19:37

Ich würde mich trotzdem stur an die Anleitung im PDF halten und auch Raid für die Festplatte einschalten.

festplatte32
Beiträge: 17
Registriert: 04.05.2012 22:18:14

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von festplatte32 » 28.10.2019 19:28:06

Die Anleitung hat mir doch etwas weitergehofen. Vielen Dank! Ich habe es aber ohne ein RAID hinbekommen. Für Alle die das auch machen möchten:

1. Eine leere Festplatte mit gparted wie folgt partitionieren

Partitionsschema: gpt
boot Partition mit 1024 MB
root Partition mit 6144 MB
swap Partition mit 6400 MB
Restlicher Speicher als Daten Partition.

2. Den Debian-Installer (https://d-i.debian.org/daily-images/arm ... lo/ls-qvl/) auf die boot-Partition kopieren.
3. Die Festplatte in die Linkstation einbauen und neustarten. Wenn das blaue Licht nicht mehr blinkt ist die Linkstation hochgefahren.
4. Dann über SSH den Installer starten (Benutzername: installer, Passwort: install).
5. Die vorher angelegten Partition so wie oben beschrieben einbinden und Debian installieren.
6. Das wars.

Ein Problem habe ich aber noch: Die Linkstation startet nach dem reboot Befehl nicht neu. Sie wird nur heruntergefahren. Habt Ihr dafür noch eine Lösung?

Cyber2077
Beiträge: 6
Registriert: 01.11.2019 04:45:32

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von Cyber2077 » 01.11.2019 04:59:39

hi,

ich habe mir auch gerade buster auf meine LS-QVL installiert. Das Befehle wie reboot nicht gut funktionieren liegt wahrscheinlich daran das /sbin nicht in das user profile eingetragen ist, aber da muss ich selber noch nachforschen.

Hast du die Lüfter Steuerung und die LEDs, Knopfe und USB Ports in den Griff bekommen ?

Es funktioniert bei mir fast alles richtig gut, ssh, samba und transmission, aber der laute Lüfter auf 5000 RPM nervt mich echt.

Mit fancontrol allein bekomme ich das Problem nicht in den Griff, wenn ein alter Hase hier im Forum einen Tipp hätte wäre ich dankbar !

grüße
Cyber2077

Benutzeravatar
Livingston
Beiträge: 308
Registriert: 04.02.2007 22:52:25
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: 127.0.0.1

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von Livingston » 02.11.2019 01:00:19

Vielleicht gibt's unter https://buffalonas.miraheze.org/wiki/Main_Page und https://github.com/1000001101000/Debian_on_Buffalo noch was Nützliches. Ich mache mich demnächst an einer LS421 zu schaffen. Mal schauen, was da raus kommt.

Cyber2077
Beiträge: 6
Registriert: 01.11.2019 04:45:32

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von Cyber2077 » 02.11.2019 19:47:19

Hi,

danke für die Links ! Die LS-QVL ist veraltet deswegen gibt es kaum Infos.

Das wichtigste wäre mir der Lüfter. Wenn ich fancontrol mit pwmconfig konfiguriere arbeitet der Lüfter bei den angezeigten 5000 RPM (255 PWM) gar nicht und fährt bis zum lautstarken Maximum bei angezeigten 0 RPM 0 (PWM), also genau falsch herum.

Könnte ich da am Source Code von fancontrol etwas umstellen und dann neu compilieren ?

Speziell für die LS421 habe ich das hier gefunden:

https://tohenk.wordpress.com/2014/12/17 ... n-ls421de/

Wenn mir jemand helfen könnte, das für die LS-QVL anzupassen wäre ich dankbar.

grüße
cyber2077

Benutzeravatar
Livingston
Beiträge: 308
Registriert: 04.02.2007 22:52:25
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: 127.0.0.1

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von Livingston » 02.11.2019 21:28:01

Zu Deinem Lüfterproblem könnte das hier aus https://github.com/1000001101000/Debian ... DME-Buster passen:
Buster Notes:

Fan gpios inverted:
For some reason the values required for the gpio-fan functionality have inverted with the current kernel I've updated the device trees to re-invert them so that they continue to function normally. I don't know which way is the "correct" way but will watch for further changes in future kernels.
Das heißt schlimmstenfalls, den Kernel aus den dort abgelegten Quellen mit den dtb/device tree-Einträgen neu bauen.

Cyber2077
Beiträge: 6
Registriert: 01.11.2019 04:45:32

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von Cyber2077 » 03.11.2019 01:44:26

Hi,

super, danke ! Dann stelle ich den Lüfter erst mal konstant auf mittlere Einstellungen, und warte auf den nächsten Kernel.

grüße
Cyber2077

1000001101000
Beiträge: 4
Registriert: 05.11.2019 02:15:27

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von 1000001101000 » 05.11.2019 05:39:29

This is the same gpio-fan issue I found on the newer devices and mentioned in this thread. The shutdown/restart issue is because the QVL uses the Wake-on-lan interrupt pin to signal shutdown/restart. The ls400 series uses the same process.

I've updated my installer to support the LS-QVL and install fixes for both issues automatically. It can be downloaded from:
https://github.com/1000001101000/Debian ... el_devices

To install the fixes manually:

I've generated a new DTB for the QVL which corrects the gpio-fan pins which can be found here:
https://github.com/1000001101000/Debian ... vice_trees

it can be installer by downloading it into /etc/flash-kernel/dtbs/ then run:

Code: Alles auswählen

flash-kernel
The shutdown issue can be corrected by downloading phy_restart.sh and phytool-armel from here:
https://github.com/1000001101000/Debian ... ster/Tools

Code: Alles auswählen

cp phytool-armel /usr/local/bin/phytool
cp phy_restart.sh /usr/local/bin/ 
chmod +x /usr/local/bin/phytool
chmod +x /usr/local/bin/phy_restart.sh
sorry for the english.

let me know if you have any questions.

Cyber2077
Beiträge: 6
Registriert: 01.11.2019 04:45:32

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von Cyber2077 » 08.11.2019 23:37:11

That are fantastic news, I'm going to install it tomorrow !

Thank you very much !

Does the fan management work with the new installer out of the box, or should i configure fancontrol or something like that manually ?

1000001101000
Beiträge: 4
Registriert: 05.11.2019 02:15:27

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von 1000001101000 » 09.11.2019 00:37:49

The installer does not set up fancontrol but you can do so with pwmconfig.

Code: Alles auswählen

apt-get install fancontrol
pwmconfig

Cyber2077
Beiträge: 6
Registriert: 01.11.2019 04:45:32

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von Cyber2077 » 09.11.2019 08:46:06

what temperature should i choose for maximum ? 45, 50, 55 degree ?

1000001101000
Beiträge: 4
Registriert: 05.11.2019 02:15:27

Re: Debian Buster auf LinkStation LS-QVL installieren

Beitrag von 1000001101000 » 09.11.2019 15:41:09

For these type devices I usually leave the fan running at full.

When I have used fancontrol I usually measure the temperature of the device when it’s idle and the the fans are on medium then set the threshold a few degrees above that. Sometimes this leads to the fan changing speed constantly which I find more annoying that the fan just running on high.

It takes some trial and error to get it how you want it

Antworten