Verzögerter SDDM Login in KDE nach Update auf Buster

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
mikelm
Beiträge: 32
Registriert: 06.10.2005 20:04:40

Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von mikelm » 17.11.2019 14:54:37

Hallo,

bei einem Rechner dauert der Login in KDE mit SDDM ca 60sec.

In der .xsession_error hängt der Login an dieser Stelle
dbus-update-activation-environment: setting _=/usr/bin/dbus-update-activation-environment

Hat jemand eine Idee, woran das liegen könnte?
Den Nutzer hatte ich schon komplett gelöscht und neu angelegt. Bei anderen Nutzern ist das Phänomen das Gleiche.

Benutzeravatar
Blackbox
Beiträge: 2943
Registriert: 17.09.2008 17:01:20
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von Blackbox » 25.11.2019 18:54:56

Vorweg, ich verwende Debiansddm nicht.
Aber nachdem deinen Beitrag keiner beantwortet hat, wäre eine Idee, doch einfach einmal in die globale Konfigurationsdatei (wahrscheinlich unter /etc/... ) zu schauen und nach dem Schlüsselwort "time" oä zu suchen.
Weiterhin wäre es schön, wenn du alle relevanten Logfiles und Konfigurationsdateien zu Debiansddm hier im Forum postest.
Bitte längere (ab 6 Zeilen ) Dateiausgaben nach NoPoste packen und hier im Thread verlinken.

Du wirst sehen, mit etwas Zuarbeit wird die Hilfsbereitschaft der Forenteilnehmer wesentlich gesteigert.
Eigenbau PC: Debian Sid - Kernel: 5.3.7 - Xfce 4.14
Desktop PC: Dell Inspiron 530 - Debian Sid - Kernel: 5.3.7 - Xfce 4.14
Notebook: TUXEDO Book BU1406 - Debian Sid - Kernel: 5.3.7 - Xfce 4.14
Rootserver: Centos 7.7.1908 - Kernel: 3.10-x86_64
Alles Minimalinstallationen.

Freie Software unterstützen, Datenschutz stärken!

mikelm
Beiträge: 32
Registriert: 06.10.2005 20:04:40

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von mikelm » 25.11.2019 19:37:12

Hallo,
ich habe das Problem eigentlich schon aufgegeben. :x
Ein Googeln brachte meistens eine Neuinstallation. Dazu habe ich ehrlich gesagt keine Lust.
Die Fehler traten, sowiet ich mich erinnere, bei anderen Distris auf (Ubuntu). Ist also kein Debian-Problem, scheint an KDE zu liegen.

So, ich habe mal den sddm.log gelöscht und geschaut, ob danach etwas Neues rein geschrieben wurde. Das war nicht der Fall.
Die ".xsession-errors" zeigt aber an, was sddm gerade versucht zu tun und wo es hängt.
Hier der Link zur ".xsession-errors" aus dem home Verzeichnis zum Login:
pastebin/?mode=view&s=40926

Der Hänger ist genau hier:

Code: Alles auswählen

dbus-update-activation-environment: setting _=/usr/bin/dbus-update-activation-environment
Falls jemand eine Idee hat, nur zu. Ansonsten warte ich auf das nächste stable release "bullseye".

KP97
Beiträge: 1890
Registriert: 01.02.2013 15:07:36

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von KP97 » 25.11.2019 20:06:53

mikelm hat geschrieben: ↑ zum Beitrag ↑
25.11.2019 19:37:12
Ansonsten warte ich auf das nächste stable release "bullseye".
Na, das kann aber noch dauern...
Du könntest aber testweise das Paket "lightdm" installieren, um zu sehen, ob der Fehler in KDE bzw. SDDM zu suchen ist.
Wenn ich mich recht erinnere, wirst Du bei der Installation gefragt, welcher Display-Manager genutzt werden soll, kann also nichts passieren.

Benutzeravatar
Blackbox
Beiträge: 2943
Registriert: 17.09.2008 17:01:20
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von Blackbox » 26.11.2019 00:01:27

mikelm hat geschrieben: ↑ zum Beitrag ↑
25.11.2019 19:37:12

Code: Alles auswählen

dbus-update-activation-environment: setting _=/usr/bin/dbus-update-activation-environment
Das Paket Debiandbus ist aber installiert?
Eigenbau PC: Debian Sid - Kernel: 5.3.7 - Xfce 4.14
Desktop PC: Dell Inspiron 530 - Debian Sid - Kernel: 5.3.7 - Xfce 4.14
Notebook: TUXEDO Book BU1406 - Debian Sid - Kernel: 5.3.7 - Xfce 4.14
Rootserver: Centos 7.7.1908 - Kernel: 3.10-x86_64
Alles Minimalinstallationen.

Freie Software unterstützen, Datenschutz stärken!

MSfree
Beiträge: 4797
Registriert: 25.09.2007 19:59:30

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von MSfree » 26.11.2019 08:16:32

Ich könnte das falsch in Erinnerung haben, aber in der Vergangenheit gab es diese Beschwerden über Boot- und Loginverzögerungen doch auch schon mal. In solchen Fällen war doch die Abhilfe, Debianhaveged zu installieren.

Benutzeravatar
willy4711
Beiträge: 2524
Registriert: 08.09.2018 16:51:16

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von willy4711 » 26.11.2019 12:29:26

MSfree hat geschrieben: ↑ zum Beitrag ↑
26.11.2019 08:16:32
In solchen Fällen war doch die Abhilfe, Debianhaveged zu installieren.
Ich habe zwar Testing, aber ähnliche Probleme.
Daran liegt es - zumindest bei mir - nicht. Ist installiert.
Es gab mal eine Zeit, (bis vor ca. 2 Monaten) da startete KDE wie eine Biene (M.2 SSD / SATA) :mrgreen:
Aber leider ist es nicht mehr so. Jetzt hängt der Bootvorgang bei diesem dusseligen Label (drei Punkte - Pfeil) um ziemlich genau 30 Sekunden,
bevor der Desktop geruht zu erscheinen. :evil:
Aber:

Code: Alles auswählen

 systemd-analyze
Startup finished in 2.564s (kernel) + 8.722s (userspace) = 11.287s 
graphical.target reached after 8.706s in userspace
Die letzten Zeilen im Journal:

Code: Alles auswählen

Nov 26 12:11:25 debiankde systemd[1]: Mounted FUSE Control File System.
Nov 26 12:11:28 debiankde dbus-daemon[1639]: [session uid=1000 pid=1639] Activating service name='org.gnome.GConf' requested by ':1.52' (uid=1000 pid=3861 comm="/usr/bin/waterfox ")
Nov 26 12:11:29 debiankde dbus-daemon[1639]: [session uid=1000 pid=1639] Successfully activated service 'org.gnome.GConf'
Nov 26 12:12:45 debiankde systemd[1]: Started Run anacron jobs.
Nov 26 12:12:45 debiankde anacron[5797]: Anacron 2.3 started on 2019-11-26
Nov 26 12:12:45 debiankde anacron[5797]: Normal exit (0 jobs run)
Nov 26 12:12:45 debiankde systemd[1]: anacron.service: Succeeded.
Nov 26 12:17:01 debiankde CRON[11323]: pam_unix(cron:session): session opened for user root by (uid=0)
Nov 26 12:17:01 debiankde CRON[11331]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Nov 26 12:17:01 debiankde CRON[11323]: pam_unix(cron:session): session closed for user root
Irgendwie ärgert mich das. Benutze KDE zwar so gut wie nie, weil viel nicht richtig läuft und ich wenig Lust habe mich damit herumzuschlagen, wenn man ein System hat, dass reibungslos höchst zuverlässig läuft (Xfce).
Werde jetzt mal lightdm installieren. Mal sehen.

Benutzeravatar
willy4711
Beiträge: 2524
Registriert: 08.09.2018 16:51:16

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von willy4711 » 26.11.2019 12:45:56

So Debianlightdm installiert
Nach dem er mich erstmal auf eine leere LXQT- Session geschickt hatte :roll: Folgende Beobachtung:
Autologin:---> Dasselbe Drama
kein Autologin -----> Eins zwei drei, die Session samt Oberfläche erscheint ohne großartige Verzögerung.
Da werde mal jemand schlau draus :facepalm:

Benutzeravatar
willy4711
Beiträge: 2524
Registriert: 08.09.2018 16:51:16

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von willy4711 » 26.11.2019 15:54:01

So - Lighdm wieder rausgeschmissen.

Es ist auch bei sddm so, das der Unterschied Autologin bzw. kein Autologin ist.

Bei beiden Display- Manager das Gleiche. :facepalm:
Oberfläche erscheint ohne Autologin in 3 -5 Sekunden nach der PW-Eingabe (also dieses Logo-> dann Desktop)
Mit Autologin dauert es ca.30 Sekunden .( Logo-> dann Desktop)
hmmmmmmmmmm :roll: 8)

dillo
Beiträge: 314
Registriert: 28.05.2005 19:53:56

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von dillo » 26.11.2019 22:06:52

willy4711 hat geschrieben: ↑ zum Beitrag ↑
26.11.2019 15:54:01
Es ist auch bei sddm so, das der Unterschied Autologin bzw. kein Autologin ist.
In den Systemsettings/Arbeitsbereich-Design/Startbildschirm 'Keiner' einstellen und es flutscht wieder mit dem Autologin...zumindest bei mir unter sid.

Benutzeravatar
willy4711
Beiträge: 2524
Registriert: 08.09.2018 16:51:16

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von willy4711 » 26.11.2019 23:12:48

dillo hat geschrieben: ↑ zum Beitrag ↑
26.11.2019 22:06:52
In den Systemsettings/Arbeitsbereich-Design/Startbildschirm 'Keiner' einstellen und es flutscht wieder mit dem Autologin...zumindest bei mir unter sid.
Danke für den Tipp. Dabei habe ich festgestellt, das dort ein ziemliches Durcheinander herrschte Nur leere Symbole ,"Keiner" war nicht vorhanden.
Hab dann das ganze Plymouth- Zeugs noch mal reinstalliert, und gesehen,das es da noch ein Debianplymouth-x11 gab, was gar nicht installiert war.
Jetzt läuft es, auch mit Bildchen :mrgreen:

mikelm
Beiträge: 32
Registriert: 06.10.2005 20:04:40

Re: Verzögerter SDDM Login in KDE nach Update auf Buster

Beitrag von mikelm » 27.11.2019 19:01:56

Danke für die Tipps, hat aber leider alles nichts gebracht. dbus und haveged waren installiert, plymouth-x11 hatte mit dem Problem nichts zu tun.

Da warte ich auf den Nachfolger von buster, der Rechner ist sowieso meistens im Standby, da tritt das Problem nicht auf.

Antworten