gelöst - Grub lässt sich nicht installieren durch EFI Partition

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Benutzeravatar
Blackbox
Beiträge: 3188
Registriert: 17.09.2008 17:01:20
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von Blackbox » 22.11.2020 18:29:18

chloris hat geschrieben: ↑ zum Beitrag ↑
22.11.2020 12:04:31
[...] ich bin Linux Anfänger und werde es immer bleiben [...]
Mit diesem "Anspruch" habe ich keine Lust zu helfen.
Warum bist du eigentlich nicht bei Windows geblieben, wenn du überhaupt keine Lust hast, etwas zu erlernen?
Eigenbau PC: Debian Sid - Kernel: 5.9.6 - Xfce 4.14
Desktop PC: Dell Inspiron 530 - Debian Sid - Kernel: 5.9.6 - Xfce 4.14
Notebook: TUXEDO Book BU1406 - Debian Sid - Kernel: 5.9.6 - Xfce 4.14
Rootserver: Centos 8.2.2004 - Kernel: 4.18
Alles Minimalinstallationen.

Freie Software unterstützen, Datenschutz stärken!

rockyracoon
Beiträge: 866
Registriert: 13.05.2016 12:42:18

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von rockyracoon » 22.11.2020 19:09:18

@Blackbox:
ich bin Linux Anfänger und werde es immer bleiben
Vielleicht hat dies chloris anders, bescheidener gemeint, als Du es interpretierst.

@chloris:
...dass ab Debian 10 Secure boot für Dual boot Systeme kein Problem mehr darstellt.
Ja schon, aber mir scheint ein "Dual-Boot" von Linux zusammen mit Windows nach wie vor sehr fehleranfällig zu sein, wie überhaupt das ganze UEFI-Geraffel.

Benutzeravatar
Blackbox
Beiträge: 3188
Registriert: 17.09.2008 17:01:20
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von Blackbox » 23.11.2020 10:05:40

rockyracoon hat geschrieben: ↑ zum Beitrag ↑
22.11.2020 19:09:18
@Blackbox:Vielleicht hat dies chloris anders, bescheidener gemeint, als Du es interpretierst.
Ja, vielleicht, es wäre schön, wenn sich der TO einmal dazu äußerte.
Dann müssten wir weniger »orakeln« ...
Eigenbau PC: Debian Sid - Kernel: 5.9.6 - Xfce 4.14
Desktop PC: Dell Inspiron 530 - Debian Sid - Kernel: 5.9.6 - Xfce 4.14
Notebook: TUXEDO Book BU1406 - Debian Sid - Kernel: 5.9.6 - Xfce 4.14
Rootserver: Centos 8.2.2004 - Kernel: 4.18
Alles Minimalinstallationen.

Freie Software unterstützen, Datenschutz stärken!

Benutzeravatar
willy4711
Beiträge: 4429
Registriert: 08.09.2018 16:51:16

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von willy4711 » 23.11.2020 10:31:29

Ich hab zwar noch nie ein System mit UEFI installiert (bleibe solange es geht beim lieben alten BIOS), aber
es gibt doch im (BIOS /UEFI) Boot- Menü die Auswahl, einen USB_Stick oder DVD im UEFI -Modus
oder BIOS Modus zu starten.

Ich bilde mir ein schon öfter gelesen zu haben, dass der BIOS_Modus im Nachhinein dann die Installation von Grub
auf der EFI- Partition ausschließt..

Vielleicht eine Möglichkeit ??

mcb
Beiträge: 329
Registriert: 25.06.2020 17:28:49

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von mcb » 23.11.2020 14:45:24

chloris hat geschrieben: ↑ zum Beitrag ↑
16.11.2020 22:42:40
Hallo,
ich habe einen Acer Travelmate Spin B118- RN Convertible 256 GB 11,6 Zoll mit Windows 10.
und wollte darauf zusätzlich Debian testing Version durch eine Iso Datei auf USB Stick installieren.
"Schwerer Fehler" Grub2 lässt sich nicht installieren. Fehler durch EFI Partition.
Ich habe Verschiedenes probiert, aber am Ende hat sich zwar das ganze System installiert, aber ohne Grub2 und die Meldung sagte: Sie müssen manuell starten.
Danach habe ich mit einem Iso File von Ubuntu 2020 das Gleiche probiert und beim Versuch Grub2 zu installieren brach die Installation ab und sagte mir "schwerer Fehler" Grub2 lässt sich nicht installieren.

1. Frage: wenn ich Windows lösche und nur Debian installiere, gibt es dann das gleiche Problem?
2. Wie kann ich manuell Debian starten, wenn sofort nach dem Einschalten Windows erscheint?
3. Wie könnte ich Grub2 nachinstallieren?

Ich bin Linux Anfänger und kenne mich nicht gut aus, brauche also genaue Erklärung
Besten Dank
chloris
Ich weiß auch nicht alles - aber Stand schon oft vor dem gleichen Problem. UEFI ist nicht wirklich logisch ...

1 - nein -> Debian oder Linux -> Auswahl komplette Platte und es geht "immer" (Ausnahmen sehr selten)
2 - das UEFI hat meist ein eigenes Bootmenue (F12 bei Thinkpads)
3 - Rettungssystem -> / und /efi & /boot auf dem internen Laufwerk Auswählen (Reperaturmodus) Grub installieren (du mußt nur das Laufwerk z.B. /sda angeben)

rockyracoon
Beiträge: 866
Registriert: 13.05.2016 12:42:18

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von rockyracoon » 23.11.2020 15:27:22

@willy4711:
Ich bilde mir ein schon öfter gelesen zu haben, dass der BIOS_Modus im Nachhinein dann die Installation von Grub
auf der EFI- Partition ausschließt..

Vielleicht eine Möglichkeit ??
Yep. Aber, wenn chloris die UEFI-Installation beim Kauf des Laptop`s mit Windows-10 vorgefunden und nicht verändert hat, dann ist das EFI statt Legacy ("altes" Bios) aktiviert.
Zur zusätzlichen Installation von Linux für ein Dual-Boot muß er dann bei der Auswahl des Boot-Mediums die UEFI-Version auswählen, statt vielleicht versehentlich die Legacy-Version, weil immer beide Boot-Quellen angeboten werden und man daher genau hinschauen muß. Fast-Boot sollte deaktiviert werden, weil Windows-Spezifisch und SSD stressend, Secure-Boot geht mittlerweile bei Debian-10/11, ist imho aber Nonsense und ich habe es deaktiviert.

O.T.:
Ich hab zwar noch nie ein System mit UEFI installiert
So habe ich es bisher auch gemacht.
Aber die Hardware-Hersteller werden leider wohl (aus welchem Grund auch immer 8) ) über kurz oder lang die Bios(Legacy)-Wahl nicht mehr zulassen und nur noch EFI mit Secure-Boot anbieten. :evil:

Benutzeravatar
willy4711
Beiträge: 4429
Registriert: 08.09.2018 16:51:16

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von willy4711 » 23.11.2020 17:29:44

rockyracoon hat geschrieben: ↑ zum Beitrag ↑
23.11.2020 15:27:22
Zur zusätzlichen Installation von Linux für ein Dual-Boot muß er dann bei der Auswahl des Boot-Mediums die UEFI-Version auswählen, statt vielleicht versehentlich die Legacy-Version, weil immer beide Boot-Quellen angeboten werden und man daher genau hinschauen muß.
Ja das genau meine Ich. Irgendwann vor langer Zeit hatte ich mal bei einer Mint- Installation nicht darauf geachtet, dann gab es zum Schluss dann auch Ärger mit dem Grub.
Aber jetzt ist das nur Spekulation.

chloris
Beiträge: 10
Registriert: 16.11.2020 22:27:06

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von chloris » 23.11.2020 19:24:47

ich bin Linux Anfänger und werde es immer bleiben
Ich lerne ständig dazu, und freu mich, aber was ich meinte, ist, dass ich nicht die Zeit hatte und haben werde, von Grund auf einen Linux Kurs zu machen um alles zu lernen. Also ein "Profi" zu werden, der mit der Konsole regelmäßig arbeitet und sich darin ohne wesentliche Probleme auskennt, also nach Belieben herum jonglieren kann.

Ich bediene mich hauptsächlich der graphischen Variante, nur wenn ich Probleme habe, gehe ich in die Konsole, habe dabei aber riesige Probleme, da ich die Grundlagen nicht von Anfang an gelernt habe. Durch Probleme lerne ich dann dazu, da ich dann im Internet mir Lösungen suche und die dann anwende. Wenn ich nichts finde, so wie jetzt, frage ich im Forum.

Ich habe bei der Installation der Partitionierung der Festplatte "manuell" ausgewählt, und eine Partitionierung für root " / " gemacht, eine Weitere für Swap, eine Dritte für home.
Zur zusätzlichen Installation von Linux für ein Dual-Boot muß er dann bei der Auswahl des Boot-Mediums die UEFI-Version auswählen, statt vielleicht versehentlich die Legacy-Version, weil immer beide Boot-Quellen angeboten werden und man daher genau hinschauen muß.
Bei der Installation von Grub , soweit ich mich erinnere, kam keine Meldung, die mich fragte, ob ich irgendetwas auswählen soll.

Als ich im Bios dann Secure boot ausschalten wollte , durch Eure Beiträge, hat mir das bios das nicht erlaubt. Ich konnte nichts verändern. Ich vermute, dass der Hardware Hersteller nur EFI mit Secure Boot angeboten hat.

Ich las irgendwo, dass man, wenn man ein Boot Passwort erstellt, man Secure Boot ausschalten kann, das habe ich noch nicht probiert. Soll ich das probieren?

rockyracoon
Beiträge: 866
Registriert: 13.05.2016 12:42:18

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von rockyracoon » 23.11.2020 19:50:15

@chloris:
Ich las irgendwo, dass man, wenn man ein Boot Passwort erstellt, man Secure Boot ausschalten kann, das habe ich noch nicht probiert. Soll ich das probieren?
Kurze Antwort: Imho Nein.
Längere Antwort: Als ich vor zwei Jahren das fragwürdige Vergnügen hatte, mich nach dem Kauf eines neuen PC`s mit dem UEFI/Secure-Boot-Geraffel auseinandersetzen zu "dürfen", hatte ich diesen Rat auch im Internet gelesen. Meinen Recherchen nach ist er aber falsch und nicht zielführend.

Was helfen kann, ist ein Blick in das Manual des Mainboards. Aber tatsächlich gibt es - entgegen den Forderungen an die Hardware-Hersteller - PC`s, bei denen man EFI und Secure-Boot nicht deaktivieren kann.
In meinem Fall - obwohl ich einen PC eines namhaften Herstellers habe - gab es im Mainboard-Manual keine Hinweise, wie man Secure-Boot deaktivieren kann! Damals war meine Debian-Version noch nicht fähig, mit Secure-Boot umzugehen, also herrschte bei mir Stress, Wut, etc. Im Internet fand ich dann einen zielführenden Link. Dort wurde empfohlen, die Secure-Boot-Schlüssel (nach sicherheitshalber vorheriger Sicherung per USB) zu löschen. Das half tatsächlich. Dann habe ich - wie willy4711 - das Mainboard auf die "alte" Bios-Option (im neudeutsch heißt das Legacy) umgestellt. Bei einer späteren Debian-Installation habe ich Secure-Boot (welches ich alles Andere als "secure" bewerte) nach wie vor deaktiviert gelassen, Debian aber mit der Efi-Option erstellt. Ich bin pessimistisch, was uns zukünftige PC-Produkte noch an Hardware-Nonsense bieten werden.
Zuletzt geändert von rockyracoon am 23.11.2020 20:00:51, insgesamt 9-mal geändert.

chloris
Beiträge: 10
Registriert: 16.11.2020 22:27:06

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von chloris » 23.11.2020 19:54:49

Im bios habe ich jetzt die Möglichkeit ausgewählt, die F12 Taste zu benützen, um beim Start das boot Menü aufzurufen.

Wenn ich das tue, dann zeigt sich in der ersten Zeile Windows,
in der zweiten Zeile: Unknown Device (Micron_1100_MTFDDAV256TBN)

Wenn ich die zweite Zeile aufrufe erscheint:
GNU Grub version 2.04
Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completion. Anywhere else TAB lists possible device or file completion.
grub>_

dann versuchte ich einzugeben: /vmlinuz /dev/sda5 root=/dev/sda5 quiet
Ergebnis:
error: can't find command "/vmlinuz"

So, was soll ich da eingeben, damit Debian startet?

rockyracoon
Beiträge: 866
Registriert: 13.05.2016 12:42:18

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von rockyracoon » 23.11.2020 20:02:17

@chloris:
Minimal BASH-like line editing is supported.
Kenne ich. Diese Meldung hatte ich auch bei meinem ersten Versuch der Efi-Installation.
So, was soll ich da eingeben, damit Debian startet?
Sorry. Keine Ahnung.
Was habe ich gemacht:
Windows installiert, damit wieder ein Efi-Eintrag entsteht.
Dann Debian mit der Efi-Option installiert, dabei aber durch eine Single-Boot Windows plattgenmacht. > Hier fehlt mir eine Faust oder so etwas als Smilie-Icon. :mrgreen:
Was ein Dual-Boot`ler machen soll, weiß ich nicht. Ich glaube sowieso, dass bei Dual-Boot`s über kurz oder lang Probleme auftauchen.
In Deinem Fall würde ich noch einmal - wie wir oben vermutet haben - überprüfen, ob Du nicht doch die falsche Boot-Version gewählt hast.
Das sieht dann so aus:
UEFI: Name des Speichermediums
Und damit Debian neu installieren.
An Partitionen hätte ich beim Dual-Boot nur eine Partition für Windows und eine für Linux. Und dann die Debian-Installationsroutine Alles machen lassen.

KP97
Beiträge: 2201
Registriert: 01.02.2013 15:07:36

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von KP97 » 23.11.2020 20:23:35

Hier im Wiki ist ein ausführlicher Beitrag zur Installation von Debian mit UEFI. Die Rede ist zwar von Stretch, aber die Abläufe sind noch genauso anwendbar.
Mittlerweile kann Buster auch mit Secureboot umgehen, aber das Ausschalten schadet auch nicht.
Ganz wichtig:
Da durch das vorhandene Windows 10 schon eine Efi-Partition existiert, mußt Du zwingend Debian auch mit UEFI installieren.
Das siehst Du beim Start des Installationsmediums. Es gibt zwei Einträge für Debian, einmal "einfach" und einmal mit dem Zusatz UEFI. Diesen Eintrag mußt Du wählen!
Wenn der "einfache" Eintrag gewählt wird, läßt sich Grub nicht installieren, da der Installer keine Efi-Partition finden bzw. anlegen kann.

Wähle eine geführte Installation, das ist für den Anfang leichter...und alles genau lesen, was an Abfragen erscheint.
Also, auf ein Neues...wird schon werden...

https://wiki.debianforum.de/UEFI

Benutzeravatar
Tintom
Beiträge: 2140
Registriert: 14.04.2006 20:55:15
Wohnort: Göttingen

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von Tintom » 23.11.2020 21:08:10

chloris hat geschrieben: ↑ zum Beitrag ↑
23.11.2020 19:54:49
So, was soll ich da eingeben, damit Debian startet?
Eher etwas wie
linux /vmlinuz root=/dev/sda5
initrd /initrd.img
boot

rockyracoon
Beiträge: 866
Registriert: 13.05.2016 12:42:18

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von rockyracoon » 23.11.2020 21:53:43

@Tintom: KP97 hat eins über Deinem Post meiner Meinung nach aber das Wesentliche zur Lösung des Problems von chloris gesagt.

chloris
Beiträge: 10
Registriert: 16.11.2020 22:27:06

Re: Grub lässt sich nicht installieren durch EFI Partition

Beitrag von chloris » 23.11.2020 22:45:56

danke für die Beiträge, ich habe mich entschieden Windows zu löschen und nur Debian zu installieren.
Das habe ich gemacht, bei der Installation sagte er mir: Debian will mit UEFI installieren, aber ein anderes Betriebssystem ist nicht mit UEFI installiert. Es sei ein Risiko mit UEFI zu installieren. Soll ich nun mit oder ohne UEFI installieren?
Ich habe gesagt nein, ohne UEFI.
Dann hat es alles installiert, inklusive Grub. Installation wurde ohne Probleme beendet.
Als ich den Laptop dann neu startete, erschien die Meldung:
No bootable Device, das heißt es hat Windows gelöscht und Debian kann ich auch nicht starten.
So, jetzt mache ich vorläufig Schluss und widme mich anderen Dingen. Der Laptop muss warten.
Später werde ich dann Debian neu installieren vielleicht mit einer anderen iso.Datei.

Antworten