10.8 Net-Installation Firmware-Version Problem

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
OrangeJuice
Beiträge: 369
Registriert: 12.06.2017 15:12:40

Re: 10.8 Net-Installation Firmware-Version Problem

Beitrag von OrangeJuice » 28.03.2021 18:11:25

Dann machen wir das anders, bitte als root einloggen. Unter GRUB_CMDLINE_LINUX="" fügst du testweise mal das ein, was ich weiter oben in "Code" eingefügt habe.

Code: Alles auswählen

noapic amd_iommu=off iommu=soft swiotlb=force,4096 hpet=disable

Code: Alles auswählen

su -
nano /etc/default/grub
update-grub
exit
Info: STRG+O speichert dir die Sache und STRG+X schließt nano wieder.
Kernel-Parameter

wolf49
Beiträge: 66
Registriert: 27.12.2018 15:41:22

Re: 10.8 Net-Installation Firmware-Version Problem

Beitrag von wolf49 » 28.03.2021 20:25:32

hallo,
die Zeile

Code: Alles auswählen

GRUB_CMDLINE_LINUX="noapic amd_iommu=off iommu=soft swiotlb=force,4096 hpet=disable"
vor den Start im boot-Menu mit e oder c geht nicht weil auf der Tastatur an dieser Stelle kein " möglich ist. in grub.config kann ich die Zeile eintragen, aber an welcher Stelle des Debian menuentry ? sie soll ja die anderen Betriebssysteme nicht beeinflussen. was Anderes: kann man diese inkompatiblen UUIDs ersetzen ?

OrangeJuice
Beiträge: 369
Registriert: 12.06.2017 15:12:40

Re: 10.8 Net-Installation Firmware-Version Problem

Beitrag von OrangeJuice » 28.03.2021 21:14:37

Müsste da sein, wo das "ä"(shift drücken) ist, ist ein englisches Layout. In Gnome kann man sich das Layout anschauen(Einstellungen->Region Sprache->Eingabequelle(auf das Auge klicken).
Ist von mir mit den Kernel-Parameter auch nur eine Vermutung/Vorschlag, es heißt nicht, dass es unbedingt klappen muss.

Bei UUID kann ich dir nicht weiterhelfen, da müsste jemand anderes weiterhelfen.

wolf49
Beiträge: 66
Registriert: 27.12.2018 15:41:22

Re: 10.8 Net-Installation Firmware-Version Problem

Beitrag von wolf49 » 29.03.2021 10:22:46

hallo,
konnte die Zeile in das boot-Menu einfügen, aber kein Erfolg. ich habe nur den maintenance-mode. das Ergebnis von

Code: Alles auswählen

dmesg -x -l crit,warn,err

Code: Alles auswählen

kern  :warn  : [    0.678063]  #2
kern  :warn  : [    0.680278]  #3
kern  :warn  : [    0.686795] mtrr: your CPUs had inconsistent variable MTRR settings
kern  :warn  : [    5.102923] wmi_bus wmi_bus-PNP0C14:00: WQBJ data block query control method not found
kern  :warn  : [    5.126386] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
kern  :warn  : [    5.131916] ACPI Warning: SystemIO range 0x0000000000000B00-0x0000000000000B08 conflicts with OpRegion 0x0000000000000B00-0x0000000000000B0F (\_SB.PCI0.SMBS.SMB0) (20180810/utaddress-213)
kern  :warn  : [    5.275730] usb: port power management may be unreliable
kern  :warn  : [    5.420069] resource sanity check: requesting [mem 0x000c0000-0x000dffff], which spans more than PCI Bus 0000:00 [mem 0x000c0000-0x000c3fff window]
kern  :warn  : [    5.420078] caller pci_map_rom+0x6a/0x1b0 mapping multiple BARs
kern  :err   : [   16.458348] kvm: disabled by bios
kern  :err   : [   16.501943] kvm: disabled by bios
kern  :err   : [   16.541379] kvm: disabled by bios
kern  :err   : [   16.579495] kvm: disabled by bios
um mehrere Betriebssysteme zu betreiben braucht man in Zukunft für jedes System eine eigene Festplatte die man dann wechseln muss. offenbar wird jetzt nur noch ein Betriebssystem je Rechner von den Software-Herstellern geduldet.

OrangeJuice
Beiträge: 369
Registriert: 12.06.2017 15:12:40

Re: 10.8 Net-Installation Firmware-Version Problem

Beitrag von OrangeJuice » 29.03.2021 18:49:14

Ist aber komisch, kannst du mal bitte folgendes zeigen.

Code: Alles auswählen

cat /etc/default/grub
Was du noch testen kannst, ob es sich mit einem neueren Kernel und aktuellen Paketen besser verhält. Lade dir am besten Debian Bullseye KDE Live non-free(Link)herunter und teste es vom USB-Stick aus.

wolf49
Beiträge: 66
Registriert: 27.12.2018 15:41:22

Re: 10.8 Net-Installation Firmware-Version Problem

Beitrag von wolf49 » 29.03.2021 19:25:46

hallo,
cat-grub:

Code: Alles auswählen

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
ich habe mal im maintenence-mode stratx eingegeben die Grafik startet und funktioniert einwandfrei. das kann ich in Autostart einfügen. ob alles andere mit nur einem tty funktioniert muss ich dann sehen. gibt es eine Möglichkeit aus dem maintenence-mode in den Normal.Modus zu kommen ?

wolf49
Beiträge: 66
Registriert: 27.12.2018 15:41:22

Re: 10.8 Net-Installation Firmware-Version Problem

Beitrag von wolf49 » 30.03.2021 08:38:56

hallo,
nachdem ich /etc/default/grub gelesen habe habe ich da UUID disabeld. nun startet der Rechner im Normal-Modus und die Grafik funktioniert einwandfrei. vielen Dank für die umfangreiche Hilfe und Geduld. Gruß

Antworten