grub default boot EINMALIG ändern

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
michaa7
Beiträge: 3342
Registriert: 12.12.2004 00:46:49
Lizenz eigener Beiträge: MIT Lizenz

grub default boot EINMALIG ändern

Beitrag von michaa7 » 22.04.2006 12:17:16

Habe meinen server nun etwas umgebaut und läuft alles soweit. Da ich ihn jedoch - soweit möglich - über putty administriere, suche ich nach einer möglichkeit, grub über putty eine anweisung zukommen zu lassen, dass beim nächsten boot, oder eben beim re-boot an stelle der default installation meine wartungsinstallation gebooted wird.
Ich habe mir dazu etwas über safedefault angelesen und über die default einträge, bin aber noch nicht so richtig schlau daraus geworden. Ich weiß nun lediglich, dass man irgendwie eine boot --once befehl senden kann. Ich poste hier mal den relevanten teil der menu-lst, damit mir vielleicht jemand sagen kann, was ich noch wo eintragen muß, damit das wie gewünscht klappt:

Code: Alles auswählen

...

#You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
default         2

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout         3

....

## ## End Default Options ##

title           Debian GNU/Linux, kernel 2.6.8-2-386
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.8-2-386 root=/dev/hde1 ro
initrd          /boot/initrd.img-2.6.8-2-386
#savedafault
#boot

title           Debian GNU/Linux, kernel 2.6.8-2-386 (recovery mode)
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.8-2-386 root=/dev/hde1 ro single
initrd          /boot/initrd.img-2.6.8-2-386
#savedefault
#boot

### END DEBIAN AUTOMAGIC KERNELS LIST

title           Debian server
root            (hd0,4)
kernel          /vmlinuz-2.6.8-1-386 root=/dev/hde6 ro
initrd          /initrd.img-2.6.8-1-386


Die ersten beiden einträge sind die einträge für meine wartungs-installation. Durch den installer waren noch jeweils die beiden zeilen

safedefault
boot

angehängt. Da mir nicht wirklich klar war, was sie bewirken, habe ich die erstmal auskommentiert.
Der dritte eintrag ist die installation die per "default 2" standartmäßig gebootet wird
gruß

michaa7

-------------------------------
Menschen ändern gelegentlich ihre Ansichten, aber nur selten ihre Motive. (Oskar Negt)
Forumsumfrage: Welche debianartige Distribution / SubDistri nutzt du?
Und wenn ihr textet das Abstimmen im Formular nicht vergessen ...

hirube
Beiträge: 68
Registriert: 14.09.2005 10:09:15

Beitrag von hirube » 23.04.2006 14:16:45

grub-reboot evtl.?

michaa7
Beiträge: 3342
Registriert: 12.12.2004 00:46:49
Lizenz eigener Beiträge: MIT Lizenz

Beitrag von michaa7 » 23.04.2006 20:01:59

hirube hat geschrieben:grub-reboot evtl.?
sieht gut aus, nur wo hänge ich das dran? In der kommandozeile funst das nicht, obwohl es die man pages gibt.

Habe aber mitlerweile das heir ergoogelt

Code: Alles auswählen

Hier muss (ebenfalls als root) durch Eingabe von grub in die Grub-Shell gewechselt werden und dann mit savedefault –default=# –once, wobei die Raute wieder für die Konfigurations-Nummer steht, das entsprechende ausgewählt werden. Funktioniert das alles nicht, ist Grub nicht entsprechend gepachted oder zu alt.

Das kann bei mir beides nicht klappen, weil das nur mit der installation klappt (und klappen kann), in der grub installiert ist ... ;-(

Da werd ich mir was einfallen lassen müssen
gruß

michaa7

-------------------------------
Menschen ändern gelegentlich ihre Ansichten, aber nur selten ihre Motive. (Oskar Negt)
Forumsumfrage: Welche debianartige Distribution / SubDistri nutzt du?
Und wenn ihr textet das Abstimmen im Formular nicht vergessen ...

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 22102
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Beitrag von KBDCALLS » 23.04.2006 22:20:45

Müßtest dir mal die Info Datei des Grubs ansehen.

Mit dem Konqueror

info:/grub/Booting once-only
info:/grub/Booting fallback systems

Mit Mozilla und Konsorten funktionieren die Links nicht.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

michaa7
Beiträge: 3342
Registriert: 12.12.2004 00:46:49
Lizenz eigener Beiträge: MIT Lizenz

Beitrag von michaa7 » 23.04.2006 23:40:13

ging auch mit dem konq nicht, habs aber im netz gefunden. Blicke das zwar noch nicht genau, aber die infos selber sind das was ich suche, danke dafür
gruß

michaa7

-------------------------------
Menschen ändern gelegentlich ihre Ansichten, aber nur selten ihre Motive. (Oskar Negt)
Forumsumfrage: Welche debianartige Distribution / SubDistri nutzt du?
Und wenn ihr textet das Abstimmen im Formular nicht vergessen ...

michaa7
Beiträge: 3342
Registriert: 12.12.2004 00:46:49
Lizenz eigener Beiträge: MIT Lizenz

Beitrag von michaa7 » 06.05.2006 18:14:28

so, jetzt habe ich mir das eingerichtet, blicke aber bei einer sache nicht durch. Wenn ich mir meine bootreihenfolge über "fallback" absichere, dann bin ich gezwungen (so verstehe ich diesen hinweis)

Code: Alles auswählen

   However, you need to run `grub-set-default' (Note: Invoking
grub-set-default) when `A' starts correctly or you fix `A' after it
crashes, since GRUB always sets next boot entry to a fallback entry.
You should run this command in a startup script such as `rc.local' to
boot `A' by default:

     # grub-set-default 0
meinen default eintrag über so ein startscripüt sicher zu stellen. Damit ist aber ein booting once-only nicht mehr möglich, denn das startscript würde diesen eintrag ja überschreiben. Sehe ich das richtig?

Diesen ganzen aufwand ( naja. so groß ist der ja nicht) treibe ich , weil ich meinen server über putty steuere und ihn daher erst nach dem booten per bildschirm sehen kann. Und bei der installation eines neuen kernels mußte ich bislang immer den monitor umstecken. Daher möchte ich mir das so einrichten, dass ich für möglichst viel eventualitäten gerüstet bin.

Meine menü.lst sieht daher folgendermaßen aus:

Code: Alles auswählen


default saved
timeout 3

#fallbackstratrgie
fallback 1 2

#default
title           Debian server
root            (hd0,4)
kernel          /vmlinuz-2.6.8-1-386 root=/dev/hde6 ro
initrd          /initrd.img-2.6.8-1-386
savedefault fallback

## ## End Default Options ##

title           Debian GNU/Linux, kernel 2.6.8-2-386
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.8-2-386 root=/dev/hde1 ro
initrd          /boot/initrd.img-2.6.8-2-386
savedefault fallback
#boot

title           Debian GNU/Linux, kernel 2.6.8-2-386 (recovery mode)
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.8-2-386 root=/dev/hde1 ro single
initrd          /boot/initrd.img-2.6.8-2-386
savedefault
#boot

### END DEBIAN AUTOMAGIC KERNELS LIST
Das bedeutet (soweit ich dies verstehe): Es wird zunächst die normale server installation gebooted. bein nächsten mal der zweite eintrag, und danach der dritte eintrag, der dann default bleibt. Will ich jedoch den ersten eintrag als default bebehalten MUSS ich das über ein startscript regeln. Dann habe ich jedoch keine möglichkeit mehr per

Code: Alles auswählen

grub-set-default 1
absichtlich denn zweiten eintrag zu booten, da dies vom startscript überschrieben würde.
gruß

michaa7

-------------------------------
Menschen ändern gelegentlich ihre Ansichten, aber nur selten ihre Motive. (Oskar Negt)
Forumsumfrage: Welche debianartige Distribution / SubDistri nutzt du?
Und wenn ihr textet das Abstimmen im Formular nicht vergessen ...

Antworten