*gelöst* xscreensaver...

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Aiellu
Beiträge: 270
Registriert: 11.05.2007 21:06:25
Lizenz eigener Beiträge: MIT Lizenz

*gelöst* xscreensaver...

Beitrag von Aiellu » 29.06.2007 18:39:34

also, seit linux hab ich immer wieder mal probleme mit den bildschirmschonern die mir regelmässig auf den senkel gehen, aber bisher weder unter google, noch in irgend einem forum oder wiki infos zu gefunden habe.

und zwar:
scheint apm zu machen was es will, es schaltet den bildschirm nach ca. 10 min schwarz, aber sperrt diesen nicht. seit ich nun ausschliesslich fluxbox verwende besteht das problem ziemlich hartnäckig. unter kde hat kpowersave den apm ziemlich gut im griff aber unter floxbox kein kpowersave und ich fühl mich dem apm *ähm* irgendwie ausgeliefert.

ich habe folgende pakete installiert: apm, acpi (wegen den sensoren), powersaved, xscreensaver

xscreensaver ist eingestellt auf:
"only one screensaver"
"XRaySwarm"
"Schwärzen nach 30 Min"
"Lock Screen nach 40 Min"

unter "Klomplex":
[X] Energieverwaltung aktivieren
alles auf "60 Minuten"

jedoch die einstellungen von xscreensaver werden völlig ignoriert. der bildschirm schaltet also bereits nach ca. 10 minuten schwarz (keine XRays), wird nicht nach 40 minuten gesperrt, aber schaltet wenigstens nach 60 minuten aus (das einzige was richtig läuft).

im xorg.conf hab ich schon den monitor-schoner abgeschaltet, also: "DPMS" "off" (ohne erkennbare wirkung)

der powersaved ist für mich als user chippi freigegeben mit:
#adduser chippi powerdev

powersave -t gibt mir aus:
CPU: 0
Throttling States: 8
Current State: 0

ich bin zwar ziemlich kreativ, aber hier nun mit meinen ideen am ende. wer weiss was hier los ist und was ich machen muss damit meine settings des xscreensavers angenommen werden.

bitte im rat, denn es nervt echt! vor allem wenn ich grad am computer am TV gucken bin und immer wieder nach ca. 10 min der bildschirm dunkel wird. *argh* :evil:

zusatzinfo: es ist weder kdm noch gdm noch kde noch gnome installiert als zusätzliches display-desktop-dings, hab ausschliesslich fluxbox drauf, login erfolgt über tty.

hardware:
cpu: intel P4 1.8GH
board: MSI intel 845 chipsatz
graka: nvidia geforce 5200 FX
moni: samsung 15'' TFT
speicher: 1GB infinion (1 DDR-riegel in der ersten bank)
Zuletzt geändert von Aiellu am 03.07.2007 12:19:57, insgesamt 3-mal geändert.

Benutzeravatar
Kalimac
Beiträge: 293
Registriert: 25.05.2004 13:19:48
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Wetterau
Kontaktdaten:

Beitrag von Kalimac » 29.06.2007 18:57:01

Probier' doch 'mal folgendes in Deiner ~/.xinitrc oder/und ~/.xsession:

Code: Alles auswählen

xset -dpms
.

Mit

Code: Alles auswählen

xset q
siehst Du die aktuellen Einstellungen.

Dann weiszt Du wenigstens ob DPMS wirklich aus ist.
Die technische Evolution ist die Wirkung eines geistigen Fortschritts gewesen und könnte nun zu seiner Ursache werden.
- Jacques Neirynck -

Aiellu
Beiträge: 270
Registriert: 11.05.2007 21:06:25
Lizenz eigener Beiträge: MIT Lizenz

Beitrag von Aiellu » 29.06.2007 19:19:30

"xset q" meldet mir: "DPMS is Disabled"

um eventuelle erfolge zu sehen werd ich nun mal die wartezeit zum einschalten des XRaySwarm-schoners auf 1 min setzen und mich wieder melden falls das angenommen wird...

/€
omg ich werd be*piep*pt es klappt, endlich klappts. spitze! vielen dank! auf "xset -dpms" in der .xinitrc wäre ich nicht gekommen, lädt sich der dpms echt (eigenwillig) im hintergrund nach obwohl es in xorg.conf abgeschaltet ist?! boa menno so ein schlawiehner! "DPMS" "off" ist doch der richtige parameter zum abschalten oder?! gibts dazu auch schon einen eintrag im wiki? denn ich bin auf meiner suche nach lösungen schon auf so manche gestossen die das gleiche problem haben, aber ohne lösung dazu.

vielen dank nochmal!!! :P

Benutzeravatar
Kalimac
Beiträge: 293
Registriert: 25.05.2004 13:19:48
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Wetterau
Kontaktdaten:

Beitrag von Kalimac » 29.06.2007 20:31:42

Aiellu hat geschrieben:"DPMS" "off" ist doch der richtige parameter zum abschalten oder?
Hm, laut man xorg.conf ja, kA warum es nicht funktioniert. In meiner xorg.conf steht nur:

Code: Alles auswählen

  Option       "DPMS"
Da ich DPMS benutze steht in meiner ~/.xsession:

Code: Alles auswählen

xset dpms 300 900 1800
.
Aiellu hat geschrieben:vielen dank nochmal!!! Razz
GICH :D
Die technische Evolution ist die Wirkung eines geistigen Fortschritts gewesen und könnte nun zu seiner Ursache werden.
- Jacques Neirynck -

Aiellu
Beiträge: 270
Registriert: 11.05.2007 21:06:25
Lizenz eigener Beiträge: MIT Lizenz

Beitrag von Aiellu » 30.06.2007 15:06:54

zu früh gefreut.

gestern nach dem testreboot hat es wunderbar geklappt, xrays schwirren pünktlich wie bestellt über den bildschirm, bildschirm sperrt sich.

nun heute nach dem einschalten wieder das gleiche problem, xscreensaver fühlt sich nicht zuständig, und irgend ein interner powermanager schaltet den bildschirm nach ca. 10min auf schwarz.

es ist zum haare raufen.

"xset -q" meldet dass DPMS abgeschaltet sei.

was kann das nur sein???

wie bereits gesagt, kpowersave hat das ganze gut im griff und unter kde funktioniert der bildschirmschoner so wie er es soll, aber nicht unter X.

habe schon verschiedene aussagen gelesen in diversen foren dass der xscreensaver schon zichmal gepatcht und trotzdem noch "einfach buggy" sein soll, und ich brauche auch nicht wirklich den screensaver, aber ich brauche die screen-lock funktion.

ich brauche also irgend eine software welche mir nach einer bestimmten zeit der inaktivität den bildschirm sperrt, und es soll unter fluxbox laufen.

Clio

Beitrag von Clio » 30.06.2007 16:49:41

Probier's mal hiermit:
Serverflags Section

Option "BlankTime" "time"
sets the inactivity timeout for the blanking phase of the screensaver. time is in minutes. This is equivalent to the Xorg server's `-s' flag, and the value can be changed at run-time with xset(1x) . Default: 10 minutes.
und hier zum Nachlesen:
http://xorg.freedesktop.org/archive/X11 ... onf.5.html

Aiellu
Beiträge: 270
Registriert: 11.05.2007 21:06:25
Lizenz eigener Beiträge: MIT Lizenz

Beitrag von Aiellu » 30.06.2007 18:22:34

ja genau dieses "feature" möchte ich abgeschaltet haben und die steuerung dem xscreeensaver überlassen.

dpms ist laut "xset q" bereits disabled und der command "xset -dpms" wird ebenso einfach ignoriert.

und trotz allem schalltet sich nach 10 der bildschirm auf schwarz. was jedoch nicht das ist was ich möchte, ansonsten würd ich nämlich einfach "xset -dpms xxx" verwenden, aber ich will dass der bildschirm per xscreensaver gesteuert wird, sich nach vorgegebener zeit ausschaltet (um strom zu sparen und um den monitor im sommer nicht unnötig heizen zu lassen) und gesperrt wird (aus sicherheitsgründen).

wenn das echt nicht mit xscreensaver geht muss ich das den kpowersave machen lassen, aber ich wills eben mit xscreensaver haben. :roll:

Benutzeravatar
Kalimac
Beiträge: 293
Registriert: 25.05.2004 13:19:48
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Wetterau
Kontaktdaten:

Beitrag von Kalimac » 30.06.2007 19:35:53

Aiellu hat geschrieben:ich brauche also irgend eine software welche mir nach einer bestimmten zeit der inaktivität den bildschirm sperrt, und es soll unter fluxbox laufen.
:D Sag' das doch gleich!

Ich benutz dafür xlock im Paket xlockmore. Der xscreensaver ist bei mir gepurged.

Ich mach das etwas anders. Hab' ins fluxbox Menu einfach:

Code: Alles auswählen

 [exec] (Xlock) {xlock -mode blank}
eintragen. Wenn ich den Laptop sperren will, klicke ich dann einfach auf den Eintrag und der Computer ist dicht. 8)
Die technische Evolution ist die Wirkung eines geistigen Fortschritts gewesen und könnte nun zu seiner Ursache werden.
- Jacques Neirynck -

Aiellu
Beiträge: 270
Registriert: 11.05.2007 21:06:25
Lizenz eigener Beiträge: MIT Lizenz

Beitrag von Aiellu » 01.07.2007 10:51:05

xlock bzw. xautolock hatte ich auch schon in erwägung gezogen jedoch kann man diese einfach durch switch auf einen anderen terminal killen, wenn man wie ich die fluxbox mit startx startet. ist also nur was um so völlig unbedarfte auszusperren. werd mal schaun, wenn ich die fluxbox über kdm starte wäre xlock eine gute option, jedoch kann ich dann auch gleich den screensaver von kde benutzen, welcher ja auch den screen abschliesst.

da ich im rahmen meiner webmaster-tätigkeit auf die großen kde-anwendungen quanta, gwenview und konqueror angewiesen bin welche mir eh den halben kde auf die platte schaufeln, hab ich den rest vom kde auch noch dazu geholt inkl. kdm und benutze nun erstmal den kpowersave zusammen mit dem kde-screensaver. da siegt dann halt einfach mein pragmatismus. :wink:

btw: das paket xlockmore ist in den etch-repos nicht zu finden, dort gibts nur das xautolock, welches kein xlock benötigt. gibt es xlockmore nur in testing/unstable?

Benutzeravatar
Kalimac
Beiträge: 293
Registriert: 25.05.2004 13:19:48
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Wetterau
Kontaktdaten:

Beitrag von Kalimac » 02.07.2007 00:06:28

Aiellu hat geschrieben:xlock bzw. xautolock hatte ich auch schon in erwägung gezogen jedoch kann man diese einfach durch switch auf einen anderen terminal killen, wenn man wie ich die fluxbox mit startx startet. ist also nur was um so völlig unbedarfte auszusperren.
Ok, das wusste ich nicht, da ich XDM verwende.
Aiellu hat geschrieben:btw: das paket xlockmore ist in den etch-repos nicht zu finden, dort gibts nur das xautolock, welches kein xlock benötigt. gibt es xlockmore nur in testing/unstable?
Scheint als wäre erst wieder dazugestoßen! Das sagt Package Search:
http://packages.debian.org/cgi-bin/sear ... elease=all
Package xlockmore

* oldstable (x11): Lock X11 display until password is entered.
1:5.13-2.1: alpha amd64 arm hppa i386 ia64 m68k mips mipsel powerpc s390 sparc
* testing (x11): Lock X11 display until password is entered.
1:5.22-1.2: alpha amd64 arm hppa i386 ia64 mips mipsel powerpc s390 sparc
* unstable (x11): Lock X11 display until password is entered.
1:5.22-1.2: alpha amd64 arm armel hppa hurd-i386 i386 ia64 kfreebsd-amd64 kfreebsd-i386 m68k mips mipsel powerpc s390 sparc
Die technische Evolution ist die Wirkung eines geistigen Fortschritts gewesen und könnte nun zu seiner Ursache werden.
- Jacques Neirynck -

cosmac
Beiträge: 4504
Registriert: 28.03.2005 22:24:30

Beitrag von cosmac » 02.07.2007 11:32:22

Aiellu hat geschrieben:xlock bzw. xautolock hatte ich auch schon in erwägung gezogen jedoch kann man diese einfach durch switch auf einen anderen terminal killen
Die anderen Terminals (Konsolen) kannst du mit vlock sperren.
Wahlweise jede für sich oder alle auf einmal.
Beware of programmers who carry screwdrivers.

Aiellu
Beiträge: 270
Registriert: 11.05.2007 21:06:25
Lizenz eigener Beiträge: MIT Lizenz

Beitrag von Aiellu » 02.07.2007 17:01:21

Kalimac hat geschrieben:

Code: Alles auswählen

xset dpms 300 900 1800
.
so mach ich es jetzt auch mal, jedoch mit bissl anderen werten, und zwar 1800, 2100, und 2220. also quasi die flucht nach vorn, quasi: "wenn es sich nicht abschalten lässt schalt ichs halt an und sag es soll sich viiiel zeit lassen." :wink:

im hintergrund läuft zur sicherheit momentan noch zusätzlich der kpowersave vom kde (fluxbox und kde scheinen wirklich gut miteinander zu können, worüber ich auch sehr froh bin denn die kde-anwendungen sind schon nicht schlecht! :-) ) und schaltet den monitor ab falls dpms da noch klemmt, werds aber wohl abschalten falls dpms mit meinen einstellungen klarkommt.

vlock (also die terminals sperren) hat sich erstmal erledigt da ich nun die fluxbox über kdm start, denn startx ist wohl echt nicht zu empfehlen da auch der screenlock des bildschirmschoners einfach per terminal-switch umgangen/gekillt werden kann.

xlock scheint eine gute sache zu sein.

was mich aber auch noch interessiert ist, warum xscreensaver sich selbst über gkrellm "lock" nicht abschliessen lässt. in der console wird mir ein "xscreensaver-command -lock" mit "no screensaver ist running on display :0.0" beantwortet. hm... :roll:

:~$ /€dit
xscreensaver läuft nun, und zwar genau so wie ich es haben will. und zwar kam mir die *ähm* idee einfach mal den "xscreensaver &" in die fluxbox-startup einzutragen... und (schon!) läufts... auch der xscreensaver-lock über gkrellm und über idle läuft nun auch wie gewünscht. :P

muss mir das jetzt peinlich sein? nö oder?! :lol:

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste