[erledigt]grüne flecken

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
xoric
Beiträge: 69
Registriert: 07.02.2013 00:29:30

[erledigt]grüne flecken

Beitrag von xoric » 08.11.2019 09:36:29

Hallo,
ich verwende Debian 8. hier die Ausgabe von uname:

Code: Alles auswählen

Linux debian 4.9.0-0.bpo.1-amd64 #1 SMP Debian 4.9.2-2~bpo8+1 (2017-01-26) x86_64 GNU/Linux
seit kurzen sind in allen Mediaausgabe grüne Flecken zu sehen, also vlc, dragon etc.
Das sieht dann so aus:Bild

Meine Frage: Wie ist das zu beseitigen?

grüße xoric
Zuletzt geändert von xoric am 08.11.2019 17:31:24, insgesamt 1-mal geändert.

pferdefreund
Beiträge: 3455
Registriert: 26.02.2009 14:35:56

Re: grüne flecken

Beitrag von pferdefreund » 08.11.2019 10:53:35

Mal nachschauen, was denn so als Updates vor den Flecken reinkam. Steht unter /var/log/dpkg.log oder so.
Wenn da nix war, könnte es auch ein Hardware-Defekt sein, insbesondere wenn es plötzlich mitten im laufenden Betrieb kam.
Mal einen einfachen Bildbetrachter probiert - sowas wie xli ? Welcher Window-Manager kommt zum Einsatz - den eventuell mal wechseln und einen ganz einfachen probieren. Wenn dann die Flecken weg sind, liegt es wohl irgendwie an der Grafikarte(chip).
Kam ein neuer Kernel in letzter Zeit ? Soweit ich mich erinnere, kam da mal die libjpeg neu - könnte sowas bewirken.

xoric
Beiträge: 69
Registriert: 07.02.2013 00:29:30

Re: grüne flecken

Beitrag von xoric » 08.11.2019 11:14:37

Hallo,
@ pferdefreund: unter /var/log ... wird nur cpio gelistet hier die Ausgabe:

Code: Alles auswählen

2019-11-05 20:22:54 startup archives unpack
2019-11-05 20:22:55 upgrade cpio:amd64 2.11+dfsg-4.1+deb8u1 2.11+dfsg-4.1+deb8u2
2019-11-05 20:22:55 status half-configured cpio:amd64 2.11+dfsg-4.1+deb8u1
2019-11-05 20:22:55 status unpacked cpio:amd64 2.11+dfsg-4.1+deb8u1
2019-11-05 20:22:55 status half-installed cpio:amd64 2.11+dfsg-4.1+deb8u1
2019-11-05 20:22:55 status triggers-pending man-db:amd64 2.7.0.2-5
2019-11-05 20:22:55 status half-installed cpio:amd64 2.11+dfsg-4.1+deb8u1
2019-11-05 20:22:55 status unpacked cpio:amd64 2.11+dfsg-4.1+deb8u2
2019-11-05 20:22:55 status unpacked cpio:amd64 2.11+dfsg-4.1+deb8u2
2019-11-05 20:22:55 trigproc man-db:amd64 2.7.0.2-5 <keine>
2019-11-05 20:22:55 status half-configured man-db:amd64 2.7.0.2-5
2019-11-05 20:22:55 status installed man-db:amd64 2.7.0.2-5
2019-11-05 20:22:55 startup packages configure
2019-11-05 20:22:55 configure cpio:amd64 2.11+dfsg-4.1+deb8u2 <keine>
2019-11-05 20:22:55 status unpacked cpio:amd64 2.11+dfsg-4.1+deb8u2
2019-11-05 20:22:55 status half-configured cpio:amd64 2.11+dfsg-4.1+deb8u2
2019-11-05 20:22:55 status installed cpio:amd64 2.11+dfsg-4.1+deb8u2
2019-11-05 20:22:56 startup packages configure
als DE nutze ich kde4. Du hast recht wenn ich die gleiche Media-Datei mit avplay starte, sind die Flecken weg. Also kann es nicht an der Hardware liegen, den eine Virtuelle Maschine (z.B. Debian Buster) zeigt ebenfalls keine Flecken. Übrigens sind die Flecken nur beim Abspielen von Video-Dateien vorhanden.
Vielleicht ein Konfigrationsproblem?

gruß xoric

MSfree
Beiträge: 4741
Registriert: 25.09.2007 19:59:30

Re: grüne flecken

Beitrag von MSfree » 08.11.2019 11:28:41

xoric hat geschrieben: ↑ zum Beitrag ↑
08.11.2019 11:14:37
als DE nutze ich kde4. Du hast recht wenn ich die gleiche Media-Datei mit avplay starte, sind die Flecken weg. Also kann es nicht an der Hardware liegen, den eine Virtuelle Maschine (z.B. Debian Buster) zeigt ebenfalls keine Flecken. Übrigens sind die Flecken nur beim Abspielen von Video-Dateien vorhanden.
Videoströme bestehen nicht aus Vollbildern, sondern Hauptsächlich aus Differenzbildern (also Differenz aus aktuellem Bild und vorherigem Bild), weil sich das stärker komprimieren läßt. Es wird nur alle paar Bilder ein Vollbild im Strom gesetzt. Ist ein Fehler im vorherigen Bild, ist auch das Folgebild kaputt und die Fehlelr akkumulieren sich bis ins Extreme.

Der Grund für solche Fehler kann sein:
- Fehler im Datenstrom
- Hardware zu langsam, so daß zwischendurch Bilder ausgelassen werden
- schnelles vor- oder zurückpringen im Datenstrom

Unterschiedliche Dekoder gehen auch noch unterschiedlich mit solchen Fehlern um und korrigieren sie unterschiedlich bzw. gar nicht.

xoric
Beiträge: 69
Registriert: 07.02.2013 00:29:30

Re: grüne flecken

Beitrag von xoric » 08.11.2019 12:56:30

@ MSfree:
auch in avplay sind Flecken zu sehen, nur sind sie dort schwarz, also weniger auffällig. Kann sein, dass früher diese schon da waren, aber nicht aufgefallen sind, Dann wäre die Frage so:
wie bekommt man grün ins schwarz?

MSfree
Beiträge: 4741
Registriert: 25.09.2007 19:59:30

Re: grüne flecken

Beitrag von MSfree » 08.11.2019 13:11:58

xoric hat geschrieben: ↑ zum Beitrag ↑
08.11.2019 12:56:30
auch in avplay sind Flecken zu sehen, nur sind sie dort schwarz,
Also Fehler im Datenstrom.
wie bekommt man grün ins schwarz?
Komprimiertes Videomaterial wird im YUV-Farbraum gespeichert, das läßt sich besser komprimieren als RGB-Material. Vor dem Anzeigen eines einzelnen Bildes wird also erst das Differenzbild auf das vorherige Bild addiert und dann wird vom YUV-Farbraum in den RGB-Farbraum transformiert. Je nachdem, welcher der YUV-Kanäle fehlerbehaftet ist, ist das RGB-Resultat dann grün, wie in deinem Fall. Ein Chance, das von aussen zu korrigieren, gibt es nicht. Es gibt nur unterschiedliche Dekoder, die im Fehlerfall solche Fehlflächen mti schwarz auffüllen, was wohl der avplay macht. Wenn du dann aber schwarz gefüllte Flächen bei hellen Bildern hast, sieht das auch nicht viel besser aus als das Grün.

JTH
Beiträge: 528
Registriert: 13.08.2008 17:01:41

Re: grüne flecken

Beitrag von JTH » 08.11.2019 13:24:14

MSfree hat geschrieben: ↑ zum Beitrag ↑
08.11.2019 13:11:58
Es gibt nur unterschiedliche Dekoder, die im Fehlerfall solche Fehlflächen mti schwarz auffüllen, was wohl der avplay macht. Wenn du dann aber schwarz gefüllte Flächen bei hellen Bildern hast, sieht das auch nicht viel besser aus als das Grün.
Es könnte schon sein, dass alle Player da defekte Daten/Sample erkennen und ersetzen: Einer „korrekt“ durch Schwarz, der andere einfach durch Nullen. Eine Null in allen drei Komponenten (oder zumindest den Farbkomponenten) bei YUV (bzw. YCbCr) ergibt, zu RGB konvertiert, wie hier beobachtet allerdings einen Grünton.

Benutzeravatar
Lord_Carlos
Beiträge: 4619
Registriert: 30.04.2006 17:58:52
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Dänemark

Re: grüne flecken

Beitrag von Lord_Carlos » 08.11.2019 13:33:26

xoric hat geschrieben: ↑ zum Beitrag ↑
08.11.2019 09:36:29
seit kurzen sind in allen Mediaausgabe grüne Flecken zu sehen,
Ich vermute du hast schon Daten getestet wo du 100% sicher bist das die keine Fehler enthalten? Also haben frueher funktioniert und funktionieren auf anderen Rechnern?

Code: Alles auswählen

╔═╗┬ ┬┌─┐┌┬┐┌─┐┌┬┐╔╦╗
╚═╗└┬┘└─┐ │ ├┤ │││ ║║
╚═╝ ┴ └─┘ ┴ └─┘┴ ┴═╩╝ rockt das Forum!

xoric
Beiträge: 69
Registriert: 07.02.2013 00:29:30

Re: grüne flecken

Beitrag von xoric » 08.11.2019 13:46:29

Ok, danke für die ausführliche Erklärung des Sachverhaltes.
Eine virtuelle Debian Jessie installation zeigt keine Flecken. Es ist gleiche DE installiert:

Code: Alles auswählen

 kwin -v
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Qt: 4.8.6
KDE: 4.14.2
KWin: 4.11.13
vlc gibt folgende Meldung:

Code: Alles auswählen

>$ VLC media player 2.2.7 Umbrella (revision 2.2.7-0-g6e32381286)
[0000000000d50118] core libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
[00007fec6509cdd8] vdpau_avcodec generic error: unsupported codec 13 or profile -1
was ist codec13?
Ich vermute dieser codec löst das problem.

gruß, xoric

xoric
Beiträge: 69
Registriert: 07.02.2013 00:29:30

Re: grüne flecken

Beitrag von xoric » 08.11.2019 17:30:59

Tja,
ich hab noch eine virtuelle Jessie installiert und auf die gleiche vlc version upgegraded und siehe da, wieder die grünen Flecken. Eine recherche im Netz ergab einen bug im codec.
Das Problem wird also nur durch eine Versionsänderung des vlc oder des ganzen Systems gelöst.
Ich setze diesen Thread auf "erledigt".

vielen Dank an alle, die geholfen haben

gruß, xoric

Benutzeravatar
hikaru
Beiträge: 10723
Registriert: 09.04.2008 12:48:59

Re: grüne flecken

Beitrag von hikaru » 08.11.2019 18:35:42

xoric hat geschrieben: ↑ zum Beitrag ↑
08.11.2019 17:30:59
Eine recherche im Netz ergab einen bug im codec.
Kannst du den Bugreport bitte verlinken? Das spart anderen die Suche.

xoric
Beiträge: 69
Registriert: 07.02.2013 00:29:30

Re: [erledigt]grüne flecken

Beitrag von xoric » 08.11.2019 18:55:36

Sorry,
den Bugreport habe ich nicht gefunden. Aber hier fand ich den Hinweis: https://askubuntu.com/questions/834997/ ... redirect=1
dann habe ich zwei und zwei zusammengerechnet, bei der früheren oder späteren version von vlc, bzw. kwin, alles ok, bei dieser version flecken...

gruß, xoric

Benutzeravatar
TRex
Moderator
Beiträge: 6259
Registriert: 23.11.2006 12:23:54
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: KA

Re: [erledigt]grüne flecken

Beitrag von TRex » 08.11.2019 19:13:52

Interessehalber, woher hast du denn die verschiedenen Versionen von vlc?
Jesus saves. Buddha does incremental backups.
Windows ist doof, Linux funktioniert nichtDon't break debian!

xoric
Beiträge: 69
Registriert: 07.02.2013 00:29:30

Re: [erledigt]grüne flecken

Beitrag von xoric » 08.11.2019 19:17:28

ich habe verschiedene VM's in virtualbox installiert

Antworten