WD My Book Studio Edition an eSATA

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
cbra
Beiträge: 13
Registriert: 17.12.2008 19:55:50

WD My Book Studio Edition an eSATA

Beitrag von cbra » 08.06.2009 17:39:56

Hallo zusammen,
ich habe mir eine Western Digital My Book Studio Edition 1TB Festplatte gekauft und möchte diese nun per eSATA an meinem PC anschließen. Allerdings werden beim Anschließen nur folgende Meldungen ins Log geschrieben:

Code: Alles auswählen

Jun  7 23:00:05 pcphenom kernel: [54445.784965] ata6: exception Emask 0x10 SAct 0x0 SErr 0x4080000 action 0xe frozen
Jun  7 23:00:05 pcphenom kernel: [54445.784973] ata6: irq_stat 0x00000040, connection status changed
Jun  7 23:00:05 pcphenom kernel: [54445.784978] ata6: SError: { 10B8B DevExch }
Jun  7 23:00:05 pcphenom kernel: [54445.784987] ata6: hard resetting link
Jun  7 23:00:12 pcphenom kernel: [54455.779197] ata6: link is slow to respond, please be patient (ready=0)
Jun  7 23:00:15 pcphenom kernel: [54460.272499] ata6: softreset failed (device not ready)
Jun  7 23:00:15 pcphenom kernel: [54460.272520] ata6: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Jun  7 23:00:15 pcphenom kernel: [54460.272526] ata6: link online but device misclassified, retrying
Jun  7 23:00:15 pcphenom kernel: [54460.272530] ata6: hard resetting link
Jun  7 23:00:22 pcphenom kernel: [54469.918619] ata6: link is slow to respond, please be patient (ready=0)
Jun  7 23:00:25 pcphenom kernel: [54474.263910] ata6: softreset failed (device not ready)
Jun  7 23:00:25 pcphenom kernel: [54474.263930] ata6: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Jun  7 23:00:25 pcphenom kernel: [54474.263936] ata6: link online but device misclassified, retrying
Jun  7 23:00:25 pcphenom kernel: [54474.263941] ata6: hard resetting link
Jun  7 23:00:32 pcphenom kernel: [54484.072653] ata6: link is slow to respond, please be patient (ready=0)
Jun  7 23:01:00 pcphenom kernel: [54524.945787] ata6: softreset failed (device not ready)
Jun  7 23:01:00 pcphenom kernel: [54524.945808] ata6: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Jun  7 23:01:00 pcphenom kernel: [54524.945814] ata6: link online but device misclassified, retrying
Jun  7 23:01:00 pcphenom kernel: [54524.945819] ata6: limiting SATA link speed to 1.5 Gbps
Jun  7 23:01:00 pcphenom kernel: [54524.945823] ata6: hard resetting link
Jun  7 23:01:05 pcphenom kernel: [54532.336507] ata6: softreset failed (device not ready)
Jun  7 23:01:05 pcphenom kernel: [54532.336529] ata6: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
Jun  7 23:01:05 pcphenom kernel: [54532.336536] ata6: link online but device misclassified, device detection might fail
Jun  7 23:01:05 pcphenom kernel: [54532.336545] ata6: EH complete
Über Firewire konnte ich die Platte erkennen und neu Partitionieren (msdos-Tabelle oder die Standardmäßige Mac-Tabelle, 1 ext3-Partition). Damit funktioniert es auch. USB habe ich (noch) nicht getestet. Da ich aber nur die langsamen Firewire400-Anschlüsse habe hätte ich dann auch eine günstigere Platte nur mit USB zulegen können. Es soll eben eSATA sein. Ich weiß, dass WD Linux nicht unterstützt, aber das hat bisher noch nie gestört. :P
Ein paar Daten zum System:
uname -a
Linux pcphenom 2.6.26-2-amd64 #1 SMP Fri Mar 27 04:02:59 UTC 2009 x86_64 GNU/Linux
Debian Squeeze
ASUS M3A78-T, AMD790GX/SB750
zur Zeit 5 interne SATA-Platten, 4 davon WD.

Ich hoffe Ihr könnt mir helfen
cbra
Alle Beiträge ohne Gewähr, Rechtschreibung inbegriffen.

Benutzeravatar
cirrussc
Beiträge: 6567
Registriert: 26.04.2007 19:47:06
Lizenz eigener Beiträge: MIT Lizenz

Re: WD My Book Studio Edition an eSATA

Beitrag von cirrussc » 08.06.2009 18:25:48

cbra hat geschrieben:Ich weiß, dass WD Linux nicht unterstützt, aber das hat bisher noch nie gestört. :P
SATA ist und bleibt Kompatiebel. Solange keine eckeligen Spezialtreiber für den USB Betrieb verlangt werden, ist diese "Herstellerunterstützung" egal.

Besorge dir ein anständiges SATA Kabel. Es sollte möglichst kurz, gut geschirmt und am besten Stecker mit Klemmverschluss haben.
Das ist wie so oft sicher nur eine Kontaktsache (siehe Forensuche).
Gruß cirrussc
--------------------
„Der Mensch steigert zur Zeit die Nutzung dessen, was seiner Willkür unterliegt - und kommt sich sehr klug dabei vor.“ H. Gruhl

Benutzeravatar
cbra
Beiträge: 13
Registriert: 17.12.2008 19:55:50

Re: WD My Book Studio Edition an eSATA

Beitrag von cbra » 09.06.2009 19:45:50

Ich weiß nicht, wie oft ich beide Seiten des Kabels mehrfach ab- und angesteckt habe. Jetzt habe ich die Platte einmal an einem anderen PC angeklemmt und dort wurde diese sofort erkannt. Nutzen konnte ich sie zwar dank Windows nicht, aber immerhin. Jetzt komme ich zurück an meinen Rechner, klemme diese an und... funktioniert.
Da verstehe einer die Technik.

Danke jedenfalls

PS: Spezialtreiber für USB oder Firewire gibt es zwar auch, die dienen aber nur dazu aus dem KnightRider-Licht eine Füllstandanzeige zu machen.Das braucht eh keiner, dann lieber ein Lauflicht.
Alle Beiträge ohne Gewähr, Rechtschreibung inbegriffen.

ruebenschuss
Beiträge: 1
Registriert: 27.05.2011 10:52:54

Re: WD My Book Studio Edition an eSATA

Beitrag von ruebenschuss » 27.05.2011 10:55:13

Hi cbra,

ich hab das selbe Problem. Habe drei verschiedene Kabel und Slotbleche probiert, aber nie wurde die Platte gefunden.
Irgendwann ist mir aufgefallen, dass die Platte im BIOS erscheint, aber dann vom Kernel nicht angesprochen werden kann.
Habe einige Foren durchforstet und da dort immer auf Treiber-Probleme hingewiesen wurde, habe ich den Kernel mit verschiedenen Modulen neu compiliert. Kein Erfolg.
Schließlich habe ich in letzter Verzweiflung im BIOS die Einstellung von "SATA automatisch" auf "emuliere IDE" gestellt. Klingt eigentlich fürchterlich, aber geholfen hat's trotzdem. Nun findet er die Platte sofort und auch alle LVMs darauf. Ich habe den Speed noch nicht gemessen, aber ein Backup von 700 GB ging gefühlt sehr schnell... Wenns jemanden interessiert, kann ich noch speedtests laufen lassen.

Schöne Grüße!

Antworten