Tastaturlayout ändert sich nach Neustart

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
phileas
Beiträge: 8
Registriert: 19.07.2011 10:03:45

Tastaturlayout ändert sich nach Neustart

Beitrag von phileas » 11.09.2012 14:31:33

Hallo,

ich versuche, mit dem Gnome-Einstellungsdialog "Tastatur" unter "Belegungen" das Layout "Deutschland" auszuwählen (wichtig: NICHT nodeadkeys / Akzenttasten deaktivieren!). Danach funktioniert das bis zum nächsten Neustart. Anschließend ist das Layout wieder nodeadkeys und im Einstellungsdialog steht als erste Belegung "Deutschland", als zweite "Deutschland Akzenttasten deaktivieren". Ich habe schon alles mögliche versucht, inkl.

Code: Alles auswählen

sudo dpkg-reconfigure console-data
oder

Code: Alles auswählen

sudo dpkg-reconfigure keyboard-configuration
. Nach einem Neustart bzw. einer Abmeldung ist alles wieder rückgängig.

Was muss ich tun?

Danke im Voraus für jede Hilfe!

phileas

Benutzeravatar
Six
Beiträge: 8046
Registriert: 21.12.2001 13:39:28
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Siegburg

Re: Tastaturlayout ändert sich nach Neustart

Beitrag von Six » 11.09.2012 14:49:45

Die von dir erwähnten Befehle kümmern sich um die Tastaturbelegung des Terminals. Für Gnome muss man es so machen, wie du zuerst beschreibst. Vermutl. ist Gnome so konfiguriert, dass es sich keine Änderungen zwischen Neustarts merkt und du musst die Einstellungen manuell speichern. Dafür benutzte man in Gnome2 noch

Code: Alles auswählen

gnome-session-save
wie es jetzt aussieht, weiß ich nicht.
Be seeing you!

phileas
Beiträge: 8
Registriert: 19.07.2011 10:03:45

Re: Tastaturlayout ändert sich nach Neustart

Beitrag von phileas » 12.09.2012 16:49:12

Danke für deine Antwort. Ist mir einleuchtend. Ich hab

Code: Alles auswählen

gnome-session-save
gerade ausprobiert, nachdem ich die Einstellungen verändert habe, und es sieht so aus als ob es funktionieren würde. Gibt es eine Möglichkeit, automatisch vor dem Abmelden gnome-session-save auszuführen bzw. Gnome so zu konfigurieren, dass das nicht mehr nötig ist?

Danke!

Benutzeravatar
kupe
Beiträge: 958
Registriert: 30.05.2011 21:58:16
Lizenz eigener Beiträge: MIT Lizenz

Re: Tastaturlayout ändert sich nach Neustart

Beitrag von kupe » 13.09.2012 10:36:40

eig. müßte das auch unabhängig von GNOME funktionieren, und zwar via /etc/X11/xorg.conf.d/10-evdev.conf bzw. /usr/share/X11/xorg.conf.d/10-evdev.conf.

dort sollten unter der keybord-section afaik folg. option ausreichen:

Code: Alles auswählen

Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
oder tritt beschriebenes verhalten trotz dieser (schon vorhandenen?) zeilen auf -> also doch GNOME-eigenheit?
phileas hat geschrieben:
Gibt es eine Möglichkeit, automatisch vor dem Abmelden gnome-session-save auszuführen bzw. Gnome so zu konfigurieren, dass das nicht mehr nötig ist?
unter KDE kann man das »ausführen beim herunterfahren« bspw. per autostart-optionen festlegen, evtl. geht's unter GNOME ähnlich?

ansonsten bspw. einfach an die shutdown-/reboot-/...-befehle koppeln oder per init-skript.
My bash says Ultraman.

phileas
Beiträge: 8
Registriert: 19.07.2011 10:03:45

Re: Tastaturlayout ändert sich nach Neustart

Beitrag von phileas » 13.09.2012 11:03:57

Danke. Ich habe keine solche Einstellung bei Gnome gefunden. Vielleicht kennt das jemand?
/etc/X11/xorg.conf.d/10-evdev.conf bzw. /usr/share/X11/xorg.conf.d/10-evdev.conf
Beide Dateien gibt es bei mir nicht. Es gibt allerdings in der xorg.conf den Eintrag "Input Device", den ich wie folgt ergänzt habe:

Code: Alles auswählen

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
	Option "XkbLayout" "de"
	Option "XkbVariant" "nodeadkeys"
EndSection
Abgesehen davon, dass dank gnome-session-save mittlerweile eh schon alles funktioniert, müsste das so passen, oder?

Danke!

Benutzeravatar
Six
Beiträge: 8046
Registriert: 21.12.2001 13:39:28
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Siegburg

Re: Tastaturlayout ändert sich nach Neustart

Beitrag von Six » 13.09.2012 15:34:34

In Gnome2 ließ sich das unter Systemeigenschaften -> Sitzung einstellen.
Be seeing you!

debianoli
Beiträge: 3925
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: Tastaturlayout ändert sich nach Neustart

Beitrag von debianoli » 14.09.2012 12:37:40

Bei gnome3 gibt es auch die Funktion "Einstellungen merken", aber das System merkt sich dabei nicht alle Veränderungen. Also zB das Bluetooth per default aus sein soll...

Wo du die Einstellung genau findest, kann ich dir gerade nicht sagen (bin gerade nicht an meinem Gnome3 Rechner). Es war aber irgend ein Punkt, an den man nie nicht denken würde, evtl sogar "Systeminfo" oder wie das heißt.

Aber geht das nicht auch über "dpkg-reconfigure locales"? Da wird doch auch nach der Tastatur-Belegung gefragt oder irre ich mich da?

Edit: Schau dir auch mal dconf-editor an, da könnte es auch einen Punkt geben

Antworten