vfat wird nicht mehr bei USB Sticks erkannt

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Raboni
Beiträge: 344
Registriert: 08.04.2006 17:38:06
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Stuttgart

vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von Raboni » 11.01.2017 17:52:00

Hallo fleissige Helfer,

Wenn ich einen USB Stick einstecke der mit fat16 formatiert ist bekomme ich folgende Meldung in Gnome:

"Error mounting /dev/sde1 at /media/brdkto/E-UP!: Command-line `mount -t "vfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush" "/dev/sde1" "/media/brdkto/E-UP!"' exited with non-zero exit status 32: mount: unknown filesystem type 'vfat' "

Das komische ist, hat bis jetzt einwandfrei funktioniert.

dmesg sagt:

Code: Alles auswählen

Linux version 3.16.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.4 (Debian 4.8.4-1) ) #1 SMP Debian 3.16.7-ckt20-1+deb8u4 (2016-02-29)
[    0.000000] Command line: BOOT_IMAGE=/vmlinuz-3.16.0-4-amd64 root=/dev/mapper/VG01-lvall_crypt ro quiet

Auf der Console:

Code: Alles auswählen

mount /dev/sde1 /mnt
gibt folgendes zurück:

Code: Alles auswählen

mount: unknown filesystem type 'vfat'
dosfstools, udisks2 und usbutils sind logischerweise installiert.

Es gab auch einen Bug Report hat wohl ne andere Unsache gehabt.

Danke schon mal

Benutzeravatar
CH777
Beiträge: 1106
Registriert: 27.05.2008 16:37:17

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von CH777 » 11.01.2017 19:49:39

Das kann manchmal nach einem Kernelupdate passieren, in diesem Falle hilft ein Reboot des Systems.

Raboni
Beiträge: 344
Registriert: 08.04.2006 17:38:06
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Stuttgart

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von Raboni » 11.01.2017 20:05:21

Hallo

danke aber das ist schon seit ein paar Tagen so und funst bei keinem USB-Stick / fvat.

Was kann man da noch tun?

Benutzeravatar
towo
Beiträge: 3072
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von towo » 11.01.2017 20:09:22

modinfo vfat

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 21287
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von KBDCALLS » 11.01.2017 22:40:44

Manchmal kann fsck.vfat hilfreich sein. Passiert wenn der Stick nicht sauber unter Winblond entfernt wird. Das verleitet ja dazu , es so zu machen.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

Raboni
Beiträge: 344
Registriert: 08.04.2006 17:38:06
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Stuttgart

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von Raboni » 11.01.2017 23:05:54

Manchmal kann fsck.vfat hilfreich sein. Passiert wenn der Stick nicht sauber unter Winblond entfernt wird. Das verleitet ja dazu , es so zu machen.
Das hab ich mir schon vor 8 Jahren abgewohnt als ich auf Linux umgestiegen bin. Stick wird immer sauber ungemountet.


modinfo vfat sagt:

Code: Alles auswählen

filename:       /lib/modules/3.16.0-4-amd64/kernel/fs/fat/vfat.ko
author:         Gordon Chaffee
description:    VFAT filesystem support
license:        GPL
alias:          fs-vfat
depends:        fat
intree:         Y
vermagic:       3.16.0-4-amd64 SMP mod_unload modversions 

Funst leider immer noch nicht!

Hab gerade ein reboot gemacht und dabei einen älteren Kernel genommen. Jetzt tut es. Also muss es irgend etwas mit dem letzten Kernelupdate zu tun haben und da was schief gelaufen sein.

Hat jemand ne Idee? Bin leider nur Anwender mit Basic Linux Kenntnissen.

:roll:

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 21287
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von KBDCALLS » 12.01.2017 08:16:25

Was sagt denn blkid und file -s /dev/sdx(n) dazu . Können cfdisk und gparted was mit dem Stick anfangen
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

pferdefreund
Beiträge: 2843
Registriert: 26.02.2009 14:35:56

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von pferdefreund » 12.01.2017 10:31:48

Was steht denn beim aktuellen Kernel in /proc/filesystems ?

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 21287
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von KBDCALLS » 12.01.2017 14:32:44

Dann stellt sich noch die Frage womit ist der Stick formartiert worden ? Der Kernel 3.16 ist ja schon etwas angegraut.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

Raboni
Beiträge: 344
Registriert: 08.04.2006 17:38:06
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Stuttgart

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von Raboni » 12.01.2017 16:53:21

blkid:

Code: Alles auswählen

/dev/sde1: SEC_TYPE="msdos" LABEL="E-UP!" UUID="E467-2E16" TYPE="vfat" PARTUUID="b8b5c66f-01"
file -s /dev/sde1:

Code: Alles auswählen

/dev/sde1: DOS/MBR boot sector, code offset 0x3c+2, OEM-ID "MSDOS5.0", sectors/cluster 64, reserved sectors 2, root entries 512, Media descriptor 0xf8, sectors/FAT 239, sectors/track 63, heads 255, hidden sectors 1536, sectors 3914240 (volumes > 32 MB) , reserved 0x1, serial number 0xe4672e16, label: "E-UP!      ", FAT (16 bit)
cfdisk:

Code: Alles auswählen

                                                 Disk: /dev/sde1                                                       
                                      Size: 1,9 GiB, 2004090880 bytes, 3914240 sectors
                                             Label: dos, identifier: 0x6f20736b

      Device            Boot                   Start                 End             Sectors          Size      Id  Type                   
>>  /dev/sde1p1       ?                778135908      1919645538      1141509631      544,3G      72 unknown                
      /dev/sde1p2       ?                168689522      2104717761      1936028240      923,2G      65 Novell Netware 386
      /dev/sde1p3       ?              1869881465      3805909656      1936028192      923,2G      79 unknown
      /dev/sde1p4       ?                             0       3637226495      3637226496          1,7T        d unknown
/proc/filesystem:

Code: Alles auswählen

nodev	sysfs
nodev	rootfs
nodev	ramfs
nodev	bdev
nodev	proc
nodev	cgroup
nodev	cpuset
nodev	tmpfs
nodev	devtmpfs
nodev	debugfs
nodev	securityfs
nodev	sockfs
nodev	pipefs
nodev	devpts
nodev	hugetlbfs
nodev	pstore
nodev	mqueue
	        ext3
	        ext2
	        ext4
nodev	autofs
nodev	binfmt_misc

Weiß zwar nicht was in /proc/filesystem drin stehen soll, aber wenn da ext2, ext3, ext4 drin steht sollte dann nicht auch fvat drin stehen?

Ach so, die beiden anderen vfat Sticks, die ich habe gehen auch nicht. Aber alle an meinem Laptop, wo auch jessy drauf ist, aber irgend ein Intel Core irgendwas drin ist.

Benutzeravatar
smutbert
Beiträge: 5750
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von smutbert » 12.01.2017 17:24:16

in /proc/filesystem stehen die unterstützten Dateisysteme drin, also ja vfat sollte da auftauchen, wenn das Modul geladen ist. Ich hoffe ich hab jetzt nichts überlesen, aber lässt sich das Kernellmodul überhaupt laden

Code: Alles auswählen

# modprobe vfat && lsmod | grep vfat
(falle es eine Fehlemeldung gibt, wär die interessant und vielleicht die letzten Zeilen der Ausgabe von dmesg)

Raboni
Beiträge: 344
Registriert: 08.04.2006 17:38:06
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Stuttgart

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von Raboni » 12.01.2017 17:39:05

(falle es eine Fehlemeldung gibt, wär die interessant und vielleicht die letzten Zeilen der Ausgabe von dmesg)

Code: Alles auswählen

modprobe: ERROR: could not insert 'vfat': Unknown symbol in module, or unknown parameter (see dmesg)
root@localhost:/home/brdkto# modprobe vfat && lsmod | grep vfat
dmesg:

Code: Alles auswählen

 44.923264] usb 1-1.4: reset high-speed USB device number 4 using ehci-pci
[   54.761870] fuse: Unknown symbol setattr_prepare (err 0)
[   57.392537] usb 3-1: 2:1: cannot get freq at ep 0x84
[   57.395457] usb 3-1: 2:1: cannot get freq at ep 0x84
[   57.529812] usb 3-1: 1:1: cannot get freq at ep 0x4
[   57.532876] usb 3-1: 1:1: cannot get freq at ep 0x4
[   57.540473] usb 3-1: 2:1: cannot get freq at ep 0x84
[   57.543507] usb 3-1: 2:1: cannot get freq at ep 0x84
[   57.561888] usb 3-1: 1:1: cannot get freq at ep 0x4
[   57.564894] usb 3-1: 1:1: cannot get freq at ep 0x4
[   57.589823] usb 3-1: 2:1: cannot get freq at ep 0x84
[   57.592820] usb 3-1: 2:1: cannot get freq at ep 0x84
[   57.770530] usb 1-1.4: reset high-speed USB device number 4 using ehci-pci
[  100.552530] vboxdrv: Found 4 processor cores
[  100.568397] vboxdrv: TSC mode is Invariant, tentative frequency 3299977649 Hz
[  100.568399] vboxdrv: Successfully loaded version 5.1.12 (interface 0x00280000)
[  100.852254] VBoxNetFlt: Successfully started.
[  100.853997] VBoxNetAdp: Successfully started.
[  100.855480] VBoxPciLinuxInit
[  100.856874] vboxpci: IOMMU not found (not registered)
[  146.835175] usb 1-1.4: reset high-speed USB device number 4 using ehci-pci
[13279.624333] fuse: Unknown symbol setattr_prepare (err 0)
[13323.493602] usb 3-2: new high-speed USB device number 3 using xhci_hcd
[13323.622263] usb 3-2: New USB device found, idVendor=8644, idProduct=800e
[13323.622267] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[13323.622270] usb 3-2: Product: USB Flash Disk
[13323.622272] usb 3-2: Manufacturer: General
[13323.622274] usb 3-2: SerialNumber: 0210890000000844
[13323.637014] usb-storage 3-2:1.0: USB Mass Storage device detected
[13323.637237] scsi6 : usb-storage 3-2:1.0
[13323.637328] usbcore: registered new interface driver usb-storage
[13324.632899] scsi 6:0:0:0: Direct-Access     General  USB Flash Disk   1.0  PQ: 0 ANSI: 2
[13324.633376] sd 6:0:0:0: Attached scsi generic sg5 type 0
[13324.633806] sd 6:0:0:0: [sde] 7831552 512-byte logical blocks: (4.00 GB/3.73 GiB)
[13324.634075] sd 6:0:0:0: [sde] Write Protect is off
[13324.634078] sd 6:0:0:0: [sde] Mode Sense: 03 00 00 00
[13324.634303] sd 6:0:0:0: [sde] No Caching mode page found
[13324.634306] sd 6:0:0:0: [sde] Assuming drive cache: write through
[13324.637235]  sde: sde1
[13324.638228] sd 6:0:0:0: [sde] Attached SCSI removable disk
[13324.921020] fat: Unknown symbol setattr_prepare (err 0)
[13327.813377] usb 1-1.4: reset high-speed USB device number 4 using ehci-pci
[13335.326616] cfdisk[6868]: segfault at 3000004e2 ip 00007f49163860cb sp 00007fffbcac2300 error 4 in libslang.so.2.3.0[7f49162eb000+11e000]
[14888.466707] perf interrupt took too long (2502 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[15287.523325]  sde: sde1
[15287.528853]  sde: sde1
[16742.094622] usb 1-1.4: reset high-speed USB device number 4 using ehci-pci
[17976.873380] fat: Unknown symbol setattr_prepare (err 0)
[18129.061275] fat: Unknown symbol setattr_prepare (err 0)
Leider reichen mein Linux Kentnisse nicht um zu wissen was ich mit den Error s machen muss. Es scheint ja irgendwie das vfat modul nicht geladen zu werden. Aber warum? bzw Wie bring ich jessy dazu das jetzt automatisch zu laden wie es eigenlich sein sollte?

MSfree
Beiträge: 2637
Registriert: 25.09.2007 19:59:30

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von MSfree » 12.01.2017 18:26:39

Raboni hat geschrieben:

Code: Alles auswählen

modprobe: ERROR: could not insert 'vfat': Unknown symbol in module, or unknown parameter (see dmesg)
root@localhost:/home/brdkto# modprobe vfat && lsmod | grep vfat
Da s heißt, daß das Kernelmodul nicht zum laufenden Kernel paßt.
Wie auch immer das bei dir passiert ist, aber da ist offensichtlich etwas bei einer Installation und/oder einem apt-get upgrade in die Hose gegangen.

Benutzeravatar
smutbert
Beiträge: 5750
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von smutbert » 12.01.2017 19:52:36

dagegen sollte es helfen den aktuellen Kernel neu zu installieren

Code: Alles auswählen

# apt --reinstall install linux-image-$(uname -r)
und, wenn dabei keine Fehler (!) auftreten, neu zu starten.

Raboni
Beiträge: 344
Registriert: 08.04.2006 17:38:06
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Stuttgart

Re: vfat wird nicht mehr bei USB Sticks erkannt

Beitrag von Raboni » 12.01.2017 23:56:51

Hallo smutbert,

Kernel neu installiert ohne Fehlermeldung. Unnötige Dateien mit Autoremove gelöscht. Neustart.

leider Fehler nicht behoben! :(

dmesg:

Code: Alles auswählen

[   48.876726] usb 1-1.4: reset high-speed USB device number 4 using ehci-pci
[   54.503831] fuse: Unknown symbol setattr_prepare (err 0)
[   56.708407] usb 3-1: 2:1: cannot get freq at ep 0x84
[   56.711481] usb 3-1: 2:1: cannot get freq at ep 0x84
[   56.864676] usb 3-1: 1:1: cannot get freq at ep 0x4
[   56.867711] usb 3-1: 1:1: cannot get freq at ep 0x4
[   56.901549] usb 3-1: 2:1: cannot get freq at ep 0x84
[   56.904583] usb 3-1: 2:1: cannot get freq at ep 0x84
[   56.922660] usb 3-1: 1:1: cannot get freq at ep 0x4
[   56.925651] usb 3-1: 1:1: cannot get freq at ep 0x4
[   56.975531] usb 3-1: 2:1: cannot get freq at ep 0x84
[   56.978557] usb 3-1: 2:1: cannot get freq at ep 0x84
[   57.172604] usb 1-1.4: reset high-speed USB device number 4 using ehci-pci
[   57.771941] usb 1-1.4: current rate 0 is different from the runtime rate 48000
[   57.775060] usb 1-1.4: current rate 0 is different from the runtime rate 48000
[   74.532131] fat: Unknown symbol setattr_prepare (err 0)
[   77.279399] usb 1-1.4: reset high-speed USB device number 4 using ehci-pci
[  168.132242] fat: Unknown symbol setattr_prepare (err 0)
[  242.070241] fuse: Unknown symbol setattr_prepare (err 0)
[  296.172175] fat: Unknown symbol setattr_prepare (err 0)
Alle anderen Abfragen sind gleich. Aber es müsste der richtige Weg sein. Habe vor der Aktion mit altem Kernel gebooten. Da hat es gefunst. Es gibt auch einen Bug Report aber ich konnte da keine Lösung ableiten: https://bugs.debian.org/cgi-bin/bugrepo ... g=808380#5

mmmm

Antworten