[Solved] hdparm: automatischer spindown geht nur mit kurzem Zeitparameter

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
thomas83
Beiträge: 3
Registriert: 19.11.2017 09:59:09

[Solved] hdparm: automatischer spindown geht nur mit kurzem Zeitparameter

Beitrag von thomas83 » 22.11.2017 19:22:23

Hi Forum,

Ich habe ein Problem eine eSata-Platte an einer Cubox i4-pro zum automatischen Spindown nach einer bestimmten Zeit zu
bringen.

Die Platte ist eine reine Datenplatte, d.h. das System selbst hat keine Dateien drauf. Auf der Platte
existiert eine LVM-Partition mit 1 pv und 2 lv. Dienste, die auf die Daten auf der Platte zugreifen könnten,
hatte ich schon abgeschaltet (Apache, Samba, Minidlna).
Die Partition ist gemounted als:

Code: Alles auswählen

/dev/mapper/vg.exthdd-media on /media type ext4 (rw,noatime,data=ordered)
Ich hatte schon versucht, die Plattenaktivität zu
überwachen, um zu sehen, ob es doch noch irgendwelche Zugriffe gibt, aber konnte nichts feststellen. Ich hatte
dazu mal iotop und auch incron benutzt.

Prinzipiell funktioniert der Spindown über den -y Parameter von hdparm. Es klappt auch, wenn ich einen kurzen
Wert für die Wartezeit einstelle, z.B. -S 12 (1min). Ab 5min klappt es scheinbar schon nicht mehr.

Das einzige, was ich feststellen konnte, ist dass die Platte automatisch immer wieder SMART einschaltet. Ich
hatte schon versucht das smart abzustellen:

Code: Alles auswählen

sudo smartctl --smart=off --offlineauto=off --saveauto=off /dev/sda1
was auch klappt:

Code: Alles auswählen

$ sudo smartctl -i /dev/sda | grep SMART\ support
SMART support is: Available - device has SMART capability.
SMART support is: Disabled
Aber nach ein paar Minuten steht das wieder auf "Enabled". Könnte deshalb die Platte den spindown verweigern?
Das würde erklären warum eine kurze Wartezeit bis zum Spindown funktioniert. Wie könnte man das noch genauer
untersuchen, oder liegt das Problem doch eher woanders?

Hier sind noch ein paar Systeminfos:

Code: Alles auswählen

$ cat /etc/debian_version 
8.9

Code: Alles auswählen

$ cat /proc/version 
Linux version 3.14.79-fslc-imx6-sr (abuild@obs-worker02) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 SMP Fri Oct 20 18:16:19 UTC 2017

Code: Alles auswählen

$ lsblk 
NAME                      MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sda                         8:0    0  1.8T  0 disk 
└─sda1                      8:1    0  1.8T  0 part 
  ├─vg.exthdd-debian.bkup 253:0    0   10G  0 lvm  
    └─vg.exthdd-media       253:1    0  500G  0 lvm  /media
    sdb                         8:16   1 14.7G  0 disk 
    └─sdb1                      8:17   1 14.7G  0 part /
    mmcblk0                   179:0    0 14.6G  0 disk 
    └─mmcblk0p1               179:1    0 14.6G  0 part /media/debian/rootfs

Code: Alles auswählen

$ sudo smartctl -i /dev/sda1
smartctl 6.4 2014-10-07 r4002 [armv7l-linux-3.14.79-fslc-imx6-sr] (local build)
Copyright (C) 2002-14, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Device Model:     Hitachi HUA723020ALA641
Serial Number:    YFGSMRTA
LU WWN Device Id: 5 000cca 223cabe9e
Firmware Version: MK7OA840
User Capacity:    2,000,398,934,016 bytes [2.00 TB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    7200 rpm
Form Factor:      3.5 inches
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 2.6, 6.0 Gb/s (current: 3.0 Gb/s)
Local Time is:    Wed Nov 22 18:13:42 2017 UTC
SMART support is: Available - device has SMART capability.
SMART support is: Disabled

Danke!

Thomas
Zuletzt geändert von thomas83 am 25.11.2017 18:58:02, insgesamt 1-mal geändert.

Benutzeravatar
smutbert
Beiträge: 6170
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: hdparm: automatischer spindown geht nur mit kurzem Zeitparameter

Beitrag von smutbert » 22.11.2017 20:31:25

Was läuft denn sonst noch so auf dem PC?
(Gnome hatte zum Beispiel früher einen eigenen Dienst zum Überwachen von smart und soweit ich weiß kann man mit den Frontends von upower, also den Stromspareinstellungen verschiedener Desktopumgebungen auch die Einstellungen der Festplatten ändern).

thomas83
Beiträge: 3
Registriert: 19.11.2017 09:59:09

Re: hdparm: automatischer spindown geht nur mit kurzem Zeitparameter

Beitrag von thomas83 » 22.11.2017 22:01:09

Auf dem Rechner läuft nicht so viel. Es ist erstmal eine Installation von einem debian image für arm: https://images.solid-build.xyz/IMX6/Debian/
Selbst installiert hatte ich noch nicht viel:

Code: Alles auswählen

$ sudo grep "apt-get install" /var/log/apt/history.log
Commandline: apt-get install lvm2
Commandline: apt-get install vim
Commandline: apt-get install apache2
Commandline: apt-get install phpunit
Commandline: apt-get install php5
Commandline: apt-get install minidlna
Commandline: apt-get install samba
Commandline: apt-get install imagemagick
Commandline: apt-get install iotop
Commandline: apt-get install smartmontools
Commandline: apt-get install incron
Laufende Services:
https://pastebin.com/uLA71pjG

Benutzeravatar
smutbert
Beiträge: 6170
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: hdparm: automatischer spindown geht nur mit kurzem Zeitparameter

Beitrag von smutbert » 22.11.2017 22:22:27

Es laufen unter anderem gvfs(d), udisks2 und der mate-power-manager – bei ersteren beiden bin ich mir nicht sicher ob es etwas damit zu tun haben kann, bei zletzterem kannst du möglicherweise in den Einstellungen von Mate („Energieeinstellungen“?) das Ausschalten der Platte aktivieren.
Einigermaßen gut ausgestattete Desktops wie gnome, kde, mate, xfce,... sind aber oft etwas problematisch was das Einschlafen der Platte angeht. Ein einfacher Windowmanager, vielleicht auch ohne lightdm oder anderen Displaymanager oder abhängig vom Einsatzzweck gar keine grafische Oberfläche sind was das angeht meist einfacher zu kontrollieren.

thomas83
Beiträge: 3
Registriert: 19.11.2017 09:59:09

Re: hdparm: automatischer spindown geht nur mit kurzem Zeitparameter

Beitrag von thomas83 » 25.11.2017 18:57:35

Es funktioniert jetzt.

Schuld war offenbar der udisks2-Service.
Ich hab außerdem alles deinstalliert was nach xorg, lightdm oder mate/gnome aussah, danke für den hinweis :D Ich hatte mir das debian-image nach der Installation anscheinen nicht genau angesehen, auf dem Server läuft überhaupt kein X.

Danke für den Hinweis :]

Antworten