Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
Lalle75
Beiträge: 71
Registriert: 25.10.2015 17:41:00
Wohnort: Ruhrgebiet

Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von Lalle75 » 04.12.2017 18:33:12

Hallo zusammen.

Ich habe meinem Rechner ein neues Board, CPU, RAM und Lüfter verpaßt. Meine alte Hardware war über 10 Jahre alt und liet zuletzt mit Debian 8.2.

Im Zuge des Updates habe ich sofort Debian 9.2 (4.9.51-1, 2017-09-28) aufgespielt, erhalte aber vom ersten Augenblick an verschiedene Fehlermeldungen rund um Board und CPU. In https://www.servethehome.com/amd-ryzen- ... oor-value/ konnte ich lesen, daß ein Kernel ab 4.10 empfolen wird. Also Kernel 4.14.3 kompiliert und installiert. Leider ist es nicht viel besser geworden.

Die ursprüngliche Fehlermeldung

Code: Alles auswählen

INFO: rcu_sched detected stalls on CPUs/tasks:
(detected by 0, t=5252 jiffies, g=-181, c=-182, q=742)
All QSes seen, last rcu_sched kthread activity 5252 (4294897687-4294892435), jiffies_till_next_fqs=1, root ->qsmask 0x0

rcu_sched kthread starved for 5252 jiffies! g18446744073709551435 c18446744073709551434 f0x2 RCU_GP_WAIT_FQS(3) ->state=0x0
tritt jetzt zwar nicht mehr auf, aber der watchdog hängt immer noch an der CPU für ca. 22 Sekunden:

Code: Alles auswählen

watchdog: BUG: soft lockup - CPU#0 stuck for 21s! [systemd-udevd:76]
Interessanter Weise zeigt dmesg mitunter an, daß die Kerne CPU#0 bis CPU#12 (!) hängen. Kann man unter Linux irgendwo die Kerne begrenzen?

Der nächste Fehler hat mit USB 3.0 zu tun:

Code: Alles auswählen

xhci_hcd 0000:05:00.0: can't setup: -110

xhci_hcd 0000:05:00.0: init 0000:05:00.0 fail, -110
Der dritte Fehler kommt wohl aus einem Bug des Kernels aufgrund einer hart gecodeten Speicheradresse und der Überlagerung von zwei Watchdogs:

Code: Alles auswählen

sp5100_tco: I/O address 0x0cd6 already in use
Diesen konnte ich durch ein blacklist des Moduls beheben, weiß aber nicht, welchen Einfluß das haben kann.

Mit den BIOS-Einstellungen habe ich bereits herumgespielt, außerdem mit den grub-Startparametern (quiet splash nosmp acpi=on/off, etc.)

Hat jemand eine Idee, wie ich mit den Fehlern rund um die Kerne und USB 3.0 umgehen kann?

Meine Hardware:
CPU: AMD Ryzen 5 1600X Six-Core Processor
Board: ASUS X370 Pro (mit aktuellem BIOS)
RAM: 2x 8 GB Corsair
GraKa: nVidia 1060 mit Treiber 384.98

In mehreren Foren weisen die User auf generelle Bugs in den letzten Kernel-Versionen hin. Könnte dies sein? Hat jemand ähnliche Erfahrungen gemacht?
Zuletzt geändert von Lalle75 am 04.12.2017 18:38:06, insgesamt 1-mal geändert.
Gruß,
Der Lalle

KP97
Beiträge: 1533
Registriert: 01.02.2013 15:07:36

Re: Fehlermeldungen mit neuen Prozessor AMD Ryzen 1600X

Beitrag von KP97 » 04.12.2017 18:37:48

Bei solch aktueller Hardware würde ich zuerst einen neueren Kernel aus den Backports probieren.
Sollte ein 4.13 sein, stable ist aber schon 4.14

Benutzeravatar
Lalle75
Beiträge: 71
Registriert: 25.10.2015 17:41:00
Wohnort: Ruhrgebiet

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von Lalle75 » 04.12.2017 18:39:48

Beides schon probiert. 4.13 macht die gleichen Zicken. Sogar noch ein paar mehr. Immerhin zeigt dmesg keine roten Fehlermeldungen für die CPU mehr an mit 4.14. Nur das Hängen des Systems für 20 Sekunden ist halt nervig.
Gruß,
Der Lalle

KP97
Beiträge: 1533
Registriert: 01.02.2013 15:07:36

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von KP97 » 04.12.2017 20:27:57

Hatte ich glatt überlesen, daß Du einen 4.14.3 installiert hast.

Ich habe in meinem 4.14.3 Kernel den watchdog für debug herausgenommen:
# Debug Lockups and Hangs
# CONFIG_WQ_WATCHDOG is not set

Ich gehe mal davon aus, daß Dein PC kein Server ist sondern ein Desktop, da dürfte das nichts ausmachen.
Nachteile konnte ich keine feststellen, evtl. wäre das noch eine Option.

Benutzeravatar
Lalle75
Beiträge: 71
Registriert: 25.10.2015 17:41:00
Wohnort: Ruhrgebiet

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von Lalle75 » 04.12.2017 21:19:18

Ich teste noch mal ein paar Einstellungen beim Kompilieren des 4.13. Mein System läuft auch extrem instabil. Ich habe den Treiber von nVidia in Verdacht. nouveau klappt bei mir nicht, auch ältere nVidia-Treiber lassen sich wegen zu neuer Kernel-Quellen erst gar nicht kompilieren. Also hab ich den Longterm Treiber 384.90 genommen, da der neuste .98 wohl nicht gut lief.
KP97 hat geschrieben: ↑ zum Beitrag ↑
04.12.2017 20:27:57
Ich habe in meinem 4.14.3 Kernel den watchdog für debug herausgenommen:
# Debug Lockups and Hangs
# CONFIG_WQ_WATCHDOG is not set
Ist bei mir übrigens auch ausgeschaltet.
Gruß,
Der Lalle

KP97
Beiträge: 1533
Registriert: 01.02.2013 15:07:36

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von KP97 » 05.12.2017 16:10:22

Das ist ja ärgerlich.
Hier ist das Archiv von Nvidia mit allen Treibern:
http://download.nvidia.com/XFree86/Linux-x86_64/

Zum Testen könntest Du ja mal einen 387... nehmen, ohne Kompilieren.
Dann wüßtest Du wenigstens genau, ob es daran liegt.

wrohr
Beiträge: 6
Registriert: 18.06.2017 10:07:07

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von wrohr » 05.12.2017 16:24:18

Mit den Ryzen Prozessoren dürfte es noch einige Probleme geben, die nicht unbedingt am Linux Kernel liegen sondern auch unter Windows auftreten.

https://www.heise.de/newsticker/meldung ... 96688.html
https://www.golem.de/news/ryzen-7-1800x ... 29456.html
http://www.pcgameshardware.de/Ryzen-7-1 ... 4-1222886/

grüsse
wrohr

winguin
Beiträge: 30
Registriert: 26.11.2017 19:56:25

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von winguin » 05.12.2017 20:47:42

Ich weiß nicht, ob dir das hilft, aber ich hab einen Ryzen 5 1600 und eine Nvidia GTX 1050 auf einem Gigabyte GA-AB350 Gaming Pro sitzen.
Ich hatte auch diverse Probleme mit Stretch und vielen anderen "Linuxen", die ältere Kernel als Grundlage haben.
Einzig der Kernel 4.13.xxx hat funktioniert - egal, ob Antergos,Ubuntu oder Debian Buster.
Somit habe ich mich für Debian Buster (Testing) entschieden und bisher gab es noch keinerlei Probleme.

Code: Alles auswählen

                                system      AB350-Gaming 3 (Default string)
/0                              bus         AB350-Gaming 3-CF
/0/0                            memory      64KiB BIOS
/0/27                           memory      16GiB System Memory
/0/27/0                         memory      [empty]
/0/27/1                         memory      8GiB DIMM DDR4 Synchronous Unbuffered (
/0/27/2                         memory      [empty]
/0/27/3                         memory      8GiB DIMM DDR4 Synchronous Unbuffered (
/0/29                           memory      576KiB L1 cache
/0/2a                           memory      3MiB L2 cache
/0/2b                           memory      16MiB L3 cache
/0/2c                           processor   AMD Ryzen 5 1600 Six-Core Processor
/0/100                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/100/0.2                      generic     Advanced Micro Devices, Inc. [AMD]
/0/100/1.3                      bridge      Advanced Micro Devices, Inc. [AMD]
/0/100/1.3/0                    bus         Advanced Micro Devices, Inc. [AMD]
/0/100/1.3/0/0      usb1        bus         xHCI Host Controller
/0/100/1.3/0/1      usb2        bus         xHCI Host Controller
/0/100/1.3/0.1                  storage     Advanced Micro Devices, Inc. [AMD]
/0/100/1.3/0.2                  bridge      Advanced Micro Devices, Inc. [AMD]
/0/100/1.3/0.2/0                bridge      Advanced Micro Devices, Inc. [AMD]
/0/100/1.3/0.2/0/0  enp5s0      network     RTL8111/8168/8411 PCI Express Gigabit E
/0/100/1.3/0.2/1                bridge      Advanced Micro Devices, Inc. [AMD]
/0/100/1.3/0.2/4                bridge      Advanced Micro Devices, Inc. [AMD]
/0/100/3.1                      bridge      Advanced Micro Devices, Inc. [AMD]
/0/100/3.1/0                    display     GP107 [GeForce GTX 1050 Ti]
/0/100/3.1/0.1                  multimedia  NVIDIA Corporation
/0/100/7.1                      bridge      Advanced Micro Devices, Inc. [AMD]
/0/100/7.1/0                    generic     Advanced Micro Devices, Inc. [AMD]
/0/100/7.1/0.2                  generic     Advanced Micro Devices, Inc. [AMD]
/0/100/7.1/0.3                  bus         Advanced Micro Devices, Inc. [AMD]
/0/100/7.1/0.3/0    usb3        bus         xHCI Host Controller
/0/100/7.1/0.3/0/1              input       Tt
/0/100/7.1/0.3/0/2              input       USB Gaming Mouse
/0/100/7.1/0.3/1    usb4        bus         xHCI Host Controller
/0/100/8.1                      bridge      Advanced Micro Devices, Inc. [AMD]
/0/100/8.1/0                    generic     Advanced Micro Devices, Inc. [AMD]
/0/100/8.1/0.2                  storage     FCH SATA Controller [AHCI mode]
/0/100/8.1/0.3                  multimedia  Advanced Micro Devices, Inc. [AMD]
/0/100/14                       bus         FCH SMBus Controller
/0/100/14.3                     bridge      FCH LPC Bridge
/0/101                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/102                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/103                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/104                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/105                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/106                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/107                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/108                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/109                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/10a                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/10b                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/10c                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/10d                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/10e                          bridge      Advanced Micro Devices, Inc. [AMD]
/0/1                scsi0       storage     
/0/1/0.0.0          /dev/sda    disk        128GB KINGSTON SV200S3
/0/1/0.0.0/1        /dev/sda1   volume      119GiB Windows NTFS volume
/0/2                scsi1       storage     
/0/2/0.0.0          /dev/sdb    disk        256GB SAMSUNG SSD 830
/0/2/0.0.0/1        /dev/sdb1   volume      18GiB EXT3 volume
/0/2/0.0.0/4        /dev/sdb4   volume      123GiB Extended partition
/0/2/0.0.0/4/5      /dev/sdb5   volume      18GiB EXT4 volume
/0/2/0.0.0/4/6      /dev/sdb6   volume      104GiB EXT4 volume
/0/3                scsi4       storage     
/0/3/0.0.0          /dev/sdc    disk        1TB SAMSUNG HD103SJ
/0/3/0.0.0/1        /dev/sdc1   volume      850GiB Windows FAT volume
/0/3/0.0.0/2        /dev/sdc2   volume      81GiB Linux filesystem partition
/0/4                scsi5       storage     
/0/4/0.0.0          /dev/sdd    disk        2TB WDC WD20EZRX-00D
/0/4/0.0.0/1        /dev/sdd1   volume      1863GiB Windows NTFS volume
/0/5                scsi11      storage     
/0/5/0.0.0          /dev/cdrom  disk        CDDVDW SH-224DB

Benutzeravatar
Lalle75
Beiträge: 71
Registriert: 25.10.2015 17:41:00
Wohnort: Ruhrgebiet

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von Lalle75 » 06.12.2017 10:57:50

wrohr hat geschrieben: ↑ zum Beitrag ↑
05.12.2017 16:24:18
Mit den Ryzen Prozessoren dürfte es noch einige Probleme geben, die nicht unbedingt am Linux Kernel liegen sondern auch unter Windows auftreten.

https://www.heise.de/newsticker/meldung ... 96688.html
https://www.golem.de/news/ryzen-7-1800x ... 29456.html
http://www.pcgameshardware.de/Ryzen-7-1 ... 4-1222886/
Hmm... heißt das jetzt, daß die Hardware - CPU und Board - nicht kompatibel sind? Bzw. daß die Ryzen-Prozessoren fehlerhaft sind? Ich will hoffen, daß es ein Software-Problem ist, welches mit einem Kernel-Update behoben werden kann.
KP97 hat geschrieben: ↑ zum Beitrag ↑
05.12.2017 16:10:22
Zum Testen könntest Du ja mal einen 387... nehmen, ohne Kompilieren.
Dann wüßtest Du wenigstens genau, ob es daran liegt.
Ich dachte, man muß den Treiber immer kompilieren. Gibt es einen Startparameter zur Verhinderung der Kompilierung?
Gruß,
Der Lalle

KP97
Beiträge: 1533
Registriert: 01.02.2013 15:07:36

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von KP97 » 06.12.2017 19:32:35

Die Treiber auf der Nvidia-HP enden alle auf .run, heißt also, daß es ein selbstentpackendes Script ist.
Man startet xxxx.run als root und beantwortet die Abfragen. So habe ich das jedenfalls in Erinnerung, ist schon einige Jahre her.
Der Nachteil ist, es geht am Paketmanager vorbei und muß bei einem Kernelwechsel neu ausgeführt werden.
Aber nur für einen Test ist das ja mal ok.
Vorher müssen aber alle Reste der Debianpakete entfernt werden, das kommt sich sonst in die Quere.

Benutzeravatar
Lalle75
Beiträge: 71
Registriert: 25.10.2015 17:41:00
Wohnort: Ruhrgebiet

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von Lalle75 » 07.12.2017 14:55:33

Hölle! Ich habe den Fehler gefunden. Nix mit Ryzen, Board oder Kernel. Es war meine PCIe-USB-Karte :facepalm: . Ich hatte eine zusätzliche Karte eingebaut, die aus irgendeinem Grund nicht mit dem Board läuft. Ich habe sie jetzt ausgebaut, und schon sind die CPU-Fehler, etc. verschwunden. Ich teste jetzt noch mal den neusten Kernel. Mal schauen ob dann alles stabil läuft.
Gruß,
Der Lalle

MSfree
Beiträge: 3624
Registriert: 25.09.2007 19:59:30

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von MSfree » 07.12.2017 15:17:10

Lalle75 hat geschrieben: ↑ zum Beitrag ↑
07.12.2017 14:55:33
Ich hatte eine zusätzliche Karte eingebaut, die aus irgendeinem Grund nicht mit dem Board läuft.
Da könnte ein UEFI-Update helfen.

Benutzeravatar
cirrussc
Beiträge: 6567
Registriert: 26.04.2007 19:47:06
Lizenz eigener Beiträge: MIT Lizenz

Re: Fehlermeldungen mit neuem Prozessor AMD Ryzen 1600X

Beitrag von cirrussc » 17.01.2018 21:57:09

wrohr hat geschrieben: ↑ zum Beitrag ↑
05.12.2017 16:24:18
Mit den Ryzen Prozessoren dürfte es noch einige Probleme geben, die nicht unbedingt am Linux Kernel liegen sondern auch unter Windows auftreten.

https://www.heise.de/newsticker/meldung ... 96688.html
https://www.golem.de/news/ryzen-7-1800x ... 29456.html
http://www.pcgameshardware.de/Ryzen-7-1 ... 4-1222886/

grüsse
wrohr
Das hätte auch so nichts mit der Angelegenheit zu tun. Der Fehler unter speziellen, extrem seltenen Lastsitutationen wurde außerdem längst gefixt.
Gruß cirrussc
--------------------
„Der Mensch steigert zur Zeit die Nutzung dessen, was seiner Willkür unterliegt - und kommt sich sehr klug dabei vor.“ H. Gruhl

Antworten