Probleme Mounten von externer SSD und SD-Karte

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Bertl68
Beiträge: 75
Registriert: 18.09.2016 15:24:28

Probleme Mounten von externer SSD und SD-Karte

Beitrag von Bertl68 » 23.05.2018 11:10:28

Hallo Zusammen,

ich habe ein Problem beim Einhängen von externer SSD und SD-Karte
Ausgabe fstab:

Code: Alles auswählen

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=e4f43f2b-3f19-43bc-b113-e21ef782e42c /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=8b0f5a33-891e-40b3-955f-b6c7f421cabf /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=e8d5d471-5a56-4677-aacc-9c2b0827eed5 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
# Externe Festplatte on /dev/sdb1
#UUID=2C0E1CF80E1CBCB0 /dev/sdb1  ntfs
/dev/sdb1	/media/bertl	ntfs	rw,user,noauto		0	0
#USB Stick on /dev/sdc1
/dev/sdc1	/media/USB		vfat	rw,user,noauto
Ich kann z.B. nur die SD Karte (sdc1) mounten, wenn beim Hochfahren des Rechners die externe SSD (sdb1) bereits angeschlossen ist. Ansonsten kommt eine Fehlermeldung "mounten nicht möglich, falsches Dateisystem"
Die Stromversorgung (und nur die) der SSD kommt vom USB Port. Scheinbar beeinflußt das das irgendwie?!
dmesg | tail gibt folgendes aus, obwohl beide (SSD und SD) gemountet sind und ich drauf zugreifen kann

Code: Alles auswählen

[   22.175369] sd 0:0:0:0: [sdc] 16099328 512-byte logical blocks: (8.24 GB/7.68 GiB)
[   22.178160]  sdc: sdc1
[   24.641197] FAT-fs (sdc1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[   52.126465] fuse init (API version 7.26)
[  558.596516] sd 0:0:0:0: [sdc] 16099328 512-byte logical blocks: (8.24 GB/7.68 GiB)
[  558.598155]  sdc: sdc1
[  564.151697] FAT-fs (sdc1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 2359.042121] sd 0:0:0:0: [sdc] 13280 512-byte logical blocks: (6.80 MB/6.48 MiB)
[ 2359.045693]  sdc: sdc1
[ 2392.896347] FAT-fs (sdc1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
Hat jemand eine Idee, was da falsch ist? Ich möchte nicht immer die exteren SSD einbinden (nur für Backup), damit ich eine SD-Karte auslesen kann.

vielen Dank schonmal im Voraus

Gruß

Bertl
Debian Stretch 4.9.0-6, XFCE 4.12 Desktop, Desktop PC, MSI H110M Gaming, Intel Pentium Skylake G4400

Benutzeravatar
hikaru
Beiträge: 9854
Registriert: 09.04.2008 12:48:59

Re: Probleme Mounten von externer SSD und SD-Karte

Beitrag von hikaru » 23.05.2018 11:23:02

Auf die Reihenfolge von Gerätenamen kannst du dich nicht verlassen. Wenn die SSD nicht angeschlossen ist, dann fehlt das Gerät, und die SD-Karte wird dann /dev/sdb. Da die erste Partition aber nicht mit ntfs sondern mit vfat formatiert ist, schlägt der Mountversuch fehl.

Falls du einen grafischen Desktop instaliert hast, dann kann der die SD-Karte vermutlich ganz ohne fstab-Eintrag mounten. Ansonsten musst du eine zuverlässige Identifizierungsmethode für die SD-Karte wählen. Falls es immer die selbe ist, böte sich die UUID an. Falls du mehrere hast, dann könntest du mit Labels arbeiten, was aber in viel Handarbeit endet.

Bertl68
Beiträge: 75
Registriert: 18.09.2016 15:24:28

Re: Probleme Mounten von externer SSD und SD-Karte

Beitrag von Bertl68 » 24.05.2018 11:38:13

Vielen Dank Hikaru,

geht das auch, daß man die SSD mittels UUID anlegt? Da hab ich nämlich wirklich immer die Gleiche
Wenn ja wie?

Grüße

Bertl
Debian Stretch 4.9.0-6, XFCE 4.12 Desktop, Desktop PC, MSI H110M Gaming, Intel Pentium Skylake G4400

Benutzeravatar
hikaru
Beiträge: 9854
Registriert: 09.04.2008 12:48:59

Re: Probleme Mounten von externer SSD und SD-Karte

Beitrag von hikaru » 24.05.2018 11:50:55

Bertl68 hat geschrieben: ↑ zum Beitrag ↑
24.05.2018 11:38:13
geht das auch, daß man die SSD mittels UUID anlegt? Da hab ich nämlich wirklich immer die Gleiche
Wenn ja wie?
Ja, das geht. Du must dir nur die UUID der Partition auf der SSD beschaffen (z.B. mit blkid) und dann in die fstab eintragen. Deiner fstab nach hattest du das schon mal so, hast es aber zugunsten der Angabe des Gerätenamens auskommentiert. Falls die UUID noch stimmt, müsste also dieser Eintrag funktionieren:

Code: Alles auswählen

# Externe Festplatte on /dev/sdb1
UUID=2C0E1CF80E1CBCB0	/media/bertl	ntfs	rw,user,noauto		0	0
(Da "bertl" vermutlich dein Benutzername auf dem System ist, wäre das allerdings ein eher ungünstiger Mountpoint, denn DARUNTER werden normalerweise alle Wechseldatenträger gemountet. Wenn du nun schon im Grundverzeichnis etwas mountest, dann führt das zu Konflikten.)

Das löst allerdings nicht dein Problem mit dem Mounten der SD-Karte, denn unabhängig davon, ob du die SSD per Gerätenamen oder UUID mountest, kriegt sie immer noch einen Gerätenamen zugewiesen, wenn sie angeschlossen ist, und verschiebt damit den Gerätenamen der SD-Karte.
Du musst eine zuverlässige Methode zum Mounten der SD-Karte wählen (s. mein 1. Post), falls du das über die fstab machen willlst. Die grundlegende Frage bleibt aber weiterhin, warum du das überhaupt über die fstab machen willst.
Zuletzt geändert von hikaru am 24.05.2018 11:55:40, insgesamt 1-mal geändert.

MSfree
Beiträge: 3420
Registriert: 25.09.2007 19:59:30

Re: Probleme Mounten von externer SSD und SD-Karte

Beitrag von MSfree » 24.05.2018 11:53:42

Bertl68 hat geschrieben: ↑ zum Beitrag ↑
24.05.2018 11:38:13
geht das auch, daß man die SSD mittels UUID anlegt?

Code: Alles auswählen

ls -l /dev/disk/by-uuid/
Zeigt die UUIDs der im System gefundenen Storagedevices an und auf welches physikalische Device dieses verlinkt ist.

Benutzeravatar
Maik aus MS
Beiträge: 547
Registriert: 19.08.2005 17:01:19
Wohnort: Münster
Kontaktdaten:

Re: Probleme Mounten von externer SSD und SD-Karte

Beitrag von Maik aus MS » 24.05.2018 11:55:07

SSD anschliessen. Als root mit:
blkit
die UUID abfragen. Dann /dev/sdc1 aendern in der fstab.
UUID=xxxxxxxxxxxx /media/USB vfat rw,user,noauto
Maik
Die mich kennen mögen mich.
Die mich nicht mögen können mich.

Bertl68
Beiträge: 75
Registriert: 18.09.2016 15:24:28

Re: Probleme Mounten von externer SSD und SD-Karte

Beitrag von Bertl68 » 24.05.2018 12:12:32

Hallo Maik,

Danke, genau so hab ich's gemacht und siehe da, die SD-Karten werden nun auch ohne angeschlossenen SSD erkannt! Einen Schritt weiter :THX:
Aber:
wenn ich jetzt eine SD-Karte gemountet habe und die SSD dazu anstecke, ist diese nicht zu sehen wird aber mittels blkid als sdb1erkannt (wie es sein soll)

Code: Alles auswählen

#blkid:
/dev/sda1: UUID="e4f43f2b-3f19-43bc-b113-e21ef782e42c" TYPE="ext4" PARTUUID="21ed23ae-01"
/dev/sda5: UUID="e8d5d471-5a56-4677-aacc-9c2b0827eed5" TYPE="swap" PARTUUID="21ed23ae-05"
/dev/sda6: UUID="8b0f5a33-891e-40b3-955f-b6c7f421cabf" TYPE="ext4" PARTUUID="21ed23ae-06"
/dev/sdc1: UUID="1CC8-2173" TYPE="vfat"
/dev/sdb1: LABEL="Volume" UUID="2C0E1CF80E1CBCB0" TYPE="ntfs" PARTUUID="1850fa47-01"
Wie bekomme ich die SSD nun auf dem Desktop angezeigt?

Grüße

Bertl
Debian Stretch 4.9.0-6, XFCE 4.12 Desktop, Desktop PC, MSI H110M Gaming, Intel Pentium Skylake G4400

Bertl68
Beiträge: 75
Registriert: 18.09.2016 15:24:28

Re: Probleme Mounten von externer SSD und SD-Karte

Beitrag von Bertl68 » 24.05.2018 12:41:43

Es geht! Super DANKE!

nachdem ich nun den Eintrag in der fstab von

Code: Alles auswählen

UUID=2C0E1CF80E1CBCB0 /dev/sdb1 .....

in

Code: Alles auswählen

UUID=2C0E1CF80E1CBCB0	/media/bertl....
geändert hab, funktioniert alles so wie es soll.

DANKE an alle für Eure Unterstützung

:THX: :hail:

Grüße

Bertl
Debian Stretch 4.9.0-6, XFCE 4.12 Desktop, Desktop PC, MSI H110M Gaming, Intel Pentium Skylake G4400

Bertl68
Beiträge: 75
Registriert: 18.09.2016 15:24:28

Re: Probleme Mounten von externer SSD und SD-Karte

Beitrag von Bertl68 » 25.05.2018 16:59:01

Ähh, Kommando zurück!

mit dieser Einstellung bootet der Rechner nicht! Es muß die externe SSD angeschlossen sein, dann gehts normal.

Code: Alles auswählen

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=e4f43f2b-3f19-43bc-b113-e21ef782e42c /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=8b0f5a33-891e-40b3-955f-b6c7f421cabf /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=e8d5d471-5a56-4677-aacc-9c2b0827eed5 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
# Externe Festplatte on /dev/sdb1
UUID=2C0E1CF80E1CBCB0 /media/BackUp  ntfs      rw,user,nonauto 0       0
#USB Stick on /dev/sdc1
/dev/sdc1       /media/USB              vfat    rw,user,noauto
soweit der aktuelle Eintrag in der fstab

Danke schonmal und Grüße

Bertl
Debian Stretch 4.9.0-6, XFCE 4.12 Desktop, Desktop PC, MSI H110M Gaming, Intel Pentium Skylake G4400

ocram
Beiträge: 57
Registriert: 26.04.2018 22:30:24

Re: Probleme Mounten von externer SSD und SD-Karte

Beitrag von ocram » 14.06.2018 22:31:54

Bertl68 hat geschrieben: ↑ zum Beitrag ↑
25.05.2018 16:59:01
Ähh, Kommando zurück!

mit dieser Einstellung bootet der Rechner nicht! Es muß die externe SSD angeschlossen sein, dann gehts normal.

Code: Alles auswählen

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=e4f43f2b-3f19-43bc-b113-e21ef782e42c /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=8b0f5a33-891e-40b3-955f-b6c7f421cabf /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=e8d5d471-5a56-4677-aacc-9c2b0827eed5 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
# Externe Festplatte on /dev/sdb1
[quote]UUID=2C0E1CF80E1CBCB0 /media/BackUp  ntfs      rw,user,nonauto 0       0[/quote]
#USB Stick on /dev/sdc1
/dev/sdc1       /media/USB              vfat    rw,user,noauto
soweit der aktuelle Eintrag in der fstab

Danke schonmal und Grüße

Bertl
Öhm ... muss das nicht heißen:

Code: Alles auswählen

UUID=2C0E1CF80E1CBCB0 /media/BackUp  ntfs      rw,user,noauto 0       0
statt

Code: Alles auswählen

UUID=2C0E1CF80E1CBCB0 /media/BackUp  ntfs      rw,user,nonauto 0       0
?
Quad core Intel Core i5-4460, H81M-E34
Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
Desktop: Xfce 4.12.3 Distro: Debian GNU/Linux 9 (stretch), +KXStudio

Bertl68
Beiträge: 75
Registriert: 18.09.2016 15:24:28

Re: Probleme Mounten von externer SSD und SD-Karte

Beitrag von Bertl68 » 24.06.2018 12:12:10

DANKE Ocram, :hail:

das war der Fehler :facepalm:

Somit funktioniert das jetzt.

Grüße

Bertl
Debian Stretch 4.9.0-6, XFCE 4.12 Desktop, Desktop PC, MSI H110M Gaming, Intel Pentium Skylake G4400

Antworten