HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
pagro
Beiträge: 6
Registriert: 13.07.2018 21:08:09

HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von pagro » 14.07.2018 16:02:22

Hallo Community,

der HDMI-Port meines Aces Aspire V3 funktionierte auf einmal nicht mehr. Ich habe es zum Reparieren gegeben und mit der Versicherung zurückbekommen, dass die Hardware technisch und elektronisch einwandfrei in Ordnung ist. Dennoch funktionierte es zu Hause nicht. Das Setup, also das HDMI-Kabel und der TV, an den angeschlossen werden soll, funktionieren mit einem anderen Gerät ohne Problem, auf dem auch Debian installiert ist. Der Output von xrandr ist hier zu sehen:

~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
1920x1080 60.01*+ 59.93
1680x1050 59.95 59.88
1600x1024 60.17
1400x1050 59.98
1280x1024 60.02
1440x900 59.89
1280x960 60.00
1360x768 59.80 59.96
1152x864 60.00
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
960x600 60.00
960x540 59.99
800x600 60.00 60.32 56.25
840x525 60.01 59.88
800x512 60.17
700x525 59.98
640x512 60.02
720x450 59.89
640x480 60.00 59.94
680x384 59.80 59.96
576x432 60.06
512x384 60.00
400x300 60.32 56.34
320x240 60.05
VGA-1 disconnected (normal left inverted right x axis y axis)

Da ich erst vor kurzen in Linux eingestiegen bin und xrandr auch nur durch kurzes Recherchieren gefunden habe, bin ich hier schon mit meinem Latein am Ende. Wenn Informationen fehlen, um die Fehlerdiagnose durchzuführen, werde ich die gern nachtragen.
Habe natürlich auch die anderen Threads gesehen, aber da tauchte überall ein HDMI auf, bei mir wird der Port ja anscheinend gar nicht erkannt.

Danke im Voraus!

Gunman1982
Beiträge: 896
Registriert: 09.07.2008 11:50:57
Lizenz eigener Beiträge: MIT Lizenz

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von Gunman1982 » 14.07.2018 18:18:09

Und welches Acer Aspire V3 ist es? Da gibt es anscheinend ein "paar" mehr Varianten. Dual Grafik mit Optimus Technology? Was sagt der Befehl "lspci" wenn du ihn in der Konsole ausführst?

pagro
Beiträge: 6
Registriert: 13.07.2018 21:08:09

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von pagro » 16.07.2018 20:09:11

ACER Aspire V3 772G

Der Output:

$ lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1c.3 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM86 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
01:00.0 3D controller: NVIDIA Corporation GK106M [GeForce GTX 760M] (rev a1)
07:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
0d:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)
0e:00.0 Ethernet controller: Broadcom Limited NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)

Benutzeravatar
hikaru
Beiträge: 9852
Registriert: 09.04.2008 12:48:59

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von hikaru » 16.07.2018 22:24:26

Laut deinem xrandr-Output ist da kein HDMI-Anschluss. eDP-1 ist das interne Display und dann wird noch der VGA-Anschluss erkannt. An dieser Stelle kannst du auch nichts bewirken.

Laut lspci ist da nur ein Intel-IGP verbaut, allerdings soll in dem Gerät laut [1] auch noch eine Nvidia-Karte stecken (falls es wirklich das Gerät ist). Von dieser weiß Debian offenbar nichts. Der HDMI-Port könnte ausschließlich an der Nvidia-GPU hängen.
Nun wäre also herauszufinden, wo sich die vermutete Nvidia-GPU versteckt. Die könnte im BIOS/UEFI abgeschaltet sein, oder man braucht Bumblebee bzw. irgendeine Firmware um die GPU überhaupt sichtbar zu machen. Davon habe ich allerdings keine Ahnung, weil ich um solche Hardware immer einen großen Bogen gemacht habe.


[1] https://www.notebookcheck.com/Test-Acer ... 280.0.html

Benutzeravatar
niemand
Beiträge: 11531
Registriert: 18.07.2004 16:43:29

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von niemand » 16.07.2018 22:37:31

hikaru hat geschrieben: ↑ zum Beitrag ↑
16.07.2018 22:24:26
Von dieser weiß Debian offenbar nichts. Der HDMI-Port könnte ausschließlich an der Nvidia-GPU hängen.
Doch, ist da:

Code: Alles auswählen

01:00.0 3D controller: NVIDIA Corporation GK106M [GeForce GTX 760M] (rev a1)
Meine Vermutung wäre auch, dass der HDMI-Ausgang daran hängt.
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

Benutzeravatar
hikaru
Beiträge: 9852
Registriert: 09.04.2008 12:48:59

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von hikaru » 16.07.2018 22:42:16

Oh, Tatsache! Ich hatte nach einem zweiten "VGA"-Eintrag gesucht.
Also vermutlich ein ganz gewöhnliches Optimus-Problem. Dazu sollten wir Threads haben und jemand der davon Ahnung hat, kommt bestimmt auch bald um die Ecke.

Jana66
Beiträge: 3799
Registriert: 03.02.2016 12:41:11

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von Jana66 » 17.07.2018 08:07:45

pagro hat geschrieben: ↑ zum Beitrag ↑
14.07.2018 16:02:22
der HDMI-Port meines Aces Aspire V3 funktionierte auf einmal nicht mehr. Ich habe es zum Reparieren gegeben und mit der Versicherung zurückbekommen, dass die Hardware technisch und elektronisch einwandfrei in Ordnung ist. Dennoch funktionierte es zu Hause nicht.
Da würde ich erst mal die Hardware testen:
Kannst du im BIOS die diskrete GPU mal testweise deaktivieren? Klappt HDMI? wenn nicht, wieder aktivieren und:
Mit dem Windows-Tool "Rufus" ein bootfähiges Windows to Go auf USB-Stick "brennen". Dazu Win10 von MS downloaden. Aktualisieren wegen Laptop-Hardware/Grafik. HDMI testen.
Dann mal Ubuntu mit NVIDIA-Prime installieren. Danach muss man in der Treiberverwaltung unfreie Treiber einstellen und. Kann deshalb gut sein, dass du das "richtig" installieren musst (USB-Stick oder HDD/SSD), nicht einfach mit Live-Iso testen. Dann auf Prime umschalten, in der Leiste gibt es dafür das NVIDIA-Applet.
Debian mit Debianbumblebee. Es könnte wegen NVIDIA-Optimus evtl. sein, dass der HDMI-Anschluss nur mit optirun funktioniert. Zur Vereinfachung würde ich bumblebee vorerst mit freien Treibern installieren:

Code: Alles auswählen

apt-get install bumblebee primus mesa-utils
adduser $USER bumblebee
sicherheitshalber Reboot und Test:

Code: Alles auswählen

service bumblebeed status
glxgears
optirun glxgears
optirun glxgears -info
glxgears und optirun glxgears zeigen signifikante Unterschiede - wenn die Hummel korrekt fliegt und brummt.
Ausführlich und für andere Anwendungen als glxgears: https://wiki.debian.org/Bumblebee

Edit: Mein löcheriges Gedächtnis sagt gerade, dass bei meinem Optimus-Laptop der HDMI-Anschluss -> TV entweder mit bumblebee ohne optirun oder nach Abschalten der diskreten GPU im BIOS mit Debian funktioniert hat. Weiß nicht mehr genau, was ich damals hatte. randr/xrandr musste ich nicht bemühen. Die Auflösung musste etwas angepasst werden (grafisches Tool "Einstellungen -> Anzeige" des DE, bei mir XFCE).
Wenn keiner was sagt, wird sich nichts ändern. Wenn alle nur reden ebenfalls nicht.

pagro
Beiträge: 6
Registriert: 13.07.2018 21:08:09

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von pagro » 17.07.2018 21:16:29

Ich habe https://wiki.debian.org/Bumblebee bemüht und sudo apt-get install bumblebee primus installiert und mich über adduser $MYUSERNAME hinzufügen gewollt mit dem Output adduser: Die Gruppe »bumblebee« existiert bereits. Neustart hat nichts geändert.

EDIT: Ich habe die proprietären Treiber direkt installiert.
Zuletzt geändert von pagro am 17.07.2018 21:20:17, insgesamt 1-mal geändert.

pagro
Beiträge: 6
Registriert: 13.07.2018 21:08:09

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von pagro » 17.07.2018 21:17:35

Den ganzen "erst Windows und dann Ubuntu installieren"-Vorgang wollte ich ehrlich gesagt nicht durchführen.

Gunman1982
Beiträge: 896
Registriert: 09.07.2008 11:50:57
Lizenz eigener Beiträge: MIT Lizenz

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von Gunman1982 » 18.07.2018 00:38:45

pagro hat geschrieben: ↑ zum Beitrag ↑
17.07.2018 21:16:29
EDIT: Ich habe die proprietären Treiber direkt installiert.
Per Debian Paketverwaltung? Oder anders?

Jana66
Beiträge: 3799
Registriert: 03.02.2016 12:41:11

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von Jana66 » 18.07.2018 07:50:05

Proprietäre Treiber müssen vor Bumblebee so installiert werden: https://wiki.debian.org/NvidiaGraphicsDrivers
Dann Bumblebee mit der entsprechenden NVIDIA-Option laut bereits verlinktem Wiki.

Code: Alles auswählen

sudo apt-get install bumblebee-nvidia primus
Mir erscheint unwahrscheinlich, dass sich dadurch bezüglich des HDMI-Anschlusses (gegenüber bumblebee mit freien Treibern) irgendwas ändert. Eher Leistung/Performance der GPU.

Diskrete GPU im BIOS abgeschaltet? Option im BIOS vorhanden?
Irgendwelche Ausgaben? Läuft Bumblebee überhaupt? Hatte oben Test-Kommandos gepostet.
Den ganzen "erst Windows und dann Ubuntu installieren"-Vorgang wollte ich ehrlich gesagt nicht durchführen.
Verständlich. Wenn du das mit Bumblebee nicht hinkriegst, die diskrete GPU im BIOS nicht deaktivieren kannst, wird dir wohl nichts anderes übrig bleiben. Ich würde mit Ubuntu beginnen, geht schneller - obwohl - wenn die HDMI-Schnittstelle mit Windows nicht funktioniert, ist sie wohl eindeutig defekt. :wink:

PS:
Hatte für Optimus, bumblebee, NVIDIA mal einen "Spickzettel" geschrieben: viewtopic.php?f=2&t=159434#p1077460
Einschließlich Tests und verlinkter Wikis.

Edit: Du kannst auch mal Ubuntu/Mint ohne Installation probieren, vielleicht genügt nur Neuanmeldung für die Umschaltung auf NVIDIA-Prime?! Nach Reboot ist eine Linux-Live-ISO jedenfalls zurück gesetzt.
Wenn keiner was sagt, wird sich nichts ändern. Wenn alle nur reden ebenfalls nicht.

pagro
Beiträge: 6
Registriert: 13.07.2018 21:08:09

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von pagro » 18.07.2018 08:23:11

Ich habe dir proprietären Bumblebee-Treiber so installiert wie es in dem Bumblebee-Wiki steht, also "sudo apt-get install bumblebee-nvidia primus". Beim Installationsprozess stand etwas von wegen " Konflikt mit Nouveau" oder so ähnlich und dass ein Neustart nach der Installation helfen könnte. Und auch was von wegen evtl. würde Firmware fehlen oder wie auch immer (Goldfisch-Gedächtnis; es war doch erst gestern...sorry). Im BIOS hab ich noch nicht geguckt, werde ich dann zuerst machen.
Schade, ich hatte gehofft, das behebt das Problem bereits. Ich komme wohl erst am Wochenende wieder dazu, mich darum zu kümmern. Wie gehe ich dann vor? Ich sehe im BIOS nach und schalte die diskrete GPU ab. Und dann? Muss ich zuerst wieder Bumblebee deinstallieren oder gleich Ubuntu? Davor graut es mir etwas, Linux ist noch immer sehr neu für mich und mir wurde Debian installiert, ich habe es nicht selbst getan... Bedeutet das, dass ich den Laptop ganz neu aufsetzen muss?

Jana66
Beiträge: 3799
Registriert: 03.02.2016 12:41:11

Re: HDMI wird nicht erkannt und auch xrandr zeigt es nicht an

Beitrag von Jana66 » 18.07.2018 18:35:58

pagro hat geschrieben: ↑ zum Beitrag ↑
18.07.2018 08:23:11
Ich habe dir proprietären Bumblebee-Treiber so installiert wie es in dem Bumblebee-Wiki steht, also "sudo apt-get install bumblebee-nvidia primus".
Dazu habe ich geschrieben. Kannste bereinigen und nochmals richtig machen:

Code: Alles auswählen

apt purge nvidia*
apt purge bumblebee*
pagro hat geschrieben: ↑ zum Beitrag ↑
18.07.2018 08:23:11
Ich sehe im BIOS nach und schalte die diskrete GPU ab. Und dann?
Erst mal HDMI probieren. Mit abgeschalteter "diskreter" GPU wird die Intel-CPU benutzt. Du musst gar nichts installieren. "Purge" vorher, Kommandos oben. Nicht bei jedem Laptop findet sich jedoch eine entsprechende BIOS-Option.
Dann würde ich erst mal Ubuntu oder Mint als Live-Iso testen - ohne zu installieren. Näheres ich geschrieben.
Windows-to-go auf USB-Stick dauert etwas, aber man kann zwischendurch was anderes tun. Würde nicht auf HDD/SSD landen. Aber für Laptop-Tools (Optimus-Grafik) muss man aktualisieren. Und das dauert ...
pagro hat geschrieben: ↑ zum Beitrag ↑
18.07.2018 08:23:11
Bedeutet das, dass ich den Laptop ganz neu aufsetzen muss?
Mit den eben beschriebenen Maßnahmen nicht.
... und mir wurde Debian installiert
Offenbar unfachmaennisch, Optimus nicht berücksichtigt.

Viel Erfolg!
Wenn keiner was sagt, wird sich nichts ändern. Wenn alle nur reden ebenfalls nicht.

Antworten