Externe USB-Festplatte wird nicht erkannt?

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Benutzeravatar
SubOptimal
Beiträge: 1704
Registriert: 10.01.2005 23:25:46
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: bei Frankfurt

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von SubOptimal » 13.05.2020 23:49:25

Hi @Strunz_1975,
Und wie???
so wie @willy4711 es geschrieben hatte.
Konsole mit

Code: Alles auswählen

dmesg -Tw
öffnen und die Platte anstöpseln.
Bitte dann nur die letzten Zeilen hier einstellen deshalb Zeitstempel.
1.) auf dem PC eine Konsole öffnen
2.) in der Konsole "dmesg -wT" starten
3.) die USB3-Festplatte am USB2-Port des Rechners anschließen
4.) warten was sich tut
5.) alle Zeilen die in der Zeit ab Punkt 3. bis 4. in der Konsole dazugekommen sind hier wieder posten

mit Gruß
SubOptimal

Benutzeravatar
Strunz_1975
Beiträge: 1905
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von Strunz_1975 » 15.05.2020 16:07:43

Hallo,

ich habe eine externe USB3.0-Controller-Karte gekauft und jetzt bringt er ständig diese Meldung:

usb usb2-port1: Cannot enable. Maybe the USB cable is bad?

Mfg
Strunz_1975
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
willy4711
Beiträge: 3714
Registriert: 08.09.2018 16:51:16

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von willy4711 » 15.05.2020 16:21:06

Wie mag wohl eine "externe USB3.0-Controller-Karte " aussehen ?
https://www.idealo.de/preisvergleich/Pr ... 94895.html

Benutzeravatar
bluestar
Beiträge: 1494
Registriert: 26.10.2004 11:16:34
Wohnort: Rhein-Main-Gebiet

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von bluestar » 15.05.2020 16:25:00

Zur nasalen oder aurikularen Anwendung?

Benutzeravatar
Strunz_1975
Beiträge: 1905
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von Strunz_1975 » 15.05.2020 16:51:19

Hier die Anzeige von "lusb":

Code: Alles auswählen

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 005: ID 8564:1000 Transcend Information, Inc. JetFlash
Bus 002 Device 004: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 002 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 002 Device 002: ID 046d:0808 Logitech, Inc. Webcam C600
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f9:004b Brother Industries, Ltd 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
und lscpi

Code: Alles auswählen

00:00.0 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
00:01.0 ISA bridge: NVIDIA Corporation MCP78S [GeForce 8200] LPC Bridge (rev a2)
00:01.1 SMBus: NVIDIA Corporation MCP78S [GeForce 8200] SMBus (rev a1)
00:01.2 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:01.3 Co-processor: NVIDIA Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
00:01.4 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:02.0 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:06.0 IDE interface: NVIDIA Corporation MCP78S [GeForce 8200] IDE (rev a1)
00:07.0 Audio device: NVIDIA Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
00:08.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:09.0 IDE interface: NVIDIA Corporation MCP78S [GeForce 8200] SATA Controller (non-AHCI mode) (rev a2)
00:0a.0 Ethernet controller: NVIDIA Corporation MCP77 Ethernet (rev a2)
00:10.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:12.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:13.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:14.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
02:00.0 VGA compatible controller: NVIDIA Corporation G94 [GeForce 9600 GT] (rev a1)
04:00.0 USB controller: VIA Technologies, Inc. VL805 USB 3.0 Host Controller (rev 01)
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
Strunz_1975
Beiträge: 1905
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von Strunz_1975 » 15.05.2020 16:56:44

lsusb -t :

Code: Alles auswählen

/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=ohci-pci/6p, 12M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=ohci-pci/6p, 12M
    |__ Port 4: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/6p, 480M
    |__ Port 2: Dev 2, If 2, Class=Audio, Driver=snd-usb-audio, 480M
    |__ Port 2: Dev 2, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 2: Dev 2, If 3, Class=Audio, Driver=snd-usb-audio, 480M
    |__ Port 2: Dev 2, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 4: Dev 3, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 2: Dev 4, If 0, Class=Vendor Specific Class, Driver=rt2800usb, 480M
        |__ Port 3: Dev 5, If 0, Class=Mass Storage, Driver=usb-storage, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/6p, 480M
    |__ Port 1: Dev 2, If 0, Class=Printer, Driver=usblp, 480M

Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
Strunz_1975
Beiträge: 1905
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von Strunz_1975 » 15.05.2020 20:46:26

Vielleicht brauche ich einen neuen Kernel???
(Backports)
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
towo
Beiträge: 3617
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von towo » 15.05.2020 20:49:42

Nee, Du brauchst Windows, Linux ist für Dich absolut ungeeignet.

Benutzeravatar
Strunz_1975
Beiträge: 1905
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von Strunz_1975 » 15.05.2020 20:59:45

towo hat geschrieben: ↑ zum Beitrag ↑
15.05.2020 20:49:42
Nee, Du brauchst Windows, Linux ist für Dich absolut ungeeignet.
ha,ha, ha sehr lustig :facepalm:
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
habakug
Moderator
Beiträge: 4229
Registriert: 23.10.2004 13:08:41
Lizenz eigener Beiträge: MIT Lizenz

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von habakug » 16.05.2020 12:21:45

Hallo,

vor kurzem hat jemand hier im Forum [1] diesen Adapter (der nur unter Windows problemlos funzt) zum Leben erweckt.
Diese Lösung ist übrigens im Internet recht weit verbreitet. Man wundert sich, dass das so leicht zu übersehen ist.

Gruss, habakug

[1] viewtopic.php?t=176710
( # = root | $ = user | !! = mod ) (Vor der PN) (Debianforum-Wiki) (NoPaste)

Benutzeravatar
Strunz_1975
Beiträge: 1905
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von Strunz_1975 » 16.05.2020 13:35:08

habakug hat geschrieben: ↑ zum Beitrag ↑
16.05.2020 12:21:45
Hallo,

vor kurzem hat jemand hier im Forum [1] diesen Adapter (der nur unter Windows problemlos funzt) zum Leben erweckt.
Diese Lösung ist übrigens im Internet recht weit verbreitet. Man wundert sich, dass das so leicht zu übersehen ist.

Gruss, habakug

[1] viewtopic.php?t=176710
Werde ich im laufe des Tages ausprobieren.Gilt dies auch für AMD-Prozessoren?

Danke für deine Hilfe :THX:
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
SubOptimal
Beiträge: 1704
Registriert: 10.01.2005 23:25:46
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: bei Frankfurt

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von SubOptimal » 16.05.2020 15:44:10

Nach dieser Seite http://www.linux-kvm.org/page/How_to_as ... T-d_in_KVM steht iommu (input–output memory management unit) stellvertretend für
"Intel VT-d" auf Intel basierendend und für "AMD I/O Virtualization Technology" auf AMD basierenden Rechnern. Ob der Nvidia Chipsatz da was entsprechendes bietet ist die Frage.

Einfacher wäre es alle mal, wenn @STrunz_1975 endlich mal folgendes nachreichen würde
  • 1. dmesg -wT starten
  • 2. Platte am USB-3 Port anschließe (den hat er ja jetzt mit der USB-3 Karte)
  • 3. die Zeilen die nach dem anstecken dazugekommen sind hier posten
mit Gruß
SubOptimal

Benutzeravatar
Strunz_1975
Beiträge: 1905
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von Strunz_1975 » 16.05.2020 15:54:18

SubOptimal hat geschrieben: ↑ zum Beitrag ↑
16.05.2020 15:44:10


Einfacher wäre es alle mal, wenn @STrunz_1975 endlich mal folgendes nachreichen würde
  • 1. dmesg -wT starten
  • 2. Platte am USB-3 Port anschließe (den hat er ja jetzt mit der USB-3 Karte)
  • 3. die Zeilen die nach dem anstecken dazugekommen sind hier posten
mit Gruß
SubOptimal
Hi,

habe ich doch gemacht, es kommt immer wieder diese Aussage:

usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
habakug
Moderator
Beiträge: 4229
Registriert: 23.10.2004 13:08:41
Lizenz eigener Beiträge: MIT Lizenz

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von habakug » 16.05.2020 16:36:34

Hallo,
usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
An Bus 2 port 1 ist der onboard USB Hub:

Code: Alles auswählen

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
...an dem einiges Geraffel eingestöpselt ist:

Code: Alles auswählen

    |__ Port 2: Dev 2, If 2, Class=Audio, Driver=snd-usb-audio, 480M
    |__ Port 2: Dev 2, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 2: Dev 2, If 3, Class=Audio, Driver=snd-usb-audio, 480M
    |__ Port 2: Dev 2, If 1, Class=Video, Driver=uvcvideo, 480M
Zunächst eine Webcam (oder zwei?) jeweils Audio und Video...

Code: Alles auswählen

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/6p, 480M
[...]
    |__ Port 4: Dev 3, If 0, Class=Hub, Driver=hub/4p, 480M
Bus 002 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
        |__ Port 2: Dev 4, If 0, Class=Vendor Specific Class, Driver=rt2800usb, 480M
Bus 002 Device 004: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
        |__ Port 3: Dev 5, If 0, Class=Mass Storage, Driver=usb-storage, 480M
Bus 002 Device 005: ID 8564:1000 Transcend Information, Inc. JetFlash
...und ein weiterer Hub an dem ein Drahtlosadapter und ein USB-Stick hängen (hoffentlich mit eigener Stromversorgung).
Die Meldung wird wahrscheinlich durch ein Gerät verursacht (Wifi-Stick?) das mehr Strom haben möchte und die Unterversorgung auf ein "bad cable" schiebt.
Es geht hier aber eigentlich um dieses Gerät:

Code: Alles auswählen

04:00.0 USB controller: VIA Technologies, Inc. VL805 USB 3.0 Host Controller (rev 01)
[...]
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
Ich bin mal gespannt, ob hier mehr erkannt wird wenn der Bootparameter wie angegeben beim Booten übergeben wird.

Gruss, habakug
( # = root | $ = user | !! = mod ) (Vor der PN) (Debianforum-Wiki) (NoPaste)

Benutzeravatar
willy4711
Beiträge: 3714
Registriert: 08.09.2018 16:51:16

Re: Externe USB-Festplatte wird nicht erkannt?

Beitrag von willy4711 » 16.05.2020 17:49:29

Vielleicht erzählt mir mal jemand auf welchem Rechner von Strunz wir uns gerade befinden.
Auf bisherigen Rechnern gab es laut dmesg Auszug und seiner Aussage gar kein USB 3 (xhci_hcd)
Nun gibt es den sogar an PCI :?: :?:
Strunz_1975 hat geschrieben: ↑ zum Beitrag ↑
15.05.2020 16:51:19
lspci
...
04:00.0 USB controller: VIA Technologies, Inc. VL805 USB 3.0 Host Controller (rev 01)
Jetzt verstehe ich endlich:
Seine "externe USB3.0-Controller-Karte" hat er nun per Supra- leitendem Luftkabel direkt an den PCI_BUS angeschlossen.
Mannomann darauf hätte man auch gleich kommen können. Das ist einfach genial 8O

Antworten