Sarge: DVD-RAM Read-Only

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
claine
Beiträge: 10
Registriert: 08.02.2006 17:27:32

Sarge: DVD-RAM Read-Only

Beitrag von claine » 08.02.2006 17:50:18

Hallo,

ich kämpfe nun schon länger mit meinen DVD-RAM (Plextor PX-750A) und Sarge.
Ich kann einfach nicht auf die DVD-RAM schreiben:

Ich habe einen 2.6.15.3 Kernel kompiliert (es geht auch mit 2.6.8.2 von Sarge nicht), mit:

CONFIG_CDROM_PKTCDVD=y
CONFIG_CDROM_PKTCDVD_BUFFERS=8
# CONFIG_CDROM_PKTCDVD_WCACHE is not set

CONFIG_UDF_FS=m
CONFIG_UDF_NLS=y


Die /etc/fstab:
/dev/hda /media/cdrom0 auto defaults,user,exec,noauto 0 0

Oder auch:

/dev/hda /media/cdrom0 udf rw,user,exec,noauto 0 0

Bringt alles nichts ...

Hier mal ein Paar Fehlermeldungen:

alara:~# mkfs.ext3 /dev/hda
mke2fs 1.37 (21-Mar-2005)
/dev/hda ist ein vollständiges Gerät, nicht nur eine Partition!
Trotzdem fortsetzen? (y,n) y
/dev/hda: Das Dateisystem ist nur lesbar beim Erstellen des Superblocks

alara:~# mkudffs --media=dvdram /dev/hda
trying to change type of multiple extents

Leere DVD-RAM:
alara:~# mount /media/cdrom0/
mount: block device /dev/hda is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hda,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Gelöschte DVD-RAM:
alara:~# mount /media/cdrom0/
mount: block device /dev/hda is write-protected, mounting read-only

syslog:
Feb 8 17:37:42 alara kernel: cdrom: hda: mrw address space DMA selected
Feb 8 17:37:42 alara kernel: cdrom open: mrw_status 'not mrw'
Feb 8 17:37:43 alara kernel: UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'Daten', timestamp 2005/12/13 10:27 (103c)

/dev/hda ist schreibbar
alara:~# ls -l /dev/hda
brwxrwxrwx 1 root cdrom 3, 0 2005-02-26 07:38 /dev/hda

UDF-Modul ist auch geladen:
udf 92676 1

Könnte es ein Problem mit dem ide-cd Module geben ? Das meint nämlich als type "cdrom".

Ich denke ich habe nur eine Kleinigkeit falsch, aber ich weiß nicht mehr was .....

Vielen Dank!!

Viele Grüße
Markus

Benutzeravatar
tomiboy
Beiträge: 328
Registriert: 28.03.2002 23:34:27
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Potsdam
Kontaktdaten:

Beitrag von tomiboy » 08.02.2006 18:46:16

Schon mal mkfs.ext2 probiert? Nur um auszuschließen ob es am udf Modul liegt. So nebenbei verwende ich nur ext2 auf RAMs, da mir udf irgendwie nicht geheuer ist.
"Aus einem verzagten Arsch kommt kein fröhlicher Furz."
Luther

Benutzeravatar
H4kk3r
Beiträge: 724
Registriert: 02.01.2006 16:50:51
Wohnort: in der Nähe von Heidelberg

Beitrag von H4kk3r » 08.02.2006 18:48:18

Um das Packet-Writing zu aktivieren, muss das Gerät in die fstab.

Code: Alles auswählen

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda2       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/pktcdvd/0	/mnt		udf	noauto,noatime,rw,user	0	0
in der /etc/default/udftools muss das richtige Gerät eingetragen sein:

Code: Alles auswählen

DEVICES="/dev/hdc"
Gruß, Marcus

„Well done! We did it!“

Debian testing
kernel 2.6.18.3
IBM R50e UR0S5GE

claine
Beiträge: 10
Registriert: 08.02.2006 17:27:32

Beitrag von claine » 08.02.2006 18:49:25

tomiboy hat geschrieben:Schon mal mkfs.ext2 probiert? Nur um auszuschließen ob es am udf Modul liegt. So nebenbei verwende ich nur ext2 auf RAMs, da mir udf irgendwie nicht geheuer ist.
Hi,
bringt auch nur das Übliche:

alara:~# mkfs.ext2 /dev/hda
mke2fs 1.37 (21-Mar-2005)
/dev/hda ist ein vollständiges Gerät, nicht nur eine Partition!
Trotzdem fortsetzen? (y,n) y
/dev/hda: Das Dateisystem ist nur lesbar beim Erstellen des Superblocks

Immer "nur lesbar"

mludwig
Beiträge: 587
Registriert: 30.01.2005 19:35:04

Beitrag von mludwig » 08.02.2006 18:54:23

folgende Möglichkeiten: sind die udftools installiert? Wurde von udev ein device /dev/pktcdvd0 erstellt? Dieses sollte für das Schreiben von udf-Scheiben genutzt werden (also auch CD/DVD-RW). DVD-Ram sollte allerdings auch mit /dev/hda funktionieren, allerdings könnte sich das mit den udftools in die quere kommen.

grüße
mludwig

claine
Beiträge: 10
Registriert: 08.02.2006 17:27:32

Beitrag von claine » 08.02.2006 18:56:09

H4kk3r hat geschrieben:Um das Packet-Writing zu aktivieren, muss das Gerät in die fstab.

Code: Alles auswählen

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda2       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/pktcdvd/0	/mnt		udf	noauto,noatime,rw,user	0	0
in der /etc/default/udftools muss das richtige Gerät eingetragen sein:

Code: Alles auswählen

DEVICES="/dev/hdc"
Also, das gibt wieder einen anderen Fehler:

Code: Alles auswählen

alara:~# /etc/init.d/udftools start
Starting udftools packet writing:
/dev/pktcdvd/0=/dev/hda ctl open: Not a directory
Brauche ich den überhaupt das pktcdvd ??
Eigentlich sollte das doch so gehen ??

Benutzeravatar
H4kk3r
Beiträge: 724
Registriert: 02.01.2006 16:50:51
Wohnort: in der Nähe von Heidelberg

Beitrag von H4kk3r » 08.02.2006 18:57:02

Ja, mach halt mal die udftools drauf, formatiere das Teil und trage /dev/pktcdvd/0 in die fstab ein. Dann noch die /etc/default/udftools anpassen und schon müsste es laufen. Das mit ext2 oder ext3 ist Schwachsinn, weil der Schreibvorgang 10 mal länger dauert. Du brauchst Packet-Writing.
Zuletzt geändert von H4kk3r am 08.02.2006 18:58:28, insgesamt 1-mal geändert.
Gruß, Marcus

„Well done! We did it!“

Debian testing
kernel 2.6.18.3
IBM R50e UR0S5GE

claine
Beiträge: 10
Registriert: 08.02.2006 17:27:32

Beitrag von claine » 08.02.2006 18:58:21

mludwig hat geschrieben:folgende Möglichkeiten: sind die udftools installiert?
Ist drin ..

mludwig hat geschrieben: Wurde von udev ein device /dev/pktcdvd0 erstellt?
Ähm, es wurde ein dev/pktcdvd0 erstellt, aber frage mich nun nicht wie ... Debian selber ...

claine
Beiträge: 10
Registriert: 08.02.2006 17:27:32

Beitrag von claine » 08.02.2006 19:01:44

H4kk3r hat geschrieben:Ja, mach halt mal die udftools drauf, formatiere das Teil
Das geht doch nicht, oder was meinst du mit "formatieren" ?
mkfsudffs, oder was ??

H4kk3r hat geschrieben:Das mit ext2 oder ext3 ist Schwachsinn, weil der Schreibvorgang 10 mal länger dauert. Du brauchst Packet-Writing.
OK, ist das schon mal klar ....

Danke !!

Benutzeravatar
H4kk3r
Beiträge: 724
Registriert: 02.01.2006 16:50:51
Wohnort: in der Nähe von Heidelberg

Beitrag von H4kk3r » 08.02.2006 19:01:57

Bei mir heißt das /dev/pktcdvd/0.
Probier jetzt doch mal das:

Code: Alles auswählen

(als root) mount -t udf /dev/pktcdvd/0 /mnt
Gruß, Marcus

„Well done! We did it!“

Debian testing
kernel 2.6.18.3
IBM R50e UR0S5GE

claine
Beiträge: 10
Registriert: 08.02.2006 17:27:32

Beitrag von claine » 08.02.2006 19:09:36

H4kk3r hat geschrieben:Bei mir heißt das /dev/pktcdvd/0.
Probier jetzt doch mal das:

Code: Alles auswählen

(als root) mount -t udf /dev/pktcdvd/0 /mnt
Bei mir hat sich das pktcdvd gerade erledigt:

Code: Alles auswählen

alara:~# pktsetup /dev/pktcdvd0 /dev/hda
open packet device: No such device or address
alara:~# rm /dev/pktcdvd0
alara:~# pktsetup /dev/pktcdvd0 /dev/hda
ioctl: Inappropriate ioctl for device
Wie kann ich das denn nun erstellen ??

Benutzeravatar
H4kk3r
Beiträge: 724
Registriert: 02.01.2006 16:50:51
Wohnort: in der Nähe von Heidelberg

Beitrag von H4kk3r » 08.02.2006 19:12:22

Wenn du das richtige Gerät in die /etc/default/udftools eingetragen hast, mach einfach einen Neustart. Dan weißt du auch, wie das Gerät heißt. Dann kann man es mounten. Alternativ kann man es auch unter /etc/init.d neu starten.
Gruß, Marcus

„Well done! We did it!“

Debian testing
kernel 2.6.18.3
IBM R50e UR0S5GE

claine
Beiträge: 10
Registriert: 08.02.2006 17:27:32

Beitrag von claine » 08.02.2006 19:12:36

Code: Alles auswählen

alara:~# cdrwtool -d /dev/hda -q
using device /dev/hda
1344KB internal buffer
setting write speed to 12x
wait_cmd: Input/output error
Command failed: 55 10 00 00 00 00 00 00 3c 00 00 00 - sense 05.26.00
00 00 00 00 00 00 00 00 05 32 20 27 0a 00 00 00 20 00 00 00 00 20 00 96 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 08 00
mode_select: Illegal seek
set_write
alara:~#
Also, ich kann da irgendwie nichts machen.

Klappt das überhaupt mit dem Plextor PX-750 ??

Was für Brenner habt ihr ??

Ich baue den Brenner mal in die XP-Kiste ein, nicht das der einen Schaden hat ...
Lesen, tut er ja alles ..

Vielen Dank !!!

Benutzeravatar
H4kk3r
Beiträge: 724
Registriert: 02.01.2006 16:50:51
Wohnort: in der Nähe von Heidelberg

Beitrag von H4kk3r » 08.02.2006 19:23:27

Toll, dann versuchst du's halt mit Windows. Geh' doch einfach mal schrittweise vor, dann funktioniert das auch.
Gruß, Marcus

„Well done! We did it!“

Debian testing
kernel 2.6.18.3
IBM R50e UR0S5GE

claine
Beiträge: 10
Registriert: 08.02.2006 17:27:32

Beitrag von claine » 09.02.2006 12:31:40

H4kk3r hat geschrieben:Toll, dann versuchst du's halt mit Windows. Geh' doch einfach mal schrittweise vor, dann funktioniert das auch.
Ähm, ich dachte das wäre mal ein Forum wo es nicht immer diese verd.... FlameWar gibt.

Was ist den so schlimm dran den Brenner unter XP zu testen und wenn da alles OK ist, weiter mit Debian dran zu arbeiten ???

Ich habe doch nicht gesagt das ich den nicht mehr unter Debian einsetzen will, der einzige Zweck ist den unter Debian als Backup-LW zu nutzen !!

Ich sehe das auch als schrittweises Vorgehen ....

Auf jeden Fall schon mal vielen Dank an alle !!

Aber noch eine Frage:
Hat überhaupt einer DVDRAM mit Plextor laufen ??

VG
Markus

Antworten