[gelöst] Nvidia GT 730: Tearing bei Debian, bei MX-Linux nicht

Smalltalk
Antworten
rwkraemer
Beiträge: 293
Registriert: 14.08.2005 23:23:40

[gelöst] Nvidia GT 730: Tearing bei Debian, bei MX-Linux nicht

Beitrag von rwkraemer » 14.05.2019 23:36:24

Ich habe mal meine Frage hier hereingestellt, da es sowohl Debian Stretch, Buster und MX-Linux 18.2 betrifft. Ich habe in letzter Zeit etwas Distro-Hopping betrieben und bin momentan bei MX-Linux 18.2 hängengeblieben. Dabei habe ich etwas interessantes festgestellt. Ich habe eine Nvidia Geforce GT 730 Grafikkarte in einem Lenovo Ideacentre 510-15abr. Der Grafiktreiber unter MX-Linux hat die Version 390.116. Unter Debian Stretch und Buster habe ich einen hässlichen horizontalen Streifen in der Mitte des Monitors. Er tritt beim scrollen im Browser und bei Videos auf, wenn die Kamera sich bewegt, also z. B. bei Kamerafahrten. Nennt man das tearing? Unter Stretch mit der Nvidia-Treiber-Version 384 hatte ich das noch nicht, erst nach einem Update auf 390. Bei Buster tritt es ebenfalls auf. Die Videoqualität unter MX-Linux, das ja auf Debian Stretch basiert, ist sehr gut, kein ruckeln, keine Streifen.

Code: Alles auswählen

System:    Host: rainer-pc Kernel: 4.19.0-1-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0 
           Desktop: Xfce 4.12.3 Distro: MX-18.2_x64 Continuum Apr 7  2019 
           base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Desktop System: LENOVO product: 90G7005CGE v: ideacentre 510-15ABR 
           serial: <root required> 
           Mobo: LENOVO model: 3100 v: NOK serial: <root required> UEFI: LENOVO v: M14KT34A 
           date: 09/22/2017 
CPU:       Topology: Quad Core model: AMD A10-9700 RADEON R7 10 COMPUTE CORES 4C+6G bits: 64 
           type: MCP arch: Excavator rev: 1 L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 27949 
           Speed: 1397 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1688 2: 1470 3: 1608 
           4: 1526 
Graphics:  Device-1: NVIDIA GK208 [GeForce GT 730] vendor: Micro-Star MSI driver: nvidia 
           v: 390.116 bus ID: 04:00.0 
           Display: x11 server: X.Org 1.19.2 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GT 730/PCIe/SSE2 v: 4.6.0 NVIDIA 390.116 direct render: Yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo 
           driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 6c:4b:90:4b:d7:3d 
           Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo 
           driver: rtl8821ae v: kernel port: d000 bus ID: 03:00.0 
           IF: wlan0 state: down mac: 72:63:a7:fe:11:9a 
Drives:    Local Storage: total: 704.24 GiB used: 135.97 GiB (19.3%) 
Info:      Processes: 207 Uptime: 2h 43m Memory: 7.80 GiB used: 994.4 MiB (12.5%) Init: SysVinit 
           runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.33 
Hat jemand eine Ahnung, wie man das unter Debian beheben kann? An sich würde ich schon ganz gern zu Buster wechseln, wenn es rauskommt. Wie gesagt, momentan habe ich MX-Linux drauf, daher habe ich keine Debian-Logfiles.
Zuletzt geändert von rwkraemer am 16.05.2019 13:45:07, insgesamt 1-mal geändert.

KP97
Beiträge: 2062
Registriert: 01.02.2013 15:07:36

Re: Nvidia GT 730: Tearing bei Debian, bei MX-Linux nicht

Beitrag von KP97 » 15.05.2019 13:21:51

Die Version 390.116 gibt es für Stretch in den Backports und für Buster im Repo.
Läuft denn Dein Buster mit diesem Treiber? Falls ja, vergleiche doch mal die Pakete mit MX.

rwkraemer
Beiträge: 293
Registriert: 14.08.2005 23:23:40

Re: Nvidia GT 730: Tearing bei Debian, bei MX-Linux nicht

Beitrag von rwkraemer » 15.05.2019 21:45:07

Hallo,

ich bin jetzt zu Debian Buster zurückgekehrt. Seltsamerweise funktioniert es jetzt. Der Treiber hat die Version 418. Hier inxi -v3:

Code: Alles auswählen

System:
  Host: rainer-pc Kernel: 4.19.0-4-amd64 x86_64 bits: 64 compiler: gcc 
  v: 8.3.0 Desktop: Xfce 4.12.4 Distro: Debian GNU/Linux buster/sid 
Machine:
  Type: Desktop System: LENOVO product: 90G7005CGE v: ideacentre 510-15ABR 
  serial: <root required> 
  Mobo: LENOVO model: 3100 v: NOK serial: <root required> UEFI: LENOVO 
  v: M14KT34A date: 09/22/2017 
CPU:
  Topology: Quad Core model: AMD A10-9700 RADEON R7 10 COMPUTE CORES 4C+6G 
  bits: 64 type: MCP arch: Excavator rev: 1 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 27946 
  Speed: 1394 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1397 2: 1397 
  3: 1397 4: 1388 
Graphics:
  Device-1: NVIDIA GK208 [GeForce GT 730] vendor: Micro-Star MSI GK208B 
  driver: nvidia v: 418.56 bus ID: 04:00.0 
  Display: x11 server: X.Org 1.20.3 driver: nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GT 730/PCIe/SSE2 v: 4.6.0 NVIDIA 418.56 
  direct render: Yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: 6c:4b:90:4b:d7:3d 
  Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ae v: kernel port: d000 bus ID: 03:00.0 
  IF: wlp3s0 state: down mac: 8e:28:0f:ba:47:ba 
Drives:
  Local Storage: total: 704.24 GiB used: 134.47 GiB (19.1%) 
Info:
  Processes: 171 Uptime: 43m Memory: 7.80 GiB used: 808.4 MiB (10.1%) 
  Init: systemd runlevel: 5 Compilers: gcc: 8.3.0 Shell: bash v: 5.0.3 
  inxi: 3.0.32 

rwkraemer
Beiträge: 293
Registriert: 14.08.2005 23:23:40

Re: [gelöst] Nvidia GT 730: Tearing bei Debian, bei MX-Linux nicht

Beitrag von rwkraemer » 02.01.2020 00:20:31

Vor einiger Zeit ging das Tearing wieder los (Debian Buster). Erst jetzt habe ich eine Lösung gefunden. Zunächst habe ich den Treiber aus den backports probiert, was aber nichts gebracht hat. Dann habe ich einen Forenbeitrag im Netz gelesen, den Link habe ich leider nicht parad.

Ich startete "nvidia-settings" im Terminal, vorher wurde ich mit "su" root (ohne Strich). Man ruft "X Server Display Configuration" auf und klickt auf "advanced". Dort kann man 2 Häckchen setzen: einmal "Force Composition Pipeline" und dann "Force Full Composition Pipeline". Man kann zunächst ein Häckchen bei ersteren setzen, wenn das nicht hilft, beim zweiten.

Darunter gibt es einen Menupunkt "Save to X Configuration File". Damit habe ich eine "xorg.conf" in "/etc/X11" angelegt. Erst dann wird die Maßnahme offenbar dauerhaft gespeichert. Vorher waren die Einstellungen bei einem Neustart weg. Auch das Ubuntuusers Wiki, wo empfohlen wird einen Autostart Eintrag mit dem Befehl "nvidia-settings -l" anzulegen, hat bei mir nicht geholfen.

Die Idee mit "nvidia-settings -l" im Autostart ist wohl, die Veränderungen ohne root zu werden durchzuführen und mit dem Befehl werden die Einstellungen dann beim Neustart wieder geladen. So habe ich es verstanden. Aber bei mir hat erst das Anlegen der "xorg.conf" geholfen.

Ach ja, vorher habe ich die Kompositeinstellung "Zeichnen mit der vertikalen Austastlücke" synchronisieren" versucht, hat aber nicht geholfen. Aber ehrlich gesagt habe ich keine Ahnung, ob das mit Tearing zu tun hat. Die Einstellung findet man bei XFCE unter "Einstellungen - Feineinstellung der Fensterverwaltung - Komposit".

Naja, jedenfalls ist das Tearing jetzt weg.

Edit: Das Tearing scheint eine XFCE-Geschichte (4.12, Debian Buster) zu sein, die mir der neuen Version (4.14, bei MX-Linux 19) offenbar behoben wurde. Ich habe jetzt Debian Buster Cinnamon installiert, und da habe ich keine Probleme.

Benutzeravatar
ralli
Beiträge: 2652
Registriert: 02.03.2008 08:03:02

Re: [gelöst] Nvidia GT 730: Tearing bei Debian, bei MX-Linux nicht

Beitrag von ralli » 26.01.2020 17:53:15

Schön, das es endlich zufriedenstellend funktioniert, das freut mich für Dich. Ich habe auch eine Nvidia Geforce GT 730 unter Debian Buster (Gnome Desktop) im Einsatz und habe diese Probleme allerdings nicht.

Grüße ralli
System: Debian Buster - Windowmanager: Openbox - CPU: Intel Core i7-870 - RAM: 16 GB - GPU: Nvidia Geforce 730 GT (2 GB) - SSD 128 GB - HD: 1 TB

Antworten