User mit Debian auf einem QNAP-NAS

Smalltalk
owl102
Beiträge: 2296
Registriert: 16.10.2010 13:05:57
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Timbuktu

Re: User mit Debian auf einem QNAP-NAS

Beitrag von owl102 » 08.10.2016 11:08:18

ingo2 hat geschrieben:piccmd("statusled", "greenon")
Das hat AFAIK den Nachteil, daß wenn die Status-LED mal aus berechtigten Gründen nicht-grün ist, sie hiermit auf grün gesetzt wird. Daher finde ich es konsequenter, bei "fanfail" einfach gar nichts zu machen (wie im Bugreport vorgeschlagen).
Ist das inzwischen eigentlich gefixt?
Leider nicht.
Fedora 28 Workstation -- openSUSE Leap 42 / Gnome -- Debian 9 (Qnap TS-109/119) -- OmniOS (HP N54L)

owl102
Beiträge: 2296
Registriert: 16.10.2010 13:05:57
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Timbuktu

Re: User mit Debian auf einem QNAP-NAS

Beitrag von owl102 » 14.04.2018 21:24:42

owl102 hat geschrieben: ↑ zum Beitrag ↑
08.10.2016 11:08:18
ingo2 hat geschrieben:piccmd("statusled", "greenon")
Das hat AFAIK den Nachteil, daß wenn die Status-LED mal aus berechtigten Gründen nicht-grün ist, sie hiermit auf grün gesetzt wird. Daher finde ich es konsequenter, bei "fanfail" einfach gar nichts zu machen (wie im Bugreport vorgeschlagen).
Ist das inzwischen eigentlich gefixt?
Leider nicht.
Obwohl es in https://bugs.debian.org/cgi-bin/bugrepo ... bug=712841 kein Update gibt, scheint das in Stretch gefixt zu sein. Zumindest piept nichts nach der Neuinstallation auf einem TS-119, was es auf dem selben Gerät unter Jessie noch tat.

Update: Ich nehme alles zurück und behaupte das Gegenteil:

Code: Alles auswählen

root@localhost:~# systemctl status qcontrol
● qcontrol.service - LSB: Change status leds for QNAP Turbo Station devices
   Loaded: loaded (/etc/init.d/qcontrol; generated; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2018-04-14 21:14:11 CEST; 18min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 275 ExecStart=/etc/init.d/qcontrol start (code=exited, status=255)

Apr 14 21:14:11 localhost systemd[1]: Starting LSB: Change status leds for QNAP Turbo Station devices...
Apr 14 21:14:11 localhost qcontrol[275]: System boot completed.
Apr 14 21:14:11 localhost qcontrol[275]: Error connecting to socket: No such file or directory
Apr 14 21:14:11 localhost systemd[1]: qcontrol.service: Control process exited, code=exited status=255
Apr 14 21:14:12 localhost systemd[1]: Failed to start LSB: Change status leds for QNAP Turbo Station devices.
Apr 14 21:14:12 localhost systemd[1]: qcontrol.service: Unit entered failed state.
Apr 14 21:14:12 localhost systemd[1]: qcontrol.service: Failed with result 'exit-code'.
Jetzt fällt mir ein: Hatten wir nicht 'mal einen Thread zu dem Thema, daß die Installation von qcontrol unter Debian 9 kaputt ist? Muß ich gleich mal suchen...

Nachtrag: viewtopic.php?f=32&t=165777
Fedora 28 Workstation -- openSUSE Leap 42 / Gnome -- Debian 9 (Qnap TS-109/119) -- OmniOS (HP N54L)

Benutzeravatar
ingo2
Beiträge: 589
Registriert: 06.12.2007 18:25:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Wo der gute Riesling wächst

Re: User mit Debian auf einem QNAP-NAS

Beitrag von ingo2 » 15.04.2018 11:43:33

Ich kann dazu leider nichts mehr beitragen, habe mein TS-109 II ausgemustert.

Ich verschenke es gerne gegen Erstattung der Portokosten.

Ich hatte schon vor einiger Zeit meinen "Server" auf ein PCEngines APU.2C4 mit Stretch umgezogen. Bin mit der ARMEL-Architektur und dem Bootvorgang nie richtig warm geworden, damit war das TS-109 überflüssig.
Habe dann noch den Upgrade von Jessie -> Stretch gemacht, mich dabei aber vom SSH-Zugang ausgesperrt. Statt jetzt lange den Fehler zu suchen (neuer Host-Key?, Editieren der sshd_config nach Ausbau der HD, ...), habe ich einfach das Gerät still gelegt und die HD ausgebaut.

Info: Das Upgrade auf Stretch ist vollständig durchgelaufen und das Stück bootete auch wieder und die darauf laufenden Server waren problemlos erreichber - nur wie gesagt SSH hat mich ausgesperrt.

EDIT: ist erledigt, das TS-109II hat einen neuen Besitzer!

Antworten