[GELÖST] OpenVPN - tun0-Device fehlt

Gemeinsam ins Internet mit Firewall und Proxy.
Antworten
AndreG
Beiträge: 45
Registriert: 04.02.2018 15:54:05

[GELÖST] OpenVPN - tun0-Device fehlt

Beitrag von AndreG » 15.06.2018 14:31:41

Hallo zusammen,

ich habe auf Debian Stretch einen OpenVPN-Server installiert und mit folgender server.conf gestartet:

Code: Alles auswählen

local 192.168.1.6
port 1194
proto udp
dev tun
ca /etc/openvpn/easy-rsa/keys/ca.crt
cert /etc/openvpn/easy-rsa/keys/mariadb.wisoserver.com.crt
key /etc/openvpn/easy-rsa/keys/mariadb.wisoserver.com.key  # This file should be kept secret
dh /etc/openvpn/easy-rsa/keys/dh2048.pem
server 172.16.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
keepalive 10 120
tls-auth ta.key 0 # This file is secret
cipher AES-256-CBC
user nobody
group nogroup
persist-key
persist-tun
status openvpn-status.log
log         openvpn.log
log-append  openvpn.log
verb 3
explicit-exit-notify 1
Ich habe das Forwarding eingestellt:

Code: Alles auswählen

echo 1 > /proc/sys/net/ipv4/ip_forward
vi /etc/sysctl.conf
=> net.ipv4.ip.forward=1
sysctl -p
und den OpenVPN-Server gestartet

Code: Alles auswählen

systemctl start openvpn
Allerdings wird kein tun0-Device angelegt:

Code: Alles auswählen

 ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 52:54:00:34:54:7e brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.6/24 brd 192.168.1.255 scope global ens3
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:fe34:547e/64 scope link 
       valid_lft forever preferred_lft forever
Woran das liegen, dass tun0 nicht erzeugt wird?

Grüße
Andre
Zuletzt geändert von AndreG am 17.06.2018 10:56:31, insgesamt 1-mal geändert.

TomL
Beiträge: 3706
Registriert: 24.07.2014 10:56:59

Re: OpenVPN - tun0-Device fehlt

Beitrag von TomL » 15.06.2018 14:35:58

Code: Alles auswählen

/usr/sbin/openvpn --mktun --dev tun0                    permanentes tun0-Device erstellen
/usr/sbin/openvpn --rmtun --dev tun0                    tun0-Device löschen
vg, Thomas

AndreG
Beiträge: 45
Registriert: 04.02.2018 15:54:05

Re: OpenVPN - tun0-Device fehlt

Beitrag von AndreG » 15.06.2018 14:56:14

Danke Tom,

damit erstellt sich zwar das Device, allerdings selbst mit dem Restart von OpenVPN wird das Device tun0 noch nicht mit der IP-Adresse bestückt. Ich dachte, dass das durch die server.conf vorgegeben wird.

Grüße
Andre

Benutzeravatar
bluestar
Beiträge: 692
Registriert: 26.10.2004 11:16:34
Wohnort: Rhein-Main-Gebiet

Re: OpenVPN - tun0-Device fehlt

Beitrag von bluestar » 15.06.2018 15:05:08

AndreG hat geschrieben: ↑ zum Beitrag ↑
15.06.2018 14:31:41

Code: Alles auswählen

dev tun
Nimm den Hinweis von TomL und ändere die Zeile ab:

Code: Alles auswählen

dev tun0

AndreG
Beiträge: 45
Registriert: 04.02.2018 15:54:05

Re: OpenVPN - tun0-Device fehlt

Beitrag von AndreG » 15.06.2018 15:16:39

In der server.conf? Hier ist die Rede von

Code: Alles auswählen

;dev tap
dev tun
Ich habe jetzt zwar "dev tun" gegen "dev tun0" ersetzt, das ändert aber nichts daran.

Code: Alles auswählen

# ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 52:54:00:34:54:7e brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.6/24 brd 192.168.1.255 scope global ens3
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:fe34:547e/64 scope link 
       valid_lft forever preferred_lft forever
4: tun0: <POINTOPOINT,MULTICAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 100
    link/none

TomL
Beiträge: 3706
Registriert: 24.07.2014 10:56:59

Re: OpenVPN - tun0-Device fehlt

Beitrag von TomL » 15.06.2018 16:38:51

Service stoppen, von Hand manuell im Vordergrund im Terminal starten und hier mal die Ausgabe posten:

Code: Alles auswählen

/usr/local/sbin/openvpn --config /etc/openvpn/server.conf
vg, Thomas

Benutzeravatar
habakug
Moderator
Beiträge: 4094
Registriert: 23.10.2004 13:08:41
Lizenz eigener Beiträge: MIT Lizenz

Re: OpenVPN - tun0-Device fehlt

Beitrag von habakug » 15.06.2018 17:51:49

Hallo,

52:54:00 = QEMU

Gruss, habakug
( # = root | $ = user | !! = mod ) (Vor der PN) (Debianforum-Wiki) (NoPaste)

AndreG
Beiträge: 45
Registriert: 04.02.2018 15:54:05

Re: OpenVPN - tun0-Device fehlt

Beitrag von AndreG » 16.06.2018 10:39:01

Mittlerweile habe ich die Varianten

Code: Alles auswählen

systemctl start openvpn
/usr/sbin/openvpn --config /etc/openvpn/server.conf --mktun
/usr/sbin/openvpn --config /etc/openvpn/server.conf --mktun --dev tun0
Erstere beiden mit "dev tun" in der server.conf und Letztere mit "dev tun0" getestet. Alle mit dem Ergebnis, dass OpenVPN überhaupt nicht richtig startet. Denn

Code: Alles auswählen

ip address
liefert keine konfigurierten tun0,1,2... Devices,

Code: Alles auswählen

ps aux | grep openvpn
zeigt keinen aktiven OpenVPN-Prozess an und

Code: Alles auswählen

netstat -tulpn
zeigt auch keinen lauschenden OpenVPN-Prozess.
Dagegen liefert

Code: Alles auswählen

systemctl status openvpn 
● openvpn.service - OpenVPN service
   Loaded: loaded (/lib/systemd/system/openvpn.service; enabled; vendor preset: enabled)
   Active: [b]active (exited)[/b] since Sat 2018-06-16 10:24:03 CEST; 12min ago
  Process: 31480 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 31480 (code=exited, status=0/SUCCESS)
Ich habe das Ganze mit aktiviertem 'AUTOSTART="all"' in der /etc/default/openvpn und

Code: Alles auswählen

# systemctl daemon-reload
# systemctl restart openvpn
durchgeführt, mit demselben negativen Ergebnis.

Grüße
Andre

Benutzeravatar
bluestar
Beiträge: 692
Registriert: 26.10.2004 11:16:34
Wohnort: Rhein-Main-Gebiet

Re: OpenVPN - tun0-Device fehlt

Beitrag von bluestar » 16.06.2018 22:37:25

Führe mal folgende Befehle nacheinander aus:

Code: Alles auswählen

/usr/sbin/openvpn --mktun --dev tun0
usr/sbin/openvpn --config /etc/openvpn/server.conf

AndreG
Beiträge: 45
Registriert: 04.02.2018 15:54:05

Re: OpenVPN - tun0-Device fehlt

Beitrag von AndreG » 17.06.2018 10:23:12

Der erste Befehl legt nur das permanente tun0-Device an, richtet es aber nicht ein.
Und

Code: Alles auswählen

/usr/sbin/openvpn --config /etc/openvpn/server.conf --verb 3
macht einfach gar nichts. Absolut keine Ausgaben weder auf der Konsole noch im Syslog.
Eigentlich ist die Option "--mktun" nur sinnvoll, wenn man das Netzwerkinterface z.B. in " /etc/network/interfaces" konfigurieren möchte. defaultmässig sollte OpenVPN das aber selbst erledigen.

AndreG
Beiträge: 45
Registriert: 04.02.2018 15:54:05

Re: OpenVPN - tun0-Device fehlt

Beitrag von AndreG » 17.06.2018 10:56:03

Das Problem liegt weniger in der Art des Startens des Services, als in einem Parameter in der server.conf. Das ist mir bei einem Blick in die openvpn.log aufgefallen

Code: Alles auswählen

ttls-auth ta.key 0
Ein Auskommentieren desselben lässt den Server wie gewünscht mit tun-Device starten.

Grüße

Andre

TomL
Beiträge: 3706
Registriert: 24.07.2014 10:56:59

Re: OpenVPN - tun0-Device fehlt

Beitrag von TomL » 17.06.2018 11:00:39

@AndreG
habakug hat geschrieben: ↑ zum Beitrag ↑
15.06.2018 17:51:49
52:54:00 = QEMU
Wenn das zutrifft, empfehle ich dir alle Aktivitäten einzustellen. Das ist schlicht Zeitverschwendung, weil du gar nicht weisst, ob Openvpn wirklich die Problemquelle ist.

Richte Openvpn zuerst auf einen stationären PC ohne Firewall und mit direkter Anbindung an den DSL-Router ein. Wenn die Konfiguration dann dort läuft, und nach anschliessender Übertragung auf die VM dann dort nicht, dann weisst du wenigstens, dass es nicht am VPN-Server liegt. So wie bisher ist das jedenfalls völlig zielloses rumstochern und führt allenfalls zufällig zum Ziel....ohne zu sehen, warum .

Jm2c
vg, Thomas

AndreG
Beiträge: 45
Registriert: 04.02.2018 15:54:05

Re: OpenVPN - tun0-Device fehlt

Beitrag von AndreG » 17.06.2018 11:06:41

TomL hat geschrieben: ↑ zum Beitrag ↑
17.06.2018 11:00:39
@AndreG
habakug hat geschrieben: ↑ zum Beitrag ↑
15.06.2018 17:51:49
52:54:00 = QEMU
Wenn das zutrifft, empfehle ich dir alle Aktivitäten einzustellen. Das ist schlicht Zeitverschwendung, weil du gar nicht weisst, ob Openvpn wirklich die Problemquelle ist.

Richte Openvpn zuerst auf einen stationären PC ohne Firewall und mit direkter Anbindung an den DSL-Router ein. Wenn die Konfiguration dann dort läuft, und nach anschliessender Übertragung auf die VM dann dort nicht, dann weisst du wenigstens, dass es nicht am VPN-Server liegt. So wie bisher ist das jedenfalls völlig zielloses rumstochern und führt allenfalls zufällig zum Ziel....ohne zu sehen, warum .

Jm2c
Was soll dieser Kommentar jetzt? Das Thema ist bereits erfolgreich gelöst und abgeschlossen. Warum jetzt noch so ein sinnloser Kommentar? Verstehe ich absolut nicht.

TomL
Beiträge: 3706
Registriert: 24.07.2014 10:56:59

Re: [GELÖST] OpenVPN - tun0-Device fehlt

Beitrag von TomL » 17.06.2018 11:28:10

Sorry, das habe ich wirklich übersehen. Und da ich nur helfen wollte und Hilfe als sinnloser Kommentar erachtet wird, bereue ich mein Posting natürlich umso mehr. Entschuldige bitte, ich versuche das in Erinnerung zu behalten, damit mir das nicht wieder passiert.
vg, Thomas

Benutzeravatar
habakug
Moderator
Beiträge: 4094
Registriert: 23.10.2004 13:08:41
Lizenz eigener Beiträge: MIT Lizenz

Re: [GELÖST] OpenVPN - tun0-Device fehlt

Beitrag von habakug » 17.06.2018 16:12:57

Hallo,

ganz oben noch so:

Code: Alles auswählen

tls-auth ta.key 0 # This file is secret
Später soll dann das weglassen von

Code: Alles auswählen

ttls-auth ta.key 0
die Lösung sein? (Man beachte das doppelte "t"...)
Ich hatte nur darauf hinweisen wollen, dass hier in einer virtuellen Maschine gearbeitet wird und es nicht für notwendig gehalten wird, dies auch für die Fehlersuche mitzuteilen.

Gruss, habakug
( # = root | $ = user | !! = mod ) (Vor der PN) (Debianforum-Wiki) (NoPaste)

Antworten