x2go Menüs aufrufen extrem langsam

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
scientific
Beiträge: 2711
Registriert: 03.11.2009 13:45:23
Lizenz eigener Beiträge: Artistic Lizenz
Kontaktdaten:

x2go Menüs aufrufen extrem langsam

Beitrag von scientific » 17.02.2017 10:09:43

Hi Leute!

Ich habe mir x2go-server auf meinem Linux-Laptop zuhause installiert. Der hängt über WLAN an einer Kabelmodem-Verbindung im Netz.
Port 22 ist dort weitergeleitet, und ich habe natürlich den Login für root verboten. Ich möchte demnächst auch ganz auf Zertifikat-only-Authentifizierung umsteigen.

Auf meiner Windowskiste in der Arbeit habe ich x2go-Client direkt von der Herstellerseite installiert und mit puttygen ein Zertifikat erzeugt, da pubkey auf meinen Linux-Laptop geladen und damit klappt die Authentifizierung wunderbar.

Ich kann sowohl den Openbox-Desktop öffnen als auch einzelne Applikationen.

Scrollen klappt alles gut. Bei größeren Inhaltsveränderungen beim Scrollen natürlich etwas verzögert, aber sehr erträglich. (Vor allem, wenn man klassische X-forwardings kennt...)
Mir fällt auf, dass das Öffnen von Menüs in Icedove aber EXTREM langsam ist. Für Menüs erster Ordnung (also wenn ich z.B. mit Mausklick rechts das Menü aufklappe) dauert das schon bis zu einer halben Minute, bis das Menü offen is. Untermenüs darin brauchen bis zu 2 Minuten... Das ist mühsam. Besonders mühsam wirds, wenn man kurz über einem Untermenü verweilt und es öffnet sich dadurch ein Untermenü, das man ja gar nicht haben wollte...

Ist das normal? Wovon hängt es ab, dass das Öffnen eines Menüs gar so derart langsam ist?
Und wie kann ich es beschleunigen?

[EDIT]
Ich habe gerade rausgefunden, dass das die Menüs bei nemo und Gimp ratzfatz offen sind. Ich las auch von Firefox-Menüs die langsam sind. Scheint also ein Mozilla-Problem zu sein...
lg scientific

[EDIT2]

Code: Alles auswählen

iptables -A INPUT -i lo -j ACCEPT
iptables -A OUTPUT -o lo -j ACCEPT
und
Workaround: In about:config, set "gfx.xrender.enabled" to "true"

bringt keine Veränderung (bzw. hatte ich schon implementiert zuvor!)
dann putze ich hier mal nur...

Eine Auswahl meiner Skripte und systemd-units.
https://github.com/xundeenergie

auch als Debian-Repo für Testing einbindbar:
deb http://debian.xundeenergie.at/xundeenergie testing main

rendegast
Beiträge: 14272
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: x2go Menüs aufrufen extrem langsam

Beitrag von rendegast » 17.02.2017 17:45:37

Du könntest in about:config Suche "animat"
einige von "true" auf "false" stellen.
Damit konform
browser.fullscreen.animateUp: "0", obwohl das jetzt auch nichts mit Menüs zu tun hat.

layers.acceleration.disabled: "true" setzen?




Ich habe das Problem unter win auf einem älteren amd-4Kern mit nvidia 8200, ff 45esr.
Sollte diese "anstrengende" Aufgabe ratzfatz erledigen können,
bekomme aber nur ein leicht ruckeliges Schneckentempo bei zBsp. "Menü öffnen".

Grafik-Farbtiefe? 32bit? 16bit?

127.0.0.1 localhost
Eintrag in /etc/hosts?
Interface lo ist up?
The right click menu in Firefox is now fast again. I disabled Pulseaudio which
tried to load ConsoleKit. This did not work sine I have unstalled ConsoleKit.
...
I commented out the text below in /etc/pulse/default.pa

Code: Alles auswählen

#.ifexists module-console-kit.so
#load-module module-console-kit
#.endif
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

scientific
Beiträge: 2711
Registriert: 03.11.2009 13:45:23
Lizenz eigener Beiträge: Artistic Lizenz
Kontaktdaten:

Re: x2go Menüs aufrufen extrem langsam

Beitrag von scientific » 17.02.2017 19:06:32

Das mit pulseaudio ist mir noch nicht ganz klar...
Ich kann auf win10 im x2go-client Pulseaudio aktivieren, obwohl ich es nicht auf Win installiert habe...
Und consolekit ist auch nicht installiert. Die anderen auskommentierten Zeilen sollten ja in so einem Fall ja gerade das erfolglose Laden verhindern...

Localhost ist in /etc/hosts, lo ist up.

Und alle anderen Menüs sind flott. Nur in den Mozillen schnarchen sie.

Ich werd morgen gleich mal die Animationen abdrehen und checken...

Vielen Dank für die Hinweise.

Ich fand inzwischen auch heraus, dass das etwas mit xulrunner zu tun hat. Die Version konnte ich hingegen noch nicht in erfahrung bringen.

Lg scientific
dann putze ich hier mal nur...

Eine Auswahl meiner Skripte und systemd-units.
https://github.com/xundeenergie

auch als Debian-Repo für Testing einbindbar:
deb http://debian.xundeenergie.at/xundeenergie testing main

scientific
Beiträge: 2711
Registriert: 03.11.2009 13:45:23
Lizenz eigener Beiträge: Artistic Lizenz
Kontaktdaten:

Re: x2go Menüs aufrufen extrem langsam

Beitrag von scientific » 20.02.2017 17:51:43

So...

Ich hab jetzt auf einem Linux-Rechner ausprobiert und die Menüs in ganz normaler Geschwindigkeit öffnen können.
Dann wieder am Win10-Rechner... schnarchlangsam.

Dann hab ich mich an die Audio-Gerät-Geschichte erinner, dass ein Rechtsklick in Icedove oder Firefox einen Zugriff auf die Audio-Hardware verursact und wenn diese fehlt, eine enorme Verzögerung dabei herauskommt... Hab im X2Go-Client Audio für diese Verbindung deaktiviert... und siehe da, die Menüs öffnen sich in normaler Geschwindigkeit.

:roll: :roll:

Damit ist das Thema zwar erledigt, aber als gelöst würd ich es noch nicht betrachten...
Denn was mach ich, wenn ich Sound auch nach Windows übertragen will? Ich kann mir hier Szenarien vorstellen (auch reale, hier mit Citrix realisiert), wo Sound durchaus ein Thema ist.

lg scientific
dann putze ich hier mal nur...

Eine Auswahl meiner Skripte und systemd-units.
https://github.com/xundeenergie

auch als Debian-Repo für Testing einbindbar:
deb http://debian.xundeenergie.at/xundeenergie testing main

Antworten