teamviewer GUI erscheint nicht?

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
xcomm
Beiträge: 666
Registriert: 21.09.2003 05:12:01
Wohnort: Europe
Kontaktdaten:

teamviewer GUI erscheint nicht?

Beitrag von xcomm » 14.11.2017 17:07:54

Hallo Gemeinde,

habe Teamviewer heruntergeladen und mit dpkg -i installiert. Auch der Dienst läuft.

Code: Alles auswählen

uname -a
 Linux xcomm 4.13.0-1-amd64 #1 SMP Debian 4.13.10-1 (2017-10-30) x86_64 GNU/Linux
dpkg -i  teamviewer_12.0.85001_i386.deb
apt-get install -f
dpkg -L teamviewer | grep bin | tail -n 5
/usr/bin
/opt/teamviewer/tv_bin/wine/lib/libwine.so
/opt/teamviewer/tv_bin/wine/lib/libwine.so.1
/opt/teamviewer/tv_bin/TeamViewer
/usr/bin/teamviewer

Code: Alles auswählen

$ teamviewer 

Init...
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

Code: Alles auswählen

# ps wauxm | grep team
root      2034  0.1  0.1 185888 13512 ?        -    16:52   0:01 /opt/teamviewer/tv_bin/teamviewerd -d
xcomm    4238  0.0  0.0   5964  3032 ?        -    16:55   0:00 /opt/teamviewer/tv_bin/wine/bin/wineserver

Aber es erscheint keine GUI wenn ich es starte - was kann das sein?

Code: Alles auswählen

cat /etc/debian_version 
buster/sid
Ist ein Unstable. Der Fehler soll wohl an der libfreetype6 in zu neuer Version liegen:
https://community.teamviewer.com/t5/Lin ... 15972#M644
I faced with the same problem on debian buster (testing). After upgrading of libfreetype6 package the teamviewer gui stop working.

There is a better solution. I download i386 libfreetype6 package for debian stable from packages.debian.org. Then I unpack this package and put two files from them (libfreetype.so.6, libfreetype.so.6.12.3) to /opt/teamviewer/tv_bin/RTlib/ directory.

Results:
1) system package libfreetype6 was NOT replaced by older version
2) teamviewer works just fine.

Habe mir nun libfreetype6_2.6.3-3.2_i386.deb von Debian Stable runtergeladen und diese ausgepackt und in das Dir vom TeamViewer geworfen.

Die libfreetype6 im System downzugraden scheint keine Option, da sie libcairo2 und dann das gesamte Gnome wegreissen will.
apt-get install libfreetype6/stable libcairo2/stable

Code: Alles auswählen

dpkg-deb -x libfreetype6_2.6.3-3.2_i386.deb .
cd usr/lib/i386-linux-gnu/
cp -a libfreetype.so.6 libfreetype.so.6.12.3  /opt/teamviewer/tv_bin/RTlib/
l /opt/teamviewer/tv_bin/RTlib/
insgesamt 32084
-rw-r--r-- 1 root root   731472 Apr 27  2017 libfreetype.so.6.12.3
lrwxrwxrwx 1 root root       21 Apr 27  2017 libfreetype.so.6 -> libfreetype.so.6.12.3
-rw-r--r-- 1 root root      370 Sep 18 18:16 README
-rw-r--r-- 1 root root   245788 Sep 18 18:16 libQtXml.so.4
-rw-r--r-- 1 root root 16835160 Sep 18 18:16 libQtWebKit.so.4
-rw-r--r-- 1 root root  3295900 Sep 18 18:16 libQtNetwork.so.4
-rw-r--r-- 1 root root  8605956 Sep 18 18:16 libQtGui.so.4
-rw-r--r-- 1 root root   424952 Sep 18 18:16 libQtDBus.so.4
-rw-r--r-- 1 root root  2507936 Sep 18 18:16 libQtCore.so.4
-rw-r--r-- 1 root root   165756 Sep 18 18:16 libpng12.so.0
drwxr-xr-x 3 root root     4096 Nov 14 10:39 plugins/
drwxr-xr-x 3 root root     4096 Nov 14 10:39 doc/
drwxr-xr-x 8 root root     4096 Nov 14 10:39 ../
drwxr-xr-x 4 root root     4096 Nov 14 17:23 ./

Code: Alles auswählen

teamviewer --daemon restart

systemctl restart teamviewerd.service

Code: Alles auswählen

$ teamviewer 

Init...
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...
Aber trotzdem noch nichts zu sehen. ;-(

Danke, xcomm
Zuletzt geändert von xcomm am 14.11.2017 18:19:13, insgesamt 1-mal geändert.

Benutzeravatar
towo
Beiträge: 3072
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: teamviewer GUI erscheint nicht?

Beitrag von towo » 14.11.2017 17:55:19

Ganz ehrlich? Nimm Anydesk, da gibts wenigstens in natives 64bit Linux Paket anstatt dieses mistige 32bit wine Gefrickel.

smiler
Beiträge: 66
Registriert: 31.03.2004 21:26:06

Re: teamviewer GUI erscheint nicht?

Beitrag von smiler » 14.11.2017 22:27:58

Hallo,

bin in das gleiche Problem mit Teamviewer reingelaufen.
ich kann nur sagen, dass der von Dir gefundene Workaround bei mir geholfen hat.
Eventuell mal mit

ps aux|grep -i team

schauen, das keine "alten" Teamviewer Prozesse übrig geblieben sind und wenn doch einfach mal killen, und danach neu starten.

Angeblich soll ja laut teamviewer support forum die nächste Version nativ sein.
Da hoffe ich auch drauf.

Gruss
Thomas

Benutzeravatar
towo
Beiträge: 3072
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: teamviewer GUI erscheint nicht?

Beitrag von towo » 15.11.2017 07:06:00

smiler hat geschrieben:Angeblich soll ja laut teamviewer support forum die nächste Version nativ sein.
Nuja, falls Du auf TeamViewer 13 ansprichst, da gibt es nur den Host als native Linux Anwendung.

smiler
Beiträge: 66
Registriert: 31.03.2004 21:26:06

Re: teamviewer GUI erscheint nicht?

Beitrag von smiler » 15.11.2017 07:56:56

Hallo,
HM...
Der blogpost ist ein bisschen missverständlich geschrieben.

https://community.teamviewer.com/t5/Lin ... td-p/16737

Vielleicht lese ich auch nur das, was ich lesen will...

Lassen wir uns überraschen und hoffen das beste...

Thomas

Antworten