LXDE speichert Desktop Einstellungen nicht

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Benutzeravatar
empty_string
Beiträge: 675
Registriert: 19.07.2003 21:26:07
Wohnort: localhost

LXDE speichert Desktop Einstellungen nicht

Beitrag von empty_string » 27.11.2018 18:15:59

Hallo,

ich habe das Problem, dass nach fast jedem (nicht jedem komischerweise) Neustart der Desktop wieder zurück gesetzt ist. Sprich Standard Hintergrundbild, Symbole, Schriftart, Schriftgröße und die Symbole sind alle wieder linksbündig ohne Sortierung. In der Konfigurationsdatei scheint alles in Ordnung zu sein.

Hat jemand eine Idee woran das noch liegen könnte? Es läuft eine normale Debian netinstall mit LXDE ohne besonderen Schnickschnack.

Vielen Dank vorab und Grüße,
empty_
„In three words I can sum up everything I've learned about life: 'It goes on.'“
— Robert Frost

sony vgn-fw4 @ debian 9.6, kernel 4.9, lxde 9

Benutzeravatar
Blackbox
Beiträge: 2837
Registriert: 17.09.2008 17:01:20
Lizenz eigener Beiträge: GNU Free Documentation License

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von Blackbox » 02.12.2018 12:52:25

empty_string hat geschrieben: ↑ zum Beitrag ↑
27.11.2018 18:15:59
ich habe das Problem, dass nach fast jedem (nicht jedem komischerweise) Neustart der Desktop wieder zurück gesetzt ist. Sprich Standard Hintergrundbild, Symbole, Schriftart, Schriftgröße und die Symbole sind alle wieder linksbündig ohne Sortierung. In der Konfigurationsdatei scheint alles in Ordnung zu sein.
Ist es möglich, dass du uns bitte relevante logfiles, die Konfigurationsdatei mit Hilfe von NoPaste zukommen lässt?
empty_string hat geschrieben: ↑ zum Beitrag ↑
27.11.2018 18:15:59
Es läuft eine normale Debian netinstall mit LXDE ohne besonderen Schnickschnack.
Was heißt denn "normal", auch dazu bedarf es etwas mehr Erläuterung.

Tipp ins Blaue, wie sieht denn dein Session Management aus?
Eigenbau PC: Debian Sid - 4.19.0-4-amd64 - Xfce 4.12
Desktop PC: Dell Inspiron 530 - Debian Sid - 4.19.0-4-amd64 - Xfce 4.12
Notebook: TUXEDO Book BU1406 - Debian Sid - 4.19.0-4-amd64 - Xfce 4.12
Rootserver: Centos 7.6.1810 - 3.10-amd64
Alles Minimalinstallationen.

Debian und gut.

Freie Software unterstützen, Datenschutz stärken!

Benutzeravatar
empty_string
Beiträge: 675
Registriert: 19.07.2003 21:26:07
Wohnort: localhost

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von empty_string » 06.12.2018 14:21:27

Hallo Blackbox und Danke für Deine Antwort. Das Problem trat jetzt ein paar Tage lang nicht auf, bis heute wieder.
Blackbox hat geschrieben: ↑ zum Beitrag ↑
02.12.2018 12:52:25
Ist es möglich, dass du uns bitte relevante logfiles, die Konfigurationsdatei mit Hilfe von NoPaste zukommen lässt?
Ja ich frage mich welches die relevanten logfiles sind. Ich dachte die "~/.cache/lxsession/LXDE/run.log" aber da konnte ich keine Fehler finden, auch in logfiles von /var/log/ nicht.
Ich hänge dennoch mal das log und die LXDE config an (".config/lxsession/LXDE/desktop.conf").
pastebin/?mode=view&s=40510
pastebin/?mode=view&s=40511
Blackbox hat geschrieben: ↑ zum Beitrag ↑
02.12.2018 12:52:25
Was heißt denn "normal", auch dazu bedarf es etwas mehr Erläuterung.

Tipp ins Blaue, wie sieht denn dein Session Management aus?
Normal heißt, dass ich nie irgendwelche Spielereien vornahm, keine configs manuell editierte, keine Software von Drittanbietern etc. Letztens mal mit openbox themes gespielt aber das Problem trat auch schon früher auf. Session Management mit lxsession, aber wie gesagt, da konnte ich keine Abnormalitäten feststellen.

Grüße,
empty_
„In three words I can sum up everything I've learned about life: 'It goes on.'“
— Robert Frost

sony vgn-fw4 @ debian 9.6, kernel 4.9, lxde 9

uname
Beiträge: 9731
Registriert: 03.06.2008 09:33:02

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von uname » 06.12.2018 14:44:50

Du könntest mal einen weiteren Benutzer anlegen (inkl. /home/<user>) und mal schauen, ob es dort zu den identischen Problemen kommt.

Benutzeravatar
empty_string
Beiträge: 675
Registriert: 19.07.2003 21:26:07
Wohnort: localhost

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von empty_string » 07.12.2018 15:27:35

uname hat geschrieben: ↑ zum Beitrag ↑
06.12.2018 14:44:50
Du könntest mal einen weiteren Benutzer anlegen (inkl. /home/<user>) und mal schauen, ob es dort zu den identischen Problemen kommt.
Ok danke das teste ich gerade nebenher, momentan stabil...
„In three words I can sum up everything I've learned about life: 'It goes on.'“
— Robert Frost

sony vgn-fw4 @ debian 9.6, kernel 4.9, lxde 9

uname
Beiträge: 9731
Registriert: 03.06.2008 09:33:02

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von uname » 08.12.2018 10:55:07

Vielleicht Dateien, die nur root speichern darf. Evtl. rekursiv alle Rechte korrigieren. Auch kannst du schauen, welche Dateien beim neuen Benutzer am Ende der Sitzung gespeichert werden. Vergleiche die Dateien mit deinen Benutzer.

Benutzeravatar
Revod
Beiträge: 3526
Registriert: 20.06.2011 15:04:29
Lizenz eigener Beiträge: MIT Lizenz

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von Revod » 08.12.2018 11:00:47

uname hat geschrieben: ↑ zum Beitrag ↑
08.12.2018 10:55:07
...Vergleiche die Dateien mit deinen Benutzer.
Das ist der aller erste Schritt... die versteckten und die in alle versteckten Ordner. :wink:

Manchmal genügt nur, als root das gesamte /home/benutzername/.cache zu löschen.
Systemd und PulseAudio, hmmm, nein danke.

Benutzeravatar
empty_string
Beiträge: 675
Registriert: 19.07.2003 21:26:07
Wohnort: localhost

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von empty_string » 04.01.2019 15:06:11

Das Problem tritt immernoch auf :-/. Bei dem Testnutzer allerdings nicht.

Die Rechteverteilung sollte passen. Auch das ~/.cache Verzeichnis ist geleert.
Nur beim Vergleich der Dateien stehe ich noch auf dem Schlauch. Ich überprüfte alle möglichen in Frage kommenden aber fand keine relevanten Unterschiede. Welche Dateien sind denn konkret für diese Desktop-Einstellungen verantwortlich?
„In three words I can sum up everything I've learned about life: 'It goes on.'“
— Robert Frost

sony vgn-fw4 @ debian 9.6, kernel 4.9, lxde 9

Benutzeravatar
Revod
Beiträge: 3526
Registriert: 20.06.2011 15:04:29
Lizenz eigener Beiträge: MIT Lizenz

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von Revod » 04.01.2019 15:49:52

Vermutlich hast Du irgend wann in Deinen originaler Benutzer irgend was mit Admin Rechte verbaut.
empty_string hat geschrieben: ↑ zum Beitrag ↑
04.01.2019 15:06:11
... Welche Dateien sind denn konkret für diese Desktop-Einstellungen verantwortlich?

Alle Dateien und Ordner, die

~/.lx, und ~/.lxde, ~/.config/lx und lxde und pcmanfm, oder ~/.local/lx und lxde...

Hiermit zeige ich Dir alle mögliche Pfade auf, worin sich die lxde Dateien und Ordner befinden können, müssen aber nicht, die zwei Hauptordner, die die lxde Einstellungen enthalten sind ~/.config und noch höchsten falls ~/.local/share.

Doch Vorsicht, es kann wieder einen unangenehmes " Salat " verursachen und noch dazu alle Deine persönliche Einstellungen über Bord werfen. Zuerst löschen geht gar nicht, direkt rein kopieren und auf überschreiben klicken.

Am besten rate ich Dir dringend Deine Daten zu tar.gz zu komprimieren und extern ab zu sichern. Danach neuer Benutzer anlegen, alles einstellen, reboot und wenn alles so passt Deine Daten wieder in den entsprechende rein kopieren, entpacken und fertig.

Das kaputte Benutzer danach komplett löschen.
Systemd und PulseAudio, hmmm, nein danke.

Benutzeravatar
empty_string
Beiträge: 675
Registriert: 19.07.2003 21:26:07
Wohnort: localhost

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von empty_string » 05.01.2019 17:35:36

Hallo Revod,

vielen Dank für deine Antwort. Ich habe die Dateien und Ordner nochmal überprüft und ich denke die relevanten sind:
/home/empty/.config/pcmanfm/LXDE mit desktop-items-0.conf und pcmanfm.conf
Sowie
/home/empty/.config/lxsession/LXDE mit autostart und desktop.conf.
Die anderen Pfade sind gar nicht vorhanden.
Ich habe diese Dateien jetzt überschrieben und der Desktop sieht genauso aus wie beim Nutzer "test", wo ja dieses Verhalten bisher nicht auftrat.
Jetzt warte ich erstmal ab und schaue ob es wieder zu dem selben Verhalten kommt, ansonsten mache ich es wie du geschrieben hast und lege einen komplett neuen Nutzer an.

Herzliche Grüße,
empty_
„In three words I can sum up everything I've learned about life: 'It goes on.'“
— Robert Frost

sony vgn-fw4 @ debian 9.6, kernel 4.9, lxde 9

Benutzeravatar
Revod
Beiträge: 3526
Registriert: 20.06.2011 15:04:29
Lizenz eigener Beiträge: MIT Lizenz

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von Revod » 05.01.2019 18:52:18

Ja richtig, /home/empty/.config/lxsession/LXDE
empty_string hat geschrieben: ↑ zum Beitrag ↑
05.01.2019 17:35:36
...
/home/empty/.config/lxsession/LXDE mit autostart und desktop.conf.
...
Im Ordner ~/LXDE erwähnst Du nur die zwei Dateien, autostart und desktop.conf.

Hast Du die Datei ~/LXDE/config übersehen, oder ist sie tatsächlich nicht darin vorhanden? Darin liest der Anmelde Manager welches Desktop für den jeweiliger Benützer gestartet werden soll.

Ich nehme Mal an, Openbox ist installiert, dann sollte der Inhalt der ~/LXDE/config Datei so aussehen

Code: Alles auswählen

[Session]
window_manager=openbox-lxde
Systemd und PulseAudio, hmmm, nein danke.

Benutzeravatar
empty_string
Beiträge: 675
Registriert: 19.07.2003 21:26:07
Wohnort: localhost

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von empty_string » 05.01.2019 19:50:15

Die ist tatsächlich nicht vorhanden und ich kann sie auch nirgends finden. find -name *config* findet nur die config von lxpanel.
~/LXDE/ oder ~/.lxde o.ä. gibt es gar nicht bei mir, es liegt alles in ~/.config/.

Der genannte Eintrag ist zu finden in der ~/.config/lxsession/LXDE/desktop.conf und sieht so aus
pastebin/?mode=view&s=40570
Die habe ich jetzt mal überschrieben mit der Datei vom test user, anschließend meine alten Einstellungen (Hintergrundbild etc.) vorgenommen und hoffe es läuft jetzt stabil.

Achso und wallpaper, Schrift etc. sind in der ~/.config/pcmanfm/LXDE/desktop-items-0.conf gespeichert:
pastebin/?mode=view&s=40571
„In three words I can sum up everything I've learned about life: 'It goes on.'“
— Robert Frost

sony vgn-fw4 @ debian 9.6, kernel 4.9, lxde 9

Benutzeravatar
Revod
Beiträge: 3526
Registriert: 20.06.2011 15:04:29
Lizenz eigener Beiträge: MIT Lizenz

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von Revod » 05.01.2019 20:06:04

Ich merke, da hat sich was im lxde mit dem neuesten Debian-Stable geändert... oder auch nicht, vielleicht irgend wo ein Fehler bei den neuesten Anmeldemanager... lxde schlichtweg vergessen von den Anmeldemanager Entwickler... ich weiss es nicht.

Um es definitiv fest stellen zu können ob die ./config Datei nicht zwingend vorhanden sein muss gucke auch unter /etc/skel/.config/lxsession und /etc/skel/.config/lxsession/LXDE nach.

Falls es nicht stabil bleibt würde ich eine config Datei im Ordner ~/LXDE speichern, mit einen Texteditor öffnen und das Inhalt einfügen, speichern und rebooten ( Wieder gelöscht kann es immer werden ). Dann sollte das als Standard Sitzung gesetzt sein.

Etwas erstaunt bin nun schon.
Systemd und PulseAudio, hmmm, nein danke.

Benutzeravatar
empty_string
Beiträge: 675
Registriert: 19.07.2003 21:26:07
Wohnort: localhost

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von empty_string » 10.01.2019 19:57:39

Hallo Revod,
danke für deine erneute Hilfe. Also unter /etc/skel/ ist nichts dergleichen zu finden, lediglich .bash_logout, .bashrc, .profile.
Dafür aber unter /etc/xdg/lxsession/LXDE/desktop.conf mit dem Eintrag
[Session]
window_manager=openbox-lxde
...

Nachdem ich jetzt die hier schon erwähnten Vorschläge ausprobiert habe bin ich gerade zufällig auf ein Phänomen gestoßen, aber noch nicht sicher ob es die Lösung ist. Es könnte eventuell an den Rechten des Hintergrundbildes bzw. von ein paar Bilddateien auf meiner Platte gelegen haben. Dort war kein Leserecht für "other" gesetzt, sondern nur für user und group (neben sinnlosen x Rechten aber das hatte keine Auswirkungen). Beim testuser konnte ich ein wallpaper mit "chmod o-r" gar nicht erst setzen. Bei meinem eigenen Nutzerkonto allerdings schon. Vielleicht hat openbox wieder default settings gestartet, nachdem es feststellte, dass dort Rechte fehlen. Allerdings nicht nach jedem logout-login sondern sehr unregelmäßig.

Werde weiter beobachten und (hoffentlich nicht mehr) berichten.
„In three words I can sum up everything I've learned about life: 'It goes on.'“
— Robert Frost

sony vgn-fw4 @ debian 9.6, kernel 4.9, lxde 9

Benutzeravatar
Revod
Beiträge: 3526
Registriert: 20.06.2011 15:04:29
Lizenz eigener Beiträge: MIT Lizenz

Re: LXDE speichert Desktop Einstellungen nicht

Beitrag von Revod » 10.01.2019 21:39:41

Einen ziemlich leeres /etc/skel Ordner ( Das ist aber ein ganz anderes Thema ).

Das was Du unter /etc/xdg/lxsession/LXDE/ gefunden hast ist für die Systemweite verschiedener Benützer Standard Einstellung, Bei mir sieht es genau gleich aus, wenn im jeweiligen Benützer sich keine " ~/config " Dateien befinden.

Openbox und lxde arbeiten auf ganz verschiedene Art, Openbox ist kein Desktop Manager sondern einen Fenstermanager daher funktionieren gewisse Desktop Einstellungen unter Openbox nicht, daher der Unterschied. Welchen Anmeldemanager hast DU, lightdm-gtk... -qt... oder einen ganz anderes? Mit dem Zusatz lDebianightdm-gtk-greeter hatte ich mit Debian am wenigsten Probleme, ob es immer noch so ist kann ich nicht sagen. Mit lightdm-gtk-greeter könntest Du auch versuchen Dir eine Datei unter
~/.config/lxsession/LXDE/config mit genau dieses Inhalt abzuspeichern.

Code: Alles auswählen

[Session]
window_manager=openbox-lxde
und reebooten.

Wie haben sich meine Vorschläge verhalten, waren sie erfolgreich, oder auch nicht?

Ich überprüfe die Berechtigungen immer mit Debianxfe, für diese Zwecke und ein paar andere Sachen sehr sehr nützlich, z. B. grosse Anzahl von Dateien von " A " > " B " , oder externe Medien zu kopieren, grosse Datenmengen zu löschen usw. finde ich der beste Dateimanager, auch wegen des Doppelfenster, empfehle ich Dir unter lxde wärmstens, auch sehr gut gut um korrekte Berechtigungen Übernahme um eine Datei auf eine zweite ext3 Partition zu kopieren. Die rekursive Handhabung ist das setzen der Berechtigungen sehr komfortabe ( Mit einen wenig Übung damit hat man sehr rasch die Bedienung und Einstellungen raus. Als look habe ich die kde Icons )l.

Meine Dateien ( Bilder,, Texte, Audio usw. ) haben alle dieses Berechtigungsschema im xfe Dateimanager, und hatte seid ca. 11 Jahren nie Probleme damit.

x x x
x x o
o o o

Bei " x " sind Berechtigungen gesetzt, bei dem " o " keine, leeres Flag Kästchen ( Wobei es sind eher Haken ).

Richtig, wenn alle Stricke reissen sollten mit einen neues Benützer weiter machen und den defekten halt löschen, hatten wir schon. Auch das Ordner mit dem alten Benutzernamen unter /media löschen, wenn darin keine permanente eingehängte Medien darin hast. Ansonsten alle aushängen und im neuen Benutzer wie einstellen.

Man darf sich immer melden um auch, es sei nur eine Bestätigung mit zu teilen. :wink:
Systemd und PulseAudio, hmmm, nein danke.

Antworten