Connection refused (Xorg) unter Buster?

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
Strunz_1975
Beiträge: 1527
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Connection refused (Xorg) unter Buster?

Beitrag von Strunz_1975 » 10.07.2019 20:30:08

Hallo,

ich habe den aktuellen "Noveau"-Treiber installiert auf mein System, allerdings erhalte
ich keine Verbindung (/home/.Xautority) zum X-Server?
Wenn ich "startx" auf einer der virtuellen Konsole wechseln will, erhalte ich die oben
genannte Fehlermeldung?

cu
Strunz_1975
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
niemand
Beiträge: 12795
Registriert: 18.07.2004 16:43:29

Re: Connection refused (Xorg) unter Buster?

Beitrag von niemand » 10.07.2019 21:17:15

Strunz_1975 hat geschrieben: ↑ zum Beitrag ↑
10.07.2019 20:30:08
Wenn ich "startx" auf einer der virtuellen Konsole wechseln will, erhalte ich die oben
genannte Fehlermeldung?
Warum fragst du uns das? Das solltest du doch auf deinem Bildschirm sehen? Weitere Informationen sollten dann in Xorg.0.log zu finden sein.
ENOKEKS

Benutzeravatar
Strunz_1975
Beiträge: 1527
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Connection refused (Xorg) unter Buster?

Beitrag von Strunz_1975 » 10.07.2019 21:39:38

niemand hat geschrieben: ↑ zum Beitrag ↑
10.07.2019 21:17:15
Strunz_1975 hat geschrieben: ↑ zum Beitrag ↑
10.07.2019 20:30:08
Wenn ich "startx" auf einer der virtuellen Konsole wechseln will, erhalte ich die oben
genannte Fehlermeldung?
Warum fragst du uns das? Das solltest du doch auf deinem Bildschirm sehen? Weitere Informationen sollten dann in Xorg.0.log zu finden sein.
Da erhalte ich ja die Fehlermeldung???
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
niemand
Beiträge: 12795
Registriert: 18.07.2004 16:43:29

Re: Connection refused (Xorg) unter Buster?

Beitrag von niemand » 10.07.2019 21:46:26

Strunz_1975 hat geschrieben: ↑ zum Beitrag ↑
10.07.2019 21:39:38
Da erhalte ich ja die Fehlermeldung?
Warum fragst du das mich? Traust du deinen eigenen Augen nicht? Ich hab weder deine Fehlermeldung gesehen, noch das Log selbst – in dem garantiert nicht nur die Fehlermeldung steht, sondern auch, was dazu geführt hat. Und bevor du jetzt wieder fragst, was du eh schon weißt: frag doch lieber, was du wissen willst. Und liefere paar Infos dazu – etwa das Log, sowie Angaben zur Hardware.
ENOKEKS

Benutzeravatar
Strunz_1975
Beiträge: 1527
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Connection refused (Xorg) unter Buster?

Beitrag von Strunz_1975 » 10.07.2019 21:52:41

Folgendes habe ich schon probiert
ln -s /home/$benutzer/.Xauthority /root/.Xauthority
Als Kernelmodul lade ich "nouveau" und im LOg-File
steht die Fehlermeldung!

Mfg
Strunz_1975
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
niemand
Beiträge: 12795
Registriert: 18.07.2004 16:43:29

Re: Connection refused (Xorg) unter Buster?

Beitrag von niemand » 10.07.2019 21:54:55

Solange du das Logfile, sowie die benötigten Infos zu deiner Hardware geheim hälst, wird das hier vermutlich nichts. Es sei denn, jemand hat Lust auf ’ne Runde lustiges Rumraten. Ich jedenfalls nicht.
ENOKEKS

Benutzeravatar
Strunz_1975
Beiträge: 1527
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Connection refused (Xorg) unter Buster?

Beitrag von Strunz_1975 » 10.07.2019 22:19:04

niemand hat geschrieben: ↑ zum Beitrag ↑
10.07.2019 21:54:55
Solange du das Logfile, sowie die benötigten Infos zu deiner Hardware geheim hälst, wird das hier vermutlich nichts. Es sei denn, jemand hat Lust auf ’ne Runde lustiges Rumraten. Ich jedenfalls nicht.
Nvidia
GeForce GT9600

Das habe ich bereits korrigiert:

sudo chown -R -v BENUTZER:BENUTZER /home/BENUTZER
sudo chmod -R -v u+rwX /home/BENUTZER
sudo chmod 600 /home/BENUTZER/.dmrc
chmod 755 /home/BENUTZER
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
niemand
Beiträge: 12795
Registriert: 18.07.2004 16:43:29

Re: Connection refused (Xorg) unter Buster?

Beitrag von niemand » 10.07.2019 22:24:00

Fein. Fehlt nur noch das vollständige Log. Dort steht nämlich drin, was zu der finalen, alleine stehend nichtssagenden, Meldung „Connection refused” geführt hat.
ENOKEKS

Benutzeravatar
willy4711
Beiträge: 1542
Registriert: 08.09.2018 16:51:16

Re: Connection refused (Xorg) unter Buster?

Beitrag von willy4711 » 10.07.2019 22:38:38

Ich muss niemand Recht geben. Deine Lust (oder Fähigkeit), konkrete Angaben zu machen ist unterirdisch.
Strunz_1975 hat geschrieben: ↑ zum Beitrag ↑
10.07.2019 20:30:08
Wenn ich "startx" auf einer der virtuellen Konsole wechseln will, erhalte ich die oben
genannte Fehlermeldung?
Das heißt für mich, dass du auf TTY7 also alles hast. Nur wenn du auf eine andere Konsole wechselst (z.B.) TTY4, kannst du
den X Server nicht starten.
Oder wie oder was ??

Benutzeravatar
Strunz_1975
Beiträge: 1527
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Connection refused (Xorg) unter Buster?

Beitrag von Strunz_1975 » 11.07.2019 18:34:51

Hier meine "xorg.conf"

Code: Alles auswählen

 nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.40  (buildmeister@swio-display-x86-rhel47-06.nvidia.com)  Thu Apr  5 22:40:54 PDT 2012
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "ServerFlags"
    Option         "ignoreABI" "True"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "de"
    Option         "XkbVariant" "nodeadkeys"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nouveau"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
niemand
Beiträge: 12795
Registriert: 18.07.2004 16:43:29

Re: Connection refused (Xorg) unter Buster?

Beitrag von niemand » 11.07.2019 18:40:30

Das ist eine Art Scherz, oder sowas wie Trollerei, oder?
ENOKEKS

Benutzeravatar
Strunz_1975
Beiträge: 1527
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Connection refused (Xorg) unter Buster?

Beitrag von Strunz_1975 » 11.07.2019 18:42:40

Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
MartinV
Beiträge: 709
Registriert: 31.07.2015 19:38:52
Wohnort: Hyperion
Kontaktdaten:

Re: Connection refused (Xorg) unter Buster?

Beitrag von MartinV » 11.07.2019 19:29:49

Das log zeigt einen Segmenation fault, der genaue Grund ist mir unklar.

Mit dem nouveau-Treiber sollte kein Xorg.conf nötig sein. Auch wenn ich dort keinen offensichtlichen Fehler erkenne, könnte da etwas falsch konfiguriert sein.

Vorschlag:
- Überprüfen, ob NVIDIA Treiber wirklich deinstalliert ist.
- Überprüfen, ob nouveau wirklich installiert ist.
- Xorg.conf umbenennen, damit es nicht verwendet wird.
Die Vernunft kann einem schon leidtun. Sie verliert eigentlich immer.

Benutzeravatar
Strunz_1975
Beiträge: 1527
Registriert: 13.04.2007 14:29:32
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Connection refused (Xorg) unter Buster?

Beitrag von Strunz_1975 » 11.07.2019 19:37:59

MartinV hat geschrieben: ↑ zum Beitrag ↑
11.07.2019 19:29:49

Vorschlag:
- Überprüfen, ob NVIDIA Treiber wirklich deinstalliert ist.
dpkg -l pipe grep nvidia-* ???
- Überprüfen, ob nouveau wirklich installiert ist.
lsmod pipe grep nouveau ???
Debian Buster | Kernel 4.19.0-5-amd64 |
XFCE 4.12

Benutzeravatar
MartinV
Beiträge: 709
Registriert: 31.07.2015 19:38:52
Wohnort: Hyperion
Kontaktdaten:

Re: Connection refused (Xorg) unter Buster?

Beitrag von MartinV » 11.07.2019 22:11:31

Code: Alles auswählen

 dpkg -l | grep nvidia
Das sollte gehen, wenn Du den NVIDIA-Treiber vorher über diePaketverwaltung installiert hast.
Es geht so nicht,falls Du stattdessen irgendein Installationsskript von NVIDIAverwendet hast.

Code: Alles auswählen

 lsmod pipe grep nouveau
Könnte gehen. Ansonsten wie oben:

Code: Alles auswählen

 dpkg -l | grep noveau
Was bekommst Du für Ergebnisse? Hast Du xorg.conf schon umbenannt?
Die Vernunft kann einem schon leidtun. Sie verliert eigentlich immer.

Antworten