Debian 11 auf Gnome 3 .38 auf Gnome 40 -> zurückgehaltene Pakete

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
congomonster
Beiträge: 16
Registriert: 08.05.2016 09:10:52

Debian 11 auf Gnome 3 .38 auf Gnome 40 -> zurückgehaltene Pakete

Beitrag von congomonster » 14.09.2021 11:12:46

Hallo,

anscheinend habe ich es geschafft und Debian "gebraked". Ich habe ziemlich viel "herumgespielt" mit verschiedenen Desktop Umgebungen.
Mal KDE installiert und mal XFCE. Nun bin ich wider bei Gnome gelandet. Evolution will nicht mehr starten aber sonst scheint soweit alles in Ordnung.
Ich habe die Pakete von KDE und XFCE wieder entfernt. Eventuell dann zu gründlich...

Nun wollte ich mal Gnome 40 aus experimentel installieren. Leider bekomme ich dann die Meldung:

Code: Alles auswählen

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 gnome-applets : Hängt ab von: libgnome-panel0 (>= 3.41.1) aber 3.38.0-1+b1 soll installiert werden
                 Hängt ab von: libgweather-3-16 (>= 40.0) aber 3.36.1-3 soll installiert werden
                 Hängt ab von: libtracker-sparql-3.0-0 (>= 3.1.1) ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
In Synaptic bin ich auch mal auf "defekte Pakete reparieren" gegangen. Leider passiert da nicht mehr viel.
Wie kann ich dem System den jetzt sagen das ich Gnome 40 installieren will?

Meine /etc/apt/sources.list schaut so aus:

Code: Alles auswählen

deb http://deb.debian.org/debian bullseye main contrib non-free
deb-src http://deb.debian.org/debian bullseye main contrib non-free

deb http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
deb-src http://deb.debian.org/debian-security/ bullseye-security main contrib non-free

deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free

deb http://deb.debian.org/debian bullseye-backports main contrib non-free
deb-src http://deb.debian.org/debian bullseye-backports main contrib non-free

deb http://deb.debian.org/debian experimental main
Das System war ursprünglich ein debian 10 welches ich auf Version 11 upgegraded habe. Vielleicht ist da etwas falsch?

Benutzeravatar
niemand
Beiträge: 15008
Registriert: 18.07.2004 16:43:29

Re: Debian 11 auf Gnome 3 .38 auf Gnome 40 -> zurückgehaltene Pakete

Beitrag von niemand » 14.09.2021 12:40:08

Dir ist bewusst, dass du unter Umständen eine Mischung aus Oldstable, Stable und Experimental hast? Wenn da kein Pinning stattfand, dürfte da ein wenig mehr im Argen liegen – dein Debian wäre in dem Fall tatsächlich kaputt („broken“), nicht nur gebremst („braked“).
„The wise man doesn't give the right answers, he poses the right questions.“ (C. Levi-Strauss – gefunden im Manual des Apachen)

non serviam.

Benutzeravatar
congomonster
Beiträge: 16
Registriert: 08.05.2016 09:10:52

Re: Debian 11 auf Gnome 3 .38 auf Gnome 40 -> zurückgehaltene Pakete

Beitrag von congomonster » 14.09.2021 18:57:11

Okay, nein das weiß ich nicht. Ich bin damals so vorgegangen wie ich das im Internet gelesen habe. Dann werde ich Mal danach schauen! Danke für deine Antwort! :THX:

Benutzeravatar
congomonster
Beiträge: 16
Registriert: 08.05.2016 09:10:52

Re: Debian 11 auf Gnome 3 .38 auf Gnome 40 -> zurückgehaltene Pakete

Beitrag von congomonster » 14.09.2021 21:23:38

Ich habe die sources.list überarbeitet und nun steht nur noch folgendes drin:

Code: Alles auswählen

deb http://deb.debian.org/debian bullseye main contrib non-free
deb-src http://deb.debian.org/debian bullseye main contrib non-free

deb http://security.debian.org/debian-security bullseye-security main contrib n>
deb-src  http://security.debian.org/debian-security bullseye-security main cont>

deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free
Anscheinend geht es nicht experimental zu aktivieren ohne testing. Von daher ist es erstmal erledigt.

mcb
Beiträge: 1220
Registriert: 25.06.2020 17:28:49

Re: Debian 11 auf Gnome 3 .38 auf Gnome 40 -> zurückgehaltene Pakete

Beitrag von mcb » 14.09.2021 23:12:43

congomonster hat geschrieben: ↑ zum Beitrag ↑
14.09.2021 21:23:38
Ich habe die sources.list überarbeitet und nun steht nur noch folgendes drin:

Code: Alles auswählen

deb http://deb.debian.org/debian bullseye main contrib non-free
deb-src http://deb.debian.org/debian bullseye main contrib non-free

deb http://security.debian.org/debian-security bullseye-security main contrib n>
deb-src  http://security.debian.org/debian-security bullseye-security main cont>

deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free
Anscheinend geht es nicht experimental zu aktivieren ohne testing. Von daher ist es erstmal erledigt.
Du müßtest sid und experimental einbinden. Den Pin von Unstable / Sid auf jeden Fall runtersetzen < 100.

Gesund ist der Umbau ehr nicht.

Code: Alles auswählen

apt policy libgnome-panel0 libgweather-3-16 libtracker-sparql-3.0-0 
libgnome-panel0:
  Installed: (none)
  Candidate: 3.38.0-1+b1
  Version table:
     3.41.2-2 -1
         -1 https://deb.debian.org/debian experimental/main amd64 Packages
     3.40.0-2 1
          1 https://deb.debian.org/debian unstable/main amd64 Packages
     3.38.0-1+b1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
libgweather-3-16:
  Installed: 3.36.1-3
  Candidate: 3.36.1-3
  Version table:
     40.0-3 -1
         -1 https://deb.debian.org/debian experimental/main amd64 Packages
 *** 3.36.1-3 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
          1 https://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libtracker-sparql-3.0-0:
  Installed: (none)
  Candidate: 3.1.2-1
  Version table:
     3.1.2-1 1
          1 https://deb.debian.org/debian unstable/main amd64 Packages

Antworten