[gelöst] Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
Filshart
Beiträge: 139
Registriert: 11.12.2010 17:05:07

[gelöst] Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

Beitrag von Filshart » 09.11.2011 12:32:40

Hallo

Nach dem hinzufügen der restlichen Wheezy-Quellen, der Installation von gnome sowie nvidia-glx nvidia-settings nvidia-xconfig und ausführen von nvidia-xconfig kann ich keine grafische Oberfläche mehr starten. startx gibt es anscheinend auch nicht mehr? Habe ich vergessen was zu konfigurieren?
Zuletzt geändert von Filshart am 17.12.2011 12:56:11, insgesamt 1-mal geändert.

mister
Beiträge: 6
Registriert: 27.06.2011 00:25:59

Re: Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

Beitrag von mister » 09.11.2011 21:45:31

Möglicherweise musst du den nouveau Grafiktreiber deaktivieren?
eine Datei /etc/modprobe.d/nouveau-kms.conf mit folgendem Inhalt erstellen:

Code: Alles auswählen

blacklist nouveau
options nouveau modeset=0
Dann rebooten.

Falls das nicht hilft bzw, du das schon gemacht hast, hier gibt es etliche Threads mit ähnlicher Fragestellung. Vielleicht hilft dir die Suchfunktion auch weiter.

Benutzeravatar
niemand
Beiträge: 10309
Registriert: 18.07.2004 16:43:29

Re: Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

Beitrag von niemand » 09.11.2011 22:36:14

startx gibt es anscheinend auch nicht mehr?
Möglicherweise möchtest du Debianxinit installieren?

cu,
niemand
Du möchtest schnell und unkompliziert auf meine Ignore-Liste? Schreibe einfach „Gesendet von meinem … mit Tapatalk“ unter deinen Beitrag, oder poste Textausgaben als Bild
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

Benutzeravatar
Filshart
Beiträge: 139
Registriert: 11.12.2010 17:05:07

Re: Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

Beitrag von Filshart » 10.11.2011 09:46:38

Danke, durch die Installation von xinit kann ich nun immerhin versuchen den X-Server zu starten und die Log zu sehen:

Code: Alles auswählen

[   268.601] (II) LoadModule: "glx"
[   268.601] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[   270.637] (II) Module glx: vendor="NVIDIA Corporation"
[   270.637] 	compiled for 4.0.2, module version = 1.0.0
[   270.637] 	Module class: X.Org Server Extension
[   270.637] (II) NVIDIA GLX Module  275.28  Wed Aug 31 18:45:27 PDT 2011
[   270.637] (II) Loading extension GLX
[   270.637] (II) LoadModule: "record"
[   270.637] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   270.638] (II) Module record: vendor="X.Org Foundation"
[   270.638] 	compiled for 1.11.1.901, module version = 1.13.0
[   270.638] 	Module class: X.Org Server Extension
[   270.638] 	ABI class: X.Org Server Extension, version 6.0
[   270.638] (II) Loading extension RECORD
[   270.638] (II) LoadModule: "dri"
[   270.638] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   270.638] (II) Module dri: vendor="X.Org Foundation"
[   270.638] 	compiled for 1.11.1.901, module version = 1.0.0
[   270.638] 	ABI class: X.Org Server Extension, version 6.0
[   270.638] (II) Loading extension XFree86-DRI
[   270.638] (II) LoadModule: "dri2"
[   270.638] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   270.638] (II) Module dri2: vendor="X.Org Foundation"
[   270.638] 	compiled for 1.11.1.901, module version = 1.2.0
[   270.638] 	ABI class: X.Org Server Extension, version 6.0
[   270.638] (II) Loading extension DRI2
[   270.638] (II) LoadModule: "nvidia"
[   270.638] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   270.639] (II) Module nvidia: vendor="NVIDIA Corporation"
[   270.639] 	compiled for 4.0.2, module version = 1.0.0
[   270.639] 	Module class: X.Org Video Driver
[   270.920] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[   270.920] (EE) NVIDIA:     system's kernel log for additional error messages.
[   270.920] (II) UnloadModule: "nvidia"
[   270.920] (II) Unloading nvidia
[   270.920] (EE) Failed to load module "nvidia" (module-specific error, 0)
[   270.920] (EE) No drivers available.
[   270.920] 
Fatal server error:
[   270.920] no screens found
[   270.920] 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   270.920] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   270.920] 
Im Syslog habe ich noch das gefunden:

Code: Alles auswählen

Nov  9 22:55:20 esprimo gdm3[1169]: WARNING: GdmDisplay: display lasted 2,879033 seconds
Nov  9 22:55:25 esprimo rsyslogd-2177: imuxsock lost 204 messages from pid 1177 due to rate-limiting
:|

Benutzeravatar
niemand
Beiträge: 10309
Registriert: 18.07.2004 16:43:29

Re: Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

Beitrag von niemand » 10.11.2011 11:01:18

Welche Grafikkarte ist verbaut?

cu,
niemand
Du möchtest schnell und unkompliziert auf meine Ignore-Liste? Schreibe einfach „Gesendet von meinem … mit Tapatalk“ unter deinen Beitrag, oder poste Textausgaben als Bild
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

Benutzeravatar
Filshart
Beiträge: 139
Registriert: 11.12.2010 17:05:07

Re: Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

Beitrag von Filshart » 28.11.2011 19:59:57

Eine N8400GS D512H MSI NVIDIA.

Bei einer neuen Installation hat es nun direkt funktioniert.

Nun wollte ich bei einem anderen Rechner mit der gleichen Grafikkarte auch Debian installieren, bin aber auch schon wieder eine Stunde an der Grafik und exakt das selbe Problem?

Nun habe ich aber bei der Installation mal genauer hin geschaut, das Problem scheint wohl folgendes zu sein:

Code: Alles auswählen

Entpacken von nvidia-xconfig (aus .../nvidia-xconfig_280.13-1_amd64.deb) ...
Trigger für nvidia-alternative werden verarbeitet ...
update-alternatives: Warnung: Neuinstallation der Alternative /usr/lib/nvidia/current ist erzwungen, weil Linkgruppe nvidia defekt ist.
Trigger für menu werden verarbeitet ...
Trigger für man-db werden verarbeitet ...
Trigger für desktop-file-utils werden verarbeitet ...
Trigger für gnome-menus werden verarbeitet ...
Trigger für glx-alternative-nvidia werden verarbeitet ...
update-alternatives: Warnung: Neuinstallation der Alternative /usr/lib/nvidia ist erzwungen, weil Linkgruppe glx defekt ist.
nvidia-glx (280.13.really.275.36-1) wird eingerichtet ...
Keine Umleitung »Umleitung von /usr/lib/xorg/modules/extensions/libGLcore.so zu /usr/lib/nvidia/libGLcore.so.xlibmesa durch nvidia-glx«, keine entfernt.
Keine Umleitung »Umleitung von /usr/lib/xorg/modules/extensions/libGLcore.a zu /usr/lib/nvidia/libGLcore.a.xlibmesa durch nvidia-glx«, keine entfernt.
Keine Umleitung »Umleitung von /usr/lib/xorg/modules/extensions/libglx.a zu /usr/lib/nvidia/libglx.a.xlibmesa durch nvidia-glx«, keine entfernt.
Aber warum funktioniert es einmal und ein anders mal nicht?

Benutzeravatar
Faber38
Beiträge: 351
Registriert: 21.03.2009 23:28:20
Wohnort: Elsdorf
Kontaktdaten:

Re: Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

Beitrag von Faber38 » 28.11.2011 20:19:10

hatten wir doch schon..

1. Debian Testing installieren
2. sources.list bearbeiten
3. aptitude update
4. aptitude full-upgrade
5. apt-get install linux-image-2.6-amd64
6. Neustart
7. apt-get install linux-headers-`uname -r`
8. Neustart
9. apt-get install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig ( Nouveau wird nach einem Neustart automatisch auf die blacklist gesetzt, es ist nicht nötig es manuell zu entfernen. )
10. nvidia-xconfig -o /etc/X11/xorg.conf
11. Neustart

Benutzeravatar
Filshart
Beiträge: 139
Registriert: 11.12.2010 17:05:07

Re: Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

Beitrag von Filshart » 28.11.2011 20:27:03

Danke, habe ich gerade gefunden.

Benutzeravatar
Filshart
Beiträge: 139
Registriert: 11.12.2010 17:05:07

Re: Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

Beitrag von Filshart » 28.11.2011 20:42:35

Leider hilft das aber bei mir nicht. Bei dem anderen Rechner war das übrigens auch nicht nötig! Dort ist auch z.B. linux-image-2.6-amd64 gar nicht installiert, wohl aber Kernel 3.1

Dort hat er auch automatisch geupdated auf 3.1, bei dem anderen musste ich erst ewig hin und her probieren und erst durch deinen genannten Befehl hat er sich dann installiert.

Benutzeravatar
Filshart
Beiträge: 139
Registriert: 11.12.2010 17:05:07

Re: Debian Wheezy mit Gnome3 und Nvidia-Grafikkarte

Beitrag von Filshart » 28.11.2011 21:53:03

Das Problem war folgendes:

Bei der Installation werden 2 Kernel angeboten, der erste Eintrag hat eine Kernel Nummer und ist vorausgewählt, diesen sollte man nicht nehmen wenn man den Nvidia-Treiber ohne Probleme installieren will. Der Zweite Kernel hat keine Nummer sondern dort steht nur kernel-amd64 oder so. Es wir aber Kernel 3.1 installiert. Mit diesem Funktioniert der Nvidia-Treiber ohne Probleme!

Antworten