Lästiger Dateidialog

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
kalpaengi
Beiträge: 15
Registriert: 08.11.2011 14:17:37

Lästiger Dateidialog

Beitrag von kalpaengi » 17.05.2014 15:26:47

Ich habe ein Problem mit dem "Datei öffnen" bzw "Datei
speichern"-Dialog in einigen GUI-Programmen, wie z.B GIMP und
iceweasel.

Ich starte häufig GIMP oder iceweasel in einem Terminal. Dann
erwarte ich intuitiv, dass der "Datei öffnen"-Dialog mir die
Dateien im aktuellen Verzeichnis zeigt. Statt dessen zeigt er mir
"kürzlich geöffnete" Dateien. Daran habe ich aber noch nie
Interesse gehabt. Ich wollte eigentlich noch nie wissen, welche
Dateien ich mal vor ein paar Tagen geöffnet habe, sondern ich
will wissen, welche Dateien im aktuellen Verzeichnis vorliegen.

Genauso beim Speichern: GIMP oder iceweasel überraschen mich
immer wieder dadurch, dass sie nicht ins aktuelle Verzeichnis
speichern, sondern irgendwoanders hin, was mich dazu zwingt,
den Dialog nochmals zu öffnen und zu untersuchen, wohin das
Programm die Dateien denn diesmal wieder geschickt haben
könnte.

Manchmal zwingt mich der Dateidialog des GIMP, mich durch mehrere
subdirectories hindurchzuklicken, wenn ich die gerade bearbeitete
Datei ins aktuelle Verzeichnis abspeichern will. Das wird bei
mehreren Dateien, die ich bearbeiten will, ziemlich schnell
ziemlich lästig.

Wie kann man dieses lästige Verhalten abschalten? Gibt es
vielleicht ein Möglichkeit, dem GIMP und dem iceweasel die
Nutzung anderer Dateidialoge vorzuschreiben (Debian stable).

Benutzeravatar
MrGerardCruiz
Beiträge: 905
Registriert: 21.08.2013 12:19:35
Lizenz eigener Beiträge: MIT Lizenz
Kontaktdaten:

Re: Lästiger Dateidialog

Beitrag von MrGerardCruiz » 17.05.2014 16:14:08

Das ist Gnome, die wissen immer besser was du wirklich brauchst. :wink:
http://www.curius.de - Ein paar pragmatische Gedanken zu Linux, KDE und Datenschutz

Benutzeravatar
peschmae
Beiträge: 4844
Registriert: 07.01.2003 12:50:33
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: nirgendwo im irgendwo

Re: Lästiger Dateidialog

Beitrag von peschmae » 17.05.2014 17:39:40

Ich bin nicht so der Gnome-Spezialist. Es gibt da schon ein passendes Setting im Debiandconf-editor unter org/gtk/settings/file-chooser/startup-mode. Scheint aber bei mir zumindest nichts zu bewirken...

MfG Peschmä
"er hätte nicht in die usa ziehen dürfen - die versauen alles" -- Snoopy

Benutzeravatar
smutbert
Beiträge: 7611
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Lästiger Dateidialog

Beitrag von smutbert » 17.05.2014 17:56:32

ist das nicht ein Feature von Debianzeitgeist? zumindest meine ich, dass es diesen „virtuellen Ordner“ der zuletzt verwendeten Dateien auf einer Installation ohne zeitgeist nicht gegeben hat.

cronoik
Beiträge: 2030
Registriert: 18.03.2012 21:13:42
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Lästiger Dateidialog

Beitrag von cronoik » 17.05.2014 18:46:34

Die Dateien werden wohl von gtk geschrieben in .local/share/.recently-used.xbel [1]. Eine richtige Lösung habe ich leider auch nicht. Zumindest für Iceweasel, könnte man dass auf das Verzeichnis der zuletzt geöffneten Datei umleiten mit browser.open.lastDir.

[1] http://www.howtogeek.com/howto/16230/wh ... -for-good/

--- Edit: Gerade gefunden, vielleicht ist das brauchbar: http://askubuntu.com/questions/63202/ca ... ser-dialog ?
Zuletzt geändert von cronoik am 17.05.2014 18:52:40, insgesamt 1-mal geändert.
Hilf mit unser Wiki zu verbessern!

Benutzeravatar
smutbert
Beiträge: 7611
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Lästiger Dateidialog

Beitrag von smutbert » 17.05.2014 20:00:23

Für gtk2-Anwendungen habe ich gerade noch etwas anderes gefunden

Code: Alles auswählen

$ cat ~/.config/gtk-2.0/gtkfilechooser.ini
[Filechooser Settings]
LocationMode=path-bar
ShowHidden=false
ShowSizeColumn=true
GeometryX=770
GeometryY=407
GeometryWidth=616
GeometryHeight=450
SortColumn=name
SortOrder=ascending
StartupMode=recent
die letzte Zeile ist wohl dafür verantwortlich, dass standardmäßig beim Erscheinen des Dialogs die zuletzt geöffneten Dateien ausgewählt sind, welchen Wert man dem StartupMode sonst zuweisen könnte, habe ich aber nicht herausgefunden.

Benutzeravatar
peschmae
Beiträge: 4844
Registriert: 07.01.2003 12:50:33
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: nirgendwo im irgendwo

Re: Lästiger Dateidialog

Beitrag von peschmae » 17.05.2014 23:14:51

Versuch mal cwd (wie in current working directory), das ist zumindest bei dem entsprechenden dconfig-Schlüssel die Alternative

MfG Peschmä
"er hätte nicht in die usa ziehen dürfen - die versauen alles" -- Snoopy

kalpaengi
Beiträge: 15
Registriert: 08.11.2011 14:17:37

Re: Lästiger Dateidialog

Beitrag von kalpaengi » 18.05.2014 07:56:52

Vielen Dank für all die ausführlichen Antworten. Jedoch:

locate gktfilechooser

ergab bei mir leider keinen Treffer.

Immerhin hatte ich damit ein neues Stichwort, um google zu füttern, und siehe da: es gibt tatsächlich bereits einen Bug-Report, der genau mein Problem anspricht:

https://bugs.debian.org/cgi-bin/bugrepo ... bug=688120

Der Bugreport ist vom September 2012. Sicher gibt es jetzt recht bald eine Lösung
:-)

Benutzeravatar
CH777
Beiträge: 1379
Registriert: 27.05.2008 16:37:17

Re: Lästiger Dateidialog

Beitrag von CH777 » 18.05.2014 10:48:31

Das ist ein "Feature" von gtk3 und lässt sich nicht konfigurieren. Die Entwickler haben bereits mehrfach entschieden abgelehnt, etwas daran zu ändern.

Benutzeravatar
smutbert
Beiträge: 7611
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Lästiger Dateidialog

Beitrag von smutbert » 18.05.2014 11:40:26

Hm, gimp verwendet aber gtk2 und da sollte die gepostete ~/.config/gtk-2.0/gtkfilechooser.ini, wie peschmae geschrieben hat, mit cwd statt recent Abhilfe schaffen. Wenn sie nicht vorhanden ist, also einfach anlegen und

Code: Alles auswählen

[Filechooser Settings]
LocationMode=path-bar
ShowHidden=false
ShowSizeColumn=true
GeometryX=770
GeometryY=407
GeometryWidth=616
GeometryHeight=450
SortColumn=name
SortOrder=ascending
StartupMode=cwd
hineinschreiben.

Jedenfalls sollte man bei gtk2 (im Gegensatz zu gtk3) das Verhalten so einstellen können wie man es möchte.

kalpaengi
Beiträge: 15
Registriert: 08.11.2011 14:17:37

Re: Lästiger Dateidialog

Beitrag von kalpaengi » 18.05.2014 12:23:29

@peschmae, @smutbert. Vielen Dank für eure Hinweise.

Ich habe jetzt die Datei ~/.config/gtk-2.0/gtkfilechooser.ini angelegt, und, wie
vorgeschlagen, die Einstellung "StartupMode=cwd" am Ende der Datei vorgenommen. Leider ohne Auswirkungen. Ich sehe nach wie vor die "zuletzt verwendeten" Dateien.

Immerhin habe ich jetzt beim Herumprobieren eine Ersatzlösung für den GIMP gefunden. Man darf nicht einfach nur den "gimp" im Terminal aufrufen, sondern man muss einen Dateinamen im aktuellen Verzeichnis als Argument auf der Kommandozeile mitgeben. Also:

$>gimp & # falsch
$>gimp bilddatei.jpg & # richtig

Wenn ich auf die zweite Weise eine Datei im aktuellen Verzeichnis aufrufe, dann zeigen sowohl der "Datei öffnen" wie auch der "Datei speichern"-Dialog wie gewünscht das aktuelle Verzeichnis an.

Wenn man im iceweasel eine Datei aus dem Internet herunterladen und abspeichern will, dann geht diese Lösung allerdings nicht. Aber da sollte ich mir vielleicht mal ein download-manager-addon suchen.

Benutzeravatar
smutbert
Beiträge: 7611
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Lästiger Dateidialog

Beitrag von smutbert » 18.05.2014 12:39:33

und peschmae's Variante mit dconf (dritter Post) funktioniert bei dir auch nicht?

Langsam gewinne ich nämlich den Eindruck, dass einige gtk2-Anwendungen, vielleicht abhängig von der Desktopumgebung die gtk3-Dialoge verwenden. Dann wäre es klar, dass das nichts bringt.
Aber bei mir (mate und e17) verhält sich der Datei-Öffnen-Dialog von gimp genau so wie ich es in der gtkfilechooser.ini festlege.

kalpaengi
Beiträge: 15
Registriert: 08.11.2011 14:17:37

Re: Lästiger Dateidialog

Beitrag von kalpaengi » 18.05.2014 13:12:41

@smutbert. Ich habe nach dem Vorschlag von peschmae jetzt dconf-editor aufgerufen. Im Untermenu org -> gtk -> settings -> file-chooser gibt es bei mir (Debian stable) keine
Option namens "Startup-Mode" oder so ähnlich. :-/

Benutzeravatar
smutbert
Beiträge: 7611
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Lästiger Dateidialog

Beitrag von smutbert » 18.05.2014 13:40:30

Debian stable, ach so, ich habe testing am laufen. Bei wheezy hätte ich gedacht, dass es dann viellleicht in gconf statt dconf ist → Debiangconf-editor. Allerdings habe ich dort nicht viel gefunden - am nächsten dran ist noch
desktop → gnome → interface → file_chooser_backend
was hier aber in keiner Einstellung irgendetwas an den Dialogen geändert hätte.

Antworten