[Gelöst] Fehlermeldung nach dist-upgrade

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Benutzeravatar
ottonormal
Beiträge: 2707
Registriert: 20.01.2014 22:25:29

[Gelöst] Fehlermeldung nach dist-upgrade

Beitrag von ottonormal » 09.11.2014 13:10:11

Hallo,

nach dem letzten dist-upgrade bekam ich folgende Fehlermeldung:

Code: Alles auswählen

root@debian:/home/ottonormal# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libaudio2 : Beschädigt: libaudio2:i386 (!= 1.9.4-1) aber 1.9.4-1+b1 ist installiert
 libaudio2:i386 : Beschädigt: libaudio2 (!= 1.9.4-1+b1) aber 1.9.4-1 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
root@debian:/home/ottonormal#

Nach apt-get install -f kam dann:

Code: Alles auswählen

root@debian:/home/ottonormal# apt-get install -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libaudio2
Vorgeschlagene Pakete:
  nas
Die folgenden Pakete werden aktualisiert (Upgrade):
  libaudio2
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 42 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 79,3 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 31,7 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] j
Lese Changelogs... Fertig
dpkg: Warnung: Dateilisten-Datei des Paketes »sunflower« fehlt; es wird angenommen,
 dass das Paket derzeit keine Dateien installiert hat
(Lese Datenbank ... 159877 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libaudio2_1.9.4-1+b1_amd64.deb ...
Entpacken von libaudio2:amd64 (1.9.4-1+b1) über (1.9.4-1) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libaudio2_1.9.4-1+b1_amd64.deb (--unpack):
 Versuch, gemeinsam benutztes »/usr/share/doc/libaudio2/changelog.Debian.gz« zu überschreiben, welches verschieden von anderen Instanzen des Paketes libaudio2:amd64 ist
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libaudio2_1.9.4-1+b1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@debian:/home/ottonormal#
Was kann/muss ich machen?

Gruß, ottonormal
Zuletzt geändert von ottonormal am 11.11.2014 16:05:49, insgesamt 1-mal geändert.

cronoik
Beiträge: 1794
Registriert: 18.03.2012 21:13:42
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Fehlermeldung nach dist-upgrade

Beitrag von cronoik » 09.11.2014 13:16:06

Warten Debian Bugreport768651 oder würgaround nutzen
Hilf mit unser Wiki zu verbessern!

Benutzeravatar
ottonormal
Beiträge: 2707
Registriert: 20.01.2014 22:25:29

Re: Fehlermeldung nach dist-upgrade

Beitrag von ottonormal » 09.11.2014 13:20:07

cronoik hat geschrieben:Warten Debian Bugreport768651 oder würgaround nutzen
Vielen Dank, diese Antwort hatte ich erhofft. :D
Ich war nur etwas besorgt, weil ich so etwas noch nie hatte.

Benutzeravatar
smutbert
Beiträge: 6659
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Fehlermeldung nach dist-upgrade

Beitrag von smutbert » 11.11.2014 11:48:46

Die beiden Würg-/Workarounds im Bugreport hast du gesehen?

Code: Alles auswählen

# mv /usr/share/doc/libaudio2/changelog.Debian.gz /usr/share/doc/libaudio2/changelog.Debian.i386.gz
# apt-get -f install
(oder statt umbenennen mit mv gleich mit rm löschen, bis, wenn überhaupt, man einen Blick in das Changelog werden will, ist doch eh mindestens die überübernächste Version aktuell)

Laut dem Bugreport soll es alternativ auch funktionieren sich die vorherigen Versionen von snapshot.debian.org herunterzuladen, also
- libaudio2_1.9.4-1_amd64.deb
- libaudio2_1.9.4-1_i386.deb
vom zB 10.10.2013 und (mit dpkg) zu installieren.

Oder du putzt diese merkwürdige Software (Skype? - igittigit) von der Platte, die die 32-Bit Version dieser Bibliothek erfordert :wink:

Benutzeravatar
Revod
Beiträge: 3621
Registriert: 20.06.2011 15:04:29
Lizenz eigener Beiträge: MIT Lizenz

Re: Fehlermeldung nach dist-upgrade

Beitrag von Revod » 11.11.2014 12:37:05

smutbert hat geschrieben:Oder du putzt diese merkwürdige Software (Skype? - igittigit) von der Platte, die die 32-Bit Version dieser Bibliothek erfordert :wink:
.... merkwürdige... könnte von mir stammen.... :D

Ja, ersetze es mit entweder mit Qutecom oder Jitsi, oder beides.
Systemd und PulseAudio, hmmm, nein danke.

Benutzeravatar
ottonormal
Beiträge: 2707
Registriert: 20.01.2014 22:25:29

Re: Fehlermeldung nach dist-upgrade

Beitrag von ottonormal » 11.11.2014 13:26:08

Skype habe ich garnicht installiert, trotzdem Qutecom oder Jitsi installieren?

cronoik
Beiträge: 1794
Registriert: 18.03.2012 21:13:42
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Fehlermeldung nach dist-upgrade

Beitrag von cronoik » 11.11.2014 13:38:30

Nee brauchst du nicht, das ist nur ein Skypeersatz. Aber du könntest mal schauen warum du das Paket Debianlibaudio2 überhaupt installiert hast:

Code: Alles auswählen

apt-cache rdepends libaudio2:i386
Hilf mit unser Wiki zu verbessern!

Benutzeravatar
ottonormal
Beiträge: 2707
Registriert: 20.01.2014 22:25:29

Re: Fehlermeldung nach dist-upgrade

Beitrag von ottonormal » 11.11.2014 13:48:20

Code: Alles auswählen

apt-cache rdepends libaudio2:i386
sagt:

Code: Alles auswählen

ottonormal@debian:~$ apt-cache rdepends libaudio2:i386
libaudio2:i386
Reverse Depends:
  libaudio2
  libaudio2
  xfaces:i386
  timidity:i386
  speech-dispatcher-audio-plugins:i386
  libqtgui4:i386
  nas-bin:i386
  nas:i386
  libaudio2
  libaudio2
  libaudio-dev:i386
  libao4:i386
  gbsplay:i386
  alsaplayer-nas:i386
  acm:i386
ottonormal@debian:~$ 

Benutzeravatar
smutbert
Beiträge: 6659
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Fehlermeldung nach dist-upgrade

Beitrag von smutbert » 11.11.2014 14:20:47

Da ist jetzt nichts dabei, was es nicht auch in der 64-Bit Version geben sollte. Hast du vielleicht irgendetwas am Paketverwaltungssystem vorbei installiert, wofür irgendwelche 32 Bit Bibliotheken oder dergleichen notwendig waren?

Wenn nicht, sollten dir die i386-Pakete nicht abgehen, wenn du sie deinstallierst. Bevor du das versuchst, wäre eine Liste der installierten i386-Pakete ganz interessant:

Code: Alles auswählen

# dpkg -l | grep :i386

JTH
Beiträge: 487
Registriert: 13.08.2008 17:01:41

Re: Fehlermeldung nach dist-upgrade

Beitrag von JTH » 11.11.2014 14:31:13

Führt die Ausgabe von

Code: Alles auswählen

aptitude why libaudio2:i386
nicht schneller zu dem Grund, warum das Paket installiert ist? apt-cache rdepends listet doch auch uninstallierte Pakete. Bei mir liefert das z.B.:

Code: Alles auswählen

$ aptitude why libaudio2:i386
i   skype:i386     Depends libqtgui4:i386 (>= 4:4.8.0)
i A libqtgui4:i386 Depends libaudio2:i386

Benutzeravatar
smutbert
Beiträge: 6659
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Fehlermeldung nach dist-upgrade

Beitrag von smutbert » 11.11.2014 15:26:45

Kann gut sein, aber ich habe aptitude auf meinem System deinstalliert, also kommt aptitude in meinen Posts normalerweise nicht vor :wink: und außerdem muss ein Pogramm, das 32 Bit Bibliotheken benötigt ja nicht unbedingt über apt/dpkg installiert worden sein.

Auf jeden Fall halte ich es nicht für falsch, einmal herauszufinden, welche i386-Pakete, ob sie jetzt von den Abhängigkeiten her notwendig sind oder nicht, installiert sind.

Benutzeravatar
ottonormal
Beiträge: 2707
Registriert: 20.01.2014 22:25:29

Re: Fehlermeldung nach dist-upgrade

Beitrag von ottonormal » 11.11.2014 15:27:23

Hast du vielleicht irgendetwas am Paketverwaltungssystem vorbei installiert, wofür irgendwelche 32 Bit Bibliotheken oder dergleichen notwendig waren?
Ja, das habe ich:

Code: Alles auswählen

root@debian:/home/ottonormal# aptitude why libaudio2:i386
i   cr3:i386       Hängt ab von libqtgui4:i386 (>= 4:4.5.3)
i A libqtgui4:i386 Hängt ab von libaudio2:i386             
root@debian:/home/ottonormal#
cr3 das ist der CoolReader3 (e-book reader)
ich habe versucht ihn zu deinstallieren, das will er aber nicht. Sobald ich irgendetwas installieren oder
deinstallieren will, kommt die Fehlermeldung ich soll apt-get -f install ausführen. Mache ich das, kommt
wieder die Fehlermeldung (siehe oben).

dpkg -l | grep :i386 ergibt: http://nopaste.debianforum.de/38094

Benutzeravatar
smutbert
Beiträge: 6659
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Fehlermeldung nach dist-upgrade

Beitrag von smutbert » 11.11.2014 15:32:39

Willst du den CoolReader behalten oder loswerden?

Benutzeravatar
ottonormal
Beiträge: 2707
Registriert: 20.01.2014 22:25:29

Re: Fehlermeldung nach dist-upgrade

Beitrag von ottonormal » 11.11.2014 15:35:42

smutbert hat geschrieben:Willst du den CoolReader behalten oder loswerden?
Ich brauche ihn nicht mehr unbedingt, wenn er stört, kann er gerne weg, aber wie?

Mounty
Beiträge: 194
Registriert: 05.01.2007 21:02:03
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Hamburg

Re: Fehlermeldung nach dist-upgrade

Beitrag von Mounty » 11.11.2014 15:38:57

Moin, moin!

Ich hatte gestern auch dieses Problem. Meine Lösung entspricht in etwa der Lösung von @smutbert in Beitrag 3. Naja, ich habe den --> /usr/share/doc/libaudio2/changelog.Debian.gz <-- einfach gelöscht und danach ein apt-get -f install durchgeführt. Danach war alles wieder im Lot, zumindest bei mir.

Gruß
Mounty
>> potato - woody - sarge - etch - lenny - squeeze - wheezy - jessie - stretch - [buster] --> bullseye

Antworten