Intel Skylake - noch Grafikprobleme?

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
captaincode
Beiträge: 11
Registriert: 20.10.2012 10:33:16

Intel Skylake - noch Grafikprobleme?

Beitrag von captaincode » 10.02.2016 10:24:06

Hallo zusammen,
ich habe meinen PC aufgerüstet und etwas voreilig bereits auf die Skylake Plattform gesetzt. Gestern habe ich Debian Jessie installiert und es läuft glücklicherweise sehr stabil.

Aber:
Die volle Grafik- und Audiounterstützung scheint nicht ohne weitere Anpassungen gegeben zu sein. Nun möchte ich mich erstmal mit der Grafik beschäftigen, vor allem der Dual Monitor Betrieb soll wieder funktionieren. Gnome zeigt mir aber lediglich eine Unbekannte Anzeige an und klont den ersten Monitor lediglich. Das Paket xserver-xorg-video-intel-2:2.99.917-2~bpo8+1. ist installiert.Zudem das Paket i965-va-driver-1.4.1-2.

xrandr spuckt folgendes aus:
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
1920x1080 0.00*
lspci:
00:00.0 Host bridge: Intel Corporation Device 190f (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Device 1912 (rev 06)
00:14.0 USB controller: Intel Corporation Device a12f (rev 31)
00:14.2 Signal processing controller: Intel Corporation Device a131 (rev 31)
00:16.0 Communication controller: Intel Corporation Device a13a (rev 31)
00:17.0 SATA controller: Intel Corporation Device a102 (rev 31)
00:1c.0 PCI bridge: Intel Corporation Device a114 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device a143 (rev 31)
00:1f.2 Memory controller: Intel Corporation Device a121 (rev 31)
00:1f.3 Audio device: Intel Corporation Device a170 (rev 31)
00:1f.4 SMBus: Intel Corporation Device a123 (rev 31)
Version:
Linux version 3.16.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.4 (Debian 4.8.4-1) ) #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17)
Bitte liefert mir einen Ansatz wie ich den Fehler beheben kann. Ich habe bislang über Google nur Hinweise zu xserver-xorg-video-intel in jessie-backports enthalten, aber das Paket habe ich doch laut Paketmanager bereits installiert?

PS: Prozessor ist ein i3-6100 mit der HD Graphics 530 auf einem Asrock H110M-HDV mit H110 Chipsatz.

Vielen Dank!
Zuletzt geändert von captaincode am 10.02.2016 10:48:34, insgesamt 1-mal geändert.

Benutzeravatar
hikaru
Beiträge: 11193
Registriert: 09.04.2008 12:48:59

Re: Intel Skylake - noch Grafikprobleme?

Beitrag von hikaru » 10.02.2016 10:37:03

Den Kernel aus den Backports wirst du ebenfalls brauchen.

Benutzeravatar
Patsche
Beiträge: 3250
Registriert: 21.06.2013 01:47:54
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: /home/10001101001

Re: Intel Skylake - noch Grafikprobleme?

Beitrag von Patsche » 10.02.2016 10:39:01

Gebe mal die Bootoption

Code: Alles auswählen

i915.preliminary_hw_support=1
mit. Danach sollte Grafik und Ton funktionieren.
Die Bootoption muss man mitgeben, weil Intel seinen Grafikkartentreiber nun auch teilweise verblobt hat.
hikaru hat geschrieben:Den Kernel aus den Backports wirst du ebenfalls brauchen.
Jupp.
Hilf mit unser Wiki zu verbessern! Unterstütze somit die Community, um schneller und effizienter mit dem besten Betriebssystem der Welt arbeiten zu können! Danke!
PS: Hier bekommt ihr stets das aktuelle Offline-Wiki!

captaincode
Beiträge: 11
Registriert: 20.10.2012 10:33:16

Re: Intel Skylake - noch Grafikprobleme?

Beitrag von captaincode » 10.02.2016 10:47:36

Besten Dank für eure schnellen Antworten :hail:

Bekomme ich den (fehlenden) Kernel wenn ich nach folgender Anleitung vorgehe?
https://www.slightfuture.com/how-to/deb ... l-graphics

Den Hinweis mit dem preliminary_hw_support hatte ich auch bereits gefunden, aber ich dachte dies wäre bei der aktuellen Version nicht mehr notwendig. Also sollte ich sowohl diesen Parameter setzen als auch die backports Treiber und Kernel nutzen?

PS: Bitte nicht falsch verstehen. Ich bin nicht zu faul zum selber Suchen oder ausprobieren, aber ich möchte mir das neue System nicht direkt durch eine falsche Konfiguration versauen. Habe die halbe Nacht damit verbracht die Daten und Einstellungen zu kopieren.

Edit: Den Hinweis mit alten Versionen hatte ich von Archlinux:
https://wiki.archlinux.org/index.php/in ... ke_Support

Benutzeravatar
smutbert
Beiträge: 7165
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Intel Skylake - noch Grafikprobleme?

Beitrag von smutbert » 10.02.2016 10:56:57

Nein, nach der Anleitung werden Pakete aus testing installiert, das funktioniert nur in Ausnahmesituationen und auf lange Sicht nie problemlos.
Du brauchst einfach nur die backports in der »/etc/apt/sources.list« und kannst danach den Kernel aus den Backports mit

Code: Alles auswählen

# apt update && apt install linux-image-amd64/jessie-backports
installieren. was du danach noch vielleicht noch mit einigen weiteren Paketen machen willst, zB:
- Debianlibdrm-intel1, Debianlibdrm2
- eventuell Debianintel-microcode und gegebenenfalls weitere Firmware

Ich weiß nicht ob das (alle?) deine Probleme löst, aber unter jessie ist es wohl das beste was du machen kannst - abgesehen vielleicht von einigen weiteren Paketen, die ich möglicherweise übersehen habe und die ebenfalls aus den Backports installiert werden sollten. Auf (m)einem Broadwell-System habe ich genau das gemacht, was man normalerweise eigentlich nicht machen sollte und alle installierten Pakete auf die backports aktualisiert (abgesehen von den tatsächlich notwendigen sind das so wenige, das ich keine Probleme erwartet habe und auch keine bekommen habe):

Code: Alles auswählen

# apt update && apt upgrade && apt -t jessie-backports upgrade
Bitte nicht als Empfehlung verstehen es mir nachzumachen, aber vielleicht könntest du zumindest nachsehen von welchen installierten Paketen neuere Versionen in den backports verfügbar wären

Code: Alles auswählen

# apt -s -t jessie-backports upgrade
(-s sorgt dafür, dass das update nur simuliert und nicht tatsächlich gemacht wird)

__

Ob du mit den Paketen aus den backports preliminary_hw_support noch benötigst probierst du am besten aus.

captaincode
Beiträge: 11
Registriert: 20.10.2012 10:33:16

Re: Intel Skylake - noch Grafikprobleme?

Beitrag von captaincode » 10.02.2016 11:11:21

Perfekt! Das korrekte Installieren der Backports hat bereits funktioniert. Ton und Grafik funktionieren :THX:

Vielen Dank allen Beteiligten für die schnelle und kompetente Hilfe.

captaincode
Beiträge: 11
Registriert: 20.10.2012 10:33:16

Re: Intel Skylake - noch Grafikprobleme?

Beitrag von captaincode » 12.02.2016 11:12:50

Ich muss mich korrigieren.

Habe vorhin mal in die Logs geschaut und gesehen, dass er sich über fehlende Firmware beschwert hat ("915/skl_dmc_ver1.bin"). Auch der Parameter i915.preliminary_hw_support=1 hat nichts geändert.

Daher habe ich von hier noch den neusten Treiber nachgeladen und installiert:
https://01.org/linuxgraphics/downloads/skylake-dmc-1.26

Nun ist der Fehler im Log weg und die kleinen Grafikproblemchen beim Scrollen im Browser ebenfalls.

Ich habe allerdings noch folgendes im Log:
Feb 12 11:01:53 WR7384928R kernel: WARNING: CPU: 3 PID: 6 at /build/linux-kTc2b3/linux-4.3.3/drivers/gpu/drm/i915/intel_pm.c:3668 skl_update_other_pipe_wm+0x1d5/0x1e0 [i915]()
Feb 12 11:01:53 WR7384928R kernel: WARN_ON(!wm_changed)
Feb 12 11:01:53 WR7384928R kernel: Modules linked in: intel_rapl iosf_mbi acpi_cpufreq(-) x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm mxm_wmi ghash_clmulni_intel(-) evdev snd_hda_intel(+) snd_hd
Feb 12 11:01:53 WR7384928R kernel: libata xhci_hcd scsi_mod usbcore usb_common i2c_hid hid
Feb 12 11:01:53 WR7384928R kernel: CPU: 3 PID: 6 Comm: kworker/u8:0 Not tainted 4.3.0-0.bpo.1-amd64 #1 Debian 4.3.3-7~bpo8+1
Feb 12 11:01:53 WR7384928R kernel: Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./H110M-HDV, BIOS P1.30 09/21/2015
Sollte mir dies Sorgen bereiten?

Antworten