Nach upgrade jessie --> stretch startet GDM3 nicht mehr

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
ulrich_th
Beiträge: 177
Registriert: 15.05.2003 09:30:11
Wohnort: Krefeld

Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von ulrich_th » 22.10.2017 19:08:31

Hallo,

komme leider hier nicht mehr weiter, obwohl der Fehler oft beschrieben wird.
Habe gerade auf einem Samsung NC10 ein upgrade von jessie auf stretch gemacht und nach einem Reboot bleibt der Rechner hängen bei
Started Update UTMP about System Runlevel Changes
Meist wird empfohlen den intel-Treiber neu zu installieren, wie hier https://unix.stackexchange.com/question ... el-changes.

Hat aber alles nichts gebracht :-(
Zum System:

Code: Alles auswählen

uname -r
4.9.0-4-686-pae

Code: Alles auswählen

lspci | grep VGA
VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller

Code: Alles auswählen

lspci -k
...
00:02:.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controlle
Subsystem: Samsung Electronics Co Ltd Notebook N150P
Kernel driver in use: i915
Kernel modules: i915
/var/log/Xorg.0.log bringt die Fehlermeldung:
Number of created screens does not match number of devices. Configuration failed
Vielleicht stehe ich gerade auf'm Schlauch, aber ich sehe keine created screens....
Auch nach dpkg-reconfigure -phigh xserver-xorg, steht in der /etc/X11/xorg.conf nur ein:
Section "Screen"
Identifier: "Default Screen"
Monitor: "Configured Monitor"
EndSection
Wäre schön, wenn irgendjemand helfen kann....

Ulrich

P.S.: Booten mit dem 3.16 er kernel hängt mit der gleichen Fehlermeldung

Benutzeravatar
Datenteiler
Beiträge: 84
Registriert: 12.10.2008 21:01:46
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Hannover
Kontaktdaten:

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von Datenteiler » 22.10.2017 21:07:19

Hi,

hilft dir evtl. der folgende Kernel-Parameter

Code: Alles auswählen

GRUB_CMDLINE_LINUX_DEFAULT="video=SVIDEO-1:d"
in

Code: Alles auswählen

/etc/default/grub
mit anschließendem

Code: Alles auswählen

grub-mkconfig -o /boot/grub/grub.cfg
Befehl?

https://wiki.archlinux.org/index.php/intel_graphics

Viele Grüße
Christian

Benutzeravatar
Datenteiler
Beiträge: 84
Registriert: 12.10.2008 21:01:46
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Hannover
Kontaktdaten:

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von Datenteiler » 22.10.2017 21:29:53

Ein zweite Sache, die ich evtl. noch ausprobieren würde:

https://axebase.net/blog/2016/06/19/uxa-statt-sna/

Die Datei "/usr/share/X11/xorg.conf.d/20-intel.conf" mit folgendem Inhalt anlegen:

Code: Alles auswählen

Section "Device"
	Identifier	"Intel Graphics"
	Driver		"i915"
	Option		"AccelMethod"  "uxa"
EndSection

ulrich_th
Beiträge: 177
Registriert: 15.05.2003 09:30:11
Wohnort: Krefeld

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von ulrich_th » 22.10.2017 22:34:34

Danke für Deine beiden Tipps. Ich habe beide unabhängig voneinander probiert, leider hat es nichts gebracht :-(
Das video=SVIDEO-1:d ist in der grub.cfg "angekommen" aber auch nach Neustart, die gleiche Fehlermeldung in /var/log/Xorg.0.log.

Ich habe auch zwischendurch den vesa-Treiber probiert, hat aber nur dazu geführt, dass die Versuche, den X-server zu starten sich gar nicht mehr abbrechen ließen.

Ich habe im Moment keine Idee mehr (und leider ein paar Stunden verloren heute), geht morgen wieder weiter.
Was vielleicht noch hilft ?? ist: Wenn ich ein X -configure mache wird die aktuelle Konfiguration ja in die /root/xorg.conf.new geschrieben (wenn ich das richtig verstehe...). Da findet sich dann
Eine Section "Device" mit Card0 und BusID PCI:0:2:0 und eine weitere mit Card1 und BusID:0:2:1
Eine Section "Screen" mit Screen0, Card0, Monitor0 und eine mit Screen1, Card1, Monitor1

Da Ding ist aber nur ein Netbook ohne zweiten Monitor. :?

ulrich_th
Beiträge: 177
Registriert: 15.05.2003 09:30:11
Wohnort: Krefeld

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von ulrich_th » 23.10.2017 20:55:05

kleines update, aber es geht in Richtung "versuchen"...
Irgendwo stand, dass der Treiber i915kms sein sollte (und nicht i915) und auch wenn das in dem Fall nicht Debian war, habe ich i915kms und drm2 mal in die /etc/modules geschrieben - die Module gibt es aber nicht.

Nach einem apt-get purge xserver-xorg-video-intel hatte ich gedacht, dass er mit vesa o.ä. weitermacht - auch nix und war etwas überrascht, dass ein lsmod, dass modul i915 immer noch als geladen anzeigt. Ich glaube, ich hatte mit dem Paket xserver-xorg-video-intel an der falschen Stelle gesucht. In der Beschreibung des Pakets steht:
The use of this driver is discouraged if your hw is new enough (ca. 2007 and newer). You can try uninstalling this driver and let the server use it's builtin modesetting driver instead.
ok, ich habe es also "gepurgt", der Treiber i915 wird immer noch geladen und ich bin kein Stück weiter.

Noch jemand eine Idee? Irgendwann brauche ich den Rechner doch schon wieder....

Mentore
Beiträge: 51
Registriert: 09.10.2007 20:42:38
Wohnort: berlin

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von Mentore » 24.10.2017 00:06:10

Ich hab leider keine ahnung sorry, haenge aber auch an einen aehnlichen problem

wenn du langeweile hast kannst du mal folgendes ausprobieren
Driver "fbdev"

bei mir startet dann immerhin x

ulrich_th
Beiträge: 177
Registriert: 15.05.2003 09:30:11
Wohnort: Krefeld

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von ulrich_th » 24.10.2017 10:44:26

Danke trotzdem. Ich kriege das modul aber nicht mal geladen :cry:
Ich habe in meiner /usr/share/X11/xorg.conf.d/ die Datei 20-intel.conf angelegt mit

Code: Alles auswählen

Section "Device"
     Identifier "Card0"
     Driver "fbdev"
EndSection
Section "Device"
     Identifier "Card1"
     Driver "fbdev"
EndSection
Card0 und Card1 stand nach einem X -configure in der /root/xorg.conf.new (so wie ich das verstanden habe wird da die aktuelle Konfiguration abgelegt).
Ich habe aber auch mit "Configured Video Device" etc. versucht, habe an der Stelle auch den Driver vesa mal probiert, es kommt bei lsmod | grep video aber immer
...
video 36864 2 samsung_laptop, i915
....
Als ich den xserver-xorg-video-intel ge"purged" hatte, dann ein X -configure gemacht, stand danach in der /root/xorg.conf.new bei Device "Card0" ein "vesa". Die /var/log/Xorg.0.log hat noch etwas von vesa und falling back.... etc., geschrieben, aber danach die gleiche Fehlermeldung "Number of created screens does not match number of detected devices".

Wenn xserver-xorg-video-intel installiert is steht nach X -configure als Treiber bei Card0 und Card1 "intel" - ich bin ja schon mal froh, dass ich überhaupt etwas nachvollziehbares sehe.

Es scheint also mit Treiber "vesa" und "intel" keinen Unterschied zu geben und ich muss irgendwie der Fehlermeldung auf den Grund gehen. Das ist ja zumindest der Grund für den Abbruch.
Muss jetzt nur noch herauskriegen, warum meine /usr/share/X11/xorg.conf.d/ die Datei 20-intel.conf ignoriert wird (an den Rechten liegt es nicht) und dann mit der X confi "spielen".

Ulrich

Mentore
Beiträge: 51
Registriert: 09.10.2007 20:42:38
Wohnort: berlin

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von Mentore » 24.10.2017 17:40:53

kannst du mir mal bitte deine komplette /etc/X11/xorg.conf posten :?
wenn er es unter /usr/sha.. nicht nimmt wuerd ich es mal loeschen
und nach dem backup der xorg.conf auch da alles rausloeschen
und nur eine minimale anlegen xorg nimmt sind dann was es findet...
die aufloesung noch anpassen

Code: Alles auswählen

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen         "Default Screen"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device" 
    Identifier "Card0"
    Driver "intel" 
    Option "AccelMethod" "sna" 
EndSection

Section "Screen"
	Identifier "Default Screen"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Modes	"1536x2048"
		Depth     16
	EndSubSection
	SubSection "Display"
		Modes "1536x2048"
		Depth     24
	EndSubSection
EndSection

ulrich_th
Beiträge: 177
Registriert: 15.05.2003 09:30:11
Wohnort: Krefeld

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von ulrich_th » 24.10.2017 20:12:22

Die /etc/X11/xorg.conf gibt es nicht, die wird ja wohl auch nicht mehr gebraucht, weil er selbst ermittelt und den Rest aus /usr/share/X11/xorg.conf.d/ holt (oder?).

Was ich aber gemacht hab ist ein X -configure (auch wenn das abstürzt). Das jedenfalls erzeugt die /root/xorg.conf.new, das soll doch das Backup der bestehenden Konfiguration sein.

Die liegt hier: http://nopaste.debianforum.de/40026
Vielleicht das "bereinigen" und als /etc/X11/xorg.conf kopieren?

Ulrich

Benutzeravatar
Datenteiler
Beiträge: 84
Registriert: 12.10.2008 21:01:46
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Hannover
Kontaktdaten:

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von Datenteiler » 24.10.2017 22:35:44

Hast du schon versucht, die Datei

Code: Alles auswählen

~/.Xauthority
zu löschen/umzubenennen? Vielleicht liegt dort an den Rechten oder den Session-Cookies das Problem, dass GDM nicht mehr starten will.

Viele Grüße
Christian

ulrich_th
Beiträge: 177
Registriert: 15.05.2003 09:30:11
Wohnort: Krefeld

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von ulrich_th » 24.10.2017 23:12:34

Ja, hatte ich auch irgendwo gelesen.
Die Datei gibt es gar nicht.

Benutzeravatar
Datenteiler
Beiträge: 84
Registriert: 12.10.2008 21:01:46
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Hannover
Kontaktdaten:

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von Datenteiler » 24.10.2017 23:31:05

Ich sag's ungern, aber vielleicht kommst du mit einer Neuinstallation schneller zum Ziel, wieder ein funktionierendes Netbook zu haben? Ich habe das N145 mit ähnlicher Hardware und Stretch läuft super. Allerdings habe ich eine SSD eingebaut und daher neu installiert und kein Dist-Upgrade gemacht.

ulrich_th
Beiträge: 177
Registriert: 15.05.2003 09:30:11
Wohnort: Krefeld

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von ulrich_th » 24.10.2017 23:42:37

Einerseits ja, aber ich würde natürlich gerne wissen, woran es liegt. Das insbesondere auch, weil das Netbook so'n Spielzeug ist, auf dass ich nicht wirklich angewiesen bin. Danach kommt mein eigentlicher PC dran von Jessie nach Stretch..... nur im Moment traue ich mich das nicht mehr 8O
Muss mal d'rüber nachdenken.....

Benutzeravatar
Datenteiler
Beiträge: 84
Registriert: 12.10.2008 21:01:46
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Hannover
Kontaktdaten:

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von Datenteiler » 25.10.2017 11:13:53

Du schreibst am Anfang "GDM3", hast du ein Gnome auf dem Netbook laufen?

Ich habe im Kali-Forum noch etwas gefunden:
What I did was the following:

use alt+f2 and login into a separate terminal session

remove gnome with

Code: Alles auswählen

sudo apt-get autoremove gnome-core gnome-shell gnome-session
reinstall it

Code: Alles auswählen

sudo apt-get install gnome-core gnome-shell gnome-session
reboot

for me this worked...
Vorher würde ich noch alle Änderungen, die du gemacht hast, die aber keine Besserung gebracht haben, Rückgängig machen.

ulrich_th
Beiträge: 177
Registriert: 15.05.2003 09:30:11
Wohnort: Krefeld

Re: Nach upgrade jessie --> stretch startet GDM3 nicht mehr

Beitrag von ulrich_th » 25.10.2017 21:44:32

Danke für die Tipps. Rückgängig machen, was ich erfolglos versucht habe ist eh klar....

Statt komplett neu aufsetzen, habe ich jetzt alles heruntergeworfen, was nach X ausssieht:

Code: Alles auswählen

aptitude purge xserver-xorg lxde-core lxde-common openbox openbox-lxde-session gdm3 xorg-common ....
 
Ach ja, ich habe openbox und lxde, kein Gnome. Mit den ganzen Abhängigkeiten war ich damit ca. 400 MB los.
Danach fast komplett aufgeräumt in den obsolete und locally created packages, danach nochmal ein apt-get autoremove.
Neustart einloggen auf Konsole, nichts auffälliges, dann:

Code: Alles auswählen

apt-get install gdm3 xorg lxdecore
Nochmal Neustart und alles wie gehabt. Ich glaube jetzt auch nicht mehr, dass ein komplett Neuaufsetzen noch mehr bringt.
Habe jetzt keine Idee mehr...
und mache erstmal Pause, genug Zeit verloren...

Falls noch jemand "Langeweile" hat, diese ist die /var/log/Xorg.0.log komplett: http://nopaste.debianforum.de/40027

Antworten