X server died during startup

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
vdvogt
Beiträge: 251
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

X server died during startup

Beitrag von vdvogt » 29.01.2018 17:29:01

Hallo,
seit einem der letzten Updates habe ich ein Problem mit KDE.

Ich nutze Debian 9 mit allen aktuellen Updates (unattended-upgrades laeuft bei mir) und KDE als GUI.

Seitdem habe ich keine grafische Benutzeroberflaeche mehr.
Ich habe schon einiges ausprobiert, allerdings alles ohne Erfolg.

ein systemctl status kdm
ergibt folgende Ausgabe:

Code: Alles auswählen

kdm.service - LSB: X display manager for KDE
   Loaded: loaded (/etc/init.d/kdm; generated; vendor preset: enabled)
   Active: active (running) since Mon 2018-01-29 16:17:12 UTC; 4min 22s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 2005 ExecStop=/etc/init.d/kdm stop (code=exited, status=0/SUCCESS)
  Process: 2061 ExecStart=/etc/init.d/kdm start (code=exited, status=0/SUCCESS)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/kdm.service
           └─2071 /usr/bin/kdm -config /var/run/kdm/kdmrc

Jan 29 16:17:12 AFX-435 systemd[1]: Starting LSB: X display manager for KDE...
Jan 29 16:17:12 AFX-435 kdm[2061]: Starting K Display Manager: kdm.
Jan 29 16:17:12 AFX-435 systemd[1]: Started LSB: X display manager for KDE.
Jan 29 16:17:12 AFX-435 kdm[2071]: X server died during startup
Jan 29 16:17:12 AFX-435 kdm[2071]: X server for display :0 cannot be started, session disabled
Hat jemand einen Rat fuer mich wie ich das beheben kann?
Vielen Dank im Voraus!

Gruesse
Veit

Benutzeravatar
niemand
Beiträge: 11181
Registriert: 18.07.2004 16:43:29

Re: X server died during startup

Beitrag von niemand » 29.01.2018 17:30:58

Du könntest zunächst im Log von X selbst schauen, ob dort ein Hinweis auf den Fehler zu finden ist.
Du möchtest schnell und unkompliziert auf meine Ignore-Liste? Schreibe einfach „Gesendet von meinem … mit Tapatalk“ unter deinen Beitrag, oder poste Textausgaben als Bild
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

RobertS
Beiträge: 279
Registriert: 15.04.2012 13:50:53
Wohnort: Rastatt BaWü

Re: X server died during startup

Beitrag von RobertS » 29.01.2018 17:44:44

Brauchts kdm überhaupt noch?
Hat nicht sddm den Job übertragen bekommen?

vdvogt
Beiträge: 251
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: X server died during startup

Beitrag von vdvogt » 30.01.2018 18:57:08

Hallo,
das Xorg.0.log ist recht lang.
Nach was soll ich filtern?

Ich habe aber folgendes gefunden:

Code: Alles auswählen

[   986.526] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[   986.526] (EE) NVIDIA:     system's kernel log for additional error messages and
[   986.526] (EE) NVIDIA:     consult the NVIDIA README for details.
[   986.526] (EE) [drm] Failed to open DRM device for (null): -22
[   986.526] (EE) [drm] Failed to open DRM device for (null): -22
[   986.526] (EE) [drm] Failed to open DRM device for (null): -22
[   986.526] (EE) [drm] Failed to open DRM device for pci:0000:03:00.0: -22
[   986.527] (EE) [drm] Failed to open DRM device for pci:0000:03:00.0: -22
[   986.527] (WW) Falling back to old probe method for modesetting
[   986.527] (II) Loading sub module "fbdevhw"
[   986.527] (II) LoadModule: "fbdevhw"
[   986.527] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   986.527] (II) Module fbdevhw: vendor="X.Org Foundation"
[   986.527]    compiled for 1.19.2, module version = 0.0.2
[   986.527]    ABI class: X.Org Video Driver, version 23.0
[   986.527] (EE) open /dev/fb0: No such file or directory
[   986.527] (WW) Falling back to old probe method for fbdev
[   986.527] (II) Loading sub module "fbdevhw"
[   986.527] (II) LoadModule: "fbdevhw"
[   986.527] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   986.527] (II) Module fbdevhw: vendor="X.Org Foundation"
[   986.527]    compiled for 1.19.2, module version = 0.0.2
[   986.527]    ABI class: X.Org Video Driver, version 23.0
[   986.527] (EE) open /dev/fb0: No such file or directory
[   986.527] vesa: Ignoring device with a bound kernel driver
[   986.527] (WW) Falling back to old probe method for vesa
[   986.527] (EE) Screen 0 deleted because of no matching config section.
[   986.527] (II) UnloadModule: "modesetting"
[   986.527] (EE) Screen 0 deleted because of no matching config section.
[   986.527] (II) UnloadModule: "fbdev"
[   986.527] (II) UnloadSubModule: "fbdevhw"
[   986.527] (EE) Screen 0 deleted because of no matching config section.
[   986.527] (II) UnloadModule: "vesa"
[   986.527] (EE) Device(s) detected, but none match those in the config file.
[   986.527] (EE)
Fatal server error:
[   986.527] (EE) no screens found(EE)

Ausserdem habe ich mal kdm gepurged und sddm installiert, aber bisher keine Aenderung.

Gruesse
Veit

Benutzeravatar
towo
Beiträge: 3152
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: X server died during startup

Beitrag von towo » 30.01.2018 19:12:27

(EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
Sagt eigentlich Alles.

Code: Alles auswählen

dkms status


wird wohl erhellend sein.

vdvogt
Beiträge: 251
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: X server died during startup

Beitrag von vdvogt » 31.01.2018 16:48:08

Hallo,
dkms status gibt folgendes aus:

Code: Alles auswählen

dkms status
nvidia-current, 375.82, 4.9.0-4-amd64, x86_64: installed
nvidia-current, 375.82, 4.9.0-5-amd64, x86_64: installed
Eigentlich sollte 384.111 installiert sein, aber 375 ist immer noch installiert.

Ich habe daraufhin den nvidia-driver neu installiert, jetzt ist der 384.111 da:

Code: Alles auswählen

dkms status
nvidia-current, 384.111, 4.9.0-5-amd64, x86_64: installed
Aber nach einem Reboot erhalte ich immer noch keine GUI zum Anmelden, sondern nur die Kommandozeile.

Woran kann das jetzt noch liegen?

Gruesse
Veit

Benutzeravatar
towo
Beiträge: 3152
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: X server died during startup

Beitrag von towo » 31.01.2018 16:50:29

Woran kann das jetzt noch liegen?
Auch hier müßte man das Xorg.0.log sowie die Ausgabe von dpkg -l | grep nvidia kennen.

vdvogt
Beiträge: 251
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: X server died during startup

Beitrag von vdvogt » 31.01.2018 17:03:10

Hallo,
ich habe mal systemctl status sddm eingegeben und erhalte folgende Ausgabe:

Code: Alles auswählen

● sddm.service - Simple Desktop Display Manager
   Loaded: loaded (/lib/systemd/system/sddm.service; static; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:sddm(1)
           man:sddm.conf(5)
Das ist also schon mal tot.
KDM hatte ich deinstalliert.

dpkg -l | grep nvidia liefert sehr viele Zeilen, was alles mit dem Namen nvidia installiert ist.
U.a.:
ii nvidia-driver 384.111-3~bpo9+1 amd64 NVIDIA metapackage

Das Xorg.log ist immer noch vom Jan 29 16:17 Xorg.0.log, also nichts neues.

KAnn es aber daran liegen, dass das Blacklisting des Nouveau nicht funktioniert?
Wie war nochmal der Befehl, das zu ueberpruefen?

Gruesse
Veit

NAB
Beiträge: 5502
Registriert: 06.03.2011 16:02:23
Lizenz eigener Beiträge: MIT Lizenz

Re: X server died during startup

Beitrag von NAB » 31.01.2018 17:21:09

Wenn X eh nicht läuft ... was passiert denn, wenn du
startx
eingibst?
sddm kann man übrigens auch manuell starten.
Never change a broken system. It could be worse afterwards.

"No computer system can be absolutely secure." Intel Document Number: 336983-001

vdvogt
Beiträge: 251
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: X server died during startup

Beitrag von vdvogt » 31.01.2018 17:27:42

Hallo,
wenn ich mich auf der Konsole angemeldet habe und startx eingebe erhalte ich folgende Fehlermeldung:

-bash: startx: Kommando nicht gefunden.

Nachdem ich systemctl start sddm eingegeben hatte kam auf einmal die GUI!!!

Danke fuer Deine Hilfe!

Wie kann ich das einrichten, dass jetzt automatisch bei jedem Start die GUI kommt?

Gruesse
Veit

NAB
Beiträge: 5502
Registriert: 06.03.2011 16:02:23
Lizenz eigener Beiträge: MIT Lizenz

Re: X server died during startup

Beitrag von NAB » 31.01.2018 17:43:31

Ja, huch? Ich bin jetzt selber überrascht.
Dein System sollte den Befehl

Code: Alles auswählen

/usr/bin/startx
kennen. Der gehört zum Paket "xinit", und das wird automatisch installiert, wenn du "xorg" installierst. Schwer zu sagen, was da bei dir nicht stimmt.

Sieht die GUI denn "normal" aus?

Tut sich im Xorg.0.log was?

Probier mal:

Code: Alles auswählen

dpkg-reconfigure sddm
Du willst, dass sddm dein Default-Displaymanager ist, falls er fragt.
Never change a broken system. It could be worse afterwards.

"No computer system can be absolutely secure." Intel Document Number: 336983-001

vdvogt
Beiträge: 251
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: X server died during startup

Beitrag von vdvogt » 31.01.2018 17:57:13

Hallo,
nachdem ich dpkg-reconfigure sddm eingegeben hatte kam der Prompt sofort zurueck, ohne dass ich irgendeine Frage gestellt bekam.

Beim Xorg.0.log hat sich viel getan, waere aber wohl zu viel, um es hier aufzulisten.
Ich bin's durchgegangen, kann aber jetzt keine Fehlermeldungen mehr erkennen.

Die GUI sieht ganz normal aus, wenn ich sie mit systemctl start sddm starte.

Gruesse
Veit

vdvogt
Beiträge: 251
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: X server died during startup

Beitrag von vdvogt » 31.01.2018 18:08:17

Hallo,
es scheint jetzt alles so zu funktionieren, wie ich das haben will.
Die GUI kommt jetzt automatisch beim Starten.

Ich hoffe, das bleibt so!

Vielen Dank fuer eure Hilfe!

Viele Gruesse
Veit

Antworten