[gelöst] xfce verliert Bildschirminhalte

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
debianoli
Beiträge: 3051
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

[gelöst] xfce verliert Bildschirminhalte

Beitrag von debianoli » 13.02.2018 13:26:05

Hallo,

nach dem Upgrade auf Stretch habe ich Xfce im Einsatz und folgendes Problem:

Die Inhalte des Bildschirms gehen verloren und man sieht zB den Bildschirm-Inhalt des Screensavers. Sobald man aber mit der Maus über den entsprechenden Bildschirm-Bereich geht, stellt der Fenster-Manager den eigentlichen Inhalt wieder her. In der XFCE-Leiste etwa erscheint dann die eigentliche Leiste, die Fenster des jeweiligen Desktops jedoch erst, nachdem man mit der Maus darüberfährt. Das Problem tritt sehr häufig mit Chromium auf, betrifft aber auch andere Programme. Unter Jessie hatte ich keine Probleme, dort war allerdings KDE4 im Einsatz (KDE5 läuft nach dem Upgrade nicht mehr, ist aber eine andere Baustelle).

Wo kann ich denn da mit der Fehlersuche ansetzen?
Ist das ein Problem vom Kernel? Grafiktreiber? Oder vom Windowmanager XFWM4? Inkompatibilät von Chromium mit der verwendeten Nouveau-Version? Oder spucken da Altlasten von Jessie rein?

System: Stretch mit 2 Monitoren, Xfce mit lightdm, Grafiktreiber Nouveau, Kernel 4.9.0-5-amd64, RAM 6 GB

Code: Alles auswählen

01:00.0 VGA compatible controller: NVIDIA Corporation G86 [Quadro NVS 290] (rev a1)
 
Screen 0: minimum 320 x 200, current 3600 x 1080, maximum 8192 x 8192
DVI-I-1 connected 1680x1050+1920+0 (normal left inverted right x axis y axis) 474mm x 297mm
   1680x1050     60.57*+
   1600x1200     60.00  
   1400x1050     74.87    59.95  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
DVI-I-2 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.90  
   1280x800      59.91  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.32                                                                                                                                                                        
   640x480       59.94                                                                                                                                                                        
   720x400       70.08    
 
Edit:

In der .xsession-errors finde ich diese Einträge:

Code: Alles auswählen

(xfce4-session-settings:21443): Gtk-WARNING **: Im Modulpfad »adwaita« konnte keine Themen-Engine gefunden werden,
13:03:18.789 WARN  unknown                          QFSFileEngine::open: No file name specified 
13:03:18.790 WARN  unknown                          QFSFileEngine::open: No file name specified 
13:03:18.791 WARN  unknown                          QFSFileEngine::open: No file name specified 
13:03:18.792 WARN  unknown                          QFSFileEngine::open: No file name specified 
13:03:18.793 WARN  unknown                          QFSFileEngine::open: No file name specified 
13:03:18.796 WARN  unknown                          QFSFileEngine::open: No file name specified 
Zuletzt geändert von debianoli am 13.02.2018 15:13:39, insgesamt 1-mal geändert.

debianoli
Beiträge: 3051
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: xfce verliert Bildschirminhalte

Beitrag von debianoli » 13.02.2018 13:37:34

Bei einem tail -f .xsession-errors kommt das:

Code: Alles auswählen

wxD-Bus: Signal from /org/freedesktop/DBus, member NameAcquired
wxD-Bus: Reply with serial 2
wxD-Bus: Signal: Error: The name org.gnome.SessionManager was not provided by any .service files
wxD-Bus: CPowerManagementInhibitor: Requesting busy
wxD-Bus: Reply with serial 3
wxD-Bus: CPowerManagementInhibitor: Request successful, cookie is 25
wxD-Bus: CPowerManagementInhibitor: Requesting idle
wxD-Bus: Reply with serial 4
wxD-Bus: CPowerManagementInhibitor: Request successful
wxD-Bus: CPowerManagementInhibitor: Requesting busy
wxD-Bus: Reply with serial 5
wxD-Bus: CPowerManagementInhibitor: Request successful, cookie is 27
wxD-Bus: CPowerManagementInhibitor: Requesting idle

Benutzeravatar
towo
Beiträge: 3200
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: xfce verliert Bildschirminhalte

Beitrag von towo » 13.02.2018 14:17:42

Vergiss -xsession.errors, diese Datei ist so aussagekräftig wie ein stück Brot.
Das liegt mit ziemlicher sicherheit am nouveau Treiber.
Du kannstja mal modesetting als DDX statt nouveau-DDX testen.
Alternativ mal schauen, ob deaktiviertes Compositing dieses Verhalten behabt.
Oder vielleicht mal mit Nvidia Blob versuchen.

debianoli
Beiträge: 3051
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: xfce verliert Bildschirminhalte

Beitrag von debianoli » 13.02.2018 14:39:47

Danke für den Tipp mit dem compositing. Das war es. Da hätte ich auch selber daraufkommen können.

Antworten