Debian 10 - Schwarzer Bildschirm nach Upgrade auf Buster

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
lod
Beiträge: 23
Registriert: 12.01.2010 09:21:55

Debian 10 - Schwarzer Bildschirm nach Upgrade auf Buster

Beitrag von lod » 13.10.2019 19:16:25

Hallo zusammen

Ich komme nicht recht weiter. Seit dem Upgrade von Debian 9 auf Debian 10 Buster ist mein Bildschirm schwarz. Das Phänomen lässt sich wie folgt beschreiben:
  • Kurz nach dem Start wird der Bildschirm schwarz
  • Es erscheint keine Meldung, dass kein Signal am Bildschirm ist, also die Lämpchen sind auf "Ein", als ob nur ein schwarzes Bild "gesendet" wird
  • Ctrl+Alt+F1 geht nicht
  • Ich kann mich via SSH verbinden
  • Der Fehler tritt mit dem Kernel 4.19 auf. Mit dem alten Kernel 4.9 klappt alles wie gewohnt
  • Wenn ich via Ubuntu Live-CR 19.04-desktop boote, erscheint ebenfalls kein Bild
  • Es klappt weder mit Lighd noch gdm3
  • Es klappt weder mit Mate noch mit GNOME3 Desktop
  • Alles läuft, nur der Bildschirm ist schwarz
Nun, wer kann mir helfen.

Folgende Infos kann ich schon mal geben:
  • Ich habe 2 Monitore, einmal über HDMI und einmal über DVI angeschlosse
  • Das Problem besteht auch, wenn ich nur einen Monitor angeschlossen habe, egal ob HDMI oder DVI

Code: Alles auswählen

 lshw -c video
  *-display
       description: VGA compatible controller
       product: Tonga PRO [Radeon R9 285/380]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:04:00.0
       version: f1
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: iomemory:38000-37fff iomemory:38000-37fff irq:34 memory:380000000000-38007fffffff memory:380080000000-3800801fffff ioport:e000(size=256) memory:fbe00000-fbe3ffff memory:c0000-dffff

sudo dpkg -l |grep linux
ii  binutils-x86-64-linux-gnu             2.31.1-16                            amd64        GNU binary utilities, for x86-64-linux-gnu target
ii  console-setup-linux                   1.193~deb10u1                        all          Linux specific part of console-setup
ii  firmware-linux-free                   3.4                                  all          Binary firmware for various drivers in the Linux kernel
ii  firmware-linux-nonfree                20190114-2                           all          Binary firmware for various drivers in the Linux kernel (meta-package)
ii  libselinux1:amd64                     2.8-1+b1                             amd64        SELinux runtime shared libraries
ii  libv4l-0:amd64                        1.16.3-3                             amd64        Collection of video4linux support libraries
ii  libv4lconvert0:amd64                  1.16.3-3                             amd64        Video4linux frame format conversion library
ii  linux-base                            4.6                                  all          Linux image base package
ii  linux-compiler-gcc-6-x86              4.9.189-3+deb9u1                     amd64        Compiler for Linux on x86 (meta-package)
ii  linux-compiler-gcc-8-x86              4.19.67-2+deb10u1                    amd64        Compiler for Linux on x86 (meta-package)
ii  linux-headers-4.19.0-6-amd64          4.19.67-2+deb10u1                    amd64        Header files for Linux 4.19.0-6-amd64
ii  linux-headers-4.19.0-6-common         4.19.67-2+deb10u1                    all          Common header files for Linux 4.19.0-6
ii  linux-headers-4.9.0-8-amd64           4.9.110-3+deb9u6                     amd64        Header files for Linux 4.9.0-8-amd64
ii  linux-headers-4.9.0-8-common          4.9.110-3+deb9u6                     all          Common header files for Linux 4.9.0-8
ii  linux-headers-amd64                   4.19+105+deb10u1                     amd64        Header files for Linux amd64 configuration (meta-package)
ii  linux-image-4.19.0-6-amd64            4.19.67-2+deb10u1                    amd64        Linux 4.19 for 64-bit PCs (signed)
rc  linux-image-4.9.0-6-amd64             4.9.88-1+deb9u1                      amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-4.9.0-8-amd64             4.9.110-3+deb9u6                     amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-amd64                     4.19+105+deb10u1                     amd64        Linux for 64-bit PCs (meta-package)
ii  linux-kbuild-4.19                     4.19.67-2+deb10u1                    amd64        Kbuild infrastructure for Linux 4.19
ii  linux-kbuild-4.9                      4.9.189-3+deb9u1                     amd64        Kbuild infrastructure for Linux 4.9
ii  linux-libc-dev:amd64                  4.19.67-2+deb10u1                    amd64        Linux support headers for userspace development
ii  util-linux                            2.33.1-0.1                           amd64        miscellaneous system utilities


sudo dpkg -l |grep amdgpu
ii  libdrm-amdgpu1:amd64                  2.4.97-1                             amd64        Userspace interface to amdgpu-specific kernel DRM services -- runtime
ii  xserver-xorg-video-amdgpu             18.1.99+git20190207-1                amd64        X.Org X server -- AMDGPU display driver


Das xorg.0.log nach dem Start sieht so aus:
http://nopaste.debianforum.de/40886

Edit 13.10.2019

Code: Alles auswählen

dpkg -l | grep firmware
ii  amd64-microcode                       3.20181128.1                         amd64        Processor microcode firmware for AMD CPUs
ii  firmware-amd-graphics                 20190114-2                           all          Binary firmware for AMD/ATI graphics chips
ii  firmware-linux-free                   3.4                                  all          Binary firmware for various drivers in the Linux kernel
ii  firmware-linux-nonfree                20190114-2                           all          Binary firmware for various drivers in the Linux kernel (meta-package)
ii  firmware-misc-nonfree                 20190114-2                           all          Binary firmware for various drivers in the Linux kernel
ii  fwupd-amd64-signed                    1.2.5+2                              amd64        Tools to manage UEFI firmware updates (signed)
ii  intel-microcode                       3.20190618.1                         amd64        Processor microcode firmware for Intel CPUs
Grafikkarte: Radeon R9 285

Wer kann mir helfen? Was werden noch für Informationen benötigt?

Vielen Dank für jeglichen Hinweis.

Gruss
L.
Zuletzt geändert von lod am 13.10.2019 20:06:55, insgesamt 1-mal geändert.

Benutzeravatar
willy4711
Beiträge: 2515
Registriert: 08.09.2018 16:51:16

Re: Debian 10 - Schwarzer Bildschirm nach Upgrade auf Buster

Beitrag von willy4711 » 13.10.2019 19:50:06


Benutzeravatar
Blackbox
Beiträge: 2940
Registriert: 17.09.2008 17:01:20
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Debian 10 - Schwarzer Bildschirm nach Upgrade auf Buster

Beitrag von Blackbox » 13.10.2019 19:52:09

Nur ein paar Ergänzungen: Du hast beispielsweise nicht erwähnt, dass dein Rechner an einem KVM Switch : ATEN CS-64U hängt, weiterhin habe ich in deinem Post keine Angabe zu deiner GPU gesehen, aber im Logfile steht etwas von einer AMD Radeon R9 380, ist das korrekt?
Eigenbau PC: Debian Sid - Kernel: 5.3.7 - Xfce 4.14
Desktop PC: Dell Inspiron 530 - Debian Sid - Kernel: 5.3.7 - Xfce 4.14
Notebook: TUXEDO Book BU1406 - Debian Sid - Kernel: 5.3.7 - Xfce 4.14
Rootserver: Centos 7.7.1908 - Kernel: 3.10-x86_64
Alles Minimalinstallationen.

Freie Software unterstützen, Datenschutz stärken!

lod
Beiträge: 23
Registriert: 12.01.2010 09:21:55

Re: Debian 10 - Schwarzer Bildschirm nach Upgrade auf Buster

Beitrag von lod » 13.10.2019 20:07:34

willy4711 hat geschrieben: ↑ zum Beitrag ↑
13.10.2019 19:50:06
Debianfirmware-amd-graphics installiert?
Hi

Ja, ist installiert. Hab es noch im Post ergänzt.

lod
Beiträge: 23
Registriert: 12.01.2010 09:21:55

Re: Debian 10 - Schwarzer Bildschirm nach Upgrade auf Buster

Beitrag von lod » 13.10.2019 20:09:54

Blackbox hat geschrieben: ↑ zum Beitrag ↑
13.10.2019 19:52:09
Nur ein paar Ergänzungen: Du hast beispielsweise nicht erwähnt, dass dein Rechner an einem KVM Switch : ATEN CS-64U hängt, weiterhin habe ich in deinem Post keine Angabe zu deiner GPU gesehen, aber im Logfile steht etwas von einer AMD Radeon R9 380, ist das korrekt?
Hi

Korrekt, es ist eine Radeon R9 380 (hab es im Post noch ergänzt). Der Switch ist ebenfalls korrekt. Deshalb hab ich einmal DVI und einmal HDMI. Also nur einer der beiden Monitore läuft über den KVM Switch. Der ist auch schon vor dem Update da gewesen und hat bis jetzt noch nie Probleme gemacht. Deshalb dachte ich, müsse ich es nicht extra erwähnen. Sorry.

Benutzeravatar
ingo2
Beiträge: 821
Registriert: 06.12.2007 18:25:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Wo der gute Riesling wächst

Re: Debian 10 - Schwarzer Bildschirm nach Upgrade auf Buster

Beitrag von ingo2 » 01.11.2019 12:46:24

Schau mal hier in diesem Thread, das ist ein bekannter Bug in Debianlight-locker.
viewtopic.php?f=12&t=175059 unter e)
https://bugs.debian.org/cgi-bin/bugrepo ... =929834#23
https://bugs.debian.org/cgi-bin/bugrepo ... 929834#131

Da gibt es mehrere Workarounds:
a) den intel DDX - das hast du schon probiert, bei AMD ist's ähnlich.

b) "xset s off" z.B. in die ~/.xsessionrc schreiben (das mache ich derzeit)

c) Den neuesten Kernel 5.3.7-1 aus "unstable" nutzen (habe ich auch getestet, geht)

Ingo

lod
Beiträge: 23
Registriert: 12.01.2010 09:21:55

Re: Debian 10 - Schwarzer Bildschirm nach Upgrade auf Buster

Beitrag von lod » 02.11.2019 08:37:13

lod hat geschrieben: ↑ zum Beitrag ↑
13.10.2019 20:09:54
Blackbox hat geschrieben: ↑ zum Beitrag ↑
13.10.2019 19:52:09
Nur ein paar Ergänzungen: Du hast beispielsweise nicht erwähnt, dass dein Rechner an einem KVM Switch : ATEN CS-64U hängt, weiterhin habe ich in deinem Post keine Angabe zu deiner GPU gesehen, aber im Logfile steht etwas von einer AMD Radeon R9 380, ist das korrekt?
Hi

Korrekt, es ist eine Radeon R9 380 (hab es im Post noch ergänzt). Der Switch ist ebenfalls korrekt. Deshalb hab ich einmal DVI und einmal HDMI. Also nur einer der beiden Monitore läuft über den KVM Switch. Der ist auch schon vor dem Update da gewesen und hat bis jetzt noch nie Probleme gemacht. Deshalb dachte ich, müsse ich es nicht extra erwähnen. Sorry.
Kleiner Hinweis noch, den ich vergessen hab zu erwähnen. Der KVM Switch ist nur für die Tastatur und Maus. Die Monitore sind direkt an der Grafikkarte angeschlossen.

lod
Beiträge: 23
Registriert: 12.01.2010 09:21:55

Re: Debian 10 - Schwarzer Bildschirm nach Upgrade auf Buster

Beitrag von lod » 02.11.2019 08:43:11

ingo2 hat geschrieben: ↑ zum Beitrag ↑
01.11.2019 12:46:24
Schau mal hier in diesem Thread, das ist ein bekannter Bug in Debianlight-locker.
viewtopic.php?f=12&t=175059 unter e)
https://bugs.debian.org/cgi-bin/bugrepo ... =929834#23
https://bugs.debian.org/cgi-bin/bugrepo ... 929834#131

Da gibt es mehrere Workarounds:
a) den intel DDX - das hast du schon probiert, bei AMD ist's ähnlich.

b) "xset s off" z.B. in die ~/.xsessionrc schreiben (das mache ich derzeit)

c) Den neuesten Kernel 5.3.7-1 aus "unstable" nutzen (habe ich auch getestet, geht)

Ingo
Hi Ingo

Vielen Dank für Deine Hinweise. Leider haben diese nicht geholfen. Ich vermute auch, dass die von Dir verwiesenen Ansätze für ein Problem mit dem Screensaver sind. Bei mir wird der Bildschrim während dem Booten schwarz. Also ich kann mich weder anmelden noch kann ich Ctrl.+Alt.+F1-x drücken. Das Bild bleibt schwarz.

a) Hab ich mit amdgpu versucht und mit fglx (oder so). Hat leider nichts geholfen
b) Hab ich versucht, sowohl im root Home wie auch in meinem regulären Home und auch beiden Orten gleichzeitig.
c) Möchte ich nicht. Dann arbeite ich lieber mit dem alten (4.9) weiter wo es ebenfalls klappt.

Jedoch trotzdem vielen Dank für Deine Ansätze.

Gruss
lod

Benutzeravatar
Teddybear
Moderator
Beiträge: 3162
Registriert: 07.05.2005 13:52:55
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Altomünster
Kontaktdaten:

Re: Debian 10 - Schwarzer Bildschirm nach Upgrade auf Buster

Beitrag von Teddybear » 02.11.2019 10:42:36

Wie wäre es denn mal mit ein paar logs?
Dann muss man nicht in die Kristallkugel schauen und ins blaue raten.

Aber scheinbar hat xorg probleme mit deinem KVM Switch, vielleicht steht noch was brauchbares im Syslog, dmesg, etc..
Versuchungen sollte man nachgeben. Wer weiß, ob sie wiederkommen!
Oscar Wilde

Mod-Voice / My Voice

Antworten