[Solved] Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

[Solved] Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 12:01:18

Hallo liebe Community,

nachdem ich seit insgesamt über 24 Stundwn erfolglos probiere irgendeine Linux Distribution auf meinem e595 (r5 3500u mit vega Grafik, 1× 8GB ddr4 2666mhz cl16 Samsung ram) zu installieren bzw. zum laufen zu bringen, habe ich es jetzt zumindest einmal geschafft Debian 10 über ein netinstall Iso zu installieren. Dieses bootet auch, bleibt aber direkt beim Start hängen und startet die Konsole bzw. es wird nur tty1-6 gestartet. Im Log von Lightdm steht: Failed to start Light Display Manager. Im Log von XORG steht: Failed to load Module amd. Module does not exist. Mittlerweile habe ich ein Kernel Upgrade von 4.19 auf 5.2 gemacht, habe die Nonfree Pakete und die Backports eingebunden, zigmal die amd Treiber Plus den Micocode neu installiert.

(Unter Windows 10 läuft alles optimal aber Linux Distributionen machen noch mehr Probleme als auf meinem Hautprechner (r7 2700x, gtx 1080). Auf dem Hautprechner musste man nur den NVIDIA Treiber ersetzen und dann lief zumindest Ubuntu 19.4.) Auf einem Acer Aspire 3 mit i5-4200m laufen alle Distributionen (außer Lmde3, welches nirgendwo läuft) optimal.

(Problem 2: Bei einer Debian 10 Installation, egal ob über die Fai oder Lokal, kann nur ein Lokaler User bzw. root Sticks mounten. Bei Usern aus dem nis steht immer: Not authorized. Scheinbar wird bei root und lokalen Usern ein udisk2 Prozess beim booten gestartet der bei Usern aus dem nis nicht gestartet wird. Das Problem besteht, allerdings erst seit Buster. Unter Debian 9 lief noch alles.)
(Ich wollte nicht zwei Threads gleichzeitig erstellen.)

Habt ihr noch eine Idee wie man die Probleme lösen könnte?

Gruß

Orkreader
Zuletzt geändert von Orkreader am 24.10.2019 11:35:27, insgesamt 3-mal geändert.

Benutzeravatar
niemand
Beiträge: 13262
Registriert: 18.07.2004 16:43:29

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von niemand » 19.10.2019 12:06:49

Orkreader hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 12:01:18
Habt ihr noch eine Idee wie man die Probleme lösen könnte?
Du könntest das Netinstall-Image mit der unfreien Firmware versuchen. Die wird für deine Grafikhardware benötigt.
non serviam.

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 12:16:33

Also unter: https://cdimage.debian.org/cdimage/unof ... d64/bt-cd/

Die normale Version?

Hmm...Aber die nonfree Versionen sind doch in sources.list eingetragen...Müsste das nicht reichen?

Benutzeravatar
niemand
Beiträge: 13262
Registriert: 18.07.2004 16:43:29

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von niemand » 19.10.2019 12:20:42

Ja, z.B.. Aber wenn deine Installation ansonsten läuft, könntest du auch non-free in die sources.list aufnehmen, und die Firmware einfach installieren.
non serviam.

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 12:23:18

Nonfree, Backports usw. stehen schon in der sources.list. Dann probiere ich mal das nonfree netinst aus dem Link.

Falscher Ordner. Da gabs ja auch noch eine mit isos.

Benutzeravatar
willy4711
Beiträge: 2525
Registriert: 08.09.2018 16:51:16

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von willy4711 » 19.10.2019 12:27:18

Ich würde an deiner Stelle gleich mit Testing loslegen.
Erstmal mit ner Live-DVD, um zu sehen, ob das klappt.
http://cdimage.debian.org/cdimage/unoff ... so-hybrid/
Wenn ja, von dort installieren.

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 12:32:26

Ok. Soweit ich das verstanden habe ist Debian testing der Beta Status, oder habe ich das falsch verstanden? Btw. ich habe kein CD Laufwerk, müsste das also über einen Stick installieren. Vorgang läuft...

Benutzeravatar
niemand
Beiträge: 13262
Registriert: 18.07.2004 16:43:29

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von niemand » 19.10.2019 12:35:43

Orkreader hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 12:23:18
Nonfree, Backports usw. stehen schon in der sources.list.
Dann reicht das Installieren des entsprechenden Firmwarepaketes. Was anderes kommt auch bei der Installation mit dem inoffiziellen Image nicht mit.
Orkreader hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 12:32:26
Ok. Soweit ich das verstanden habe ist Debian testing der Beta Status, oder habe ich das falsch verstanden.
Sowas in der Art. Willy mag keine Noobs, deswegen empfiehlt er sowas.
non serviam.

Benutzeravatar
willy4711
Beiträge: 2525
Registriert: 08.09.2018 16:51:16

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von willy4711 » 19.10.2019 12:39:44

Orkreader hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 12:32:26
Ok. Soweit ich das verstanden habe ist Debian testing der Beta Status, oder habe ich das falsch verstanden
Naja Beta ist etwas über (oder unter) trieben. Davor sind noch experimental und sid. Die Pakete sind also schon relativ "abgehangen", bevor sie
überhaupt nach Testing kommen. Ich nutze Testing ausschließlich seit Jahren. Ärger gab es nur 2 Mal.
Musst halt möglichst täglich deine Updates fahren, da eben häufig neue Pakete kommen.

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 12:42:37

Jetzt sollten wir uns vielleicht erstmal auf einen Vorgang einigen. Die Firmwarepakete habe ich ja schon in die Distribution geladen. apt upgrade und apt upgrade meinen beide, das alles aktuell sei. Die Treiber sind auch drauf. Wie installiere ich denn den richtigen Treiber, bzw. welcher ist überhaupt der richtige?

Neuinstallieren mit testing oder probieren den richtigen Treiber zu treffen in der derzeitigen Installation?

Benutzeravatar
willy4711
Beiträge: 2525
Registriert: 08.09.2018 16:51:16

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von willy4711 » 19.10.2019 12:46:49

Ich denke du bräuchtest Debianfirmware-amd-graphics aus den Backports

@niemand : ich denke, ich setzte mir mal heute einen Helm auf, damit es nicht soviel Beulen gibt. :wink:

Benutzeravatar
niemand
Beiträge: 13262
Registriert: 18.07.2004 16:43:29

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von niemand » 19.10.2019 12:47:06

Orkreader hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 12:42:37
Die Firmwarepakete habe ich ja schon in die Distribution geladen
Hast du? Schriebst du gar nix von.
Dann würde ich nun das Log durchgehen und schauen, ob’s beim Laden der FW Probleme gibt.
non serviam.

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 13:01:20

Ein apt install firmware amd graphics und ein xserver-xorg-video.amdpu und ein apt install amd-microcode habe ich gemacht.
Als Bilder: Einmal das XORG Log und einmal sources.list und einmal systemctl status lightdm.service.

gallery/image/2321
gallery/image/2322
gallery/image/2323
Zuletzt geändert von Orkreader am 19.10.2019 13:13:26, insgesamt 1-mal geändert.

Benutzeravatar
willy4711
Beiträge: 2525
Registriert: 08.09.2018 16:51:16

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von willy4711 » 19.10.2019 13:09:59

Orkreader hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 13:01:20
Ein apt install firmware amd graphics und ein xserver-xorg-video.amdpu und ein apt install amd-microcode habe ich gemacht.
Aus den Backports ?
Zur Verwendung der Backports (deutsch und etwas älter)
https://wiki.debian.org/de/Backports
auf Englisch und etwas neuer:
https://wiki.debian.org/Backports

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 13:15:29

Ich habe im vorigen Post ein paar Bilder eingefügt. Synaptic startet nicht, da der Verbindungsaufbau scheitert bzw. die Initalisierung von GTK fehlschlägt.

Die Backports sind drin, allerdings gibts sloppy nicht.

Im XORG steht immer noch: Load Module "AMD". Warning, could not open module amd. Failed to load module amd (module does not exist, 0).
No drivers avaiable.

Ok. Parameter - t und die Bakports mitgeschrieben...Jetzt passiert etwas. Libre Office 6.3.2 wird installiert...

Possible missing firmware for amd...Interessant

Immer noch der gleiche Lightdm Fehler...

Mit dem live testing image bekomme ich eine grafische Oberfläche...Allerdings konnte ich das Buster stable auch grafisch installieren.

Die Performance des live testing images ist sehr schlecht.
Zuletzt geändert von Orkreader am 19.10.2019 13:49:37, insgesamt 9-mal geändert.

Antworten