[Solved] Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 17:32:43

niemand hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 17:23:47
Orkreader hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 17:19:58
Ohne Bilder gibts keine Logs, da ich am Notebook nur eine Textkonsole habe.
Debianpastebinit
Alternativ ssh und altmodisches Copy&Paste des Textes.

ssh geht nicht. Windows schreibt immer: Connection refused. Komischerweise steht unter ip address show am Debian Notebook viel mehr als da stehen sollte. Da stehen zahlreiche scope global temporary dynamic Enträge mit inet6.

Hm. Die Ausgabe per scp in eine Datei umlenken und diese dann auf einen Stick kopieren...scp -r /Quelle /media/ aber da gibts kein Media...
Zuletzt geändert von Orkreader am 19.10.2019 17:39:34, insgesamt 1-mal geändert.

Benutzeravatar
niemand
Beiträge: 13262
Registriert: 18.07.2004 16:43:29

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von niemand » 19.10.2019 17:38:18

Debianopenssh-server zu installieren und zu starten, wird Abhilfe schaffen. Anmeldung als Root geht allerdings aus Gründen nicht.
non serviam.

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 17:50:43

niemand hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 17:38:18
Debianopenssh-server zu installieren und zu starten, wird Abhilfe schaffen. Anmeldung als Root geht allerdings aus Gründen nicht.
ssh, Putty, Openssh sagen alle: Connection refused...Jetzt sitze ich schon wieder 6 Stunden daran...:( :evil:


Die andere Idee war ja den Radeon 19.30 Treiber von Ubuntu zu installieren.

https://wiki.debian.org/AMDGPUDriverOnStretchAndBuster2

https://www.amd.com/de/support/kb/relea ... stallation aha....ohne Link zum Download...
Zuletzt geändert von Orkreader am 19.10.2019 17:59:45, insgesamt 1-mal geändert.

Benutzeravatar
willy4711
Beiträge: 2537
Registriert: 08.09.2018 16:51:16

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von willy4711 » 19.10.2019 17:57:11

Orkreader hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 15:27:53
Debian Testing ist auf einmal wieder im Auswahlmenü.
Na dann kannst du ja von dem funktionierenden Testing auf die Logs des nicht funktionierenden Stable zugreifen.
Vielleicht bekommst du es ja so irgendwann zum Laufen, obwohl ich das bezweifele.

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 18:05:46

[/quote]
Na dann kannst du ja von dem funktionierenden Testing auf die Logs des nicht funktionierenden Stable zugreifen.
Vielleicht bekommst du es ja so irgendwann zum Laufen, obwohl ich das bezweifele.
[/quote]

Und wie greife ich auf die Logs des stable zu? Ich habe mich jetzt beim testing als root angemeldet. In der grafischen Oberfläche kann man anscheinend nur die Logs des testing aufrufen.

Mein Chef probiert am Montag nochmal etwas aus. Wünsche euch noch ein schönes Wochenende.

(Wer noch eine Lösumg für das Problem 2 aus dem Startpost hat...Lösungen sind gerne gesehen.)
Zuletzt geändert von Orkreader am 19.10.2019 18:44:59, insgesamt 1-mal geändert.

Benutzeravatar
willy4711
Beiträge: 2537
Registriert: 08.09.2018 16:51:16

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von willy4711 » 19.10.2019 18:43:32

Orkreader hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 18:05:46
Und wie greife ich auf die Logs des stable zu? Ich habe mich jetzt beim testing als root angemeldet. In der grafischen Oberfläche kann man anscheinend nur die Logs des testing aufrufen.
Normaler weise solltest du im Dateimanager die Partitionen des anderen Systems sehen
aber vielleicht erstmal die Ausgabe von

Code: Alles auswählen

lsblk
hier einstellen?

Benutzeravatar
towo
Beiträge: 3450
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von towo » 19.10.2019 18:55:22

Mit einem 4.19er Kernel wird das alles mit Sicherheit nichts, da damit weder die CPU (Ryzen 2) noch die Grafik unterstützt ist, punkt.
Debian Stable ist für solch neue Hardware absolut ungeeignet und ob Backports die notwendigen, aktuellen Pakete hat, weiss ich nicht.

Benutzeravatar
niemand
Beiträge: 13262
Registriert: 18.07.2004 16:43:29

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von niemand » 19.10.2019 18:58:57

towo hat geschrieben: ↑ zum Beitrag ↑
19.10.2019 18:55:22
ob Backports die notwendigen, aktuellen Pakete hat, weiss ich nicht.
Da in den Backports derzeit in etwa die Versionen sind, die in Testing auch zu finden sind, würde ich mal davon ausgehen.

Falls du nun zu Siduction raten wolltest: gerne – dann aber auch in eurem Forum weitermachen :)
non serviam.

Benutzeravatar
towo
Beiträge: 3450
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von towo » 19.10.2019 19:00:47

Ich habe nirgendwo zu siduction geraten, weil ich einem unbedarften User niemals zu einem Debian unstable raten würde.
Das Problem, neueste Hardware und Debian stable ist aber keine Neues.

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 19.10.2019 19:08:32

root@deb10stable-e595:~# lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 931,5G 0 disk
├─sda1 8:1 0 512M 0 part /boot/efi
├─sda2 8:2 0 28G 0 part /
├─sda3 8:3 0 5,9G 0 part [SWAP]
└─sda4 8:4 0 897,2G 0 part /home
sdb 8:16 1 114,6G 0 disk
├─sdb1 8:17 1 2,8G 0 part /media/root/d-live nf 10.1.0 ci amd64 das ist der Stick.
└─sdb2 8:18 1 2,9M 0 part
nvme0n1 259:0 0 465,8G 0 disk
├─nvme0n1p1 259:1 0 529M 0 part
├─nvme0n1p2 259:2 0 100M 0 part
├─nvme0n1p3 259:3 0 16M 0 part
└─nvme0n1p4 259:4 0 465,1G 0 part
root@deb10stable-e595:~#


Ausgabe von lsblk.


Update: Ich habe den Stick nochmal formatiert und den 5.3.7 Kernel von https://www.kernel.org/ darauf kopiert (Die Patch Datei xz). Könnte mir jemand beim upgrade des Kernels helfen?

Btw. unter debian10stable wird der Stick nicht mehr angezeigt.

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 24.10.2019 11:33:52

Problem 1 gelöst!


Die non-free Iso hat ein funktionierendes Buster mit grafischer Oberfläche installiert. Allerdings wurden zwei verschiedene Kernel installiert (4.19 und 5.2), sodass ich gedacht habe die 5.2er Version wäre immer noch testing. Jetzt habe ich den 4.19er Kernel entfernt und benutze nur noch den 5.2er

KP97
Beiträge: 1894
Registriert: 01.02.2013 15:07:36

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von KP97 » 24.10.2019 11:58:57

Orkreader hat geschrieben: ↑ zum Beitrag ↑
24.10.2019 11:33:52
....sodass ich gedacht habe die 5.2er Version wäre immer noch testing.
Ganz generell: Buster ist Stable! In Stable wird niemals etwas von Testing landen, und das bezieht sich auch auf die Backports.
Backports sind neuere Versionen, die an die Libs von Stable angepaßt werden, das kann man auch an dem Kürzel bpo in den Versionsbezeichnungen erkennen.
Wenn der neuere Kernel 5.2 installiert wurde, kommt der aus den Backports, da Du die Quelle in der sources.list eingetragen hast.

Unbedingt lesen:
https://wiki.debianforum.de/Grundsatzfragen

Orkreader
Beiträge: 20
Registriert: 17.10.2019 19:42:38

Re: Debian 10: Lightdm startet nicht bzw stoppt direkt nach dem starten

Beitrag von Orkreader » 24.10.2019 12:06:30

KP97 hat geschrieben: ↑ zum Beitrag ↑
24.10.2019 11:58:57
Orkreader hat geschrieben: ↑ zum Beitrag ↑
24.10.2019 11:33:52
....sodass ich gedacht habe die 5.2er Version wäre immer noch testing.
Ganz generell: Buster ist Stable! In Stable wird niemals etwas von Testing landen, und das bezieht sich auch auf die Backports.
Backports sind neuere Versionen, die an die Libs von Stable angepaßt werden, das kann man auch an dem Kürzel bpo in den Versionsbezeichnungen erkennen.
Wenn der neuere Kernel 5.2 installiert wurde, kommt der aus den Backports, da Du die Quelle in der sources.list eingetragen hast.

Unbedingt lesen:
https://wiki.debianforum.de/Grundsatzfragen
Ja. Ich habe gar nicht über die Bedeutung des bpo nachgedacht aber so macht das Sinn. Allerdings ist die Performance von Youtube Videos sehr schlecht. Videos die unter Windows in 8k laufen, laufen unter Debian 10 noch nichtmal in 1440p.

Antworten