[Solved] XFCE Shutdown und Reboot ausgegraut

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
KP97
Beiträge: 1892
Registriert: 01.02.2013 15:07:36

Re: [Solved] XFCE Shutdown und Reboot ausgegraut

Beitrag von KP97 » 22.10.2019 17:59:00

An einer falschen Berechtigung wird es wohl nicht liegen, sonst käme ein 'Permission denied'. Vielleicht mal in /etc/X11/xinit schauen, ob da alles stimmt.
Kann es evtl. sein, daß der lightdm installiert ist und dazwischenfunkt, selbst wenn der Service disabled ist?
K.A. da ich weder Vbox noch Lightdm nutze, habe ich keine rechte Idee dazu.

Benutzeravatar
willy4711
Beiträge: 2526
Registriert: 08.09.2018 16:51:16

Re: [Solved] XFCE Shutdown und Reboot ausgegraut

Beitrag von willy4711 » 22.10.2019 18:49:25

KP97 hat geschrieben: ↑ zum Beitrag ↑
22.10.2019 17:59:00
Vielleicht mal in /etc/X11/xinit schauen, ob da alles stimmt.
Das, was da immer steht:

Code: Alles auswählen

#!/bin/sh

# /etc/X11/xinit/xinitrc
#
# global xinitrc file, used by all X sessions started by xinit (startx)

# invoke global X session script
. /etc/X11/Xsession
KP97 hat geschrieben: ↑ zum Beitrag ↑
22.10.2019 17:59:00
Kann es evtl. sein, daß der lightdm installiert ist und dazwischenfunkt, selbst wenn der Service disabled ist?
War nie installiert. Es gibt noch nicht mal die /etc/X11/default-display-manager

Aber hmmm........
Hab mich mal gerade spaßeshalber auf tty5 mit einem anderer User angemeldet:
Da kommt mit startxfce4 die selben Meldungen wie in der VM , während startx problemlos ne neue Xsession aufmacht.
Scheint meine "Aura" zu sein

Christoph Franzen
Beiträge: 130
Registriert: 22.08.2005 19:58:49
Lizenz eigener Beiträge: Artistic Lizenz
Wohnort: Aachen

Re: XFCE Shutdown und Reboot ausgegraut

Beitrag von Christoph Franzen » 24.10.2019 03:18:59

Hallo!
Christoph Franzen hat geschrieben: ↑ zum Beitrag ↑
20.10.2019 23:35:41
Das Problem habe ich auch auf dem Rechner meiner Mutter. Mal untersuchen…
Teddybear hat geschrieben: ↑ zum Beitrag ↑
21.10.2019 00:15:50
Wie Hikaru schon vermutet hat, wird es an fehlendem Debianpolicikit-1 liegen.
Eben nicht, das ist und war auch vorher da. Auto-Mount geht nicht und manuelles Einhängen auch nicht mehr.
Christoph

KP97
Beiträge: 1892
Registriert: 01.02.2013 15:07:36

Re: XFCE Shutdown und Reboot ausgegraut

Beitrag von KP97 » 24.10.2019 11:49:11

Christoph Franzen hat geschrieben: ↑ zum Beitrag ↑
24.10.2019 03:18:59
Auto-Mount geht nicht und manuelles Einhängen auch nicht mehr.
Vielleicht beschreibst Du das mal genauer mit aussagefähigen Fehlermeldungen und Angaben zum System, möglichst in einem eigenen Thread.

Christoph Franzen
Beiträge: 130
Registriert: 22.08.2005 19:58:49
Lizenz eigener Beiträge: Artistic Lizenz
Wohnort: Aachen

Re: XFCE Shutdown und Reboot ausgegraut

Beitrag von Christoph Franzen » 24.10.2019 13:54:05

KP97 hat geschrieben: ↑ zum Beitrag ↑
24.10.2019 11:49:11
Christoph Franzen hat geschrieben: ↑ zum Beitrag ↑
24.10.2019 03:18:59
Auto-Mount geht nicht und manuelles Einhängen auch nicht mehr.
Vielleicht beschreibst Du das mal genauer mit aussagefähigen Fehlermeldungen und Angaben zum System, möglichst in einem eigenen Thread.
Das ist es ja eben: Fehlermeldungen gibt es nicht; ich muß das also erst genauer untersuchen. Das System ist ein uraltes, immer wieder aktualisiertes, ich nehme stark an, daß es damit dann auch zusammenhängt. Ich hatte halt gehofft, irgendjemand hätte eine spontane Idee.
Christoph

Benutzeravatar
willy4711
Beiträge: 2526
Registriert: 08.09.2018 16:51:16

Re: [Solved] XFCE Shutdown und Reboot ausgegraut

Beitrag von willy4711 » 24.10.2019 14:04:44

bitte mal (eventuell als Root):

Code: Alles auswählen

udevadm monitor
Stick einstecken und Ausgabe hier einstellen.
oder, was auch geht:

Code: Alles auswählen

journalctl -f
weiter die Ausgabe von:

Code: Alles auswählen

 dpkg -l pol*|grep ii
von

Code: Alles auswählen

dpkg -l *gvfs*|grep ii

Code: Alles auswählen

ls -al /etc/xdg/autostart/ |grep pol

KP97
Beiträge: 1892
Registriert: 01.02.2013 15:07:36

Re: [Solved] XFCE Shutdown und Reboot ausgegraut

Beitrag von KP97 » 24.10.2019 14:07:34

Früher wurde auch das Paket policykit-1-gnome benötigt, evtl. hilft das weiter. Zum automounten über Thunar braucht es gvfs und die Abhängigkeiten, aber das weißt Du sicher.
Ist der User in der Gruppe plugdev?

Benutzeravatar
willy4711
Beiträge: 2526
Registriert: 08.09.2018 16:51:16

Re: [Solved] XFCE Shutdown und Reboot ausgegraut

Beitrag von willy4711 » 24.10.2019 14:15:26

KP97 hat geschrieben: ↑ zum Beitrag ↑
24.10.2019 14:07:34
Früher wurde auch das Paket policykit-1-gnome benötigt, evtl. hilft das weiter.
Richtig, nicht nur früher. Daher meine Fragen.Ohne das geht gar nichts (automatisch)
Das trägt sich nämlich bei der Installation automatisch in Autostart- Order /etc/xdg/autostart/ ein :wink:

Antworten