.desktop Datei starten ohne nachfrage

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Brudal1
Beiträge: 3
Registriert: 28.11.2019 05:31:10

.desktop Datei starten ohne nachfrage

Beitrag von Brudal1 » 04.03.2021 06:48:04

Hallo,

zum direkten starten eines Scriptes habe ich auf den Desktop einen Datei RDP.desktop angelegt.

Leider kommt beim Doppelklick auf das Icon das options Fenster mit "Execute / Execute in Terminal / Open / Cancel"

wie kann ich die .dektop Datei ohne nachfrage starten?

ich habe die Datei bereits mit chmod 755 ausfuehrbar gemacht (die Datei FreeRDP.sh auch).

das einzige das ich gefunden habe waere in pcmanfm die Meldung unter:
"Edit - Preferences - General - Don't ask option on launch exectutables file" allgemein zu deaktivieren

Das ganze hat bei Debian 9 funktioniert jetzt mit Debian 10 leider nicht mehr. (immer mit lxde)

Hier noch der Inhalt der RDP.desktop Datei

Code: Alles auswählen

[Desktop Entry]
Type=Application
Exec=/usr/lib/freerdp/FreeRDP.sh
Name=RDP
GenericName=RDP
Comment=start RDP 
Categories=Network
Icon=/usr/share/images/rdp.png
Terminal=false

Das ganze hat meiner Meinung nach nichts mit dem sh Script zu tun, da die Meldung auch "Exec=pacmanfm" kommt

hat jemand eine Idee?

Vielen Dank

Brudal1
Beiträge: 3
Registriert: 28.11.2019 05:31:10

Re: .desktop Datei starten ohne nachfrage

Beitrag von Brudal1 » 04.03.2021 07:23:52

Jetzt habe ich es doch noch selber gefunden.

anscheinend liegt es pcmanfm V1.31

ich habe die rdp.desktop Datei nach /usr/share/applications verschoben.
Hier werden dann die Dektop Datein direkt ins Menü verlinkt.
Um wie gewohnt eine Desktop Link zu haben, habe ich diese Link dann auf den Desktop kopiert.

Antworten