Mate/Xorg - Tastatur spinnt - Einfügen auf einmal Tottaste [gelöst]

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
nudgegoonies
Beiträge: 887
Registriert: 16.02.2009 09:35:10

Mate/Xorg - Tastatur spinnt - Einfügen auf einmal Tottaste [gelöst]

Beitrag von nudgegoonies » 12.05.2021 21:34:35

Meine Tastatur spinnt seit dem letzten Aufklappen des Laptops und auch ein Neustart hat nicht geholfen. Im Mate-Terminal und diversen anderen Programmen, sogar der Mate-Tastatureinstellung selbst, ist die "Einfügen"-Taste auf einmal eine Tottaste. Das heißt, ich muss sie zweimal hintereinander drücken, um z.B. im Midnight-Commander eine Datei zu markieren. Das geht im Mate-Terminal nicht mehr. Aber im xterm und uxterm geht es wie immer. Auch in einer Text-Konsole funktioniert alles wie gehabt. Was machen die beiden xterms anders als all die anderen Programme? Und wie kriege ich das für Mate/Xorg oder wo immer das Problem sitzt wieder hin?

P.S.
Das Mate-Terminal startet auch sehr langsam und die ersten Sekunden funktioniert es. Danach nicht mehr und die Tastatur reagiert auch sonst merkwürdig. Ach ja, es muss eine Einstellung irgendwo in meinem home-Verzeichnis sein. Bei einem anderen User geht es normal.

Im Terminal im normalen Eingabeprompt kommt beim doppelt drücken diese Sequenz:
^[[2~

Sorry, der Beitrag sollte in die Sektion "Grafische Oberflächen"
Zuletzt geändert von nudgegoonies am 15.05.2021 10:53:10, insgesamt 1-mal geändert.
Soft: Buster AMD64, MATE Desktop. Repo's: Backports, kein Proposed, eigene Backports. Grafik: Radeon R7 360 MESA.
Hardware: Thinkstation S20, Intel X58, 8GB, Xeon W3530, BCM5755 NIC, EMU10K1 SND, SATA SSD+HD und DVD+RW.

Benutzeravatar
hikaru
Moderator
Beiträge: 11546
Registriert: 09.04.2008 12:48:59

Re: Mate/Xorg - Tastatur spinnt - Einfügen auf einmal Tottaste

Beitrag von hikaru » 13.05.2021 12:39:39

nudgegoonies hat geschrieben: ↑ zum Beitrag ↑
12.05.2021 21:34:35
Sorry, der Beitrag sollte in die Sektion "Grafische Oberflächen"
Ich hab es mal verschoben.

Eine Lösung habe ich leider nicht. Mir fällt nur ein zu testen, ob sich das Problem unter einem frischen Nutzer reproduzieren lässt.

nudgegoonies
Beiträge: 887
Registriert: 16.02.2009 09:35:10

Re: Mate/Xorg - Tastatur spinnt - Einfügen auf einmal Tottaste

Beitrag von nudgegoonies » 13.05.2021 16:38:56

Danke Dir fürs Verschieben :THX:

Wie oben beschrieben, wenn ich mich mit einem anderen User einlogge ist alles normal.

Sogar bei einem anderen Terminalprogramm, xterm statt Mate-Terminal, ist alles normal.

Und in einer reinen Text-Konsole ist auch alles normal.

Es scheinen also nur Mate/Gnome bzw. GTK/QT Programme betroffen zu sein. In xterm (was glaube ich nur Xorg Bibliotheken benutzt) besteht das Problem nicht.

Tastaturlaylout habe ich schon einmal gewechselt und zurückgewechselt. Hat nicht geholfen.

Und ich habe die Mate Einstellungen "Tastatur" mit denen des anderen Users, wo es noch funktioniert, verglichen. Sie sind identisch.

Ich habe mir schon überlegt ob es irgendeine magische dconf Einstellung ist. Auch wenn ich daran nichts verändert habe.

Bleibt nur noch, dass ich irgendwann aus Versehen eine komische Tastenkombination gedrückt habe, welche diese Veränderung ausgelöst und persistiert hat. Im Prinzip ist aus der "Einfügen" Taste eine Art Tot-Taste geworden, die ich zweimal drücken muss um eine Änderung des Einfügen Modus auszulösen oder im MC eine Datei zu markieren. Und durch länger drücken wird sie nicht mehr mehrfach ausgelöst, wie sonst.
Soft: Buster AMD64, MATE Desktop. Repo's: Backports, kein Proposed, eigene Backports. Grafik: Radeon R7 360 MESA.
Hardware: Thinkstation S20, Intel X58, 8GB, Xeon W3530, BCM5755 NIC, EMU10K1 SND, SATA SSD+HD und DVD+RW.

nudgegoonies
Beiträge: 887
Registriert: 16.02.2009 09:35:10

Re: Mate/Xorg - Tastatur spinnt - Einfügen auf einmal Tottaste [gelöst]

Beitrag von nudgegoonies » 15.05.2021 10:58:30

Es ist Orca! Auch beim normalen Tippen kamen die Tasten ab und an total verzörget. htop zeigte mir eine hohe Auslastung von Orca. So kam ich dahinter. Keine Ahnung mit welcher Tastenkombination ich Orca aktiviert hatte. Ich habe auch noch nicht herausgefunden, warum der automatisch gestartet wird. Aber alleine dass ein killall orca reicht um wieder eine normale Tastatur zu haben reicht mir schon für ein [gelöst].

P.S.
Anscheinend reicht es den orca Prozess zu beenden und ~/.local/share/orca zu löschen.
Soft: Buster AMD64, MATE Desktop. Repo's: Backports, kein Proposed, eigene Backports. Grafik: Radeon R7 360 MESA.
Hardware: Thinkstation S20, Intel X58, 8GB, Xeon W3530, BCM5755 NIC, EMU10K1 SND, SATA SSD+HD und DVD+RW.

Antworten